Jump to content

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)


MacPeet
 Share

1,596 posts in this topic

Recommended Posts

Yes, the actual install finished, its the screen that starts at 7 mins left and counts down.

 

once it finishes it immediately reboots though.

Start the installation again and open up the installer log and be sure to select "all logs" or something like that. Keep it on front. Normally it would prevent the system from rebooting, until you close the log window. Save the installer log to your USB  (or another hd, if there's one) and post it here

 

Before you start the installation, you could open up terminal and either type

 

 

ls "/Volumes/Macintosh HD"

 and take a picture, or 

ls "/Volumes/Macintosh HD" > /path/ls.txt

 where /path/ is the location of where you want to store it and post it here

Link to comment
Share on other sites

Start the installation again and open up the installer log and be sure to select "all logs" or something like that. Keep it on front. Normally it would prevent the system from rebooting, until you close the log window. Save the installer log to your USB  (or another hd, if there's one) and post it here

 

Before you start the installation, you could open up terminal and either type

 

 

ls "/Volumes/Macintosh HD"
 and take a picture, or 

ls "/Volumes/Macintosh HD" > /path/ls.txt
 where /path/ is the location of where you want to store it and post it here

 

 

Log:

 

Jun 14 09:21:55 iMac InstallAssistant[551]: Hardware: iMac14,2 @ 3.29 GHz (x 4), 4096 MB RAM

Jun 14 09:21:55 iMac InstallAssistant[551]: Running OS Build: Mac OS X 10.12.5 (16F73)

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: DYLD_NO_FIX_PREBINDING=1

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: PWD=/

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: XPC_FLAGS=0x0

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: XPC_SERVICE_NAME=0

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: SHLVL=1

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: __OSINSTALL_ENVIRONMENT=1

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: CI_DEFAULT_OPENCL_USAGE=0

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: OS_INSTALL=1

Jun 14 09:21:55 iMac InstallAssistant[551]: Env: _=/System/Library/CoreServices/Language Chooser.app/Contents/MacOS/Language Chooser

Jun 14 09:21:57 iMac osinstallersetupd[555]: OSISChunkedDownload loaded...

Jun 14 09:21:57 iMac osinstallersetupd[555]: OSISAppStoreDownload loaded...

Jun 14 09:21:57 iMac osinstallersetupd[555]: Checking Software Update catalog URL https://swscan.apple.com/content/catalogs/others/index-10.12customerseed-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

Jun 14 09:21:57 iMac osinstallersetupd[555]: mountDiskImageWithPath: /Volumes/Image Volume/Install macOS Sierra.app/Contents/SharedSupport/InstallESD.dmg

Jun 14 09:21:58 iMac osinstallersetupd[555]: Could not load Software Update catalog: Error Domain=NSURLErrorDomain Code=-1009 "The Internet connection appears to be offline." UserInfo={NSUnderlyingError=0x7f7fe2e11230 {Error Domain=kCFErrorDomainCFNetwork Code=-1009 "The Internet connection appears to be offline." UserInfo={NSErrorFailingURLStringKey=https://swscan.apple.com/content/catalogs/others/index-10.12customerseed-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz, NSErrorFailingURLKey=https://swscan.apple.com/content/catalogs/others/index-10.12customerseed-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz, _kCFStreamErrorCodeKey=50, _kCFStreamErrorDomainKey=1, NSLocalizedDescription=The Internet connection appears to be offline.}}, NSErrorFailingURLStringKey=https://swscan.apple.com/content/catalogs/others/index-10.12customerseed-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz, NSErrorFailingURLKey=https://swscan.apple.com/content/catalogs/others/index-10.12customerseed-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz, _kCFStreamErrorDomainKey=1, _kCFStreamErrorCodeKey=50, NSLocalizedDescription=The Internet connection appears to be offline.}

Jun 14 09:22:00 iMac osinstallersetupd[555]: Mounting disk image complete, results dict = {

"system-entities" = (

{

"content-hint" = EFI;

"dev-entry" = "/dev/disk20s1";

"potentially-mountable" = 1;

"unmapped-content-hint" = "C12A7328-F81F-11D2-BA4B-00A0C93EC93B";

"volume-kind" = msdos;

},

{

"content-hint" = "Apple_HFS";

"dev-entry" = "/dev/disk20s2";

"mount-point" = "/Volumes/OS X Install ESD";

"potentially-mountable" = 1;

"unmapped-content-hint" = "48465300-0000-11AA-AA11-00306543ECAC";

"volume-kind" = hfs;

},

{

"content-hint" = "GUID_partition_scheme";

"dev-entry" = "/dev/disk20";

"potentially-mountable" = 0;

"unmapped-content-hint" = "GUID_partition_scheme";

}

);

}

Jun 14 09:22:00 iMac osinstallersetupd[555]: Mount point /Volumes/OS X Install ESD

Jun 14 09:22:01 iMac osinstallersetupd[555]: osinstallersetupd registered client

Jun 14 09:22:02 iMac Unknown[502]: Jun 14 09:22:02 InstallAssistant[551] : CGColorSpaceCreateWithName failed for kCGColorSpaceITUR_709

Jun 14 09:22:02 iMac Unknown[502]: Jun 14 09:22:02 InstallAssistant[551] : CGColorSpaceCreateWithName failed for kCGColorSpaceITUR_2020

Jun 14 09:22:02 iMac Unknown[502]: Jun 14 09:22:02 InstallAssistant[551] : CGColorSpaceCreateWithName failed for kCGColorSpaceROMMRGB

Jun 14 09:22:02 iMac Unknown[502]: 2017-06-14 09:22:02.683 InstallAssistant[551:19324] NSColorList could not parse color list file /System/Library/Colors/System.clr

Jun 14 09:22:02 iMac Unknown[502]: 2017-06-14 09:22:02.695 InstallAssistant[551:19324] Failed to connect (continuePane) outlet from (IASetupWindowController) to (NSTextField): missing setter or instance variable

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: DM ..F-[DMManager(PrivateMethods) clientConforms:error:]: currentThread=32791=0x8017 expectedThread=775=0x307

Jun 14 09:22:03 iMac InstallAssistant[551]: diskAppeared: disk20s1

Jun 14 09:22:03 iMac InstallAssistant[551]: Ignoring non-user-visible disk IADisk_10_6: disk20s1 EFI as target

Jun 14 09:22:03 iMac InstallAssistant[551]: diskAppeared: disk20s2

Jun 14 09:22:03 iMac InstallAssistant[551]: Ignoring non-user-visible disk IADisk_10_6: disk20s2 OS X Install ESD as target

Jun 14 09:22:03 iMac InstallAssistant[551]: diskAppeared: disk20

Jun 14 09:22:03 iMac InstallAssistant[551]: Ignoring non-user-visible disk IADisk_10_6: disk20 (null) as target

Jun 14 09:22:03 iMac InstallAssistant[551]: diskMounted: disk20s2

Jun 14 09:22:03 iMac InstallAssistant[551]: Ignoring non-user-visible disk IADisk_10_6: disk20s2 OS X Install ESD as target

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/BaseSystemResources.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.BaseSystemResources";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/Essentials.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.Essentials";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/OSInstall.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.OSInstall";

options = 16;

version = "10.12.5.1";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/FirmwareUpdate.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.FirmwareUpdate";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/EmbeddedOSFirmware.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.EmbeddedOSFirmware";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: version = 10.12.5

Jun 14 09:22:04 iMac osinstallersetupd[555]: OSISCustomizationController: Using version 10.12 from InstallSystemSizes.plist

Jun 14 09:22:04 iMac osinstallersetupd[555]: OSISCustomizationController: System size: 10515609460 bytes

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/BaseSystemResources.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.BaseSystemResources";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/Essentials.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.Essentials";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/OSInstall.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.OSInstall";

options = 16;

version = "10.12.5.1";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/FirmwareUpdate.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.FirmwareUpdate";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:04 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/EmbeddedOSFirmware.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.EmbeddedOSFirmware";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:22:41 iMac Unknown[502]: 2017-06-14 09:22 InstallAssistant[551] (FSEvents.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)

Jun 14 09:23:36 iMac osinstallersetupd[555]: mountDiskImageWithPath: /Volumes/Image Volume/Install macOS Sierra.app/Contents/SharedSupport/InstallESD.dmg

Jun 14 09:23:37 iMac osinstallersetupd[555]: Mounting disk image complete, results dict = {

"system-entities" = (

{

"content-hint" = "GUID_partition_scheme";

"dev-entry" = "/dev/disk20";

"potentially-mountable" = 0;

"unmapped-content-hint" = "GUID_partition_scheme";

},

{

"content-hint" = EFI;

"dev-entry" = "/dev/disk20s1";

"potentially-mountable" = 1;

"unmapped-content-hint" = "C12A7328-F81F-11D2-BA4B-00A0C93EC93B";

"volume-kind" = msdos;

},

{

"content-hint" = "Apple_HFS";

"dev-entry" = "/dev/disk20s2";

"mount-point" = "/Volumes/OS X Install ESD";

"potentially-mountable" = 1;

"unmapped-content-hint" = "48465300-0000-11AA-AA11-00306543ECAC";

"volume-kind" = hfs;

}

);

}

Jun 14 09:23:37 iMac osinstallersetupd[555]: Mount point /Volumes/OS X Install ESD

Jun 14 09:23:37 iMac osinstallersetupd[555]: Got and processed license agreement message

Jun 14 09:23:49 iMac InstallAssistant[551]: Failed to check if a disk is FDE.

Jun 14 09:23:49 iMac osinstallersetupd[555]: Helper tool loaded

Jun 14 09:23:49 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/BaseSystemResources.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.BaseSystemResources";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:23:49 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/Essentials.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.Essentials";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:23:49 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/OSInstall.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.OSInstall";

options = 16;

version = "10.12.5.1";

}) missing reference.

Jun 14 09:23:49 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/FirmwareUpdate.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.FirmwareUpdate";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:23:49 iMac osinstallersetupd[555]: Specifier (:

{

URL = "file:///Volumes/OS%20X%20Install%20ESD/Packages/EmbeddedOSFirmware.pkg";

authLevel = 2;

displayName = macOS;

identifier = "com.apple.pkg.EmbeddedOSFirmware";

options = 16;

version = "10.12.5.1.1.1493423442";

}) missing reference.

Jun 14 09:23:49 iMac osinstallersetupd[555]: Using product at distance 10

Jun 14 09:23:49 iMac osinstallersetupd[555]: Using product based on media at /Volumes/OS X Install ESD at distance 5

Jun 14 09:23:49 iMac osinstallersetupd[555]: No available package ref for compatibility update. Ignoring.

Jun 14 09:23:49 iMac osinstallersetupd[555]: OSISDownloadOperation: totalEstimate=378.000000, significantDownload=1

Jun 14 09:23:50 iMac osinstallersetupd[555]: Verify calculated time estimate: 67.118706

Jun 14 09:23:50 iMac osinstallersetupd[555]: Operation queue started

Jun 14 09:23:50 iMac osishelperd[572]: Privilaged helper tool loaded.

Jun 14 09:23:50 iMac osishelperd[572]: Will not add removal tool because target is not /.

Jun 14 09:23:50 iMac osinstallersetupd[555]: Using product PKSecureNetEnabledProduct at distance 5

Jun 14 09:23:50 iMac osinstallersetupd[555]: No available package ref for compatibility update. Ignoring.

Jun 14 09:23:50 iMac osinstallersetupd[555]: OSISDownloadOperation: totalEstimate=378.000000, significantDownload=1

Jun 14 09:23:50 iMac osinstallersetupd[555]: No available package ref for compatibility update. Ignoring.

Jun 14 09:23:50 iMac osinstallersetupd[555]: Retrieving 2 packages (4.956 GB)

Jun 14 09:23:50 iMac osinstallersetupd[555]: No native mechanism to verify InstallInfo.plist

Jun 14 09:23:50 iMac osinstallersetupd[555]: Retrieved package com.apple.installer.info (file:///Volumes/Image%20Volume/Install%20macOS%20Sierra.app/Contents/SharedSupport/InstallInfo.plist)

Jun 14 09:34:31 iMac powerd[152]: Assertion TimedOut. Type:UserIsActive Name:'com.apple.iohideventsystem.queue.tickle.4294968422.6' Id:0x900008002 Process:hidd [system: PrevIdle DeclUser kDisp]

Jun 14 09:34:32 iMac powerd[152]: Display is turned off

Jun 14 09:34:32 iMac powerd[152]: Assertion Summary. Type:NoIdleSleepAssertion Name:'OSInstaller Setup' Id:0x100008014 Process:osinstallersetupd [system: PrevIdle]

Jun 14 09:34:32 iMac powerd[152]: Assertion Summary. Type:ExternalMedia Name:'com.apple.powermanagement.externalmediamounted' Id:0x800008000 Process:powerd [system: PrevIdle]

Jun 14 09:52:53 iMac powerd[152]: Assertion Created. Type:UserIsActive Name:'com.apple.iohideventsystem.queue.tickle.4294968422.17' Id:0x900008015 Process:hidd [system: PrevIdle DeclUser kDisp]

Jun 14 09:52:53 iMac powerd[152]: Display is turned on

Jun 14 09:52:55 iMac Unknown[502]: 2017-06-14 09:52 InstallAssistant[551] (FSEvents.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)

 

 

 (spoilers ftw)

 

Picture of "/Volumes/Macintosh HD"  and what I see when clover opens.

http://imgur.com/a/GspV7

 

And a video of what happens when the installation ends

 

Thanks!

Link to comment
Share on other sites

@fishcake321

 

What do you exactly did to prepare the USB pen?

 

 

I did the CreateInstall thing on it,

 

 

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --applicationpath /Applications/Install\ macOS\ Sierra.app --volume /Volumes/"USB"

 

then installed clover with the OP's options, then I dragged the config.plist and DSDT, which I downloaded from here, into the correct folders. I couldn't find a DSDT for the 990 that wasn't patched for the HD5450 graphics though, so I used the one under Optiplex780/760 called  Generic_DSDT.aml.zip and  config.plist_for_other_graphics_cards.zip

 

The kexts I put in were AppleALC, FakeSMC, IntelMausiEthernet, and USB_Injector. which again were from the OP. 

 

I also wasn't sure if I was supposed to place all of these in the EFI partition of the usb or not. so I just put all of them in the normal partition.

Link to comment
Share on other sites

I'm not sure if there are significant differences between 990 and 780...
Eventhough the DSDT for 990 is patched for the HD5450, you can still use it. Or someone could be nice for you by removing the patch. My hack died today and I'm trying CPR on him atm so I can't do it  :blush:

Also, the kexts should be in /EFI/Clover/Kexts/10.12/

Link to comment
Share on other sites

I'm not sure if there are significant differences between 990 and 780...

Eventhough the DSDT for 990 is patched for the HD5450, you can still use it. Or someone could be nice for you by removing the patch. My hack died today and I'm trying CPR on him atm so I can't do it  :blush:

 

Also, the kexts should be in /EFI/Clover/Kexts/10.12/

 

Yeah, the kexts are in that folder.

 

Ok, ill try using the 990 files and see if that works.

Thanks

Link to comment
Share on other sites

I'm not sure if there are significant differences between 990 and 780...

Sandy Bridge vs Core2Duo… ;).

 

Eventhough the DSDT for 990 is patched for the HD5450, you can still use it. Or someone could be nice for you by removing the patch.

Done. Not sure you can use it as it. The HD 5450 DSDT injection is quite specific.

 

Also, the kexts should be in /EFI/Clover/Kexts/10.12/

Or /EFI/Clover/Kexts/Other so you don't care about OS version and you're ready for High Sierra :).

  • Like 1
Link to comment
Share on other sites

Yeah, the kexts are in that folder.

 

Ok, ill try using the 990 files and see if that works.

Thanks

Use the files from polyzargone in the post above you  :yes: 

 

 

 

Sandy Bridge vs Core2Duo… ;).

 

Ah, of course. :rofl:  I was confused with the 790, which also is Sandy Bridge  :P 

 

Link to comment
Share on other sites

Try this :

Hey @polyzargone, I really appreciate the help, but now it crashes about a second after I click the button in clover telling it to install sierra. heres a video of it

 

https://youtu.be/BypPMteiyQM

 

i tried messing with the boot flags, with these files i have tried:

 

-v nv_disable=1 kext-dev-mode=1

 

-v nv_disable=1

 

-v kext-dev-mode=1

 

Would inject nvidia help? and it still wasn't clear, am i supposed to be placing all of this on the EFI partition of the usb or not, because there is an EFI folder in the USB as well, which would make it either

 

/EFI/EFI/Clover/...

 

or

 

"Install macOS Sierra"/EFI/Clover/...

 

 

Thanks!

Link to comment
Share on other sites

Hey @polyzargone, I really appreciate the help, but now it crashes about a second after I click the button in clover telling it to install sierra. heres a video of it

 

https://youtu.be/BypPMteiyQM

 

i tried messing with the boot flags, with these files i have tried:

 

-v nv_disable=1 kext-dev-mode=1

 

-v nv_disable=1

 

-v kext-dev-mode=1

 

Would inject nvidia help? and it still wasn't clear, am i supposed to be placing all of this on the EFI partition of the usb or not, because there is an EFI folder in the USB as well, which would make it either

 

/EFI/EFI/Clover/...

 

or

 

"Install macOS Sierra"/EFI/Clover/...

 

 

Thanks!

The panic is related to your CPU. For now I'd just use NullCPUPowermanagement.kext to get you installed.

 

You need to overwrite the EFI folder on the root of your USB with the one polyzargone sent you. Ups, he didn't.

 

Config.plist goes to /EFI/CLOVER/

DSDT.aml goes to /EFI/CLOVER/ACPI/Patched/

USB_Injector.kext goes to /EFI/Clover/kexts/10.12/ or  /EFI/Clover/kexts/Other

 

Then place the NullCPUPM.kext in either /EFI/CLOVER/kexts/10.12 or /EFI/CLOVER/kexts/Other

 

It should look like this (assuming you didn't install Clover in the ESP, in which case it's on your EFI partition)

post-1502423-0-79130000-1497490686_thumb.png

 

NullCPUPowerManagement.kext.zip

  • Like 1
Link to comment
Share on other sites

Yep ricoc90's right !

 

In addition and to avoid any confusion, delete the EFI folder at the root of the USB : "Install macOS Sierra"/EFI/Clover/

 

Furthermore, make sure you installed Clover with these settings (sorry, it's in french but you get the idea) :

 

gBYVJ9U.png

Link to comment
Share on other sites

Ok, so I tried putting in the kext you gave me, and it got further this time, but it crashes without nv_disable=1. and when I do use nv_disable=1, it brings me to the macOS Utilities page, except that it doesn't let me start the installation or open disk utility.

 

 

 

Videos:

(gets to macOS Utilities)
https://youtu.be/RBXFZ2aj0Fc


(not using nv_disable)
https://youtu.be/dHfE1YOruLk

 

 

(ignore the tv in the background  :rofl: )

 

I will re install clover with those settings and try again tomorrow, thank you so much for your help.

 

also, I looked in the settings, do i need to disable things like intel speedstep and turboboost? I already disabled vt-d and set the HD to AHCI

Link to comment
Share on other sites

Make sure you have FakeSMC.kext in /EFI/CLOVER/kexts/10.12 or /EFI/CLOVER/kexts/Other.

 

It's a mandatory kext for every Hackintosh.

 

Also, the GeForce GT 730 is supposed to work OOB with Sierra so you shouldn't need to boot with nv_disable=1. As I see, you're loosing signal… What's the video output you're using for your monitor?

Link to comment
Share on other sites

and when I do use nv_disable=1, it brings me to the macOS Utilities page, except that it doesn't let me start the installation or open disk utility.

Yeah, it's a common bug I'm always experiencing too when I use the createinstallmedia method. What sometimes works for me is going back to language chooser (file -> language chooser).  I always install through the BaseSystem restore method because of this.

 

 

Ok, so I tried putting in the kext you gave me, and it got further this time, but it crashes without nv_disable=1

Try this. I believe the GT 730 doesn't work with SMBios iMac12,2. Actually it doesn't crash, it's just that your Monitor doesn't get signal. It's a common issue with (for what I've seen) Kepler cards since the 10.12.5 update 

 

config.plist.zip

  • Like 1
Link to comment
Share on other sites

Make sure you have FakeSMC.kext in /EFI/CLOVER/kexts/10.12 or /EFI/CLOVER/kexts/Other.

 

It's a mandatory kext for every Hackintosh.

 

Also, the GeForce GT 730 is supposed to work OOB with Sierra so you shouldn't need to boot with nv_disable=1. As I see, you're loosing signal… What's the video output you're using for your monitor?

I do have FakeSMC in there, and I am using the VGA output from the GPU.

 

 

Yeah, it's a common bug I'm always experiencing too when I use the createinstallmedia method. What sometimes works for me is going back to language chooser (file -> language chooser).  I always install through the BaseSystem restore method because of this.

 

 

 

Try this. I believe the GT 730 doesn't work with SMBios iMac12,2. Actually it doesn't crash, it's just that your Monitor doesn't get signal. It's a common issue with (for what I've seen) Kepler cards since the 10.12.5 update 

 

 

Thanks! I'll try it out later today

Link to comment
Share on other sites

Hey, I just wanted to be sure about something, my usb is supposed to be formatted as "Mac OS Extended (Journaled)" with the GUID Partition Table right?

but when I look at clover for installing to the ESP, it says to use Fat32? does that mean I only format the EFI as Fat32 or the entire thing?

 

I have been booting the usb from legacy not UEFI, just wanted to make sure I am doing this part right.

 

Thanks

Link to comment
Share on other sites

Hey, I just wanted to be sure about something, my usb is supposed to be formatted as "Mac OS Extended (Journaled)" with the GUID Partition Table right?

but when I look at clover for installing to the ESP, it says to use Fat32? does that mean I only format the EFI as Fat32 or the entire thing?

 

I have been booting the usb from legacy not UEFI, just wanted to make sure I am doing this part right.

 

Thanks

Only the EFI partition needs to be FAT32, but I believe Clover is doing that for you

Link to comment
Share on other sites

Hey, I just wanted to be sure about something, my usb is supposed to be formatted as "Mac OS Extended (Journaled)" with the GUID Partition Table right?

but when I look at clover for installing to the ESP, it says to use Fat32? does that mean I only format the EFI as Fat32 or the entire thing?

 

I have been booting the usb from legacy not UEFI, just wanted to make sure I am doing this part right.

 

Thanks

 

Every EFI partition must be in FAT32 whatever the OS you're using. This is part of the UEFI specs.

 

All the beauty of Clover is that even if your Bios/computer isn't UEFI aware or simply too old, it simulates a full UEFI environment so you can boot any UEFI OSes. In. other words, you can boot macOS/Windows/Linux, etc. in full UEFI mode. It also means that you can format all your drives in GUID/GPT (GPT stands for GUID Partition Table) on an old PC such as the Optiplex 760 for instance.

 

It's a kind of hybrid UEFI/Legacy install of Clover because the EFI folder is in the EFI partition (UEFI mode) instead of the root of the main partition but the bootloader is the boot file (Legacy mode) and not the BOOTX64.efi/CLOVERX64.efi.

 

Only the EFI partition needs to be FAT32, but I believe Clover is doing that for you

 

In fact, it's the Disk Utility that do the job when you format any drive in Mac OS Extended (Journaled) GUID ;).

Link to comment
Share on other sites

Woo! got it to boot, :D  I reinstalled clover on the EFI partition and changed the SMBIOS to iMac 14,2 and did the whole uuid and serial num thing. So, after I formatted the EFI to Fat32 and installed clover, and put all the files I have in there, I have only one problem remaining which is that I can still only boot with nv_disable=1. I am currently using a VGA monitor though, is that the reason? Also, I put the appleALC kext in with the others which means I should have sound right? (I can't tell yet because this monitor doesn't have built in speakers). Also, do I still need to keep that NullCPUPowerManagement kext in?

 

Thank you @polyzargone and @ricoc90 without you two it would have taken me forever to get all of this figured out. 

  • Like 2
Link to comment
Share on other sites

Congrats :D !
 

I have only one problem remaining which is that I can still only boot with nv_disable=1. I am currently using a VGA monitor though, is that the reason?


Could be but it should work in VGA too…:unsure:

 

Try to install NVIDIA's webdrivers using this app : http://www.insanelymac.com/forum/files/file/474-nvidia%C2%AE-webdriver-updaterapp/
 

Also, I put the appleALC kext in with the others which means I should have sound right? (I can't tell yet because this monitor doesn't have built in speakers).


Yeah, you should have audio. One good hint to check if it actually works is to look at SysPrefs > Sound and see if you have audio output and input. Ofc, it's best to test with speakers or headphones ;).
 

Also, do I still need to keep that NullCPUPowerManagement kext in?


I don't know for sure if it's really needed on your model but if you can boot without it using your USB pen as a "test bootloader", it's best to remove it.

As its name suggests, it nulls Power Management and it's not good for sleep/wake.

Link to comment
Share on other sites

Woo! got it to boot, :D  I reinstalled clover on the EFI partition and changed the SMBIOS to iMac 14,2 and did the whole uuid and serial num thing. So, after I formatted the EFI to Fat32 and installed clover, and put all the files I have in there, I have only one problem remaining which is that I can still only boot with nv_disable=1. I am currently using a VGA monitor though, is that the reason? Also, I put the appleALC kext in with the others which means I should have sound right? (I can't tell yet because this monitor doesn't have built in speakers). Also, do I still need to keep that NullCPUPowerManagement kext in?

 

Thank you @polyzargone and @ricoc90 without you two it would have taken me forever to get all of this figured out. 

You could try SMBios13,1

 

On page 34 of this topic there are two persons with the GT 730 reporting their card works under SMBios13,1.

 

And like polyzargone said, you could try without NullCPUPM.kext (as long as you keep it on your USB, in case you're getting a panic).

If you still need it or not depends on why AppleCPUPowerManagement gives you a panic though.... On your video I could only see the panic was caused by AICPUPM but couldn't see why because the text wasn't clear  :lol:

 

In fact, it's the Disk Utility that do the job when you format any drive in Mac OS Extended (Journaled) GUID ;).

 

 

Yeah, I meant the createinstallmedia, excuse-moi  :blush:

  • Like 1
Link to comment
Share on other sites

Hi,

 

I have a dell 790 i5 2400 with a 710 graphics card. I can't get the graphics card to be recognized and have tried every combination under the sun.

 

Can somebody post me a working EFI for sierra please. Alternatively, a working DSDT and config file.

 

Thanks in advance.

Link to comment
Share on other sites

Which SMBios are you using? The GT 710 doesn't work with certain SMBios (iMac10,1 for example).

I'm using SMBios10,1 with the board-id from iMac14,1 to get my GT 710 working.

In case other SMBioses don't work: in a couple of days i'll get my Optiplex with the same CPU, I can look into it then.

Link to comment
Share on other sites

  • Allan unpinned this topic
 Share

×
×
  • Create New...