Jump to content

Haswell-E 5820k 5930k installation guide with full speedstep working


358 posts in this topic

Recommended Posts

Thanks for this Stinga! You always come through ;)

 

Finally had time to play with this extensively and am now getting much improved performance, but not quite the solid line I would like in Intel Power Gadget when using Cinebench. Still, this is far far improved.

 

I had to manually set my power limits in the BIOS, just as Pike did in his example in order to get my highest turbo bins to hit consistently. My 12-core Xeon uses 160W/190A, which I think is the general rule for any of the 30MB or 35MB cache CPUs. The most I see in Intel Power Gadget is ~120W though, so perhaps I have a bit more headroom needed in order to get a little higher.

USB 3.0 working, speedstep & turbo now, but can't get the system to sleep nor an SSDT or Clover patch to work for editing AppleGraphicsDevicePolicy ( I don't want to patch the kext, tired of updates and security updates breaking it). Nevermind, all working! Turbo, USB 3.0, sleep/wake, VoodooHDA so completely update proof!

 

I tried Balamut's suggestion of the additional flag for -x 1, but it did not seem to make any difference for me.

 

Screen_Shot_2015_12_19_at_5_27_33_PM.png

Can you please post your BIOS settings for watts & amps or a screenshot ?

 

Thanks.

 

Boa sorte,

Paulo

Sure! I just did what Pike outlined in his blog post all those months back and that was linked in the OP. Also, I just checked (set the BIOS back to optimized defaults) and still have proper watts showing in IPG, so not sure why I have it. Perhaps it is a Xeon thing?

 

The settings (on an ASUS X99) are under the Ai Tweaker->Internal CPU Power Management:

Long Duration Package Power Limit: 160 Watts

CPU VR Integrated Current Limit: 190 Amps

 

While the don't change my Intel Power Gadget readouts, they do give my turbo an extra ~20-30 Watts which allows it to stay at its highest binned turbo (3.0GHz) more, but also allows me to occasionally hit 3.1GHz all core.

 

My clover settings are from the guide, other than KernelPm enabled and using Balamut's addition of the "-x 1" flag when generating my SSDT.

Greatly appreciate the OP for this! I am now able to get most of my machine working, especially the 1150 audio that I just could not get working with any other method, including all of the toleda utilities. However, one major issue is that after waking from sleep, the USB stops working. No mouse movement, no keyboard input. End up having to do a hard shutdown. Any solution for this? My mobo is an Asrock X99M, with a 5820k.

 

And as a related issue (probably because of the unsupported CPU, whether I use fakecpuid or not), I have not been able to get virtualization (VMWare, Parallels) to work. Virtual machines run ridiculously slow or crash out upon bootup. Anyone else experienced this? Is there a workaround?

 

Thanks!

Hello..

 

booting with the kexts from X99 USB3.0.zip stops at usbmc identifier (non-unique) ... After many seconds the screen shows only still waiting for root device and nothing happens..

 

What to do?

 

I´m booting with a Clover USB stick after I copied the kexts to the USB stick..

 

Thanks for help!   :thumbsup_anim:

Without X99_Injector.kext my DUAL XEON system is booting, but Clover cannot load the two other kexts..

 

Clover Boot Log

 

4:306  0:013  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
4:308  0:001  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.11
4:320  0:011    Extra kext: EFI\CLOVER\kexts\10.11\LegacyUSBHub.kext
4:325  0:004  Thinning fails
4:325  0:000  Thinning failed: EFI\CLOVER\kexts\10.11\LegacyUSBHub.kext
4:325  0:000    Extra kext: EFI\CLOVER\kexts\10.11\ACPISensors.kext
4:335  0:010    Extra kext: EFI\CLOVER\kexts\10.11\CPUSensors.kext
4:339  0:004    Extra kext: EFI\CLOVER\kexts\10.11\GPUSensors.kext
4:349  0:010    Extra kext: EFI\CLOVER\kexts\10.11\LPCSensors.kext
4:364  0:014    Extra kext: EFI\CLOVER\kexts\10.11\VoodooTSCSync.kext
4:367  0:002    Extra kext: EFI\CLOVER\kexts\10.11\X79PlatformPlugin.kext
4:367  0:000  Thinning fails
4:367  0:000  Thinning failed: EFI\CLOVER\kexts\10.11\X79PlatformPlugin.kext

4:376  0:009    Extra kext: EFI\CLOVER\kexts\10.11\FakeSMC.kext

 
Does anybody know, what the following message means?
 
4:243  0:000  Out of control with CPU numbers
 
The complete Clover Boot Log is attached..

Boot Log 2015-12-30.zip

XCPM and AppleIntelCPUPowerManagement.kext

 

XCPM worked with out SSDT

1   Board-ID=Mac-77EB7D7DAF985301

2   ProductName=iMac14,3

3.FakeCPUID with or without =0x0306A0

 

AppleIntelCPUPowerManagement.kext Loaded

 

FakeCPUID =0x0306E0

2. XCPM Not registered 

If AppleIntelCPUPowerManagement.kext Loaded XCPM Not.

 

3 FakeCPUID =0x0306E2  Haswell Final

GeekBench score without overclock with FakeCPUID =0x0306E2

 

 

hi stinga, hi everybody.

please stinga, could you please share with us your clover config.plist and your cpu bios settings?

 

if i have understood well, following stinga's guide we are using xcpm for power management.

so, as pikersalpha said on this blog, we can even disable on bios:

 

-eist

-turbo

-c(n) states

 

i have few questions:

-what about lpc kext not loading?pikersalpha said that it is needed for proper power management

-can i enable xpm memory profile on bios (and on clover config.plist)?

 

https://pikeralpha.wordpress.com/2013/10/05/xnu-cpu-power-management/

https://pikeralpha.wordpress.com/2014/05/26/major-breakthrough-for-power-management/

 

i attach here my config.plist, my bios settings and my geek bench, stock speed.

it is a bit lower than others scores but i'm using only 2x4gb 3200 ddr4 ram. tomorrow i will receive the full kit

 

edit2: i found out that, disabling rpm memory profile in bios and in clover config, allows me having a more stable system, but i have more wattage draw in intel power gadget

config.plist.zip

post-612691-0-95065800-1452100256_thumb.png

post-612691-0-18927700-1452100296_thumb.jpg

post-612691-0-63134600-1452100318_thumb.jpg

post-612691-0-63406400-1452101253_thumb.png

Hi manor I'm not clear on your last post. Can you please share the config.plist you used to get that geek bench score?

Try DSDT patch

http://www.insanelymac.com/forum/files/file/516-dsdt-for-gigabyte-x99/

Hey @Stinga if u have some time take a look on my DSDT

 

I try many methods and can't take full usb working on 10.11.2

 

I would appreciate your proposal or an idea if there is.

 

Thanks bro.

 

attachicon.gifDSDT.aml.zip

 

 

hi. for usb3 with asus x99 you have to use dsdt patches + clover remove limit usb (see my config.plist above).

then you have to use 3 kexts: genericxhci + usbinjectall + xhcix99injector

 

https://github.com/RehabMan/OS-X-USB-Inject-All

This guide AppleIntelCPUPowerManagement.kext not load.

This guide AppleIntelCPUPowerManagement.kext not load.

This guide was made to work with XCPM not AppleIntelCPUPowerManagement.kext

This guide was made to work with XCPM not AppleIntelCPUPowerManagement.kext

Any way thanks for your guide.

×
×
  • Create New...