Jump to content

[AMD] Yosemite Kernel Testing (for help use the Help Topic)


Duran Keeley
 Share

1,948 posts in this topic

Recommended Posts

Amazing work by bronya,
AMD Phenom ii x6 1055t (overclocked @3.5GHz) 
8GB 1666Mhz overclocked ram
Gigabyte GA78LMT USB-3 (rev 4.1)
Ati Radeon 7770 (His iCooler) 
everything works including iCloud, FaceTime worked once, since then never logins 
no issues, latest X-code works well, but I feel simulator for iPhone 6s is very slow for some reason(other all simulators work fine)


 

  • Like 1

@Spakk,

I'm unable to boot with your latest kernel:

 

attachicon.gifIMG_1627.JPG

I can see V3 kernel in your image, have you tried to boot without cache? -f and look at the line kext-dev-mode=1, ext-dev-mode=1.


I can see V3 kernel in your image, have you tried to boot without cache? -f and look at the line kext-dev-mode=1, ext-dev-mode=1.

Thanks, but I'm successfully using now the latest Bronya's kernel.

Thanks, but I'm successfully using now the latest Bronya's kernel.

I can boot with prelinked-kernel cache without problem.

The only imperfectness is incompatible with VoodooHDA 2.8.6 which I need to enable both ALC-887 and HDMI audio from Nvidia GTX-680 display card in Asus M4A78 Plus MB.

Only older kernel got here before 2015-9-18 worked for me now.

All the newer kernels seem incomptible with VoodooHDA in my Hackintosh.

 

[solved]

The lateset Bronya's 10.10.5_RC3 kernel is compatible with VoodooHDA 2.8.8 in Asus M4A78 Plus MB.

Thank you very much, Bronya and VoodooHDA team !

Edited by jsl

V2 and V3 I have clock running slow.

AMD Athlon x2 5100+ processor.

Any fix available??

 

what bootloader ? 

 

and flag : fsb=200 Mhz ? :)

 

what 5100 + ? (5200/5400/5600 but no 5100 ?)


To continue:

Using Bronya's AMD kernel_10.10.5_rc3 in place of rc1. 

So far runs the same as using the Haswell kernel on this machine.

HWMoniter reports the same idle temperatures on the individual cores (4 of them)

Idle speed is 792 Mhz which is the same

idle power consumption is between 4.57 watts and 7.7 watts. CPU Total pkg.

 

I find that Firefox runs at lower speeds and power consumption than using Safari.

The CPU fan runs 1500 rpm give or take, at idle

 

And when Bronya say all cpus, he means it.

All in all, very good work. 

 

petes-iMac:~ pete$ uname -a

Darwin petes-iMac 14.5.0 Darwin Kernel Version 14.5.0: Tue Sep  1 21:23:09 PDT 2015; root:xnu-2782.50.1~1/RELEASE_X86_64 x86_64

 

And also the same kernel in El Cap 10.11.1:

petes-iMac:~ pete$ uname -a
Darwin petes-iMac 15.0.0 Darwin Kernel Version 15.0.0: Sat Sep 19 15:53:46 PDT 2015; root:xnu-3247.10.11~1/RELEASE_X86_64 x86_64


Ok, so did a clean install from an intel image from my other machine, and then added few kext and Bronya's V3 kernel...and all running 

fine! Time is correct, not glitches, other than can't log into the app store...did fix the network EN0 issue.

 

This is AMD Athlon x2 5000+, 4G ram, added Nvidia 610 video card, old  Acer Aspire AM1201 box, boot loader is Enoch 2795 >

 

Thanks all, I've been watching development for over a year now. Huge effort!

 

App Store fix ?

: )

( same kernel runs El Cap?)

 

Thanks again!


No El Capitan kernel yet, we're waiting for the el capitan sources to be released so bronya or another dev can make a kernel.


  • 3 weeks later...

Hey , i just update my 10.10 yosemite (Hackintosh) to 10.10.5

on my vm,

and i used SSE2 for replace system file (using ubuntu)

replace process is successfully , but unfortunately the OSX keep kernel panic

 

am i wrong for the step ?

Thanks in advance !

 

My Processor : AMD FX 6300


Hey , i just update my 10.10 yosemite (Hackintosh) to 10.10.5

on my vm,

and i used SSE2 for replace system file (using ubuntu)

replace process is successfully , but unfortunately the OSX keep kernel panic

 

am i wrong for the step ?

Thanks in advance !

 

My Processor : AMD FX 6300 Yours truly help

Try adapting this guide http://www.insanelymac.com/forum/topic/301284-how-to-mavericks-retail-on-vmware-amd-system/

Yours truly and some other AMD virtual hackintosh guys made it.


:)

 

woooohhh !!  :P

 

je n'ai jamais été aussi loin dans le fonctionnement d'hackintosh AMD avec la reconnaissance périphérique audio automatique , la mise en veille avec reprise intégrale des applications en cours fonctionnelles en sortie de veille , Screen Flow a continué son chemin même en sortie de veille , j'ai juste relancé iTunes , la qualité sonore du média est correct  :angel:

 

pièces jointes : AppleRTC patched  (GA 78LMTUSB3) + voodooHDA + AppleHDADisabler (for no deleted AppleHDA) + voodooPState et une petite vidéo pour montrer tout ça :)

 

 

I've never been this far in the operation of AMD hackintosh audio device with automatic recognition, setting sleep with full functional recovery of current applications from sleep, Screen Flow continued its way even from sleep, I just relaunched iTunes, the sound quality of the media is correct   :angel:
 
Attachments: AppleRTC patched (GA 78LMTUSB3) + voodooHDA +  AppleHDADisabler (for no AppleHDA deleted) + voodooPState and a small video to show it all   :)

 

http://www.sendbox.fr/b801b25571a0a7dc/test.zip

Archive.zip

post-1093405-0-79634000-1449454583_thumb.png

  • Like 1

Apple has taken a very long time and just the xnu source was finally released for El Capitan.

So the releaseed the sources? if so where did you find el cappitan's sources?


Bronya and I will still build tonight a new kernel for el capitan and upload

annoying, is that I am actually not at home. I'm going to build the kernel in about 1 hour....

  • Like 5

Bronya and I will still build tonight a new kernel for el capitan and upload

annoying, is that I am actually not at home. I'm going to build the kernel in about 1 hour....

 

Will restore an installed image to my spare HDD for testing :D

  • Like 2

Awesome new finally they released the source :thumbsup_anim::yoji:

  • Like 2

Caught this when copying large file via LAN. Ideas?

Anonymous UUID:       358553CC-CBE9-EBA4-0EEA-6311EC62D5D9

Tue Dec 15 13:47:05 2015

*** Panic Report ***
panic(cpu 7 caller 0xffffff800034671b): "thread_invoke: preemption_level 1, possible cause: blocking while holding a spinlock, or within interrupt context"@/Users/mein/spakk/10.10.5_SSEPlus_V3/osfmk/kern/sched_prim.c:2207
Backtrace (CPU 7), Frame : Return Address
0xffffff81098931a0 : 0xffffff800032ce41 
0xffffff8109893220 : 0xffffff800034671b 
0xffffff81098932b0 : 0xffffff8000343fcf 
0xffffff81098932f0 : 0xffffff7f811bcb81 
0xffffff8109893310 : 0xffffff7f814b68e8 
0xffffff8109893360 : 0xffffff7f811bd2b2 
0xffffff81098933a0 : 0xffffff80008d49e4 
0xffffff81098933f0 : 0xffffff7f811bd392 
0xffffff8109893410 : 0xffffff7f811bc780 
0xffffff8109893480 : 0xffffff7f811bc9ac 
0xffffff81098934c0 : 0xffffff800059ffdc 
0xffffff8109893600 : 0xffffff8000670cbd 
0xffffff8109893980 : 0xffffff8000681eab 
0xffffff8109893a90 : 0xffffff8000681487 
0xffffff8109893cb0 : 0xffffff8000812b90 
0xffffff8109893da0 : 0xffffff80007f0386 
0xffffff8109893dd0 : 0xffffff80007ea2a5 
0xffffff8109893e80 : 0xffffff80007ea0f2 
0xffffff8109893ee0 : 0xffffff8000848caa 
0xffffff8109893f40 : 0xffffff800041b2e0 
0xffffff8109893fb0 : 0xffffff8000436865 
      Kernel Extensions in backtrace:
         com.apple.iokit.IONetworkingFamily(3.2)[150D35F0-A5B1-3C6C-803A-A45B70166285]@0xffffff7f811ab000->0xffffff7f811ddfff
         com.insanelymac.ALXEthernet(1.0.2)[6348F8DB-1233-3D33-A7FD-66E3ED3E7EB6]@0xffffff7f814b5000->0xffffff7f814c2fff
            dependency: com.apple.iokit.IONetworkingFamily(3.2)[150D35F0-A5B1-3C6C-803A-A45B70166285]@0xffffff7f811ab000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[05578B0B-C99C-3A87-9F3E-B4746D19CEF4]@0xffffff7f80b24000

BSD process name corresponding to current thread: Dropbox
Boot args: slide=0 dart=0 npci=0x2000 kext-dev-mode=1 EthernetBuiltIn=Yes GraphicsEnabler=No -cpuEFI 

Mac OS version:
14F1021

Kernel version:
Darwin Kernel Version 14.5.0: So 25 Okt 2015 06:31:33 PDT; mein:10.10.5_SSEPlus_V3/BUILD/obj/RELEASE_X86_64
Kernel UUID: A38AC754-327A-3767-830E-2F78DB870E58
__HIB  text base: 0xffffff8000100000
System model name: MacPro3,1 (Mac-F42C88C8)

System uptime in nanoseconds: 318043482287
last loaded kext at 270241863244: com.apple.filesystems.msdosfs	1.10 (addr 0xffffff7f82d07000, size 69632)
last unloaded kext at 112014712015: com.apple.driver.AppleFileSystemDriver	3.0.1 (addr 0xffffff7f81d2d000, size 8192)
loaded kexts:
org.voodoo.driver.VoodooHDA	2.8.4
net.osx86.kexts.GenericUSBXHCI	1.2.8d9
com.insanelymac.ALXEthernet	1.0.2
org.netkas.driver.FakeSMC	1082
org.tgwbd.driver.NullCPUPowerManagement	1.0.0d2
com.apple.filesystems.msdosfs	1.10
com.apple.iokit.CSRBluetoothHostControllerUSBTransport	4.3.6f3
com.apple.filesystems.autofs	3.0
com.apple.iokit.IOBluetoothSerialManager	4.3.6f3
com.apple.driver.AppleUpstreamUserClient	3.6.1
com.apple.kext.AMDFramebuffer	1.3.2
com.apple.iokit.IOUserEthernet	1.0.1
com.apple.driver.AppleOSXWatchdog	1
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.driver.AppleHWAccess	1
com.apple.driver.AppleHV	1
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleIntelSlowAdaptiveClocking	4.0.0
com.apple.kext.AMD7000Controller	1.3.2
com.apple.driver.AppleBacklight	170.7.4
com.apple.driver.AppleMCCSControl	1.2.12
com.apple.driver.XsanFilter	404
com.apple.iokit.IOAHCIBlockStorage	2.7.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.BootCache	36
com.apple.driver.AppleUSBHub	705.4.2
com.apple.driver.AppleUSBXHCI	710.4.11
com.apple.AMDRadeonX4000	1.3.2
com.apple.driver.AppleUSBEHCI	705.4.14
com.apple.driver.AppleUSBOHCI	656.4.1
com.apple.driver.AppleAHCIPort	3.1.2
com.apple.driver.AppleACPIButtons	2.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleAPIC	1.7
com.apple.nke.applicationfirewall	161
com.apple.security.quarantine	3
com.apple.security.TMSafetyNet	8
com.apple.iokit.IOBluetoothHostControllerUSBTransport	4.3.6f3
com.apple.kext.triggers	1.0
com.apple.iokit.IOSerialFamily	11
com.apple.iokit.IOSurface	97.4
com.apple.iokit.IOBluetoothFamily	4.3.6f3
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.driver.IOPlatformPluginFamily	5.9.1d7
com.apple.iokit.IOSlowAdaptiveClockingFamily	1.0.0
com.apple.kext.AMDSupport	1.3.2
com.apple.AppleGraphicsDeviceControl	3.10.25
com.apple.iokit.IOUSBUserClient	705.4.0
com.apple.driver.AppleBacklightExpert	1.1.0
com.apple.driver.AppleSMC	3.1.9
com.apple.iokit.IONDRVSupport	2.4.1
com.apple.driver.AppleSMBusController	1.0.13d1
com.apple.iokit.IOSMBusFamily	1.1
com.apple.iokit.IOSCSIBlockCommandsDevice	3.7.5
com.apple.driver.AppleUSBAudio	295.23
com.apple.iokit.IOAudioFamily	203.3
com.apple.vecLib.kext	1.2.0
com.apple.iokit.IOUSBHIDDriver	705.4.0
com.apple.iokit.IOUSBMassStorageClass	3.7.2
com.apple.iokit.IOSCSIArchitectureModelFamily	3.7.5
com.apple.driver.AppleUSBMergeNub	705.4.0
com.apple.driver.AppleUSBComposite	705.4.9
com.apple.iokit.IONetworkingFamily	3.2
com.apple.iokit.IOAcceleratorFamily2	156.16
com.apple.iokit.IOGraphicsFamily	2.4.1
com.apple.iokit.IOUSBFamily	720.4.4
com.apple.iokit.IOAHCIFamily	2.7.5
com.apple.driver.AppleEFINVRAM	2.0
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.DiskImages	398
com.apple.iokit.IOStorageFamily	2.0
com.apple.iokit.IOReportFamily	31
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleACPIPlatform	9.9
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.Libm	1
com.apple.kec.corecrypto	1.0
Model: MacPro3,1, BootROM MP31.006C.B05, 8 processors, 3.1 GHz, 8 GB, SMC 1.25f4
Graphics: AMD Radeon HD 7xxx, AMD Radeon HD 7xxx, PCIe, 1024 MB
Memory Module: DIMM3, 8 GB, DDR3, 1600 MHz, Corsair, CMZ8GX3M1A1600C10
Network Service: Ethernet, Ethernet, en0
PCI Card: AMD Radeon HD 7xxx, Display Controller, PCI Slot 0
PCI Card: ALX Ethernet Driver, Ethernet, Ethernet
Serial ATA Device: ST2000DX001-1CM164, 2 TB
USB Device: USB 2.0 Hub [MTT]
USB Device: Mass Storage Device
USB Device: FULL HD 1080P Webcam
USB Device: Hub
USB Device: Bluetooth USB Host Controller
USB Device: HID-compliant Mouse
USB Device: USB Keykoard
Thunderbolt Bus: 


 Share

×
×
  • Create New...