Jump to content

[Guide] AIO Guides For Hackintosh


607 posts in this topic

Recommended Posts

Hello,

After updating to Yosemite Public Beta 4 yesterday, I cannot connect anymore to iMessage, even if I use MLB & ROM values from my MBA.
I just check with iMessage_debug, and all seems to be OK : values are where they should be...

 

Anyone having trouble after updating ?

Ok, may be related to clover... I deleted all file related to iMessage in Library, and 
I revert to an old version r2909 and now I can log in.


Pokenguyen :) 

I suggest you add under your tool to finish the tool by installing it on you HDD, since many ppl are trying to install it to their USBs when trying to make config.plist or boot.plist, so please, make sure you point out that they need to install it on the booting HDD to get the config.plist/boot.plist :) 

Thanks

  • Like 1

@fusion71au,

 

Hello,

 

MLB and ROM seem to be buggy for me on my device.  When I wake from sleep I loose audio and USB bluetooth.  That is with Genuine iMAC14,2 information all entered in correctly.


@oSxFr33k,

 

What Clover version are you using at the moment?  UEFI boot or legacy?

 

I've read some people have had problems with certain revisions eg r2923 introduced some changes to RT Variables which needed to be rolled back in r2945 - see changelog.

 

Personally, I'm on r2916 and find that OK.

 

If you still have problems after installing a stable Clover version, upload the output of running the imessage_debug tool on your machine (you can hash out some/all of the characters in the serials for security purposes)...

 

Can't really say much about your sleep issue - maybe DSDT/kext related?


I have tried absolutely everything. I cannot get chameleon 2401 and filenvram 1.1.2 or 1.1.3 to cooperate. it ALWAYS generates a new ROM, MLB every reboot, no matter what is in SMBios. imessage debug shows Hardware UUID, SerialNumber, System-ID always stay the same.

 

it's ROM and BoardSerialNumber that are always random every boot. Until this is fixed, getting apple to unlock account is useless cause it'll just keep locking if file nvram can't get it together and stop generating random stuff. 

 

BoardSerialNumber is SerialNumber with 5 random letters generated every reboot added into the serial number. but the letters always different. 

 

I don't really want to switch to clover cause I tried it once and found it far more difficult to setup then chameleons simple setup. there are plenty of chameleon users this works for so I need to figure out why my rom and MLB simply won't stick. I can do nvram write every single boot and force feed it working values but doing that every single reboot is far from ideal. I need a way to make the values STICK and stop changing.

 

Is there any way to make filenvram file is read only, to filenvram? literally lock it so NOTHING can change it, ever?


Hi...

 

is the script for Yosemite for DP or for BETA...as I heard there is a difference on " installmedia "..on DP and BETA at :

 

 

Choice 1 (easy guide, but can result in blank screen after boot)


Step 3: Download OS X Yosemite from the Appstore, check if the “Install OS X Yosemite.app” is in the folder Application. Open Terminal and run this command ( note that Untitled is a HFS+ partition )

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/MacUSB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction "


Hi...

 

is the script for Yosemite for DP or for BETA...as I heard there is a difference on " installmedia "..on DP and BETA at :

 

 

Choice 1 (easy guide, but can result in blank screen after boot)

Step 3: Download OS X Yosemite from the Appstore, check if the “Install OS X Yosemite.app” is in the folder Application. Open Terminal and run this command ( note that Untitled is a HFS+ partition )

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/MacUSB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction "

The script is for Final. You can change the script by altering the .app name. Say you can add "Developer Preview.app" to make it work for DP.


Hi all,

 

I followed the guide to install yosemite. I was able to get the usb boot and I see the bootmenue as well as the option to install yosemite.

When I initiate that  (booting -v) then it runs thru until the display switches again to the apple and a progressbar (see picture). but it continues to stay there forever. I van see the mouse pointer colored ball spinning. But nothing more.

 

What can I do?

My system:

Dell Latitude  e5520

Processor: i5, 2.4 GHz

Chipset: Sandybridge 2430m

Grafics: HD3000

Display: 1920x1080 WUXGA

RAM: 16GB DDR3, 1333 MHz

HDD: Seagate SSHD ST1000LM014, Hitachi Travelstar 1.5 TB as HDD2 in Modularbay

WiFi: Atheros  AR5B93  Half Mini PCIe AR9283

WWAN: Sierra Wireless 8781 Aircard UMTS WWAN (3G) Mini PCI Card

Bluetooth

SD Card Reader

Webcam

PC Express USB3 card

USB adapter for HMPCIe for the mouse receiver build in

post-587793-0-02746000-1413582934_thumb.jpg


I'm  trying to install Yosemite on my hackintosh (triple boot with Gentoo Linux and Win 8.1), going for a fresh install to try and fix some issues on my Mavericks install.  I got the usb installer up, however when I try to boot from it, it launches the clover install on my hackintosh then will boot it.  It boots from that clover, but once it makes it past the boot screen I get the spinning cursor and some graphical glitches (it's completely unusable in that state) any ideas? At the moment any attempt to boot from the clover on my HDD results in the touch pad and keyboard being unusable (even to the installer, the usb mouse works though), however booting from the clover on the usb when it was the mavericks installer allowed those to work.  My GPU is a Haswell HD 4400 Low Res, which has support built in from the Vietnam Tool.  I have an i5 proc, I can't think of the mobo model off the top of my head, but could get it if you think it's got something to do with this.

 

I'm fairly new to hackintoshing, but as long as you can explain more advanced tasks I'll be fine.  I have a pretty decent understanding of Unix based OSs, I prefer to figure things out myself, it's just putting up quite a bit of a fight.  Also if it matters, to create the USB installer I followed choice 2.


ERMM.... Nope, it works for me :P

make sure it's in SLE and then run Kext Utility to fix caches and stuff :)

@Pokenguyen, can you add the "Legacy Clover" way too? Many ppl may need it over chameleon, here my lil guide about it if you need it :)http://pastebin.com/BtBS7SsE

 

Are you using the final release of Yosemite? my AppleHDAIDT can't be loaded :( and the latest Kext Utility doesn't work for me, but the latest Kext Wizard does!


What?

I just installed Yosemite (the latest one, not beta, the release version) and ran Kext Utility to fix caches and stuff, and it worked, if you're patching AppleHDA then you may have no luck (probably you will) and it should work with kext-dev-mode=1.

For me, I made DummyHDA, configured it, installed it on SLE, configured Clover for the correct values and then rebooted : it works!


you mean putting the dummyKext into /Clover/kexts/10.10 or just install it into /S/L/E 

 

certainly i'm using kext-dev-mode=1 :)

 

DummyHDA.kext MUSTbe in SLE, Clover injection doesn't work :(

  • Like 1

-f -v GraphicsEnabler=Yes EnableDualLink=Y

 

 

I am new to clover. In vietnam tool I can not find -f nor Grafics enabler or  dual link ?

 

Am I using the wrong tool for the config.plist?

 

rgds

 

lemans


I'm sure 80% you have chosen the wrong configuring, and btw I see a wwan card, remove it and try again, if still remove AHCIInjector.kext from Clover > EFI > CLOVER > kexts > Other, and then retry, hope you get it fixed.


Hi,

 

I cured my issue by using choice 2 for step three ( Manual copy of the install esd thing) that works very well. However can someone point me to the thread that shows how to use clover to boot and how to create a system revovery partition that is functional.

 

Thansk for the great work on this guide Thums up.  :thumbsup_anim: :thumbsup_anim:

lemans


  • Allan featured and unpinned this topic
×
×
  • Create New...