Jump to content

Lenovo ThinkPad T420 with UEFI Only


Go to solution Solved by tluck,
5,243 posts in this topic

Recommended Posts

i got the EFI pack from a forum member of another forum now, and i am back at a normal rat. 1:29 left at 29% battery on a 9cell battery.

i guess something is wrong on the new dsdt or kext files.

 

that is my impression.

 

Can you post the necessary files? What kexts did you change?

 

My t420 also squanders battery like crazy; a battery monitor app showed an insane battery consumption. If I can I'll upload a picture later, but with 40% of the battery I could barely get an hour's worth of laptop time!

i am curious about these battery issues. and what you are finding is different in your solutions.

 

from my perspective, nothing has changed in zip bundles in a long time around batteries/power. The battery is defined in the DSDT and there  the ACPIBatteryManager.kext. I have 2 T420 boxes with different size batteries - 6 and 9 cell. my 6cell gets about 3-4 hours under normal web browsing and email etc. 

 

when you first install OSX it will take a long time indexing files and chews up CPU and battery. but after a day or so - it should settle down. i have used the Lenovo Battery manager feature to recalibrate - charge/discharge batteries - a few times. and it resets some parameter values on the battery. I did this for my Lenovo G780 as well that was only showing 45 minutes of time. even on windows this is action is needed after the battery gets old. 

Here is a screenshot of my BatteryHealth app information. Apart from the obvious decay my battery has suffered, I am worried about the humungous battery usage (bottom of the image). This is what my thinkpad consumes while idle (I was using a different computer at the time).

 

Captura_de_pantalla_2016_09_28_a_las_0_2

My battery usage is large too. After calibration my battery works about 1.10-1.20, so it is better. I see that after laptop restart the battery % power is even 40-70% smaller (on the newest ACPIBatteryManager):/ I installed older ACPIBatteryManager from the end of May, so let's see now.

 

EDIT: On older ACPIBatteryManager after restarting it is ok.

Hi, When I shutdown computer my PC just restart instead of shutdown normally and give me error window:

ea6f363c2de14a81953b929b53be286f.png

Anonymous UUID:       0C650AB2-23ED-9912-312B-2C69A6F8357E

Wed Sep 28 15:40:12 2016

*** Panic Report ***
panic(cpu 0 caller 0xffffff8000409f4a): Kernel trap at 0xffffff800083c68f, type 13=general protection, registers:
CR0: 0x0000000080010033, CR2: 0xffffff8093071000, CR3: 0x0000000003e18000, CR4: 0x00000000000626e0
RAX: 0x0000000000000017, RBX: 0x0000000000000017, RCX: 0xffffff800beeb040, RDX: 0x0000000000000000
RSP: 0xffffff8098ec3c00, RBP: 0xffffff8098ec3c40, RSI: 0xffffff8000ac1470, RDI: 0xffffff800bef6e40
R8:  0x0000000000000000, R9:  0xffffff800bef61c0, R10: 0xffffff800bef61e0, R11: 0x0000000000000000
R12: 0xffffff800bef61c0, R13: 0xffffff800bef6080, R14: 0xdeadbeefdeadbeef, R15: 0xffffff8000ac1470
RFL: 0x0000000000010282, RIP: 0xffffff800083c68f, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0xffffff8093071000, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0

Backtrace (CPU 0), Frame : Return Address
0xffffff807300ac50 : 0xffffff80002f748c 
0xffffff807300acd0 : 0xffffff8000409f4a 
0xffffff807300aeb0 : 0xffffff80002a9743 
0xffffff807300aed0 : 0xffffff800083c68f 
0xffffff8098ec3c40 : 0xffffff7f830c5093 
0xffffff8098ec3c80 : 0xffffff7f830c6e00 
0xffffff8098ec3ca0 : 0xffffff7f830c7142 
0xffffff8098ec3d30 : 0xffffff7f830c72b9 
0xffffff8098ec3d80 : 0xffffff7f830f0421 
0xffffff8098ec3e00 : 0xffffff7f830f0b7e 
0xffffff8098ec3e40 : 0xffffff800089bdcd 
0xffffff8098ec3e80 : 0xffffff800089bb1e 
0xffffff8098ec3f10 : 0xffffff800089b0d6 
0xffffff8098ec3f60 : 0xffffff800089caee 
0xffffff8098ec3fb0 : 0xffffff80002a6af7 
      Kernel Extensions in backtrace:
         org.netkas.driver.FakeSMC(1412.0)[795B5E1A-E6F1-327C-A5C7-C4A4FD92F32A]@0xffffff7f830c3000->0xffffff7f830dbfff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[4F7FB6AD-2498-3F71-827C-ED7AA4BF2511]@0xffffff7f810d9000
         org.hwsensors.driver.ACPISensors(1412.0)[D0045A22-8D14-37BE-8D58-E38589C4DE42]@0xffffff7f830ef000->0xffffff7f830fcfff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[4F7FB6AD-2498-3F71-827C-ED7AA4BF2511]@0xffffff7f810d9000
            dependency: org.netkas.driver.FakeSMC(1412)[795B5E1A-E6F1-327C-A5C7-C4A4FD92F32A]@0xffffff7f830c3000

BSD process name corresponding to current thread: kernel_task
Boot args: slide=0 kext-dev-mode=1 

Mac OS version:
Not yet set

Kernel version:
Darwin Kernel Version 16.0.0: Mon Aug 29 17:56:20 PDT 2016; root:xnu-3789.1.32~3/RELEASE_X86_64
Kernel UUID: 622D2470-C34D-31F9-A62B-6AA9A3C6A3CD
__HIB  text base: 0xffffff8000100000
System model name: MacBookPro8,1 (Mac-94245B3640C91C81)

System uptime in nanoseconds: 1188206882
last loaded kext at 1082493498: com.apple.driver.usb.AppleUSBHostPacketFilter	1.0 (addr 0xffffff7f813ed000, size 20480)
loaded kexts:
com.insanelymac.IntelMausiEthernet	2.2.0d4
com.rehabman.driver.IntelBacklight	1.0.10
org.hwsensors.driver.ACPISensors	1412
org.rehabman.voodoo.driver.PS2Controller	1.8.24
org.hwsensors.driver.CPUSensors	1412
org.netkas.driver.FakeSMC	1412
org.rehabman.driver.AppleSmartBatteryManager	1.70.1
com.apple.driver.AirPort.Brcm4331	800.20.24
com.apple.driver.AirPort.Brcm4360	1100.37.1a16
com.apple.driver.AppleUSBXHCI	710.4.11
com.apple.driver.AppleAHCIPort	326
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleACPIButtons	5.0
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleACPIEC	5.0
com.apple.driver.AppleAPIC	1.7
com.apple.driver.AppleIntelCPUPowerManagementClient	219.0.0
com.apple.nke.applicationfirewall	171
com.apple.security.quarantine	3
com.apple.security.TMSafetyNet	8
com.apple.driver.AppleIntelCPUPowerManagement	219.0.0
com.apple.driver.usb.AppleUSBHostPacketFilter	1.0
com.apple.iokit.IO80211Family	1200.12.2
com.apple.driver.mDNSOffloadUserClient	1.0.1b8
com.apple.driver.corecapture	1.0.4
com.apple.iokit.IOUSBFamily	900.4.1
com.apple.iokit.IOAHCIFamily	288
com.apple.driver.AppleUSBHostMergeProperties	1.1
com.apple.iokit.IONetworkingFamily	3.2
com.apple.driver.usb.AppleUSBEHCIPCI	1.1
com.apple.driver.usb.AppleUSBEHCI	1.1
com.apple.iokit.IOUSBHostFamily	1.1
com.apple.driver.AppleEFINVRAM	2.1
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOGraphicsFamily	2.4.1
com.apple.driver.AppleBusPowerController	1.0
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.iokit.IOSMBusFamily	1.1
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.DiskImages	444
com.apple.iokit.IOStorageFamily	2.1
com.apple.iokit.IOReportFamily	31
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleACPIPlatform	5.0
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.Libm	1
com.apple.kec.pthread	1
com.apple.kec.corecrypto	1.0
Model: MacBookPro8,1, BootROM MBP81.0047.B2A, 2 processors, Intel Core i5, 2.49 GHz, 4 GB, SMC 1.68f99
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK0/DIMM0, 4 GB, DDR3, 1600 MHz, Samsung, M471B5273DH0-CK0
AirPort: Third-Party Wireless Card
Network Service: Wi-Fi, AirPort, en1
PCI Card: Intel 82579LM PCI Express Gigabit Ethernet, Ethernet, Ethernet
PCI Card: sppci_expresscard_name
Serial ATA Device: Samsung SSD 850 EVO 120GB, 120.03 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: USB Receiver
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Integrated Camera
Thunderbolt Bus:

Now I can't shutdown my computer from macOS  :(

a couple things to check and consider on the battery topic:

 

1) a laptop battery will degrade over time and will last 2-4 years - the T420 is 5 years old.

2) consider recalibrating your battery. 

3) using 1800ma is not a battery problem but a system problem - i wondering what processes are running and consuming energy?

4) the ACPIbatterymanager kext is just reporting what values it finds on the battery. recalibrate will write new values for it to see/use. there is a debug version that will provide more info.

 

Otherwise i suggest one to download a simple tool called coconutBattery.app

it will show the "design" capacity of your battery vs current capacity.

post-954945-0-28581200-1475140986_thumb.png

 

my T420 has a 6 cell batter with last night i recalibrate and got another 20% out of my battery

charge ability went from about 82% of design capacity (7950 mAh) to 94%. so means about 1 more hour on battery.

i replaced my battery about 2 years ago. so this is fairly new one.

 

idle power usage is something like 8-10 watts with it full loaded:  LCD, external monitor, SSD, internal disk, PCI card and 2 external disks .  i will strip it down on the weekend and see what the basic power consumption is.

I used Battery Health app to analize my battery, and squeezed an extra 10% battery; you can see my battery's info on the previous image.

 

Is there any way to recalibrate the battery in OSX? I don't have a dual boot with Windows.

 

Also my computer has massive battery usage while idle even after a fresh OSX install; with only Safari and a couple apps running (like battery health, popclip and bartender). Could it be something in the kexts?

a couple things to check and consider on the battery topic:

 

[...]

3) using 1800ma is not a battery problem but a system problem - i wondering what processes are running and consuming energy?

 

 

Cpu is i5 2520m. In idle it jumps around whole scale x8 x12 ... x30.

Averege is ~1.6ghz (what hwmonitor shows)

@pepo930 - you can edit the DSDT.dsl file to modify the logic - change from 0x7 (max) to something like 0x1 or whatever speed level you like - 0x1 to 0x7 (low to high). search for ThinkVantage and it will take you to the spot. 

 

@veer - search this thread for windows -- but don't make a NTFS partition with disk utilty since it will turn the PBMR into MBR and mess up UEFI boot for Win7 or Win10.  I use gpt to make an NTFS partition. or use windows to format the  space. 

 

@jus12 - not sure what happened? so I take it this panic was not a 1 time thing? i moved on to the betas right a way I'm on 10.12.1beta2 ... 

 

battery/power consumption topic - i don't know of a tool in OSX to reset a battery. i ran the Lenovo Settings tool downloaded from the Windows Store on Windows 10 to reset my battery. more than about 10 idle power means something is running and using power. run activity monitor or top on the command line to see what is running. cpu at 98% or 99% idle is really idle. 

hi. first of all, sorry my english!! :D

after 3 months with hackintosh, i have a question about the battery life.

recently, i installed ubuntu mate 16.04, have like 5hrs with 60-70% brightness and wifi on. but with same settings on hackintosh, have around 4hrs.

why? need to change some parameters in the system? this 1h+ its essentials (im student , and use the laptop on sites without charger ports...)

thanks.

Okay so for me personally, it was probably what tluck wrote.

the reindexing on first install.

 

i compared the DSDT file i have, with the one from tluck's file, there is no difference.

 

my battery is btw new, i just bought it for 60 bucks, and Battery Health 2 says 100% health ^^.

i reach ~6-7hours on my 9cell with it. + the 6 cell i still have in the laptop bag i think i am at arround 11 hours ^^

 

Very nice package, i don't know how much this fits to your package, but on 10.11.6, Apple changed the handling of usb ports. if you want to use a WWAN Card in the T420, you have to use a modified USBInjector.kext (or something similar) and fix the usb port handling. i just did that for myself and it works very nice.

As you already changed the DSDT file and renamed EHC1 and EHC2 to EH01 and EH02, i think this kext file could be helpful.

 

I attached the file i modified. i renamed the port definitions on EH01 and EH02 to fit to the T420 which is on the T420 PRT1 - PRT7 on EH01 and PRT8 - PRTC on EH02.

 

Kind regards

Tepoo

USBInjectAll.kext.zip

Just completed a fresh install of 10.11.6 on my T420s, using the resources here. I am experiencing very jumpy and imprecise cursor movement when using the trackpoint. Perhaps there is a value in Voodoops2trackpad.kext/Contents/info.plist that can be altered to help with this? Everything else is perfect. Thanks! 

@vanmanradio - are you using the provided T420s DSDT which defines the PS2K/Trackpad as LENOVO/T420 ?

 

but yes the Trackpad Info.plist is where to focus and if the T420 key is defined will pick up those values vs default. I know that changing MouseMultiplier is one thing that may change the trackpoint behavior. i am not near my system right now and cannot remember if VoodooPS2mouse has any impact. 

 

so i changed MouseMultiplier from 6 to 2 - TrackPoint seems less jumpy - just have to push a little harder!

Edited by tluck
×
×
  • Create New...