Jump to content
InsanelyMac Forum

jus12

Members
  • Content count

    63
  • Joined

  • Last visited

About jus12

  • Rank
    InsanelyMac Protégé
  1. jus12

    Lenovo ThinkPad T420 with UEFI Only

    OK I think I found the problem. For many years I had installed external disk in CD Bay instead of CD Drive. When I put CD Drive back, or just remove the external drive from CD Bay, led behaves as it should. So something is not right with the external drive sitting in the cd bay, then.
  2. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Hi tluck, thanks for the update. Well, it is strange. I have been using your packages for years now with a great success. I have never created dedicated DSDT. I was always using yours. For my W520 I had created one but not for T420. So all files I'm using as they are in your packs. So I have tried to use DSDT files from previous (working) builds. But no change. Latest HS maybe have changed something? I'm running now 10.13.3.
  3. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Hi, I need your help. yesterday I had to reinstall High Sierra on my T420. All is working fine with the latest Clover.zip package. But after wake from sleep my power led and sleep led on the cover keeps flashing. Everything else works fine after sleep. I need to reboot, of course, for both leds to stop flashing. Do you have ideal what can cause that? I have disabled hibernation and removed sleep image (hibernate mode set to 0). OK I think I found the problem. For many years I had installed external disk in CD Bay instead of CD Drive. When I put CD Drive back, or just remove the external drive from CD Bay, led behaves as it should. So something is not right with the external drive sitting in the cd bay, then.
  4. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Thanks for the suggestion. I will try to change the settings and will keep you posted with the results. Hi Tluck, your suggestion looks very promising. So far no glitches. I have disabled the BT by default and enabling that only on demand. So the system seems to work nicely. I'm predominantly using my W520 with NVidia enabled as it has i7 processor and more graphical power but only that doesn't work on 10.13 yet. So stuck there on 10.12.6.
  5. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Hi All, I have just upgrade the Clover/EFI with latest packages. Something is still not right with the 10.13 macOS. 10.12.6 was just running perfectly fine. Now I lost conidence. I still do get some graphical issues, especially when opening system preferences or playing flash videos, I do see occasionally horizontal lines. I don't use much BT so the sleep/wake works with it disabled.
  6. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Hi Eman, is sleep working for you? For me clean install worked, but there is still the issue with Bluetooth when putting the system into sleep. Also after sleep, I identify some graphical glitches (minimal but still random single horizontal lines) but still that's new and not seen in Sierra.
  7. jus12

    Lenovo ThinkPad T420 with UEFI Only

    I'm using W520 with Nvidia with Sierra with great success, but upgrading to High Sierra messes graphics on Nvidia. So I'll keep it at 10.12.6 for now. My T420 I have used to try Hight Sierra. Installation went fine, but have two issues at the moment. Sleep and Trackpad. Battery Meter after sleep/wake. 1. Sleep, when I disabled hibernation (change to mode 0) and power off bluetooth, sleep and wake works, but when wakes I get strange graphical glitches, artefacts, flickering, text disappearing while typing this post. So I'll need to reboot in a moment. I think it's a problem with the bluetooth kext. 2. Trackpad at the moment doesn't fully work, touch to click or double touch to select doesn't work. Also high Sierra doesn't find trackpad anymore. In settings it's searching for bluetooth trackpad. After a while the trackpad has been recognised and works. The only thing that doesn't work is double tap and hold to select. OK trackpad is sorted now. I used these command to make dragging by touching working: (I cannot enable that in pref panel) com.apple.applemultitouchtrackpad DragLock -int 1 defaults read com.apple.applemultitouchtrackpad Dragging -int 1 3. When after sleep/wake switched form power source to battery, battery icon doesn't update status automatically. Only after enabling/disabling show percentage the status refreshes, bot you need to do that each time to see the current status and current battery capacity. Weird.
  8. Hi Tluck, I just got T450S with HD5500 Graphics. will those files posted here work with it? Or the differences between T450S and T460 are too great?
  9. Hey Shikumo, same here. W520 with 1000m not working with high Sierra. I've tired with older kexts for applegrahics.. NV.... No luck.
  10. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Hi Tluck, where to you put your files now? You used to attach them to the post. Now not?
  11. jus12

    Lenovo ThinkPad T420 with UEFI Only

    That's interesting. It works great on my T420. It fails however on W520. I'm using same image on both except the ACPI and config.plist (MB10.1 on W520).
  12. jus12

    Lenovo ThinkPad T420 with UEFI Only

    I have recently noticed a lot of entries in console related to cssm. On T420 as well as W520. Are you having same issue? See screenshot for details.
  13. jus12

    Lenovo ThinkPad T420 with UEFI Only

    Hi @tluck, is the trackpad pref pane really working. On my W520 systems preferences crashes each time I try to open trackpad pref pane. ( I'm using latest zip from Nov 4th). Error: "System Preferences quit unexpectedly"
  14. jus12

    Lenovo ThinkPad T420 with UEFI Only

    When I opened after reboot trackpad settings all was working promising, but then I selected different tap within it and the system preferences crashed. I cannot open the trackpad pref pane anymore. Will try to restart the system, to see if I can replicate that. OK after reboot now I was able to open the pref pane for trackpad, and I was able to see that the more gesture tab was selected, immediately after open it system preferences crashes. So all looks good when using first tab (general settings) and second tab, speed of the pointer. but if switching to more gestures all crashes. will see if I can get this working again. Another reboot.
  15. jus12

    Lenovo ThinkPad T420 with UEFI Only

    @Somez. to get the right click you need to make sure the other touch commands work, dragging, left muose click (single finger tap etc). Once it's confirmed you need to enable right click in voodootrackpad.kext. The right click will work with two finger tap. I have reported that in previous posts. Search in this forum.
×