Jump to content

Lenovo ThinkPad T420 with UEFI Only


Go to solution Solved by tluck,
5,243 posts in this topic

Recommended Posts

@Tetonne -

 

For well known issues on Sierra, there is a nice whats broken in 10.12.x on another popular hack site by RehabMan.

 - but yes F1- F12 stopped working with Sierra on all PS2 Hacks

 - same with Audio buttons etc on Laptop.

 

So install Karibiner-Elements and it will allow the F keys to work again.

So to support Karibiner-Elements - I turn off the custom key maps in VoodooPS2Keyboard.kext Info.plist

 

so stay with current kext pack and install Karibiner-Elements. i am using the default key maps in K-E.

 

 

-----

 

Battery topic 

 

so i was curious as to much power my system actually uses.

 

with 1 SSD, running on 9 cell battery - killed apps and let it settle down.

the fans turn at 1920RPM, and CPU is 99% idle. 

with LCD set to low brightness - 2 bars,  cocobattery says it is draining the battery at right around 7 watts

with LCD set to max brightness, cocobattery says it is draining the battery at right around 11.5 watts.

 

with my battery, it says full charge is 7465 mAh vs 7950 (original design capacity) - so it is about 6 % degraded.

 

at 12 volts * 7.5 Ah = 90 Watt Hour

lets say my idling power is around 10 watts on average - that means the battery would lasts about 9 hours. not bad.

but actually using the system for doing heavy work - compiling, copy files, etc - and jumps the power to 45 watts  - the battery lasts about 2 hours. 

Hello guys.

It's my first post and hope I don't something wrong.

My english is not very good but i try follow this guide and i have now a working T420 with macOS Sierra. ( Really thanks tluck about guide )

That post is for 2 questions. Im not sure i understand all good...

 

1) Its normal audio and trackpad do not work with Sierra OS at the moment, right ? Something other don't work with Sierra OS ?

2) I understand the wifi card don't work and to replace it, i need mod the bios. Right ? I have the 1.46 Version, where i can find the right mod ?

 

Thanks Alberto

Hello guys.

It's my first post and hope I don't something wrong.

My english is not very good but i try follow this guide and i have now a working T420 with macOS Sierra. ( Really thanks tluck about guide )

That post is for 2 questions. Im not sure i understand all good...

 

1) Its normal audio and trackpad do not work with Sierra OS at the moment, right ? Something other don't work with Sierra OS ?

2) I understand the wifi card don't work and to replace it, i need mod the bios. Right ? I have the 1.46 Version, where i can find the right mod ?

 

Thanks Alberto

 

Hey Alberto!

 

1. Do you mean you don't have sound at all? That's not normal. Trackpad is also working but there is no configuration screen in Settings.

2. Here you can find the 1.46 without whitelist.

@Somez

 

Thanks your fast reply.

U are right sorry !!! About Audio i see the grey volume graphics and think don't work ! I put headphone and its work !! Really Sorry !! :)
About Bios Mod i try download and try use it !!

Thanks !!

Hi all, I know my ultrabook is not the sane as this laptop, but do you think some of this guide will work for mine

 

Samsung NP540u3c-A02UK ultrabook

Core i3, Intel HD 4000.

6gb ram.

 

All advice is appreciated. Thanks

 

Sent from my SM-G928F using Tapatalk

@NSCXP2005

well. many aspects should be the same in terms of the process, but there may be significant differences depending on the devices - meaning the custom kexts may not apply.

 

key devices to check:

 

1) ethernet

2) audio codec 

3) bluetooth 

4) gfx - HD 3000 vs HD4000

 

the DSDT will be very different.

@tluck

 

Hello Sir,

 

Thanks for let us turn our Lenovo T420 systems into MacBook Pro.

 

I am facing two problems.

 

(1) - I tried to install several time but there is no sound at all. Neither from speakers, nor through headphone/mic combo jack. (I don't have Camera+Mic module in my laptop) and I could not check whether is WiFi working or not as don't have any device to connect with my laptop,

 

(2) - I converted the installer for MBR installation and it also works fine like as for GPT scheme. but in both case, my system boots only with USB installer.

 

Could you please teach me how to make my HDD bootable.

 

Moreover, I want to prepare my system for three operating systems: Mac OS X, Windows 7/10 and Ubuntu with MBR scheme. Please instruct me how do I accomplish this.

 

Thanking you in advance.

 

My system specs is:

 

Lenovo T420,

Model: 4236Y19

Core i5 2520M

BIOS: 83ET78WW 1.48

Chipset: Intel Cougar Point QM67, Intel Sandy Bridge

4 GB DDR3-1333

Intel HD Graphics 3000

Conexant Cx20590 High Definition Audio Controller

Intel 82579LM Gigabit Ethernet Adapter

Intel Centrino Advanced-N 6205 AGN 2x2 HMC WiFi Adapter

No WWAN module

No Camera+Mic module

 

3 primary partitions of 40gb and 1 extended with two equal volumes of remaining space.

@Naveed

- what version of OSX?

 

audio etc.

- did you install the kexts in /Library/Extensions with the script?

 

boot from HD vs USB

do you have MBR or GUID format on your HD? UEFI will boot with GUID formats. if so, did you install everything in the ESP?

 

Thank you very much for your quick reply.

 

Currently I have 10.11 (15A283), and 10.11.6 (Russian version USB installer for MBR scheme :().

I just asked a friend to download 10.11.6 and 10.12 from App Store for me.

 

Yes I did. As I am a newbie and don't have sound knowledge about hackintosh, I followed all of your instructions step by step.

 

I tried both schemes (first GUID then MBR). and installed Clover onto ESP as well.

@naveed - once you have 10.11.x  installed you can update it from the App store yourself. 

 

but if you have installed the AppleHDA_20672.kext in /Library/Extensions you should have sound if the symbolic link in there is working.

 

run these 2 commands and post output - it should look like this:

$ ls -l /Library/Extensions/AppleHDA_20672.kext/Contents/MacOS/
total 8
lrwxr-xr-x  1 root  wheel  64 Oct  2 18:21 AppleHDA -> /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA
$ kextstat|grep HDA
   98    2 0xffffff7f813ad000 0xf000     0xf000     com.apple.iokit.IOHDAFamily (278.17) 4D67014F-C71C-3131-ADD7-06B7656635FD <5 4 3 1>
   99    1 0xffffff7f813bc000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (278.17) 9EB8D69B-2DC4-3558-9862-3945D2020F03 <98 97 78 12 7 6 5 4 3 1>
  120    0 0xffffff7f8155e000 0xb4000    0xb4000    com.apple.driver.AppleHDA (999.99) 89A4089D-2773-36AF-ACBB-EDF02A4C3127 <119 99 98 97 84 78 12 11 6 5 4 3 1>

so is your HD MBR or GUID now? 

@naveed - once you have 10.11.x  installed you can update it from the App store yourself. 

 

but if you have installed the AppleHDA_20672.kext in /Library/Extensions you should have sound if the symbolic link in there is working.

 

run these 2 commands and post output - it should look like this:

$ ls -l /Library/Extensions/AppleHDA_20672.kext/Contents/MacOS/
total 8
lrwxr-xr-x  1 root  wheel  64 Oct  2 18:21 AppleHDA -> /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA
$ kextstat|grep HDA
   98    2 0xffffff7f813ad000 0xf000     0xf000     com.apple.iokit.IOHDAFamily (278.17) 4D67014F-C71C-3131-ADD7-06B7656635FD <5 4 3 1>
   99    1 0xffffff7f813bc000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (278.17) 9EB8D69B-2DC4-3558-9862-3945D2020F03 <98 97 78 12 7 6 5 4 3 1>
  120    0 0xffffff7f8155e000 0xb4000    0xb4000    com.apple.driver.AppleHDA (999.99) 89A4089D-2773-36AF-ACBB-EDF02A4C3127 <119 99 98 97 84 78 12 11 6 5 4 3 1>

so is your HD MBR or GUID now? 

 

Thanks again tluck :)

 

I'll try these commands and let you know the result, but I don't know what is symbolic link meant to.

 

Currently I prepared my HDD with GUID but I love to use MBR system as I am familiar with it.

I also have a 250gb spare drive to play with Operating Systems.

 

Could you please teach me also (or refer to some post) how can I use Windows 7/10 and Ubuntu along with OS X.

 

Thanking in advance.

UEFI and GUID is the way to go - forget MBR - it was how it was done last decade. 

if you are online with your T420 - sign in the App Store - check for updates then run the updates to get the OS to the latest.

 

if you installed the kexts with the included _kext-install.command script it will fix the symbolic links - which is a file that points to another file - in this case the AppleHDA binary.

and if you have installed the custom zip configuration files on the USB or the HD, then you will get the proper codec patching etc.

Updated the zip - minor kext updates etc.

Changed some params etc to get the TrackPoint working pretty smooth now. 

 

But yeah, the latest 10.12.1 beta 3 is showing some nice improvements - less glitchy on the GFX front and some of the keys started working again.

 

The VoodooPS2 maps are not totally working as expected in this latest beta - some work but the F1/F2 is doing weird both LCD and Audio at the moement, so I have removed them as a default for now. I am using Karabiner-Elements to map my keys using the F1-F12 default layout. However, the "just working again" Audio Keys above F1-F3 dont work!

×
×
  • Create New...