Jump to content
27,333 posts in this topic

Recommended Posts

Clover completely hangs (before showing boot menu) when config.plist turbo set to Yes.

According to the ARK page the Intel i5-2400 CPU has Turbo Boost.

I have no overclock, run the latest BIOS, and Clover.

 

Is this a (known) bug?

 

Thanks!

 

Used config.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>ACPI</key>
   <dict>
       <key>DropOemSSDT</key>
       <string>Yes</string>
       <key>GenerateCStates</key>
       <string>Yes</string>
       <key>GeneratePStates</key>
       <string>Yes</string>
       <key>EnableC6</key>
       <string>No</string>
       <key>EnableC4</key>
       <string>No</string>
       <key>EnableC2</key>
       <string>Yes</string>
       <key>EnableISS</key>
       <string>Yes</string>
   </dict>
   <key>CPU</key>
   <dict>
       <key>Turbo</key>
       <string>Yes</string>
       <key>QPI</key>
       <string>4800</string>
       <key>BusSpeedkHz</key>
       <string>99790</string>
   </dict>
   <key>Graphics</key>
   <dict>
       <key>GraphicsInjector</key>
       <string>Yes</string>
       <key>LoadVBios</key>
       <string>Yes</string>
   </dict>
   <key>SystemParameters</key>
   <dict>
       <key>boot-args</key>
       <string>-v slide=0</string>
       <key>prev-lang:kbd</key>
       <string>en:0</string>
       <key>DefaultBootVolume</key>
       <string>Macintosh HD</string>
       <key>CustomUUID</key>
       <string>**</string>
   </dict>
   <key>SMBIOS</key>
   <dict>
       <key>ProductName</key>
       <string>MacPro5,1</string>
       <key>Family</key>
       <string>Mac Pro</string>
       <key>SerialNumber</key>
       <string>G8010DF5EUE</string>
       <key>Board-ID</key>
       <string>Mac-F221BEC8</string>
       <key>BiosVersion</key>
       <string>MP51.88Z.007F.B03.1010071432</string>
   </dict>
</dict>
</plist>

Very nice bootloader, I've been using it for 10 days. It wasn't easy to figure out how to make it work, but once I did I love it!. Nice work, and it's beeing constantly improved.

I just love to have the option to switch to Chameleon while booting through Clover, and booting from Lion & Mountain Lion installer partitions itś a dream come true.

 

Thanks a lot to ALL the Clover developers, having too bootloaders at hand it much better than one.

Clover completely hangs (before showing boot menu) when config.plist turbo set to Yes.

According to the ARK page the Intel i5-2400 CPU has Turbo Boost.

I have no overclock, run the latest BIOS, and Clover.

 

Is this a (known) bug?

 

Thanks!

 

Used config.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DropOemSSDT</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>EnableC6</key>
<string>No</string>
<key>EnableC4</key>
<string>No</string>
<key>EnableC2</key>
<string>Yes</string>
<key>EnableISS</key>
<string>Yes</string>
</dict>
<key>CPU</key>
<dict>
<key>Turbo</key>
<string>Yes</string>
<key>QPI</key>
<string>4800</string>
<key>BusSpeedkHz</key>
<string>99790</string>
</dict>
<key>Graphics</key>
<dict>
<key>GraphicsInjector</key>
<string>Yes</string>
<key>LoadVBios</key>
<string>Yes</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>boot-args</key>
<string>-v slide=0</string>
<key>prev-lang:kbd</key>
<string>en:0</string>
<key>DefaultBootVolume</key>
<string>Macintosh HD</string>
<key>CustomUUID</key>
<string>**</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>ProductName</key>
<string>MacPro5,1</string>
<key>Family</key>
<string>Mac Pro</string>
<key>SerialNumber</key>
<string>G8010DF5EUE</string>
<key>Board-ID</key>
<string>Mac-F221BEC8</string>
<key>BiosVersion</key>
<string>MP51.88Z.007F.B03.1010071432</string>
</dict>
</dict>
</plist>

 

same problem, hangs with turbo=yes on my hard

I have again slow boot ....now return on chemeleon...thz for help.

for me it 's too slow to get to the theme, while Chameleon a superfast

 

Carmine

Write nolog into refit.conf

 

@Slice

 

Here a patch for adding an Icon to Clover-pkg...

Enjoy.

 

IconPKG.patch.zip

 

Fabio

Icon.icns file is not produced by the

patch -p1

Upload, please, the Icon separately.

Upload, please, the Icon separately.

 

Strange....

Here we are...

Archivio.zip

Unpack into

 

../edk2/Clover/CloverPackage/package/buildpkg.sh

../edk2/Clover/CloverPackage/package/Icon.zip

 

Don't decompress the Icon.zip! the compressed file preserve the sequestered icon (resource fork)

 

Note: If you have a "better" icon... post here... need to be 512px x 512px in .PNG or .TIFF with transparent background...

Fabio

Revision 718 has mouse pointer support.

Write into config.plist the follow

<key>Pointer</key>
<dict>
<key>Speed</key>
<string>8</string>
</dict>

Larger value - faster speed.

Some mice don't properly work. Sorry for the drivers restrictions.

For me Logitech works fine.

hello Slice

 

for me mouse works good, and trackpad too

 

i will give it a try

 

any new sugestion about the EDID, i don't know u remenber that i post, with only the string customedid, with values in the config file, the internal monitor in note don't work, only work with that values in the file /s/l/d/o.

 

good hack

Is there a way to set a resolution in clover? (Just for the menu and boot logo).

I've got it pretty much working on my ASRock Extreme 11 (i7-3930k). Though it always needs the argument WithKexts no other options work with the kernel cache. (Maybe because of VoodooTSC).

 

Other question:

 

How do you guys install with the InstallESD.dmg? The instructions tell to add /s/l/e, coreservices and mach_kernel in stage 2. But there is no way to that in my case. After the files are copied. Reboot takes place and if i want to reboot in the InstallESD usb drive to add those files it will immediately start a installation that can't find the packages link... (Some destination is set in the nvram or clover dunno..)

 

A normal basesystem + packages + mach_kernel will work fine though, but it won't make the restore partition.

hello Slice

 

for me mouse works good, and trackpad too

 

i will give it a try

 

any new sugestion about the EDID, i don't know u remenber that i post, with only the string customedid, with values in the config file, the internal monitor in note don't work, only work with that values in the file /s/l/d/o.

 

good hack

Yes, I remember, but I just don't know what to do.

Is there a way to set a resolution in clover? (Just for the menu and boot logo).

You mean Screen Resolution? Clover always set maximum available. See no reason to reduce it.

I've got it pretty much working on my ASRock Extreme 11 (i7-3930k). Though it always needs the argument WithKexts no other options work with the kernel cache. (Maybe because of VoodooTSC).

 

Other question:

 

How do you guys install with the InstallESD.dmg? The instructions tell to add /s/l/e, coreservices and mach_kernel in stage 2. But there is no way to that in my case. After the files are copied. Reboot takes place and if i want to reboot in the InstallESD usb drive to add those files it will immediately start a installation that can't find the packages link... (Some destination is set in the nvram or clover dunno..)

 

A normal basesystem + packages + mach_kernel will work fine though, but it won't make the restore partition.

My way is to install Lion and then upgrade it to ML. During the upgrade I obtained recovery partition while I need no it.

Write nolog into refit.conf

 

:help:

 

still takes a long time to get to the gui .... about 7 seconds ... maybe there is something that does not work well in clover ... I dont think this is normal.

 

 

This is a my config plist

 

 

<key>SystemParameters</key>

<dict>

<key>boot-args</key>

<string>-v npci=0x2000</string>

<key>prev-lang:kbd</key>

<string>it:0</string>

<key>DefaultBootVolume</key>

<string>Lion</string>

<key>CustomUUID</key>

<string>9E713465-14B8-3EA7-846A-07AE97F3A114</string>

</dict>

<key>SMBIOS</key>

<dict>

<key>BiosVendor</key>

<string>Apple Inc.</string>

</dict>

<key>Graphics</key>

<dict>

<key>GraphicsInjector</key>

<string>Yes</string>

</dict>

</dict>

</plist>

 

 

 

 

And This a refit . conf

 

 

 

#

# refit.conf

# Configuration file for the rEFIt boot menu

# Customized for black_green theme by blackosx

#

 

# Timeout in seconds for the main menu screen. Setting the timeout to 0

# disables automatic booting (i.e., no timeout).

#

timeout 5

 

# Disable menu options for increased security. These are intended for a lab

# environment where the administrator doesn't want users to mess with the

# operating system. List the names for the options you want to hide from

# the boot menu. Currently supported:

# shell - remove the EFI shell

# tools - remove all EFI tools (shell and gptsync)

# optical - no booting from optical drives

# external - no booting from external disks or USB flash drives

# internal - no booting from internal disks; this setting is not

# recommended because it locks you out of all operating

# systems installed on the internal hard disks.

# singleuser - remove the submenu options to boot Mac OS X in single-user

# or verbose modes

# hwtest - remove the submenu option to run Apple Hardware Test

# all - all of the above, except for 'internal'

#

#disable external optical shell singleuser

#disable all

disable hwtest

 

# Note: The 'disableopticalboot' and 'disableexternalboot' options from

# Charles Ahn's patch are also supported for compatibility. They are

# equivalent to 'disable optical' and 'disable external', respectively.

 

# THEME SET

#theme metal

#theme buttons

theme black_green

#theme hellfire

 

#Use custom font or embedded

# alfa - transparent embedded font

# gray - gray embedded font

# load - load from file with custom name

#

# theme independent

#

#font alfa

font load

 

# this font is default for theme metal and buttons, width=8

#font_file_name WoB_mplus2mMedium_9W.png

#char_width 9

 

# this font is used for theme black_green, width=10

font_file_name WoB_PTMono_10W_NA.png

char_width 10

 

# pixel size of letters in text. depends on font and wanted design

# may differ from letter width allowing overriding

# default value 7 corresponding embedded font

#

#char_width 10

 

# Use a custom title banner instead of the rEFIt icon and name. The file

# path is relative to the directory where refit.efi is located. The color

# in the top left corner of the image is used as the background color

# for the menu screens. Currently uncompressed BMP images with color

# depths of 24, 8, 4 or 1 bits are supported.

# V2 - PNG image supported

# The location of the file theme dependent

#

banner logo.png

 

# Custom images for the selection background. There is a big one (144 x 144)

# for the OS icons, and a small one (64 x 64) for the function icons in the

# second row. If only a small image is given, that one is also used for

# the big icons by stretching it in the middle. If only a big one is given,

# the built-in default will be used for the small icons.

#

# Like the banner option above, these options take a filename of

# an uncompressed BMP image file.

# V2 - PNG image supported

# location is theme independent

#

selection_big Selection_big.png

selection_small Selection_small.png

 

#Selection bar in menu may have different colors

# default white RGBA={0xFF, 0xFF, 0xFF, 0x00}

#

selection_color 0x31520E00

 

 

# Hide the volume badge icons in the graphical main menu. There are three

# settings:

# none - show all volume badges (default)

# internal - hide badges on internal disk volumes only, allowing you to

# distinguish CDs and occasionally connected external disks

# all - never show volume badges (not recommended)

#V2

# swap - show OSIcon as Volume and DriveIcon as Badges

# - default: Drive for Volume and OS for Badge

# drive - show OSIcon as Volume and no badges

#

hidebadges swap

 

# Hide various user interface elements. Here you can list the names of

# interface elements to hide. Currently supported:

# banner - the rEFIt title banner

# shell - the EFI shell icon

# tools - all EFI tools (shell and gptsync)

# funcs - built-in functions (about, restart)

# ('tools' and 'funcs' together hide the complete second row of icons.)

# label - text label in the menu

# hdbadges - volume badges for internal disk volumes (same as

# 'hidebadges internal')

# badges - all volume badges (same as 'hidebadges all'); this setting

# is not recommended because it won't let you distinguish

# installed OSes and bootable CDs/DVDs.

# all - all of the above, except for 'badges'

#

# Note: The 'shell' and 'tools' options are equivalent to the 'disable'

# options with the same names.

#

#hideui tools funcs hdbadges

#hideui all

 

# Use text mode only. When enabled, this option forces rEFIt into text mode.

#

#textonly

 

# Disable display of text-mode output when in graphics mode. This

# option is unnecessary on Macs, but without this option, UEFI-based

# PCs tend to display text-mode messages relating to boot loader probing

# over the GUI display.

#

#quiet

 

# List legacy options first. When enabled, legacy BIOS based boot options

# (e.g. Windows, Linux via LILO or GRUB) will be listed first. This is

# intended as a quick fix to change the default boot choice until full

# configurability arrives.

#

#legacyfirst

#nolegacy

nolog

 

# EOF

 

 

 

if you have any ideas, I am available to do other tests to improve clover

 

Many Thanks

Carmine

:help:

 

still takes a long time to get to the gui .... about 7 seconds ... maybe there is something that does not work well in clover ... I dont think this is normal.

 

 

Very long? This is a time to connect to devices, drives, to check your partitions.

Chameleon is faster at this moment because it uses BIOS drivers that are already connected. But then Chameleon works with INT13 while Clover by AHCI.

You may see at kext loading. When Chameleon loads all kexts and is writing to the screen something like

[HFS+] AppleHDA.kext is loading...

...

you may go for a cup of coffee or may be sleep a little.

Hi Slice

 

I'll post here as projectosx is down (same problem that used to happen with Insanely until they updated forum software).

 

Bug report using Clover rev720.

At the GUI my keyboard locks up when pressing return to boot the selected volume.

When the GUI is first drawn my keyboard works as far as pressing left and right, but pressing for example A, or return just locks the machine. I've tried unplugging the keyboard and reconnecting it but as far as I can tell the machine is locked and I have to power off.

 

Oh, I did see 720 appear in white text and the bottom right half of the screen?

Hi Slice

 

I'll post here as projectosx is down (same problem that used to happen with Insanely until they updated forum software).

 

Bug report using Clover rev720.

At the GUI my keyboard locks up when pressing return to boot the selected volume.

When the GUI is first drawn my keyboard works as far as pressing left and right, but pressing for example A, or return just locks the machine. I've tried unplugging the keyboard and reconnecting it but as far as I can tell the machine is locked and I have to power off.

Be sure you have recent pointer.icns or create your own black-green pointer ;) 32x32pixels

Oh, I did see 720 appear in white text and the bottom right half of the screen?

Yes, people asked me to do this. I just can't place it in the corner.

Thanks Slice, that fixed it and I can boot again. :)

 

My mouse pointer doesn't move though, but I saw above you posted about it doesn't work for everyone. I have two mice here; one cheap USB and a bluetooth Apple Magic mouse.

 

The pointer.icns you supply in the clover source looks great, so I don't think I need to create a different one for the black_green theme.

I want to thank Slice and all of those who have worked tirelessly on Clover for many months, as it is absolutely fantastic, using an Asus Z77 Sabertooth and an intel i7 3770K slightly overclocked to 3.8 GHz, NO DSDT and Clover is very fast and stable with version 709.

 

Geekbench 64 give me 1K more sped than with Chameleon. I am delighted, the only issue I have is that I cannot get it to boot directly with UEFI.I am very grateful to you all - It is goodbye chameleon for me.

 

What a big difference and please be assured that many are very appreciative of the effort you have put into this project.

Archive.zip

×
×
  • Create New...