Jump to content

Atheros Network Drivers


  • Please log in to reply
379 replies to this topic

#21
cyrana

cyrana

    Prophetess of Doom

  • Retired
  • 1,462 posts
  • Gender:Female
  • Location:Somewhere out there
No luck for me, I have the 168c 0013 device (two of them, one miniPCI onboard, one in a cardbus card). Both will show up in system profiler, but I can't configure in networking, etc.

#22
Tak

Tak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Works fine here on an Atheros 5005GS mini PCI (168c 0013). Can't get any form of encryption working though, so can only connect to open networks. Maybe 10.4.4/5 fixes that.

I had to change it from en0 to en1 as my onboard network adapter isn't supported so the wireless is automatically set to en0 and OS X needs Airport cards to be en1:

http://forum.osx86pr...indpost&p=40054 (thanks ohpossum)

#23
Celticmoon

Celticmoon

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
I can't find the IO80211Family.kext in the update. Am i just being dense?

#24
h4n9m4n

h4n9m4n

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
i cant find it either. i extract the "archive" file in the package, but i couldnt find any IO80211Family.kext in the extensions folder. i tried both the delta and the combo, and nothing. is the update supposed to be "MacOSXUpd10.4.5PPC.dmg"? i think its wrong because it has ppc in the name but thats the only one available for download.

#25
Celticmoon

Celticmoon

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

i cant find it either. i extract the "archive" file in the package, but i couldnt find any IO80211Family.kext in the extensions folder. i tried both the delta and the combo, and nothing. is the update supposed to be "MacOSXUpd10.4.5PPC.dmg"? i think its wrong because it has ppc in the name but thats the only one available for download.


That's the same file I am searching in as well (the combo), and although there are quite a few .kext files in there, IO80211Family.kext is not among them.

#26
poteck

poteck

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Buenas, como te llamas Fernando voy a suponer que eres espaol jejejejeje, asi que mejor te lo cuento en castellano que va ser mas rapido. Ah ante todo gracias por responder.

Tengo la version 10.4.3 y aunque me costo un poco encontrar el family kext del archivo del
upgrade al final lo encontre. Los saque los dos, tanto el 80211 como el family network.
Segun entendi debia extraerlos y reemplazar los que tenia en mi sistema por esos.
Restableci los permisos despues de esto con el reparador de permisos que tiene el osx.
EL problema es que cuando reinicio, primero me quede sin LAN, me decia que estaba desactivada,
y wifi nada de nada. En cuaanto a lo de arranzar windows para ver si es que tiene un arranque
medio raro negativo. No uso windows, uso debian y he instalado macos por probar. En debian
me va sin problemas la tarjeta al tener driver atheros. Si pudieras especificarme como
reemplazar los archivos y que hacer exactamente te lo agradezco.

Por cierto mi tarjeta no es exactamente la 5354 es una 3054 de Senao pero lleva el chipset
ATHEROS el aries 2 concretamente. Lo he comprobado en la web de Engenius que son quienes las fabrican
y ambas llevan el mismo chipset el aries 2, la unica diferencia es que la mia no soporta el modo A, solo el B y G. Asi que supongo deberia funcionar con el mismo driver, especulo claro, pero supongo que deberia ser asi. En cualquier caso por probar no pierdo nada.

Un saludo.

#27
Qapf

Qapf

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
There is an intel only 10.4.5 update, you are downloading the PPC one

#28
kalle_19

kalle_19

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
How about Orinoco cards, can they work? Just replace IO80211.kext?

#29
Celticmoon

Celticmoon

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

There is an intel only 10.4.5 update, you are downloading the PPC one


The update page I downloaded from made reference to both PPC and Intel, and was the only one I could find.

#30
Fernando Birra

Fernando Birra

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts

Buenas, como te llamas Fernando voy a suponer que eres espaol jejejejeje, asi que mejor te lo cuento en castellano que va ser mas rapido. Ah ante todo gracias por responder.

Tengo la version 10.4.3 y aunque me costo un poco encontrar el family kext del archivo del
upgrade al final lo encontre. Los saque los dos, tanto el 80211 como el family network.
Segun entendi debia extraerlos y reemplazar los que tenia en mi sistema por esos.
Restableci los permisos despues de esto con el reparador de permisos que tiene el osx.
EL problema es que cuando reinicio, primero me quede sin LAN, me decia que estaba desactivada,
y wifi nada de nada. En cuaanto a lo de arranzar windows para ver si es que tiene un arranque
medio raro negativo. No uso windows, uso debian y he instalado macos por probar. En debian
me va sin problemas la tarjeta al tener driver atheros. Si pudieras especificarme como
reemplazar los archivos y que hacer exactamente te lo agradezco.

Por cierto mi tarjeta no es exactamente la 5354 es una 3054 de Senao pero lleva el chipset
ATHEROS el aries 2 concretamente. Lo he comprobado en la web de Engenius que son quienes las fabrican
y ambas llevan el mismo chipset el aries 2, la unica diferencia es que la mia no soporta el modo A, solo el B y G. Asi que supongo deberia funcionar con el mismo driver, especulo claro, pero supongo que deberia ser asi. En cualquier caso por probar no pierdo nada.

Un saludo.


No, I'm Portuguese. All I did was to replace my 80211 extension with the one from 10.4.5. I didn't touch the IONetworkingFamily extension. I'm still using the 10.4.3 version. What is the Vendor and Device ID of your card?

Fernando Birra

#31
poteck

poteck

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
First of all thanx for your response fernando,
About the vendor is EnGenius 11g mini-pci NET-AL-3054
with Atheros chip. As i told u, is the same card as the 5045 but the only difference is that
the 3045 don't support 802.11a mode, just b/g.

About the vendor ID how can i see it on linux?
In My configuration log in linux i found this, As u can read it detect the card as an AR5212 abg
but really it didn't support the A mode. But it works fine under linux.
I imagine in osx the problem goes with the vendor or device id. How can i resolve that.
0000:02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

One more thing, i'd copy the IO80211Family.kext to the Extension directory and then i repair
permissions, but when i restart it told me that the is a problem with the file because the
instalation of it was bad o something like that i don't remenber the exact message.

#32
Fernando Birra

Fernando Birra

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts

First of all thanx for your response fernando,
About the vendor is EnGenius 11g mini-pci NET-AL-3054
with Atheros chip. As i told u, is the same card as the 5045 but the only difference is that
the 3045 don't support 802.11a mode, just b/g.

About the vendor ID how can i see it on linux?
In My configuration log in linux i found this, As u can read it detect the card as an AR5212 abg
but really it didn't support the A mode. But it works fine under linux.
I imagine in osx the problem goes with the vendor or device id. How can i resolve that.
0000:02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

One more thing, i'd copy the IO80211Family.kext to the Extension directory and then i repair
permissions, but when i restart it told me that the is a problem with the file because the
instalation of it was bad o something like that i don't remenber the exact message.


Repair the permission with these commands:

chmod -R 755 IO80211Family.kext
chown -R root:wheel IO80211Family.kext

that specific error should go away.

About the vendor,deviceid try to look under /proc/pci. I believe there should be some file in there with that information.

Fernando

#33
poteck

poteck

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I on linux now i foud the vendor and device id and vendor
device id: 0x168c 0013
In theory the same as the driver support. I going to proff restonring the permissions.
I will told u what happend.

Thanx.

#34
poteck

poteck

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
WOOOOO IT WORKS NOW WIRELESS in OSX86 i cant believe it

Thank fernando, the problem was with the permissions, i
restored the permissions and then restart. It detect an AIRPORT on the
system. It works FINE with WEP 128 bits encryption too.

So on more Wireless card to the hardware list.

Engenius NET-EL3054MPPLUS - ENGENIUS 11g/b mini-pci Aries2 Atheros

#35
weeguy

weeguy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
I got it working on my Thinkpad X31 as well with just the IO80211Family.kext. Just make sure you go to the Network preference pane in System Preferences after you restart to turn the Airport card on.

#36
ripoflive

ripoflive

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts
Dude, I have a thinkpad t41 and I cant get it to WORK! I successfully loaded the kext, it sees it as an airport, but when i try to configure it, it freezes and goes insane. When I go to system profiler, and go to "airport" it doesnt display any info and when I go to "Network" in system profiler, it just crashes....maybe I need to add my dev id or somethin....PLEASE HELP ME!!!!!!!

#37
TB205GTI

TB205GTI

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Woohoo!

IO80211.kext works for the Topcom Skyracer 108Mbit PCMCIA card in my T42. The onboard Intel 2200 still doesn't work, but now I'm able to connect via WIFI. Only downside is that I cannot connect to my normal WPA (no Radius server) - only if I remove the encryption from it.

It's not a major issue as there is no encryption on the university's network. (we use other authentication)

#38
cromas

cromas

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Has anyone tried this with Atheros a/b/g card, PCI 168c:1014? I'm looking at buying a card for my ThinkPad X41 Tablet, and I don't know of the 0013 card is compatible.

0013: here
1014: here

#39
CLucas916

CLucas916

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hello,

I have a Proxim Orinoco Gold PCMCIA card. I have installed IO80211Family.kext and the IONetworkingFamily.kext from the 10.4.5 update package. OSX recognizes my card as en1 when i go to the network utility, but I don't see where i can connect to a network. There is no wireless icon in the top right of the screen like I would assume there would be. If anyone has any idea what im doing wrong, let me know. BTW, im using the 10.4.3 version of OSX86.

Thanks.
Chris

#40
weeguy

weeguy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Launch "Internet Connect" from Applications. Is Airport shown as one of the tabs?
If yes, click on it and check "Show AirPort status in menu bar".
You can also turn AirPort on/off and select wireless network from this app.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy