Jump to content

[How to] Asus P5K-VM guide


  • Please log in to reply
1236 replies to this topic

#1201
bikinifarm

bikinifarm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Chicago, Illinois
I did have a few problems in the end:

AppleHDA inside /S/L/E results in:


kxld[com.apple.driver.AppleHDA]: The following symbols are unresolved for this kext:
kxld[com.apple.driver.AppleHDA]: DspFuncManager::resetAllDspFuncs()
kxld[com.apple.driver.AppleHDA]: DspFuncManager::process(void const*, unsigned int, void const*, unsigned int, unsigned int, unsigned int)

My best guess is that it is 32bit. But not sure. So, audio is out of commission. I will try to do that from within /Extra and update. It also gave a number of errors regarding the kext not being authentic. NextI will the audio hack for ALC883 that Xantrax mentioned, assuming that it is the LegacyALC883.kext.


Looks like that was my mistake. All worked out from BlackCH's AppleHDA.kext in the /S/L/E folder.

Secondly, I took your BlackCH's DSDT, and adapted it to Q6600 @ 2.4GHz. But looks like my Geekbench scores are down to 2000 or so. Which is almost half of what it should be, I believe. Considering that I am getting more than that on a real mac with CoreDuo 2.16... The fans also seem to be running at constant speed, instead of revving up or down. I will include the DSDT here. Would appreciate if you could take a look...

EDIT: Looks like I am at geekbench 2330, which is pretty low.

Attached Files



#1202
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,615 posts
  • Gender:Male
  • Location:BCN
The stepping tables seems to be OK. Re-check them in any case. See if they are loaded on the IO reg.
See if the smbios.plist is ok and the machine model (MacPro 2,1) is loaded; this is required for proper steping.

Note my dsdt is tuned for 4 GB ram only. You need to put the right value in this line:

"OperationRegion (BIOS, SystemMemory, 0xCFF8E064, 0xFF)"

You need to re-dump your DSDT from windows or linux and get that value from it.


I dont have any issues with audio. As I mention before I get some sound assertions errors at boot but the sound works... I'll do some tests over the weekend if I find time.

#1203
bikinifarm

bikinifarm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Chicago, Illinois

The stepping tables seems to be OK. Re-check them in any case. See if they are loaded on the IO reg.
See if the smbios.plist is ok and the machine model (MacPro 2,1) is loaded; this is required for proper steping.

Note my dsdt is tuned for 4 GB ram only. You need to put the right value in this line:

"OperationRegion (BIOS, SystemMemory, 0xCFF8E064, 0xFF)"

You need to re-dump your DSDT from windows or linux and get that value from it.


I dont have any issues with audio. As I mention before I get some sound assertions errors at boot but the sound works... I'll do some tests over the weekend if I find time.


Thanks for the help. Tried a few things, but no go:

- The smbios.plist is ok and the machine model (MacPro 2,1) is loaded;
- Got 8 gigs. But the set-up is still 0xCFF8E064, 0xFF. I think it is related to the ROM version, if I remember right.
- Went thru smbios and org.chameleon.Boot, seems fine, but no dice.

Still single speed fan, and geekbench at 2000 or so... I am out of ideas...

EDIT: OK, I got everything working. Turns out my crappy intel CPU fan had popped up, failing to cool the CPU. Once I seated it back down, the modified dsdt I posted works fine for Q6600 along with blackCH's kexts. I have the geekbench at around 5200 again. So all is fine. Thanks, for all the help.

#1204
lundi

lundi

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
hi guys, thanks for your great work. my system runs very good with mountain lion. i only have a problem with sleep. when i take the pc in sleep mode i cant wake it up. the cpu fan runs during the whole time during sleep mode.
I use the kexts posted from BlackCH and the dsdt file from bikinifarm ( also have a q6600)
Does anyone has an idea how to solve the problem??
Thanks in advance

#1205
elviejo

elviejo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 273 posts

hi guys, thanks for your great work. my system runs very good with mountain lion. i only have a problem with sleep. when i take the pc in sleep mode i cant wake it up. the cpu fan runs during the whole time during sleep mode.
I use the kexts posted from BlackCH and the dsdt file from bikinifarm ( also have a q6600)
Does anyone has an idea how to solve the problem??
Thanks in advance

You see the post from BlackCH about the

"OperationRegion (BIOS, SystemMemory,

0xCFF8E064, 0xFF

)", make sure you put the right value there

:wink2:



#1206
lundi

lundi

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
hmm, I have the same values there.. do I have to change them?
speed seems to be ok, I got 5200 in geekbench

#1207
elviejo

elviejo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 273 posts

hmm, I have the same values there.. do I have to change them?
speed seems to be ok, I got 5200 in geekbench


Is really rare to have different machines with the same value there, to be sure you have to make a clean DSDT ( Linux live cd is a god way to do it ), navigate to that section and check the value in the new obtained DSDT, if is different you need to replace the wrong value with the new one obtained. :wink2:

#1208
lundi

lundi

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
I made the dsdt with DSDTSE under mac osx, hope this is also ok. the values there are: OperationRegion (BIOS, SystemMemory, 0xCFF8E064, 0x2D)
But it doesnt change anything :(
the problem has been since the beginning. with windows it works without problem..

#1209
elviejo

elviejo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 273 posts
Attached File  Asus P5K-VM EFI.zip   3.58MB   28 downloadsAttached File  AppleHDA.kext.zip   1.1MB   25 downloads

I made the dsdt with DSDTSE under mac osx, hope this is also ok. the values there are: OperationRegion (BIOS, SystemMemory, 0xCFF8E064, 0x2D)
But it doesnt change anything :(
the problem has been since the beginning. with windows it works without problem..


You make the DSDT when running a clean installation?, or with another DSDT running in the system, if you make it in a clean installation then you have another problem, this tread have a big section dealing with the kind of problem you have, you can check it over ( I know is tedious ) or you can use the DSDT I posted in the guide about Lion and modify it to adapt to your system, you need to change the processor and OperationRegion values to the values of your system, if you use the EFI method of installation I'm posting the files I use on it, remember, You need a CLEAN DSDT values in OperationRegion section. Good luck. :wink2:

#1210
drone996

drone996

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi,

I followed this thread for a while. now after installing ML and using the files from BlackCH an my DSDT it runs but there is no network (ethernet). tried a lot but no chance. what to do? I use P5K-Vm_2.kext in E/E. even tried Marvel Kext from ox86.net but no ethernet?

thx

#1211
pippopippo1

pippopippo1

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi,

I am running fine 10.7.4...following the BlackCH suggestion to obtain Montain Lion will I lose all my data/application?

In other words is it a new fresh installation (Hard Disk formatted) or only an upgrade that saves data/application?

tks.

bye

#1212
elviejo

elviejo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 273 posts
If you have implemented a backup with Time Machine you can make a clean installation and transfer all your data and applications during the installation, it gives you the choice to do it as part of the installation or after ( it's better to do it during the installation ), so that's not a problem. :angel_not:

#1213
dan b

dan b

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
thanks to Riley Freeman we have AppleHDA.kext 2.3.0 from ML patched for ALC883 (no sound assertions errors):
use:
1. with custom DSDT where HDEF device is added (ALC883 patch or P5K-VM patch) and Layout ID set to 12
2. without DSDT with HDAEnabler.kext

also we have MarvellYukon88E8056.kext working in ML for integrated network (no need to modify IONetworkingFamily.kext)
use with npci=0x3000 and PCIRoot=0 in org.chameleon.boot.plist:
1. with custom DSDT where LAN0 is added or not (doesn't matter)
2. without DSDT

Attached Files



#1214
pippopippo1

pippopippo1

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi,

I followed the BlackCH suggestion in order to install ML.
I followed the guide http://www.insanelym...howtopic=280756 and then installed (from BlackCH):

p5k-vm_2-kext ;
Patched_10.7_Apple RTC.kext;
AppleHDa.kext;

I create a very first DSDT following the guide:
1. Open DSDT Editor
2. Go-to File -> Extract DSDT
3. Go-to IASL -> Compile (if you get any errors click “Fix Errors”)
4. Go-to IASL -> Save AML as. Save it as “DSDT.aml” in /Extra.

Ethernet is working, sound no.

I did not installed yet FakeSMC.kext and JMicronATA.kext from BlackCH.

The hackintosh is running but sometimes it hangs (i think that it does not wake up when goes in sleep mode).

In the S/L/E some Kext have a strange symbol (see photo).

Could You give me some hint?

tks

pippo

Attached Files



#1215
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,615 posts
  • Gender:Male
  • Location:BCN
First, the DSDT has to be extracted under linux or windows. Then decompile, modify and recompile it (use mine as a model; but keep the right values for your RAM, GFX, etc).

Those kexts have wrong permissions. Install them again with kextwizard.

#1216
pippopippo1

pippopippo1

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Hi,

I have got my dsdt file using a Linux live distro with the following command: sudo cat /proc/acpi/dsdt > dsdt.aml

I am trying to compare by dsdt with the one from BlackCH but is too hard for me....

Here my hardware configuration:

Motherboard Asus P5K-VM
Graphics NVIDIA GeForce 8500 GT 1024 MB
Memory 5 GB 800 MHz DDR2 SDRAM
Processor 2.33 GHz Intel Core 2 Duo E6550
Bios 1001
Sata port 0 HD SAMSUNG HD501LJ , capacity 500G
Sata port 1 DVD HL-DT-ST DVDRAM GSA-H62N
Sata port 4 HD Seagate ST31000528AS , capacity 1T
Sata port 5 HD FUJITSU MHY2250BH , capacity 250G
Firewire PCI card


Could You please give me an help?

Thanks in advance.

p.s. I cannot access into my Apple Store account..

Pippo

Attached Files



#1217
pippopippo1

pippopippo1

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
upgrade from appstore to 10.8.2.

loaded again kext from BlackCH...

works everything exept for sleep.

bye

#1218
groggy86

groggy86

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hello,

Currently in 10.6.6 (using the blackch great bootdisc), i want to upgrade to ML..
I have tried two times to follow the guide but i have a problem !

I success to start from the USB key, i also access to the chameleon bootloader, but when i select the usb key for launching the ML installation my computer reboot..

Moreover, if i start from the chameleon bootloader from the harddisk in order to launch the usb key i have this message : "efi inject get devprop string null trying stringdata"

Does it mean something for someone ?

#1219
groggy86

groggy86

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Finally, i finally install it

my problem was resolve by checking Execute Disable Bit : Enabled in the bios

#1220
germi

germi

    InsanelyMac Protégé

  • Donators
  • 5 posts
I have a problem to start my installed ML partition.
I installed ML using the guide BlackCH prefered in post 1198.
I can install the sytem via usb stick, but when try to start the ML partition the monitor freezes and i have start the mac again.
I have installed all the recommended kexts. But i have no idea where the error come from.

It would be nice, if anyone has an idea.

Attached Files







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy