Jump to content

HELP TOPIC - for help in OS X Yosemite (10.10) and below

SL ML AMD APU FX Bulldozer

  • Please log in to reply
2846 replies to this topic

#1961
expertmac2

expertmac2

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male

What bsa kernel do you use?

 

This one: http://www.osx86.net...l-sse4-support/



#1962
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 3,774 posts
  • Gender:Male
  • Location:marocain

Check an AMD kernels that are uploaded here to download. 
http://www.insanelym...gory/6-kernels/  

Or search by Andy Van Dijk BSA kernel R6, R7, R8 or R9 kernel. alternatively you can use the last test of Bronya or cassa. All test kernels can be found here
on insaneleymac. 

http://www.insanelym...n-amd/page-258 


try to boot without busratio


and last sinetek kernel

#1963
expertmac2

expertmac2

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male


Check an AMD kernels that are uploaded here to download.
http://www.insanelym...gory/6-kernels/
Or search by Andy Van Dijk BSA kernel R6, R7, R8 or R9 kernel. alternatively you can use the last test of Bronya or cassa. All test kernels can be found here
on insaneleymac.
http://www.insanelym...n-amd/page-258

try to boot without busratio
and last sinetek kernel


http://www.insanelym...-amd/?p=1998937

That kernel worked for me :lol: Installing now! I will report back if it works!
Apparently "Essential System Software" is missing from my install disk. I'll try to create it again using myhack...
Still getting the same error :| Opening Terminal and running
ls /System/Installation/Packages
shows that all the packages are indeed there though. I suspect it is OSInstall.mpkg, so I'll copy a clean one and apply an MBR patch manually instead of having myHack do it for me...
The partition I created the installer on wasn't big enough! myHack didn't copy Essentials.pkg because there wasn't enough space. Resized it and now I'm creating the installer again

Late update, but successfully installed! Thanks!

#1964
Redbyte

Redbyte

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The Core

Followed Spakk's instructions. Backed up System.kext and Sandbox.kext, installed the update and rebooted into single user mode to copy the kexts back to S/L/E and fixed permissions. Now we're up and running on 10.9.2. System is running HELLA slow, but it's running.

 

I have two systems that I hotswap my OS X drive from and they are very similar. The main difference between the two is one has an FX-8350 plus GTX 680x2 and the other one has an FX-8150 plus GTX 760. I installed OS X 10.9.2 on a second partition on the FX-8150 build without any slowdown in the install but as soon as I would boot up in the account creation menu/desktop (after I had an account set up) it would be as you put it "HELLA slow". But as soon as I moved it over to my main build (See sig) everything is mostly stable and I have no slowdown/lag.


Edited by Redbyte, 04 March 2014 - 07:58 PM.


#1965
iammclovin804

iammclovin804

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Kailua, HI

Hello! Literally just put together my newest rig. Specs are as follows:

Asus A88XM-A mobo

Crucial Ballistix 1866 8GB

Corsair CX430 PSU

AMD A10-7850K APU with R7 graphics.

 

Now my question is, is there a specific kernel to use with the new kaveri APU's? I tried using the Niresh distro and I kept getting kernel panics during installation and I have no idea why. Boot flags I used were -amd -x -v. It wouldn't boot without -x. 



#1966
Li Tan

Li Tan

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Did you try this amd kernel? http://www.insanelym...testing-on-amd/



#1967
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 3,774 posts
  • Gender:Male
  • Location:marocain

sorry mod. Can you please move to the appropriate section?

http://www.insanelym...nel-irc/page-98



#1968
xan1242

xan1242

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Well, since I was pointed here to ask for help, I'll do so.

 

Anyhow, I still haven't found a proper way around BSA kernel getting stuck and (apparently) it never returns a kernel panic, so it just hangs. On the laptop though, what I've noticed is that the kernel extensions are still running, except they're doing absolutely nothing. (ApplePS2Keyboard doesn't recognize some keyboard codes which are the Fn buttons)

 

It seems to me that some change in the opemu code screwed something up. BSA kernel v8 runs on my desktop machine just fine, though.

 

Also, people have found ways around it, but never shared it, exactly.

 

A bit offtopic as well but is there any way of making the old HD 2400 Pro 512 MB to work with Mavericks? My dad also wants a Hackintosh and his only thing blocking it is the GPU. I've been trying to make it to work with SL before, but whenever a framebuffer tried to load, it corrupted the framebuffer for a second and then stopped working. It's a Megalodon framebuffer, I think, since Iago is 256 MB. I also think that Megalodon isn't present in Mavericks, so can I just take the drivers from Lion or SL?

 

I've already tried putting the Device and Vendor IDs in the AMD2400Controller.kext. (pci1002,94c3)



#1969
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 577 posts
  • Gender:Not Telling

...xan1242, see here from 10.9.2...

 

/Users/rustyballs/Downloads/ati-personality.pl.0.15/ati-personality.pl
Script version 0.15
Kext /System/Library/Extensions/AMD2400Controller.kext/Contents/MacOS/AMD2400Controller
Personality: Iago
ConnectorInfo count in decimal: 2
Disk offset in decimal 662352
0000000 02 00 00 00 40 00 00 00 09 00 00 00 00 01 00 12
0000010 00 10 00 00 16 00 00 00 c4 00 00 00 10 00 01 11
0000020

...seems Iago is the only native (AMD2400Controller) personality



#1970
mrjayviper

mrjayviper

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 234 posts

can someone recommend which 10.8.5 kernel to use? thanks



#1971
xan1242

xan1242

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

...xan1242, see here from 10.9.2...

 

/Users/rustyballs/Downloads/ati-personality.pl.0.15/ati-personality.pl
Script version 0.15
Kext /System/Library/Extensions/AMD2400Controller.kext/Contents/MacOS/AMD2400Controller
Personality: Iago
ConnectorInfo count in decimal: 2
Disk offset in decimal 662352
0000000 02 00 00 00 40 00 00 00 09 00 00 00 00 01 00 12
0000010 00 10 00 00 16 00 00 00 c4 00 00 00 10 00 01 11
0000020

...seems Iago is the only native (AMD2400Controller) personality

 

Hm, thanks for telling me this. It seems to me that at least Lion has Megalodon. Will search for the pl script myself and try further. Also I will attempt to run 10.9.1 rather than 9.2, since that's the one I got the OPEMU error with before I knew about rollbacking the kexts for the update.



#1972
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 577 posts
  • Gender:Not Telling

...i just looked again...

 

Kext /System/Library/Extensions/AMD3800Controller.kext/Contents/MacOS/AMD3800Controller
Personality: Megalodon
ConnectorInfo count in decimal: 3
Disk offset in decimal 666400
0000000 00 02 00 00 14 00 00 00 00 00 00 00 00 01 02 11
0000010 04 00 00 00 16 00 00 00 00 00 00 00 00 10 01 12
0000020 80 00 00 00 02 00 00 00 04 00 00 00 00 10 00 00
0000030

 

...there, i see your Megalodon personality(still 10.9.2)



#1973
xan1242

xan1242

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Hmm, interesting. People have gotten the HD 2400 Pro to work in Leopard and Snow Leopard by using the Megalodon framebuffer, but it seems like that framebuffer is made for the 3870. I'll experiment with other framebuffers from the RV630 family. I still don't understand how the 2400 works in regular iMacs and not here...

 

Thanks for looking it up for me, though. I got the script, but haven't ran it yet.



#1974
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 577 posts
  • Gender:Not Telling

...so here's my quandary...I'm running 10.8.3 on an Intel D945GNT/PentiumD(Presler)940, at present using IDE HDD Partitioned MBR:SystemReserved/Win7/MacOSX...i have an external SATA HDD  partitioned MBR: NTFS(Data)/OS10.9.1/OS10.9.2(I use this external SATA drive in the eSATA port of my other box to boot into OS X Mavericks...Win8.1 on internal HDD)...now as i have 2 installs of Mavericks, I am tempted to attach this HDD internally to the Intel box...I'll add a hopefully working(Andy?) amd_kernel(10.9), go with no DSDT, and maybe boot up -v -x UsekernelCache=No from the first OS X partition.

  ...just wondering about the potential of borking my external drive... :smoke:

...and yes, I run Mavericks from an  eSATA HDD(to keep it away from Windows8.1)



#1975
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 3,774 posts
  • Gender:Male
  • Location:marocain

I installed, but in an unconditional way. I used my desktop to install through it's external SATA Mount, copied over the AnV 10.9 mach kernel applied the appropriate kexts, DSDT, edited my chameleon boot file, applied the latest bootloader(chameleon), and then rebuilt S/L/E and E/E from Kext Wizard.

 

Messing with different boot flags I get to a new issue: SleepCapability. Unfortunately any attempt to alter my DSDT with an EHCI patch results it "ATT3" object not existing being produced.

 

On an additional note, the Nonpci kext was applied to my system too. That gave me better results than the "npci=0xX000" flags.

 

What is contained in my Extra Folder: http://dl.dropboxhse...18315/Extra.zip

 

I've included my Original DSDT pulled from an Ubuntu Live session.

 

Image: http://s28.postimg.o...0330_114204.jpg

 

unfortunately I can not download the Extra folder.
either the link is broken, or my firewall is armed?
Please use this provider: http://www.file-upload.net/

 

 

I've looked at your picture,
take the AppleCPUPowerManagement.kext from S / L / E

what kernel are you using at the moment?
what boot flags you're using at the moment?

 

 

Edit:

 

it can various little things (errors) be the cause
a) is the  DSDT.aml fully patched on your system and cleans all the errors by the compilers?
if not, then boot without the DSDT.aml, you're doing as follows:

when entering the boot flags then write -->   DSDT=NO -v -f npci=0x2000 CPUS=1 usekernelcache=No

 

Edit:

otherwise repair the permissions

 

boot with -s

chmod -R 755 /Volumes/Mac/System/Library/Extensions

chown -R root:wheel /Volumes/Mac/System/Library/Extensions

exit

...


Edited by spakk, 30 March 2014 - 07:12 PM.


#1976
DemisesAngel

DemisesAngel

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Not Telling

unfortunately I can not download the Extra folder.
either the link is broken, or my firewall is armed?
Please use this provider: http://www.file-upload.net/

 

....

 

I'm assuming you meant AppleIntelCPUPowerManagement, in which case I did remove that. It made no difference. Kernel is AnV 10.9. My boot flags are set in the chameleon.boot.plist, the link should be correct now.

 

Edit: Your repost still has the incorrect link: https://dl.dropboxus...18315/Extra.zip



#1977
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 3,774 posts
  • Gender:Male
  • Location:marocain

I'm assuming you meant AppleIntelCPUPowerManagement, in which case I did remove that. It made no difference. Kernel is AnV 10.9. My boot flags are set in the chameleon.boot.plist, the link should be correct now.

 

Edit: Your repost still has the incorrect link: https://dl.dropboxus...18315/Extra.zip

 

 

first of all repair the permissions

 

boot with this flag: -s npci=0x2000

 

chmod -R 755 /Volumes/Mac/System/Library/Extensions                        (press Enter)

chown -R root:wheel /Volumes/Mac/System/Library/Extensions            (press Enter)

exit                                                                                                                 (press Enter, then your system reboot)



#1978
DemisesAngel

DemisesAngel

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Not Telling

first of all repair the permissions

 

boot with this flag: -s npci=0x2000

 

chmod -R 755 /Volumes/Mac/System/Library/Extensions                        (press Enter)

chown -R root:wheel /Volumes/Mac/System/Library/Extensions            (press Enter)

exit                                                                                                                 (press Enter, then your system reboot)

You are still aware that I cannot get to single user mode, correct? Any alterations I make are through connecting the HDD to my computer. I could perform those same tasks through Terminal on my working computer, but doesn't 'Kext Wizard' perform the same permission changes to those directories / files?



#1979
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 3,774 posts
  • Gender:Male
  • Location:marocain

oh shit, you're right, I was a few steps too far, sorry :rofl:



#1980
T10NAZ

T10NAZ

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I seen that if I wanted to install the 10.9.2 kernel I would need kexts from 10.9.1? I havent gotten to installing 10.9.1 so is possible to use kexts from 10.9?







Also tagged with one or more of these keywords: SL, ML, AMD, APU, FX, Bulldozer


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy