Jump to content

AudioGod's Aorus Z390 Master Patched DSDT EFI for Catalina Mini Guide and Discussion


AudioGod
1,810 posts in this topic

Recommended Posts

5 minutes ago, hungrywallet said:

• Boot -> Windows 8/10 Features -> Win 8/10

 Settings -> IO Ports -> Above 4G Decoding -> Enabled

 

These are fairly new changes correct or have they always been this way?

Yes correct new changes and good changes too :) 

  • Like 1
Link to comment
Share on other sites

9 hours ago, hungrywallet said:

So what 4K 32" monitor do you guys recommend for development and gaming on the side?  Been looking at some freesync options which I guess are wasted on macoS.


live had a good few 4K monitors in the last few months and I finally settled with a dell 28” with freesync and hdr, they all work so go with what suits you and your eyes but macOS can be problematic with certain monitors like for example a Samsung monitor via a display port clover can’t always work out what the resolution is and you end up with a messed up clover boot splash in the lowest res possible and no fix for it other then enabling CSM in the bios. 
With Dell monitors MacOS sets the colour pallet wrong and you need to force RGB via macOS to correct it. 

 

Link to comment
Share on other sites

7 hours ago, AudioGod said:


live had a good few 4K monitors in the last few months and I finally settled with a dell 28” with freesync and hdr, they all work so go with what suits you and your eyes but macOS can be problematic with certain monitors like for example a Samsung monitor via a display port clover can’t always work out what the resolution is and you end up with a messed up clover boot splash in the lowest res possible and no fix for it other then enabling CSM in the bios. 
With Dell monitors MacOS sets the colour pallet wrong and you need to force RGB via macOS to correct it. 

 

 

Thanks for the input.  Really liking the LG offerings @ 32",  Moving from a dual 1440P 27" setup to a single monitor I'm thinking anything under 32" might feel weird to me.

Link to comment
Share on other sites

35 minutes ago, hungrywallet said:

 

Thanks for the input.  Really liking the LG offerings @ 32",  Moving from a dual 1440P 27" setup to a single monitor I'm thinking anything under 32" might feel weird to me.


one thing about 4K monitors is desktops are better scaled too 1440p or it’s all just too small. That’s what I do and everybody else I know. Even windows defaults the same way with 4K monitors.

32” helps but not that much and the LG Displays are awesome  :thumbsup_anim:

Link to comment
Share on other sites

On 11/27/2019 at 1:37 PM, AudioGod said:


one thing about 4K monitors is desktops are better scaled too 1440p or it’s all just too small. That’s what I do and everybody else I know. Even windows defaults the same way with 4K monitors.

32” helps but not that much and the LG Displays are awesome  :thumbsup_anim:

 

So I got my monitor today and there's one small problem.  macOS detects my 32" monitor as 27".  Any way to change this?  Googling has gotten me nowhere.

 

 

Screen Shot 2019-11-30 at 5.21.33 PM.png

Edited by hungrywallet
Link to comment
Share on other sites

2 minutes ago, hungrywallet said:

 

So I got my monitor today and there's one small problem.  macOS detects my 32" monitor as 27".  Any way to change this?  Googling has gotten me nowhere.

That’s an aesthetic thing and won’t make any difference to the monitor itself. MacOS gets a lot of monitors wrong in lots of ways...as long as the colour palet is correct and res and refresh rate then your good.

Edited by AudioGod
  • Like 1
Link to comment
Share on other sites

Hi All Guys

 

Serial Port option has disappeared from Gigabyte BIOS F10. I can't disable it.

 

So Catalina shows up in Preferences/Network, not configured of course.

 

Do you know how to disable Serial Port via DSDT or specific SSDT? Please.

 

Thanks

 

EDIT: DSDT and SSDT are great, works fine

Serial Port.png

Edited by Matgen84
Link to comment
Share on other sites

22 minutes ago, juanillo62gm said:

Hey guys,

I have this problem with Aorus Z390 Master and RX 5700 XT. Any ideas about how to fix that ? I followed all steps of your bios config and Glasgood's guide.

2019-12-06 22.53.44.jpg

2019-12-06 22.53.46.jpg

 

you need to use the new Catalina 10.15.2 Beta for this to be corrected.

you can also try the new Whatevergreen 1.3.5 and Lilu 1.4.0 kexts beforehand to see if that fixes it for you. 

  • Like 1
Link to comment
Share on other sites

On 12/6/2019 at 11:20 PM, AudioGod said:

 

you need to use the new Catalina 10.15.2 Beta for this to be corrected.

you can also try the new Whatevergreen 1.3.5 and Lilu 1.4.0 kexts beforehand to see if that fixes it for you. 

With an USB with Catalina 10.15.2 beta 4, that kexts and still the same :(

2019-12-10 16.11.10.jpg

Edited by juanillo62gm
  • Sad 1
Link to comment
Share on other sites

On 12/10/2019 at 4:03 PM, juanillo62gm said:

With an USB with Catalina 10.15.2 beta 4, that kexts and still the same :(

2019-12-10 16.11.10.jpg

Fixed

The only thing you have to do (if you have a RX 5700 XT) is finish the installer (In my case using TAB, SPACE, ENTER and mouse to move a bit the window) is a bit tricky but possible

photo_2019-12-10_16-50-46.jpg

  • Confused 1
Link to comment
Share on other sites

20 minutes ago, juanillo62gm said:

Fixed

The only thing you have to do (if you have a RX 5700 XT) is finish the installer (In my case using TAB, SPACE, ENTER and mouse to move a bit the window) is a bit tricky but possible

photo_2019-12-10_16-50-46.jpg

Why are you using 10.15.1 beta when 10.15.2 release is out? 
also your smbios is wrong as it should say what iMac you have and not be blank like that buddy. Ops!

Link to comment
Share on other sites

Hi audiogod

 

i have been reading your posts intently over the holidays I will be updating my system to z390 master is it possible for you to kindly share your open core efi 

  • Like 1
Link to comment
Share on other sites

1 hour ago, gibbo592 said:

Hi audiogod

 

i have been reading your posts intently over the holidays I will be updating my system to z390 master is it possible for you to kindly share your open core efi 


sure i don’t mind but I don’t endorse OC at the moment as there’s to many quirks about it that I don’t like. If your using windows as well as MacOS then Your be in a world of hurt because they do not play well together at all.

im just about to release a new clover EFI that is using the best bits of OC for stability and It’s my best EFI yet so I would recommend going with that when I release it in the next day or two. :thumbsup_anim:

Edited by AudioGod
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

NEW EFI & GUIDE UPDATE 17th December


The EFI has now been updated to the my latest version.

Changes made include,

AptioMemoryFix & FSInject have now been replaced with OcQuirks & FwRuntimeServices,

Clover rc scripts is no longer used or needed,

5700XT Optimised to work as best it can be for now,

WEG 1.3.6 (Beta)

Lilu 1.4.1 (Beta)

Clover Updated too Revision 5100

Plus other minor tweaks and changes

 

EFI Update - 17/12/2019

 

Z390 Master Vega-Navi EFI.zip

Z390 Master RX EFI.zip

 

If you prefer using SMBios 1,1 then by all means switch to it but all the old problems of using 19,1 are corrected now with this EFI plus DRM is fully working unless you have a Polaris GPU. Just to add, SMBios 19,1 is the correct one to be using for our chipset and cpu, if you check the spec of a real MacPro it is not a using a CoffeeLake CPU or Z3xx chipset. It does work perfectly but correct is correct so 19,1 it is.

 

 

I have made this bios profile for you all to use that will unlock CFG on your motherboard making it play alot more friendly with the NVRam.

It also has all the bios settings listed on this guide pre done and saved onto the profile.



 MSR Unlocked.zip

 

1 - Download the profile and save it to a USB Key

2 - Go into the bios,

3 - Load the profile, 

4 - Save and exit

5 - Go straight back into the bios and save your bios to a new profile and name it Default CFG Unlocked or something like that.

6 - Reset your Motherboard by removing the power cable and then remove the battery from the motherboard for a minute or two to clear out the bios fully.

7 - Go back into your bios and load back in the saved profile you made,

8 - Boot back into Catalina go into your clover config and under Kernal and Kext Patches Uncheck KernalPM 

9 - Save the changes and then restart and your done, your motherboard will now be CFG (MSR) Unlocked

 

PLEASE NOTE - If you reset the bios or load bios defaults it will clear the Unlock making CFG Locked again. 

 

Edited by AudioGod
  • Thanks 3
Link to comment
Share on other sites

Hi @AudioGod

 

Thanks a lot, Bro. :)

 

As I said before, my desktop cas is lock, so I can't remove the CMOS Battery. Using back bios button and remove the power cable, do the job? How to do if not?

 

My stupid question: I suppose that your profile contains all BIOS settings for Hackintosh and not only unlocks CFG.

 

Other stupid question: in the latest versions of Clover, they implemented injection without this FSInject.efi driver? Right!

 

Have a nice day :)

Link to comment
Share on other sites

35 minutes ago, Matgen84 said:

Hi @AudioGod

 

Thanks a lot, Bro. :)

 

As I said before, my desktop cas is lock, so I can't remove the CMOS Battery. Using back bios button and remove the power cable, do the job? How to do if not?

 

My stupid question: I suppose that your profile contains all BIOS settings for Hackintosh and not only unlocks CFG.

 

Other stupid question: in the latest versions of Clover, they implemented injection without this FSInject.efi driver? Right!

 

Have a nice day :)


yes the  bios reset button will work but nothing beats popping out the battery,

 

yes all the correct settings as per my guide are in the unlocked CFG profile.

 

no I removed FSinject because of  OcQuirks & FwRuntimeServices, if you look at my beta EFI I sent you with clover 5099 it’s the same deal with the drivers. :) 

  • Thanks 1
Link to comment
Share on other sites

6 minutes ago, AudioGod said:

no I removed FSinject because of  OcQuirks & FwRuntimeServices, if you look at my beta EFI I sent you with clover 5099 it’s the same deal with the drivers. :) 

 

Thanks again :)I do not understand the relationship between OcQuirks+FwRuntimeServices and FSInject. FSInject is the driver that allows Clover to inject kexts from the EFI/CLOVER/Kexts folder. According to my modest knowledge.

 

Do you know the settings include in FwRuntimeServices for Aorus Master: they would be useful for OC testing.

Link to comment
Share on other sites

6 hours ago, Matgen84 said:

Hi @AudioGod

 

Thanks a lot, Bro. :)

 

As I said before, my desktop cas is lock, so I can't remove the CMOS Battery. Using back bios button and remove the power cable, do the job? How to do if not?

 

My stupid question: I suppose that your profile contains all BIOS settings for Hackintosh and not only unlocks CFG.

 

Other stupid question: in the latest versions of Clover, they implemented injection without this FSInject.efi driver? Right!

 

Have a nice day :)

 

 

That should work.  I haven't needed to remove the battery ever with this board to reset nvram.

 

@AudioGod  New EFI has been working lovely so far.  :thumbsup_anim:

  • Like 2
Link to comment
Share on other sites

  • MaLd0n pinned this topic
×
×
  • Create New...