Jump to content
tonyx86

Mojave on Dell Latitude E6410

22 posts in this topic

Recommended Posts

Posted (edited)

I was inspired by @duduclx post for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5.  Everything works perfectly except for sleep.  I'm starting this thread hoping to help others install Mojave on their E6410s and to diagnose and resolve the sleep issue.  This thread is not currently intended to be an installation guide and is better suited to the intermediate/advanced hackintosher.  Eventually, it may evolve into a guide.

 

I started with this thread (Many thanks, @duduclx !!!) and ended up with the system captured in the attached files.  The keys were to change the LPCB._DSM.Name to "3b09" and remove all CLOVER configs not necessary for Mojave, plus some other items mentioned below.

 

My system is as follows:

  • Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17)
  • MacOS: Mojave 10.14.5 (APFS) (Patched with DosDude Mojave Patcher 1.3.3)
  • MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09")
  • Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 5, not the original version)
  • Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext)
  • MacOS: Mojave 10.14.5
  • CLOVER (Legacy): R4961

 

Configuration items that may be different from what you have seen in other E6410 configurations

  • LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2
  • ECDV renamed to EC so that AppleBusPowerController loads
  • AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads
  •  No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states)
  • DSDT patched to include HDAU device (device-id 0x0be3) 

 

What is NOT working:

  • Sleep (display goes blank, but power light stays on.  System cannot wake and must be forced off with power button)
  • Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings.  The slider appears in Display settings (because of the backlight DSDT injection in AGP.VID._DSM), but the slider doesn't work (yet).  Haven't spent time to figure this out, but would love help.
     

What is NOT tested:

  • SD Card Slot
  • Smartcard Reader
  • eSata (I have this disabled in my BIOS)
  • Display Port
  • Firewire Port (it does appear in the Network settings, just haven't tried it)
  • Microphone Jack
  • PC Card Slot (I have this disabled in my BIOS)
  • Camera (I have this disabled in my BIOS)

 

What IS working:

  • Everything else not mentioned above.  
  • Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long
  • Shutdown is fast
  • Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher)
  • Brightness (adjusted with brightness keys on keyboard) works perfectly
  • Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext.
  • Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext)
  • Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout."
  • Ethernet port (with IntelMausiEthernet.kext)
  • Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext)
  • Optical Drive
  • External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: @PlutoDelic) for working external VGA display.
  • Headphone jack

 

Known issues and their solutions

  • AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  This has been completed and tested, but does not fix the sleep behavior.  This fix is not reflected in the attached files.
  • ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement (except for switched keys).  I've implemented and tested this on my system.  The fix is not reflected in the attached files.  I need to fix the switched-keys problem before updating this first post.

 

Brief Installation Guide (for the experienced Hackintosher):

  • Follow duduclx's guide for BIOS config
  • Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh).
  • Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist
  • Install MacOS to your SSD
  • Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original)
  • Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys)
  • Install VoodooHDA
  • Install HWMonitor application

 

Screen Shot 2019-06-08 at 10.19.59 AM.png

Screen Shot 2019-06-08 at 12.11.23 PM.png

CLOVER.zip

Edited by tonyx86
Added missing MacModel

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

EDIT: I found @Hervé 's suggestion mentioned by @duduclx here but it does not resolve the sleep problem for me.  The suggested solution was to apply Rehabman's PRW 0x0D patch.  This patch did not change the behavior of my laptop and did not resolve the sleep problem.  Still looking for a sleep solution.

 

@Hervé in @duduclx thread (here), @hackintoshmalang mentioned that you resolved sleep.  Do you mind sharing your sleep fix?  Thank you!

Edited by tonyx86

Share this post


Link to post
Share on other sites

Installed BrcmPatchRam2.kext and BrcmFirmwareRepo.kext to enable Bluetooth.  Updated Post #1 to reflect the working status of Bluetooth.

Share this post


Link to post
Share on other sites

Changed audio solution to VoodooHDA (from AppleALC) to resolve slow boot issue.  Updated Post #1 to reflect change.  Only remaining issue is Sleep.  Mojave 10.14.5 is OUTSTANDING on this laptop.  Will be PERFECT when sleep is resolved.

Share this post


Link to post
Share on other sites

@hackintoshmalang my EFI is shared as an attachment to the first post in this thread.  Battery life is OUTSTANDING.  With Mac Model set to MacBookPro 6,2 and LPCB._DSM.Name set to "3b09," power management works great with no CLOVER configs.  CLOVER Enable C and Enable P states actually screws up speedstep. Note my clover config.plist attached to post 1 (in the Zip file).  No CPU configs necessary.

 

Have you solved sleep?

Edited by tonyx86

Share this post


Link to post
Share on other sites

@hackintoshmalang I noticed that AGPM (AppleGraphicsPowerManagement) was not loading for my GPU.  Closer inspection of the IORegistry shows that the Nvidia 3100m GPU has a device ID of 0x0a6c which does not have an entry in AppleGraphicsPowerManagement.kext for MacPro 6,2.  Injecting device-id of 0x0a29 (a device that does exist in the AGPM.kext/config.plist) causes AGPM to load.  The other device to try is 0x0a34 (it is the only other device listed in AGPM.kext for MacBookPro 6,2.  Do you know enough to experiment with DSDT injection of these device IDs?  If so, experiment with them to see if they help increase your battery life. 

 

I also renamed ECDV to EC in my DSDT to cause AppleBusPowerController to load (wasn't loading before).  Based on what I've observed of other patched DSDTs for the E6410, a lot is missing.  All the patched DSDTs that I've found for the E6410 include only applications of the basic, well-known patches (except for @duduclx 's very clever shutdown fix which I'd love to know how he figured that out).  I've only started looking at the E6410 a couple of days ago and I'm out of time for now, but will continue experimenting.  Please post your findings here.

 

EDIT: A benefit of manually patching the DSDT for Nvidia Graphics is that the Display Brightness slider now appears in the Display Preferences (see attached screenshot).  The slider doesn't work, so I have some homework to do.  Still controlling brightness with the keyboard.  I have the display brightness slider working on my Thinkpad T61 (ask @Hervé :) - sorry I never could help you get it working on your T61) running Mojave 10.14.5, so I'm looking at my Thinkpad to see if I can figure out why the Latitude E6410 slider is visible but sliding it does not change brightness.

 

Screen Shot 2019-06-11 at 3.19.42 PM.png

Edited by tonyx86
Added comment about shutdown fix

Share this post


Link to post
Share on other sites
On 6/11/2019 at 12:34 AM, hackintoshmalang said:

@tonyx86...hi how is about battery consumption ? and core frequency GPU ...my dell 6410 nvidia stuck at 405 mhz gpu frequency, cause my battery drain out prety fast...do you mind share your EFI ?, thanks

@hackintoshmalang I've been working on my E6410 for 3:20 and just realized my laptop is unplugged.  Battery indicator shows 23% remaining. Over 3 hours on battery from 2010 - not bad.

 

@hackintoshmalang I'm running again without the A/C adapter to get a better feel for battery life.  It appears that these items made the difference:

  • Inject device-id 0x3b09 for LPCB (in concert with selecting Mac Model MacBookPro 6,2)
  • Do not add any CLOVER CPU configs (e.g. don't enable Generate P and Generate C states)
  • ECDV -> EC rename (to get AppleBusPowerController to load)
  • injecting the device-id for Nvidia graphics (0x0a29) (to get AGPM to load)

 

My laptop fan hardly runs and battery life is outstanding.

Edited by tonyx86
Changed Nvidia graphics device-id to 0a29

Share this post


Link to post
Share on other sites

My E6410 is similar in build to yours. Mine is: Dell Latitude E6410 (i5-520m, NVS 3100M, 8GB DDR3 -- Dual 4GB Sticks, 1x OCZ-Vertex 120GB SSD -- MacOS & 1x Corsair Force GT 120GB SSD -- Windows 10 1903/Ubuntu Desktop 18.04, 1440x900 display, BIOS: A17, Wi-Fi: Broadcom  BCM4322 -- Dell Wireless 1510, Bluetooth: BCM92046DG-CL1ROM -- Broadcom 2046 -- Targus). Any suggestions as to things I would have to change (Kexts/Settings/Etc) from your install guide of Mojave to make it work?

 

Thanks for your help in keeping this awesome little laptop current!

Share this post


Link to post
Share on other sites
23 minutes ago, MadHatter806 said:

My E6410 is similar in build to yours. Mine is: Dell Latitude E6410 (i5-520m, NVS 3100M, 8GB DDR3 -- Dual 4GB Sticks, 1x OCZ-Vertex 120GB SSD -- MacOS & 1x Corsair Force GT 120GB SSD -- Windows 10 1903/Ubuntu Desktop 18.04, 1440x900 display, BIOS: A17, Wi-Fi: Broadcom  BCM4322 -- Dell Wireless 1510, Bluetooth: BCM92046DG-CL1ROM -- Broadcom 2046 -- Targus). Any suggestions as to things I would have to change (Kexts/Settings/Etc) from your install guide of Mojave to make it work?

 

Thanks for your help in keeping this awesome little laptop current!

 

Our systems look almost identical, except for Wi-Fi and CPU.  The CPU shouldn't make a difference.  I can't be certain that your BIOS settings are the same, so I'd strongly recommend that you extract your own ACPI files (CLOVER-F4) and patch according to @duduclx 's guide and then my changes (LPCB._DSM, ECDV rename) and inject device-id "0a29" for the Nvidia 3100m so that AppleGraphicsPowerManagement loads.  You might want to google solutions for your BCM4322 wi-fi.  It's possible that Lilu and AirportBrcmFixup 2.0.0 will work for you, too.  Use my CLOVER config.plist.  Keep me posted and definitely let me know if you get sleep to work. I'm getting ready to post an updated set of config files, so get started on yours and then we can compare notes.

Share this post


Link to post
Share on other sites

Ok. Will be grateful to attempt MacOS Mojave install on my E6410. (Also) To accommodate for testing/(fixing) sleep issues, I have a spare HDD to put in place of the SSD. [For sake of testing will also replace modular bay with optical drive -- thus dealing with only 1 storage drive and 1 optical drive]. My WiFi card was previously an almost vanilla card, so if it works great -- if not can replace to match yours (assuming it will work on Ubuntu when finished playing with Mojave install).

 

However for the remainder of this endeavor please treat me as a noob (my apologies). While I have been building computers since '97 and am extremely proficient within Windows, decently proficient within Linux, I am a beginner to "advanced" Hackintosh. I've used Apple OS nearly all my life, however most "Hackintosh" I've built have been nearly vanilla or using a simple fix method like the beast (which cannot apply here).

 

That said, what steps did you take differently from steps #1-#9 of the aforementioned El Capitan guide? (I've never done ACPI extraction before -- I assume this guide "Patching LAPTOP DSDT/SSDTs" is still a good resource?)

 

Any (& all) guidance you would be willing to lend would be appreciated! I look forward to getting the E6410 on Mojave (and with sleep/hibernate working as should be on a HDD -- sorry, still unsure of doing it on a SSD), and eventually end up with a very solid triple-boot system with all the latest OS' installed and flawlessly working.

Share this post


Link to post
Share on other sites

Also a bit of research into sleep/hibernate on a SSD led me to this: http://bit.ly/2WHOmjm

(I was using Win 7 -- prior to final release; with a first gen Kingston 30GB SSD. While this SSD has come back to life, I've never ventured into sleep/hibernate with a SSD again)

So once we can figure out the install (with a simplified installation guide for Mojave) on similar hardware E6410s and find/fix the sleep/hibernate issue, I will be more than happy to attempt replication of said on a fresh install to a SSD rather than a HDD.

 

And to be clear as crystal -- you are booting clover from UEFI not legacy right? (As current, my El Capitan is booting from Clover only in legacy; everything else is an EFI boot -- even within clover).

Share this post


Link to post
Share on other sites
9 hours ago, MadHatter806 said:

...you are booting clover from UEFI not legacy right?

I'm booting CLOVER Legacy.  I have updated Post #1 to include CLOVER (Legacy) as part of my system configuration and I have added new EFI files with updated DSDT.aml (includes HDAU device).

 

Follow duduclx's original guide referenced in post #1 (great instructions!) and then apply my changes here to create your own EFI.

 

EDIT: @MadHatter806 If you're new, I'd suggest installing High Sierra first, since it still supports MacBookPro 6,2 without any Mojave patches.  After you get your system working with High Sierra, then we can talk about Mojave.

Edited by tonyx86

Share this post


Link to post
Share on other sites

This thread was not intended to be an installation guide.  I have a long way to go to match the outstanding instructions presented by duduclx in his original guide for install El Capitan on the E6410.  While most of my comments will remain most suitable for intermediate to advanced hackintoshers (not claiming any expertise of my own), I have added basic installation steps to post #1 of this thread.

Share this post


Link to post
Share on other sites
On 6/11/2019 at 12:34 AM, hackintoshmalang said:

@tonyx86...hi how is about battery consumption ? and core frequency GPU ...my dell 6410 nvidia stuck at 405 mhz gpu frequency, cause my battery drain out prety fast...do you mind share your EFI ?, thanks

 

@hackintoshmalang I'm not ignoring your "stuck at 405 mhz" comment - it just hasn't been a priority for me.  My method of injecting the device-id for Nvidia gets AGPM loaded, but it's probably not the correct solution.  I re-read duduclx original El Capitan thread and saw that @Hervé had done some OUTSTANDING work on this.  See here for his analysis.  I haven't tried any of it yet, but what he does makes a lot of sense. 

Share this post


Link to post
Share on other sites

EDIT2: updated Clover.zip with new NVCAP is now attached to Post #1.

 

EDIT: It turns out that I only needed @PlutoDelic 's NVCAP.  It appears that I had the wrong NVCAP in my Nvidia config.  Once I changed my NVCAP to match the one specified by plutdelic, my second display started working.  I was using the NVCAP that was automatically injected by CLOVER R4961, so it looks like CLOVER was injecting the wrong NVCAP for the 3100m in the Latitude E6410.

 

Originally posted before EDIT above:

I needed a second display on my E6410 and found that external VGA wasn't working.  Take a look at @PlutoDelic 's post in the duduclx's original el capitan thread.  I copied his config.plist configuration exactly into my config.plist and my external VGA is now working.  I have more work/experimentation to do in order to see exactly what change(s) is/are required, but for now, just copying plutodelic's config works.

Edited by tonyx86

Share this post


Link to post
Share on other sites

EDIT: I found this guide for Yosemite that includes the _PTS shutdown patch in the patched DSDT.  Still no indication of how this patch was determined.

 

FYI - I'm starting to track down the sleep issue.  @duduclx's  _PTS patch (for shutdown) is incomplete for sleep in High Sierra and Mojave (not sure about previous MacOS versions).  If anyone know's how he arrived at his _PTS patch, I might be able to determine the necessary changes to get working sleep.  A clue for others who want to help find the sleep solution is that the following modification to his shutdown patch (removing the conditional if/else) enables sleep, but the laptop then wakes immediately with a black screen.  I'm fairly certain that the black screen is because we need to modify _WAK as well.  I've applied Rehabman's PRW 0x0D patch (I think I applied it correctly if someone wants to check the DSDT I attached to Post #1) which was supposed to address the immediate wake from sleep, so I'm not sure why it wakes immediately.

 

    Method (_PTS, 1, NotSerialized) 
    {
            Store (Zero, SLPE)
            Sleep (0x10)
    }
Edited by tonyx86
Added historical link

Share this post


Link to post
Share on other sites

I traced the _PTS shutdown fix back to the beginning of Hackintosh time here.  The patch was only ever intended to resolve shutdown (to be conditional on LEqual (Arg0, 0x05)).  SLPE appears to be a register for controlling NVidia dGPU.  The same _PTS shutdown patch is required for the Thinkpad T61 for those who are curious (although SLPE is at a different location on the Thinkpad T61 (NVS 140m): OperationRegion (PMRS, SystemIO, 0x1030, One) ).  Looks like sleep on the Latitude E6410 is going to be a challenge.

 

EDIT: For the interested reader, here's more about SLPE and shutdown / sleep.

Edited by tonyx86
Added link with more info...

Share this post


Link to post
Share on other sites

I noticed that AAPL,clock-id and device_type are absent from the IORegistry for EHC1 (EH01).  I don't see anything wrong with my DSDT rename/_DSM for EH01 (in DSDT.aml) and USB ports work correctly, but I'd like to eliminate any potential USB issues in order to resolve this sleep problem.  The only fix I found (thanks to @feartech) was to use CLOVER on-the-fly rename/fix for USB.  I have changed this on my system and tested it.  Unfortunately it does not resolve the sleep problem (no change in sleep behavior).  I haven't updated the attached files in Post #1 to reflect this change.

Share this post


Link to post
Share on other sites

Alps trackpad performance is lousy with the "standard" VoodooPS2Controller.kext (a known issue).  Switching to the "Refined ALPS Touchpad driver" is a big improvement.  I made the switch, but haven't updated the attached files in Post #1 to reflect this change.

 

EDIT: The "Refined VoodooPS2Controller.kext" switches keys on the keyboard.  Annoying.

 

EDIT2: Key remapping in "System Preferences > Keyboard > Modifier Keys" may do the trick.  Switch the Option and Command keys.  See attached screenshot and reply with your own suggestions.

Screen Shot 2019-06-15 at 5.17.31 PM.png

Edited by tonyx86
Having trouble attaching the screenshot

Share this post


Link to post
Share on other sites

I have been able to modify my DSDT to get close to a working sleep solution for the Latitude E6410. I now believe that the solution will combine a change to _PTS and a change in _EJD (Ejected Device notification). Search for _PTS and _EJD in my attached DSDT.aml and you will see what I mean. With these changes in the attached DSDT.aml (attached to this post, not the first post), the USB device at EHC1.PRT1 generates the Ejected Device notification (not the device at EHC2.PRT3 which doesn't exist). The original DSDT has the _EJD notification in EHC2.PRT3 which doesn't have a device present and thus doesn't trigger an _EJD notification. With this change, the laptop shuts down on sleep. I feel that this is very close and I could use any help and advice. I suspect that SLPE should only be set to zero in _PTS for shutdown and that something else should be done for sleep. If I move Store (Zero, SLPE) back into the if condition (so that SLPE is only set to Zero on shutdown), the laptop does not shutdown (or sleep) when I attempt to put it to sleep, so something similar to Store (Zero, SLPE) is still required for sleep.

DSDT.zip

Edited by tonyx86

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Patch Catalina or Mojave macOS Installer App for Unsupported Machines
       
      Often for economic reasons, Apple prevents the Installer.app for its latest macOS from installing on older machines perfectly capable of running it eg macOS 10.14 Mojave on Unsupported Macs Thread.
       

       
      In Mojave 10.14, @ASentientBot posted a method to patch the distribution file in OSInstall.mpkg to enable the Mojave installer to install on unsupported machines (with or without graphics card metal support). 
       
      In Catalina 10.15beta, the above method no longer works since Apple is checking OSInstall.mpkg for its file signature and the mandatory requirement in Catalina to install to 2 separate apfs volumes necessitates using the original Catalina macOS Base System Installer.  Fortunately, it is still possible to substitute High Sierra’s Apple Signed OSInstall.mpkg inside the Catalina or Mojave InstallESD.dmg by making it R/W.
       
      The procedure below will allow Macs or Hacks able to install High Sierra to also install Catalina or Mojave (eg SMBIOS MacPro5,1, iMac11,3, MacBook Pro7,1 which have been unsupported in macOS 10.14.x and 10.15beta) -credit to @ASentientBot's post.
       
      Prerequisites
      1. Mac or Hack capable of and running High Sierra 10.13.x
      2. An original, untouched copy of OSInstall.mpkg from High Serra InstallESD.dmg - attached OSInstall_10.13.6.mpkg.zip save to your ~/Downloads folder
      3. macOS Installer App eg for Catalina beta or Mojave downloaded to /Applications
      4. Add NVRAM boot arg (or Clover config.plist boot arg on a hack) -no_compat_check to enable system to boot to final completed Mojave or Catalina install.
       
      Procedure
      1. Open Terminal and type the following
       
      open /Applications/Install*/Contents/SharedSupport/InstallESD.dmg (assuming the Catalina or Mojave Installer App is in /Applications)  
      2. Open Disk Utility, click File|New Image|Image from ‘InstallESD”
      3. Save as read/write image, no encryption in /Applications
      4. Unmount InstallESD in DU by clicking the "eject" icon next to it
       
       
      5. Open the R/W InstallSD.dmg in /Applications and replace Catalina’s/Mojave's OSInstall.mpkg with High Sierra’s version by typing in terminal
       
      open /Applications/InstallESD.dmg cp ~/Downloads/OSInstall_10.13.6.mpkg /Volumes/InstallESD/Packages/OSInstall.mpkg  
      6. Unmount InstallESD in DU by clicking the "eject" icon next to it
      7. Replace original Catalina/Mojave InstallESD.dmg with our patched one, making a backup of the original.  In terminal, type
       
      sudo mv /Applications/Install*/Contents/SharedSupport/InstallESD.dmg /Applications/InstallESD_orig.dmg sudo mv /Applications/InstallESD.dmg /Applications/Install*/Contents/SharedSupport/  
      8.  Test the newly patched installer!…

    • By Coddyx
      Hi,
       
      I followed the AMD OSX Vanilla Guide and managed to successfully build my first hackingtosh.
      Everything works great EXCEPT for my MSI - Radeon RX 580 8 GB GAMING X.
      I ran some benchmarks (and tried World of Warcraft) and I am getting ~50% of the performance I am usually getting in Windows 10.
      Unigine Heaven reports ~950 vs 1750 in Windows and World of Warcraft runs @ 30 fps lowest settings vs 60 fps ultra settings in Windows.
       
      Here are the kexts I am using:
      AppleALC Lilu NullCPUPowerManagement RealtekRTL811 VirtualSMC WhateverGreen  
      I should mention that this is an AMD hackingtosh running on Ryzen 5 1600 3.2 GHz 6-Core Processor.
       
      I read and I completely understand that I should not expect 100% performance. But I believe a 50% drop is out of the ordinary.
       
      If anyone has ideas on what I could try to up the performance it would be greatly appreciated.
       
      Thank you!
       
       
    • By fusion71au
      Clover r4961 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4961 for VMware.zip". Mount Clover-v2.4k-4961-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By ludufre
      Installing macOS Mojave 10.14.5 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      06/10/2019 00:44h GMT-0
      - Completely rewritten.
       
      10/17/2018 08:12h GMT-0
      - Fix Kexts permissions commands adjusted.
      - Removed FrameBuffer patch that is not needed.
      - Added audio solution and HDMI.
      - Unfortunately DisplayPort does not work.
      - Replaced Wifi/BT with DW1560 (BCM94352Z)
       
      10/11/2018 04:15h GMT-0
      - Added USB 3.0 patch.
      - Adjusted some steps.
      - Changed text formatting.
       
      10/11/2018 03:42h GMT-0
      - Added missing UEFI configuration.
       
      10/07/2018 00:36h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Not tested yet.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Make audio work.
      - Make HDMI audio work.
      - Test DisplayPort.
      - Make second ethernet work.
      - Replace Wifi/Bluetooth.
      - Test DP.
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover Configurator
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install--nointeraction This will take about 30 minutes.
       
       

      Install bootloader

      Download the CloverEFI (used 4953, from Automated Clover Builds) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix-64
      - UEFI Drivers - HFSPlus
      - UEFI Drivers - NvmExpressDxe-64 (I have an NVME SSD)
      - FileVault 2 UEFI Drivers (I strongly recommend enable FileVault)


       
       
      Make things works
       
      We'll make a full working flash drive, so follow these instructions:
       
      Will be mounted the EFI partition of the flash drive.
       
      Open the the /Volumes/EFI/CLOVER/config.plist inside this new partition with Clover Configurator (used 5.4.4.0)
       
      Important modifications
       
      config.plist

      BOOT Page
       
      - Add: Arguments - darkwake=2
      - Uncheck: NeverDoRecovery
      - Check: Legacy - XMPDetection=Yes
       
      KERNEL AND KEXT PATCHES Page
       
      - Check: KernelPm
       
      RT VARIABLES Page
       
      - Change: CsrActiveConfig - 0x3
       
      SMBIOS Page
       
      - Change: Macmini8,1 - Mac mini (Late 2018) | Intel Core i7-8700B @ 3.20 GHz

       
      - Click: Generate New (few times in the two buttons)

       
       
      Need some Kexts in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the HWSensors 3 from here. I used the FakeSMC.kext, ACPIMonitor.kext and IntelCPUMonitor.kext inside of DMG version r196.
      - Download the Lilu.kext from here. I used the version 1.3.6.

       
      Intel UHD 630
       
      ACPI Page
      - Uncheck: Fixes - AddHDMI
      - Uncheck: Fixes - FixDisplay
      - Uncheck: Fixes - FixHDA
       
      GUI Page
      - Change: Screen Resolution - 3840x2160 (My monitor is 4K)

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the WhateverGreen.kext from here. I used the version 1.2.9.

       
      Audio ALC 1220 and HDMI audio

      BOOT Page
      - Add: Arguments - alcid=11

      DEVICES Page
      - Change: Audio - Inject - 11
      - Uncheck: Audio - AFGLowPowerState
      - Uncheck: Audio - ResetHDA

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the AppleALC.kext from here. I used the version 1.3.8.

       
      All USBs (2.0, 3.0, Type-C, internal)
       
      KERNEL AND KEXT PATCHES Page - KextsToPatch
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 1 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 2 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 3 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FF0F0F
      - Replace* [HEX]: 83FF3F0F
      - Comment: USB Port Limit Patch 4 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Need SSDT patch in the folder /EFI/CLOVER/ACPI/patched/
       
      - Download the SSDT-EC.aml, SSDT-UIAC.aml and SSDT-USBX attached bellow.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      LAN Cards
       
      Need a Kext for feach card in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the IntelMausiEthrenet.kext from here. I used the version 2018-1031.
      - Download the SmallTreeIntel82576.kext attached bellow. I do not remember where I found it.

       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: Periphelrals - Initial Display to IGP
      - Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Change value: Chipset - DVMT Pre-Allocated to 128M
      - Save & Exit Setup
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - It will show twice. One with UEFI prefix and another without.
      - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer"
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "HD".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the EFI folder inside your destination disk EFI parittion, with EFI folder inside flash card EFI partition.

      If the flash drive EFI partition of your destination disk or flash drive is unmounted:
      Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 0 for destination disk and 1 for flash drive.
       
      Then, eject the flash drive.
       
      Last step
       
      Move all Kexts from EFI partition to /Library/Extensions, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
       
       
       
       
       
       
      Z370N-WIFI.zip
×