Jump to content
About Just Joined group Read more... ×
duduclx

[GUIDE] Dell Latitude E6410 Nvidia El Capitan Clover [ENG]

217 posts in this topic

Recommended Posts

here it is:

https://drive.google.com/open?id=0B-sUmdgLOBgBUWVYRmZ3UUdiX1k

 

there's an efi folder in it ...

 

you may need to change audio patch if you install 10.11.2 or above.

 

here is a partial config file for clover, with some test patches to have DP + vga working through the port station.

not sure it will work, just an exemple to find a way to have all video ports working with the dock station.

-- > https://drive.google.com/open?id=0B-sUmdgLOBgBVThOM0dzVEhkdDg

(normaly, vga work out of the box with and without port station)

 

Remember, i don't have this computer anymore ... and don't support this tread anymore.

Because this laptop is outdated.

 

i just can say that it was working great with my dell e6410 and this guide.

if something's wrong, restart the guide, and debug yourself (also, google is your friend).

 

i took time to write a "from scratch" guide, allowing people to understand and change things to support an updated osx.

i don't like to give a folder "ready to use" ... copy/paste a folder is not a guide and don't provide knowledge.

 

hope you'll have a working mac on your laptop, but can't do more about that.

 

cheers !

 

EDIT:

about wireless, here a ref i used on many computer:

https://www.amazon.com/AzureWave-Broadcom-BCM94352HMB-BCM94352-867Mbps/dp/B00JY6X9HM

 

the last i used, with ngff m2 port is:

Broadcom-BCM94352Z-M-2-NGFF

 

no driver needed !

 

about sleep, hervé know it good ...

for this laptop, i doesn't disable/enable it for the system (no patch or tips).

i've just set to never sleep in the preference panel.

 

here is a tips from hervé about sleep issue with an other computer (dell e6230):

http://www.insanelymac.com/forum/topic/311218-guide-dell-latitude-e6230-1010x-100-eng/?p=2231717

looks like adding a patch on the dsdt do the work as well !

 

cheers again !

Edited by duduclx

Share this post


Link to post
Share on other sites
Advertisement

Hi Duduclx; I have followed everything for my E6410, but after configuring the clover file and putting the config.plist in efi/clover, I get stuck with the following screen shots; the second screen shot shows the circle sign with mutulated text...

 

What do you recommend me to do ? Will try to give the config.plist file as well here.

 

Thanks for baring with me  B)

 

Bart

I cannot upload the content of my usb stick because in compressed form it is 20 MB which is too big :(

I was successful boot into installer without any error. Put Fake.SMC.kext", "ApplePS2SmartTouchPad.kext", "NullCPUPowerManagement.kext", "VoodooHDA.kext" (If needed) and "VoodooPS2Controller.kext" in "Other" Folder and delete everything, just leave folder "Other"

Share this post


Link to post
Share on other sites

I was successfully boot into the installer without any error during boot. Here how. 

 

1) Extract The Archive

2) Extract All

3) Copy "DSDT.aml" into EFI/Clover/ACPI/patched

4) Copy "config.plist" into EFI/Clover

5) Go to EFI/Clover/kexts and delete everything,  just leave "Other" folder

6) Copy kexts in EFI/Clover/kexts/Other

 

Done, unplug the drive and go to your PC

 

1) Start up your PC and hit F2 for BIOS Setup

2) Select "Load Default"

3) Go on "System Configuration>SATA Operation and change SATA mode from "RAID" to "AHCI Mode"

4) Save and Exit

5) Press F12 on startup

6) Select Your USB drive

7) At Clover screen, go to options

8) Set the following boot_args: -v slide=0 nv_disable=1 kext-dev-mode=1

9) Go to Binaries Patching Menu and set the following FakeCPUID: 0x000206A0

10) Hit Exit

11) Go to your USB Drive, hit space (DO NOT HIT ENTER)

12) Select Boot Mac OS X in verbose mode

13) Once You reach to the installer, follow the tutorial

 

 

 

Hope this help you

Solution Fix.zip

Share this post


Link to post
Share on other sites

Hi all! Wow time flies; Is anybody interested in getting High Sierra installed and working on the E6410. I still love this machine and it is now very affordable. Best 'Bang for the Buck'  :yes: . Please let me know. 

 

Cheers, Bart

Share this post


Link to post
Share on other sites

I am very interested in getting high sierra working on the e6410. Love this machine. Only thing that bothers me is it’s a dual core i7. Not exactly great for video production but still pretty decent.

Share this post


Link to post
Share on other sites
On 10/15/2017 at 1:46 PM, bartrap said:

Hi all! Wow time flies; Is anybody interested in getting High Sierra installed and working on the E6410. I still love this machine and it is now very affordable. Best 'Bang for the Buck'  :yes: . Please let me know. 

 

Cheers, Bart

I actually done it on dell E6410 High Sierra 1 year ago

Share this post


Link to post
Share on other sites
On 11/21/2016 at 3:00 AM, duduclx said:

With my setup and guide, battery and battery management and shutdown are working perfectly.

About sleep, Hervé did the trick.

 

One thing upsetting me is to debug what person did and help him to do what i have write.

 

So i prefer skip the "support" part and move to a tool / dev project.

 

I'm happy to see people enjoying hackintosh using one of my guide, or people getting way over (like @midi on the ativ pro).

But i can't spend my time.

 

I prefer install kexts by myself Than using app, to install it where i want and give people some skills.

 

I still think than hackintosh need to learn and use OS X (and unix system) from a certain time.

 

I've started my first hackintosh on an Asus with os x 10.5.1.

About 9 years i use only hackintosh laptop and servers.

 

Hope people will understand what was in my mind and will continu it without me.

 

Learn, test, do, compare and more is up to you !

 

Cheers

@duduclx...can you give me link how @herve do the trick for sleep/wake on this machine ?...best regards

 

Edited by hackintoshmalang

Share this post


Link to post
Share on other sites

I know this is an old thread, but I followed this guide exactly to patch my E6410 DSDT and created a Mojave installer using DosDude's Mojave Patcher.  I just booted the installer and was able to get to the install GUI, but that's as far as I've gotten (need to make time to continue).  Anyone interested in getting Mojave to work on this E6410?

Share this post


Link to post
Share on other sites

Just curious - does anyone have sleep working on the Latitude E6410 (with Nvidia NVS 3100m graphics) on ANY version of MacOS?  If so, what version of MacOS and what was the trick?  I'm at the point where my E6410 dual-booting High Sierra / Mojave is working perfectly with the exception of sleep.  Attempts to sleep in both High Sierra and Mojave turn off the display, but the laptop is still on and the only way to recover is to force power-off with the power button.  Thank you for any help.

 

BTW - I did try @Hervé 's suggestion on Page 9 of this thread to apply Rehabman's PRW 0x0D patch (returning 0x0D, 0x00 instead of 0x0D, 0xXX), but that did not work for me.  Even with Rehaman's patch sleep doesn't work for me.  If anyone else has successfully implemented @Hervé's or another sleep suggestion, can you share it?  Thank you.

Edited by tonyx86

Share this post


Link to post
Share on other sites

I currently do not use sleep on my Latitude E6410. I use (x2) ssd(s) on my laptop. [Currently drive #1 is MacOS El Capitan -- following this guide, with several issues I have yet to take the time to resolve; Drive #2 is a dual boot drive with Windows 10 1903 & Ubuntu desktop 18.04] SSD & Sleep/Hibernate (maybe only used to???) kill an ssd drive. (Really don't want to take that chance).

 

A side note, as per your specs on your post of Mojave install, my E6410 is similar in build to yours. Mine is: Dell Latitude E6410 (i5-520m, NVS 3100M, 8GB DDR3 -- Dual 4GB Sticks, 1x OCZ-Vertex 120GB SSD -- MacOS & 1x Corsair Force GT 120GB SSD -- Windows 10 1903/Ubuntu Desktop 18.04, 1440x900 display, BIOS: A17, Wi-Fi: Broadcom  BCM4322 -- Dell Wireless 1510). Any suggestions as to things I would have to change from your install guide of Mojave to make it work? (I will also post this question on that thread)

 

Thanks for your help in keeping this awesome little laptop current!

Share this post


Link to post
Share on other sites
On 3/22/2016 at 5:52 AM, PlutoDelic said:

A quick general question on this one.

 

I have installed Clover on the EFI partition in the first disk where Windows resides. I have found out that the only way to detect an UEFI Clover and boot is through the Windows EFI and not the standard one. That being said, i can run Clover without any issue, and this time it even injected the boot options in to the UEFI/BIOS, which i never could before.

 

I need to know if i can avoid having Clover on the USB at all, since it will detect the USB with the OS X installer inside.

 

PS, a year a go i made some config.plist changes which resulted in VGA and DP Port working in Mavericks and Yosemite, it worked through the Dockin Stations as well, although i never got audio from the DP. have a look at the attachment...

 

EDIT: here's the proof of research and trail...

config.plist_VGA+DP.zip

 

@PlutoDelic I'm experimenting with VGA-out on my Latitude E6410 with Mojave.  Your Nvidia configuration in CLOVER config.plist enabled my external VGA port (not working without it).  It turns out that the only thing required from your configuration (at least for me) is the NVCAP.  I was using the wrong NVCAP (the one automatically injected by CLOVER R4961) and yours fixed it!  It looks like CLOVER R4961 injects the wrong NVCAP for 3100m graphics in the Latitude E6410.  Nice work!

Edited by tonyx86

Share this post


Link to post
Share on other sites

@duduclx - I'm not sure, but I'm hoping you might still be paying attention to this thread.  I'm impressed with your shutdown patch in _PTS.  Nice work!!!  I think that your patch may offer a clue to sleep.  Can you please explain how you arrived at your _PTS shutdown patch?  I have reviewed sleep fixes for other Latitude models and they all involved modification of _PTS (and _WAK).  In the other cases, they called _OFF and _ON methods that were defined in SSDTs.  The E6410 doesn't have these _OFF and _ON methods, so I believe the key is to manually set the correct register(s) like you have done for shutdown.  If you can explain how you arrived at your shutdown solution (below), that would be a big help.  Thank you!!!  And thanks for this guide - VERY NICE WORK!

 

    

    OperationRegion (PMRS, SystemIO, 0x0430, One)
    Field (PMRS, ByteAcc, NoLock, Preserve)
    {
            ,   4,
        SLPE,   1
    }

 

 

    Method (_PTS, 1, NotSerialized) 
    {
        If (LEqual (Arg0, 0x05))
        {
            Store (Zero, SLPE)
            Sleep (0x10)
        }
        Else
        {
            APTS (Arg0)
            EV5 (Arg0, Zero)
        }
    }

 

Share this post


Link to post
Share on other sites

@duduclx I have proof that your _PTS logic is key to sleep.  I removed the conditional as shown below and sleep "works," but the system wakes immediately with a black screen.  I suspect that your _PTS logic requires some modification and that there is "inverse" logic that needs to be applied to _WAK.  I'm happy to look at this if you can provide insight into how you arrived at your _PTS logic.  Thank you!

 

    Method (_PTS, 1, NotSerialized) 
    {
            Store (Zero, SLPE)
            Sleep (0x10)
    }
Edited by tonyx86

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      This thread for installing Catalina on the Dell Latitude E6410 WITH NVIDIA GRAPHICS (BIOS A17, NVidia 3100m) will help you install a fresh installation of Catalina on your Dell Latitude E6410, it will help you upgrade from 10.15.2 to 10.15.x (if you originally installed Catalina from this thread) and it will also help you upgrade from Mojave 10.14.6 if you have already installed Mojave by following the instructions here.  The instructions in this first post assume that you are installing Catalina in an APFS container.  If you are curious about the evolution of this solution and how sleep/wake was solved, review the Mojave installation thread.
       
      Important: This Thread is NOT intended to help you install macOS on a Latitude E6410 with Intel HD Graphics (without Nvidia graphics).  The DSDT attached to this first post (in E6410-Catalina.zip) is VERY SPECIFIC to the Nvidia graphics implementation and has not been edited for HD Graphics - there are elements required for HD Graphics that are missing from the attached DSDT and there are DSDT mods that have not been tested with HD Graphics.  Also, the kexts attached to this first post are specific to a Broadcom Wi-Fi card which must replace the original Intel Wi-Fi card.
       
      This first post will be modified to reflect lessons learned and to reflect the most current working state of my Latitude E6410 (with NVidia 3100m discrete graphics) running Catalina.  Issues, observations and performance tips are recorded toward the bottom of this first post.  My recommended CLOVER configuration is specified toward the bottom of this first post.
       
      *** If you want help with your installation, please post your issue along with problem reporting files generated using @black.dragon74's problem reporting tool.  Google 'GENERATE PROPER PROBLEM REPORTING FILES black.dragon74' to find it. ***.  If Catalina's Read-Only protections block your installation of black.dragon74's gen_debug script, please copy the attached gen_debug script to your Desktop, change script properties with the terminal command 'chmod a+x ~/Desktop/gen_debug' and run the script from your Desktop.
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) Wi-Fi: Broadcom BCM 94352HMB (replaced original Wi-Fi card) BIOS (version A17) configured as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC:Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace:Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;   
      Versions of the software used in this installation are listed below the installation steps.  EFI and kexts for Catalina are attached to this first post in E6410-Catalina.zip.  CLOVER configuration is specified below the installation steps.  You MUST BE LOGGED-IN to download attachments from this forum.
       
      Wi-Fi connection to an Access Point is delayed when using AppleALC for sound.  Do not use Apple ALC.  Use VoodooHDA pkg 2.9.2 v15 for sound.
       
      Steps to install Catalina on a Dell Latitude E6410 (BIOS A17, NVidia 3100m)
       
      If you want to upgrade to 10.15.7, see instructions at this post.
       
      If you want to upgrade to 10.15.6, see instructions at this post.
       
      If you want to upgrade to 10.15.5, see instructions at this post.
       
      If you want to upgrade to 10.15.4, see instructions at this post.  
       
      Follow instructions below for 10.15.2 and 10.15.3.
       
      Make sure that your system matches my system description above (including BIOS version, Wi-Fi card, BIOS settings) If performing an upgrade from Mojave or a previous version of Catalina, backup your Mojave or Catalina partition! (Carbon Copy or similar) Download Catalina Installer Download DosDude Catalina Patcher Use DosDude Patcher to create Catalina USB Installer Delete LegacyUSBInjector.kext (we're using @RehabMan's USBInjectAll.kext with custom SSDT) and delete SIPManager.kext (CLOVER is managing SIP) from Catalina USB Installer's /Library/Extensions folder Copy all but the FakeSMC sensor kexts in E6410-Catalina.zip (attached) LE folder to the Catalina USB Installer /Library/Extensions (copy all kexts (including FakeSMC.kext) but not the FakeSMC sensor kexts) Install CLOVER Bootloader (Legacy) on USB Installer using the EFI in the E6410-Catalina.zip (attached).  Use the CLOVER configuration specified below.  Be sure to replace the XX-MASKED-XX parameters in the attached config.plist with your own values. Reset your Latitude E6410 NVRAM by doing the following (this may be important if you're making changes to your existing EFI and won't hurt anything if you're not making any changes) turn-off your laptop remove A/C power and main battery press and hold the power button for 30 seconds restore A/C power and battery Boot your Latitude E6410 from the Catalina USB Installer that you created in steps 5-8. Select "Reinstall macOS" (note that I have existing installations of Mojave and High Sierra on my Latitude E6410, so it's possible that this menu item changes to "Install macOS" if you don't have any previous macOS installations). Select your Catalina destination partition (which will be your Mojave or previous Catalina partition if you are upgrading) After the Catalina Installer reboots the first time, boot from the "macOS Installer" partition on the disk that you selected as your Catalina destination (not the macOS installer on the USB) After the Catalina Installer reboots the second time, boot the Catalina macOS Installer on the USB Select the Post Install Patcher utility Select only the following Post Install Patches (no other patches / options) Install Patch Updater Legacy Video After the Post Install Patcher reboots,  boot from the newly installed (or upgraded) Catalina partition and complete the macOS configuration Remove these kexts (if they exist) from /Library/Extensions: LegacyUSBInjector.kext, LegacyUSBVideoSupport.kext and SIPManager.kext If you are performing a fresh installation of Catalina: Install CLOVER (LEGACY - NOT UEFI) on your boot disk and configure EFI using files in the attached E6410-Catalina.zip.  Use the CLOVER configuration below.  Be sure to replace the XX-MASKED-XX parameters in the attached config.plist with your own values. Install all kexts in the attached E6410-Catalina.zip LE folder to your /Library/Extensions folder. Copy HWMonitor from the application folder in the attached E6410-Catalina.zip to your Applications folder. Install VoodooHDA (I installed using the Classic method) Skip to Step 21 If you are upgrading from a previous version of Catalina using the instructions from this thread or from Mojave that you installed using the instructions here: Replace 3rd-party kexts in EFI/Clover/kexts/Other with those in the attached EFI folder.   Replace EFI/Clover config.plist with the attached config.plist (Be sure to replace the XX-MASKED-XX parameters in the attached config.plist with your own values) Replace EFI/Clover/ACPI/patched with the files in the attached EFI/Clover/ACPI/patched Replace 3rd-party kexts in /Library/Extensions with those in the attached LE folder Remove VoodooSDHC.kext from /Library/Extensions Re-install VoodooHDA if necessary (I installed using the Classic method for Catalina) Ensure PROPER kext installation: If you're manually installing kexts in /Library/Extensions, make sure that you execute the following (in terminal) cd /Library/Extensions sudo chown -R root:wheel *.kext sudo chmod -R 755 *.kext sudo kextcache -i / After you execute 'sudo kextcache -i /' you should observe that ALL kexts are allowed.  If not, your kext directory attributes are probably incorrect.  Repeat kext installation and try again. Reboot from your new/upgraded Catalina partition Welcome to macOS Catalina! Change the keyboard type to ISO (System Preferences > Keyboard > Change Keyboard Type) Swap the Command and Option keys (System Preferences > Keyboard > Modifier Keys) Set hibernatemode: In terminal, execute sudo pmset -a hibernatemode 0 sudo rm -f /var/vm/sleepimage sudo touch /var/vm/sleepimage sudo chflags schg /var/vm/sleepimage  
      Version Info at the time of this writing:
      Catalina Installer 10.15.7 CLOVER r5119 DosDude Catalina Patcher: v1.4.4 Lilu.kext 1.4.7 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) AirportBrcmFixup.kext 2.0.9 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) BrcmFirmwareData.kext 2.5.4 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) BrcmBluetoothInjector.kext 2.5.4 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) BrcmPatchRAM3.kext 2.5.4 (not yet included in the attached E6410-Catalina.zip archive.  Get latest version here) IntelMausi.kext 1.0.3 (Not IntelMausiEthernet.kext)
      EFICheckDisabler.kext 0.5
      VoodooHDA.kext 2.9.2 v15 (NOT AppleALC)
       
      What is not working (that was working in Mojave)
      SD Card Slot (had to remove VoodooSDHC.kext which caused system freeze on wake)  
      Known Issues and Their Solutions
      (Not yet included in E6410-Catalina.zip archive attached to Post #1) There are new versions of acidanthera kexts as described here.  I hadn't noticed any issues with the older kexts, so the kexts are not yet included in the E6410-Catalin.zip archive attached to this first post and will be included in a future update to the E6410-Catalina.zip archive. (Solved - no further work required) Clover r5118 requires the config.plist key <key>NoDefaultProperties</key><false> to permit macOS to boot with Clover's "Inject Nvidia" = True.  See details here.  config.plist in the attached E6410-Catalina.zip archive includes this change. (Solved - no further work required) EFICheck is loaded.  Solution is to install EFICheckDisabler.kext which you can get here.  EFICheck.kext is included in the attached E6410-Catalina.zip archive. (Solved - no further work required) Some users experience display issues.  The solution is to remove Device (PNLF) from the DSDT.  Use the attached DSDT.  Removal of PNLF will disable sleep on lid closure.  Device (PNLF) can be added without modifying the DSDT by enabling the Clover PNLF ACPI patch.  The attached Clover config.plist enables the PNLF DSDT patch.  Disable the Clover PNLF patch if you experience display issues. (Solved - no further work required) USB sleep/wake power IORegistry keys are not injected (not included in Mojave's or Catalina's IOUSBHostFamily.kext).  Solution is to added SSDT-USBX.aml to EFI/CLOVER/ACPI/patched.  The attached SSDT-USBX.aml includes USB sleep/wake properties for MacBookPro6,2 from High Sierra 10.13.6 IOUSBHostFamily.kext. (No solution yet) Brightness slider does not work in System Preferences > Displays.  Brightness is easily controlled with Dell brightness keys.  There is some work on this later in this thread, but I will not be solving this as I'm content with the Dell brightness keys (and Ambient Light Sensor works to auto-adjust brightness). (No intention to solve) Display Settings in System Preferences are "garbled" when bright slider is visible.  This is a known issue with the legacy graphics patch and does not affect laptop operation. I continue to refine the DSDT and CLOVER config.plist to optimize my Latitude E6410 for multi-booting between various macOS versions (High Sierra, Mojave and Catalina at the time of this writing). If you upgrade your Latitude E6410 EFI using my attached EFI, you may find that your Latitude E6410 is stuck in a boot-loop that ends in a white screen and reboots.  Clear your system by doing the following: turn off your laptop, remove A/C power, remove the main battery, press and hold the power button for 30 seconds, restore A/C power and battery, boot normally.  I have only found this to be necessary (very rarely) after making an EFI change, but you may find it helpful if making kext changes in /Library/Extensions as well. (Solved - no further work required) Brcm firmware does not update when using BrcmFirmwareRepo.kext in /Library/Extensions.  Solution is to install BrcmFirmwareData.kext and BrcmPatchRAM3.kext in E/C/k/O with Clover "Inject Kexts" = YES. (Solved - no further work required) Laptop does not sleep when closing lid.  Solution appears to be a combination of adding Notify (LID0) code to Method (BTNV) and adding Device (PNLF) in the DSDT. I am using the same EFI for High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.3 and it works in all three macOSes. (No solution yet) No SD Card Slot (had to remove VoodooSDHC.kext) - I read somewhere that there is a solution that does not require any kexts (just a DSDT edit).  Haven't yet implemented this fix. (Not a problem that needs to be solved - leaving for historical purposes.  I am running Catalina without this.) - IOHWControl does not load under GFX0 (as observed in IORegistryExplorer).  Solution (if it needs to be solved) is to install AppleHWSensor.kext from a DosDude-patched Mojave /S/L/E in Catalina's /L/E.  Copy and install your own or use the kext attached to this post. (Solved - no further work required) Wi-Fi connection is delayed until a minute or so after boot - Use VoodooHDA and NOT AppleALC (Solved - no further work required) External USB ports do not work after waking from sleep (S3) - Upgrade Lilu.kext and replace BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (in /L/E) with latest BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext. (Solved - no further work required) Boot and shut-down time of Catalina is slower than Mojave - Upgrade Lilu.kext and replace BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (in /L/E) with latest BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext. (Solved - no further work required) Wi-Fi is not immediately available at OS startup - Upgrade Lilu.kext and replace BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (in /L/E) with latest BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext. (Solved - no further work required) Laptop freezes on wake - Remove VoodooSDHC.kext from /Library/Extensions  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z (I haven't noticed this issue for a while since I completed DSDT edits for Mojave, but keeping this here for historical purposes)  
      CLOVER Installation: Use these configuration options (These configuration options configure Clover for LEGACY BIOS - NOT UEFI)
      Install Clover in the ESP Boot Sectors Install boot0af in MBR Clover for BIOS (LEGACY - NOT UEFI) booting Clover EFI 64-bits SATA BIOS Drivers, 64-bit Recommended drivers FSInject File System drivers ApfsDriverLoader Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane After clicking "Continue", if prompted with "This Clover package is incompatible with this version of macOS," install anyway  
      After CLOVER installation is complete Copy the following from the attached E6410-Catalina.zip ACPI patched contents config.plist (change XX-MASKED-XX values to your own) kexts/Other (remove all other kext folders) Remove christmas and new year folders from themes (if present)  
      Screenshots
       
      Credits
      Thanks to those who contributed to my Mojave solution and to the DosDude team (for the incredible macOS patchers), I think this Catalina installation was the easiest macOS installation that I have experienced (so far).  Many thanks to @Slice and his team for the incredible work on CLOVER and for continuing to support old legacy systems like this.  Also, thanks to @Mieze and @headkaze and others I'm sure for maintaining the Brcm kexts.  And finally, I still prefer to manually apply patches to the DSDTs in my systems.  CLOVER offers extensive patching functionality, but I'm old-school and like to have an error-free, fully-patched DSDT with a simple CLOVER config.plist.  I think that this manual DSDT patching approach (which required an extensive review and debugging of the original unpatched DSDT in this thread) is the reason that this Latitude E6410 is such a perfect MacBookPro6,2.  Thank you @RehabMan for being a great teacher and for always insisting on problem reporting files .
       
       
      AppleHWSensor.kext.zip
      gen_debug
      E6410 Catalina-5v2.zip
    • By Sudo User
      My configuration is:
      Dell XPS 13 9300 Core i7-1065g7 (G7 Iris plus graphics) 16 GB RAM UHD+ monitor (4k: 3840x2400 Touchscreen)  
      The problem that i am currently experiencing is that the internal display is recognised but for some reason is not functioning the way it should. The internal display becomes partially fragmented after few seconds of not doing anything, Although the internal monitor is not functioning, when i connect an external monitor (with FHD resolution) It becomes fully recognised and functioning. When i connect the external monitor the internal monitor becomes blank. With the external monitor i can confirm that i have acceleration.
       
      Here is a log Boot log.
      Here is the config.
       
      Here is a picture of the fragmentation.
       
      Here is a picture when there is an external monitor connected.
       
    • By le332313
      Can someone share the dell 5593/5493 EFI ? I try to fit the graphics driver, but it not working please help me thanks
       
×