Jump to content

Wake reason: RTC (Alarm) - how to deactivate?


Go to solution Solved by mnfesq,
215 posts in this topic

Recommended Posts

Same here, with two Gigabyte systems, under Clover (Z97x-SLI and an H97m-DH3). I've been trying to troubleshoot this for months, because it usually takes a few days' worth of sleep/wake to check.

 

No, 10.10.4 did not fix the issue, and I've been through all sorts of troubleshooting steps, everytime a similar post appeared in the forums [ALC audio, UEFI boot, Nvidia GPU freeze, and so on]. SMBIOS 14,2.

 

I'll keep you posted.

 

[currently, I'm checking the following configuration: fresh Clover install, BIOS - enable internal graphics, but don't use them].

 

 

Any luck, xenophon? The only thing which works for me is to disable sleep entirely.

Haven't made progress. Here are the threads that, I believe, are relevant and maybe you should check:

 

http://www.(banned).com/general-help/148289-memory-corrupted-after-longer-sleep.html

 

At insanelymac:

 

http://www.insanelymac.com/forum/topic/303388-reset-when-waking-from-sleep/

 

http://www.insanelymac.com/forum/topic/306287-pc-haswell-un-usable-after-wake/

 

http://www.insanelymac.com/forum/topic/305457-haswell-memory-corruption-after-sleep-kernel-panic/

 

Please report if you find a solution. Good luck!

  • 1 month later...

I've updated to El Capitan and the issue was back again. So I did the trick with -DisableSleepProxyClient and it's working. I mean it doesn't wake up every two hours now. The only difference was, that I had to reboot to rescue mode, perform "csrutil disable", boot normally, do the trick, reboot to rescue mode, perform "csrutil enable" and reboot.

I've updated to El Capitan and the issue was back again. So I did the trick with -DisableSleepProxyClient and it's working. I mean it doesn't wake up every two hours now. The only difference was, that I had to reboot to rescue mode, perform "csrutil disable", boot normally, do the trick, reboot to rescue mode, perform "csrutil enable" and reboot.

Do you mean that after you apply the RTC patch, you re-enalbe SIP?

Have you saved your original file? Actually, I didn't replace the files. I edited my original files. Well, one file only, with following command:

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist ProgramArguments -array-add -DisableSleepProxyClient

That is all I did. Then recovery mode, enabling SIP, reboot.

 

Does it help, when you unload and load the mDNSResponder? By:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

When i try to load the mDNSResponder via Terminal it says: Path had bad ownership/permissions

 

Seems that this blocks mDNSResponder to load on startup and thus keeps me from connecting to the internet. Does anyone know how to get this issue solved?

  • 2 years later...
×
×
  • Create New...