Jump to content

Haswell memory corruption after sleep - Kernel Panic


3 posts in this topic

Recommended Posts

I tried for a long time to fix memory corruption after a long sleep time. (just normal sleep, hibernate is working)

After between 1 and 2 days the system crashes after wakeup. (page fault Kernel Panic)


A long time i thought its up to my mb but now i found out it seems all Haswell systems are affected.


Now i found out what causes this problem:

I edited the plist in Resources folder from X86Platformplugin.kext for my system and deleted the IOPlatformSystemSleepPolicy.


After i did this my system was running without problem.

Sleep and hibernate is still working without this entry, but i just tried them not in combination. 


Now it would be interessting if it could be patched before i leave it deleted.


Maybe somebody will help this to save time and nerves.



  • Like 2
Link to comment
Share on other sites

  • 4 months later...
  • 2 months later...

  • Create New...