Jump to content

Guide Samsung Ativ 700t (Yosemite)


192 posts in this topic

Recommended Posts

Finally managed to get this working :thumbsup_anim::thumbsup_anim::thumbsup_anim::thumbsup_anim: (Yosemite Beta)

 

But no WiFi - can anyone please let me know how I can set this up??

 

Thanks in advance

The wifi card is Intel so it won't ever work you nee to pop it open and replace it or use a usb wifi dongle

Am I doing something wrong?

 

Followed the guide to create the installer usb.

 

I can boot into Clover and start the installer, but it just hangs about 40% of the way through the progress bar...

The screen flicks to 8 distorted apple logos across the middle of the screen, spinning ball of death, and the language select box never arrives.

 

I tried verbose...

takes roughly the same time to switch from the standard verbose logging screen ( final message: com.apple.xpc.launchd[1]... caller not allowed to perform action) to the apple progress bar (at 0% with spinning ball of death), and hangs there instead.

 

I tried -x, exactly the same as without it (not convinced -x does anything when loading the installer anyway)

 

The only part of the guide I couldn't really follow was the pre/post kext stuff.

The zip only contains a single folder of kexts and a plist (is the guide out of date?), so I simply copied all onto the EFI partition so that the plist replaced the existing one and kexts fell into the kext folder.

 

any help appreciated.

Ignore me.

 

Followed the steps again and its worked beautifully the second time.

 

Thanks for the guide :)

 

Possibly a problem with the restore the first time.

 

I've now created a partition on the ssd, installed to that (left windows in tact) and then booted clover from usb and now added clover to bios options.

 

Works like a charm, except I can't seem to get the elan trackpad drivers installed for multitouch.

 

And the sd card reader doesn't get loaded anymore either (did when I booted from usb based clover), and I've ended up with the touch works/ pen doesn't combo.

 

I guess the kexts from the usb aren't copied over to the windows efi partition automagically, although fakeSMC must do?

 

Anyway, I'll keep beavering away to get these 2 sorted.

 

Any ideas how to access the clover kexts folder once it's installed as a boot option?

  • 1 month later...

Hello,

 

Thanks for kexts and clover help.

 

I've put automatic boot on the osx drive, because when keyboard is out, we can not select the drive to boot,

here an exemple for /EFI/CLOVER/config.plist

<key>Legacy</key>
<string>PBR</string>
<key>Timeout</key>
<integer>5</integer>
<key>DefaultVolume</key>
<string>MacHDD</string>

--> change "MacHDD" to yours

 

to mount EFI partition, you can use Clover Configurator.

 

Other thing, The huawei MU377 module (3G modem) is attached as USB (behind an usb controller).

i've read this guide about wwan modules

So i tried to patch /SL/E/CellPhoneHelper.kext

Unfornutaley, that doesn't work, even if a "HUAWEI Mobile Connect - 3G Modem" file was created automaticaly in /L/Modem Scripts

 

I'd like to have an advice on how to make it run.

 

I tried many driver for E3xx Huawei usb module, but the card was never recognised by osx. (mobile partner, huawei universal, and more)

 

Here pictures (first is on /SL/E/CellPhoneHelper.kext)

 

About Wifi, please repot to Half airport

post-448933-0-54393600-1412069830_thumb.jpg

post-448933-0-91664600-1412069850_thumb.jpg

post-448933-0-86688200-1412069864_thumb.jpg

  • 3 weeks later...
So after many failed attempts at using my previous style of updating, with uni and that direction, and a chameleon folder, I tried the chameleon yosemite installer from this site, got through the install even over cloned partitions of my older 10.9.5 set up, but it would never show up as a choice or even as a bootable disk. finally tried this threads method, substituting the released version of the yosemite installer in the installer build. Using this, suddenly all my drives had OSs on them, one with a working 10.9.5 [now on a guid drive with uefi working, that was a first] and an additional one with the 10.10 on it. 


Encouraged, I re installed the installer over the working 10.9.5 and it updated great. So far the touch-base drivers are working, the wacom internal is not working at all, the wifi works [i swapped in a larger ssd and compatible wifi-bluetooth].  Now I have to figure out the details of how clover really works, and how to augment and edit the config.llst. Im trying to get my windows cloned image [from when I bought the ativ] to reload back onto the device too, but so far no good on that side.  Cloned ok back on, but it resets when I tried to run it through clover, and when I turned secure boot back on to see if that was nec for it to work, I got an error about an incorrect signature and it refused to boot clover. As usual any pointers are appreciated, just learning stuff about this now.

KWJ

Fixed my problems with a new problem  :wallbash: A veery irritating problem: The mouse & trackpad work fine (still no gestures though) work for a while, then disconnects and takes ~1 sec to reconnect. Occurs every ~15-~30 sec. Veery annoying

so heres an update after a couple of days figuring out whats going on in the new set up, 

1)   no working wacom on either 10.9.5 partition or 10.10

2)   SD card reader doesn't work anymore - tried adding back into clover the AHCI 3rdparty SATA but hasn't fixed

3)   audio looks like its working but Im not getting any input output sources, only airplay choices

4)   no messages yet, not a priority though, from what Ive  been reading it might be a new SN for the device might fix

5)   touch-base works multi - but is crashing intermittently with yose, reached out to vendor for info

6)  battery indicator appears to be working with voodoo battery in there- but isn't really, config.list is supposed to patch Appleintelcpupowermanagement on the fly, when I remove all the modifiers and try to let the config work it doens't give any power feedback so any tips on what configuration on this folks are using etc.

 

I tried installing a third party widget for battery reporting [to test app store and get a alt battery informer] and it said no internal battery detected, but the menu bar item says 100% and gives details. this is the case with either voodoo battery, or appleintelcpu--

 

for audio, I had been using a patched appleHDA kext in 1095, tried adding that to the clover efi but Im not seeing the same results.

both ways only give me airplay options in internal audio, I used to get the headphone choice

 

any tips to what users are doing to resolve any of these issues would be appreciated.

working: wifi-bluetooth, [replaced internal card], app store 

 

in other user queries, I never had any advanced elan drivers working on this tablet in mountain lion, mavericks or now yose, so I don't know what I should be expecting other than mouse mode. it does work consistently however.

I don't have actual brightness working currently either, just the controls appear no results with interactions.

 

thanks all!

Which wacom driver are you using? If its the newest that might be why, its been a while since Ive worked on this but i remember different drivers having different results and having to frankenstein a couple different versions to get it fully working. 

i did go back and try the earlier driver and the newer one as well as try hotswapping in parts of the old one into the newer formation— I remember in the earlier thread on another site where you spoke of the configuration that was successful for you, Ill go back and take a look at that again, although Im not getting any feedback from the pen at all, usually it at least is off calibration but responsive, so far no arrangement has given me that, including removing the GenericUSBXHCI.kext for USB 3. i didn't go as far as editing the internal kext mentioned in post #23 of this thread. Mayne thats whats blocking the bus, but I hate losing usb 3.

 

This stuff is usually my weekend brainteaser/melter. I do use the laptop to run a bigger wacom screen too, so that driver is in there too, but it didn't matter with mavericks, and I tried reinstalling a clone of my earlier mavericks partition to see if i could get it to work, but theres something about the yosemite setup thats making it not see the usb bus.

thanks for the reply!

I managed to get both the pen and usb-3 working. I removed AppleUSBXHCI.kext from inside the IOUSBFamily.kext/Contents/Plugins. then installed GeneriUSBXHCI.kext from yosemite from the site

http://sourceforge.net/projects/genericusbxhci/files/

now I have both high speed usb (from what i see in the system profiler) and also the pen is working.

 

I don't have any palm rejection. I mainly use my mackintosh to take notes. so i installed touchbase driver and disabled the touch.

 

the only problem that i seem to have is a weird one: normally sleep works fine. but if i remove the keyboard, or attach it, the sleep sometimes work (after a long time) sometimes never work. when i try to put my mackintosh into sleep, it immediately wakes. does anybody have a similar problem?

thanks for the suggestions guys, since I didn't have even any pen I/O at all with yosemite-clover builds I tried leptogenesis kext mod suggestion first, before checking out mactabletman's wacom driver config threads for that path, the kext patching /generic kext swapping totally fixed my wacom pen, even getting the preferences pane working correctly, and it also got my SD card slot working, which has been a dud since switching to clover, I've restarted multiple times, and it appears to be good to go - so kudos to all,  thats a big advance for this thing being full functioning.

Yeah sorry I havent been as active here lately guys, I Was working on my cintiq companion as a "brain melter" haha. I also had some busy time with halloween.  I would like to use OSX on the ativ as a daily driver but the lack of any application like autohotkey or art dock makes it less productive as apposed to windows... ewwww.  What is your guys set up?  Do you use OSX on the ativ?  Hows palm rejection/ pen, do you use touchbase?  I really cant see paying over $100 for a driver when the tablet only costs about $400.  

your guide here totally got me working systems, so Im super grateful, I was having a horrible time trying to upgrade with chameleon. I hear you about the missing artdock/autohotkey item, If you're using it as the main drawing device, its pretty necessary, and I used to run win8.1 [i kind of like windows 8] just to have those, but then wacom and adobe and microsoft were not agreeable with the way the thing worked and corel painter was always a more pleasurable experience. Still haven't gotten to getting windows back on my hardware.

Since this is my travel computer/wacom screen-home computer workstation when I use it I always have a bluetooth keyboard for hitting modify, other options you could try; 1) the ios/android support app, both photoshop and painter have free extended toolbar functionality these days, 2) that radial menu from the wacom screens is now an option on the pen, you could assign it to one of the pen buttons and have 6 quick functions. 

 

no palm rejection currently, I do use touchbase- I got versions of the drivers with and without the wacom enabled, to have the option, glad too, now that the wacom preferences always work now. they never did on the chameleon-builds. I had problems at first with touchbase and yosemite but its going good now, they have updated version of that UPDD gestures app on their site, direct link on their homepage. I don't think its a necessity but I knew I was keeping this computer for a pretty long time due to its general compatibility]

 

If you're really into it, I swear I dicked around with tablet pcs since 08 and have had about a new one every year and a half, get a used wacom screen off ebay, I finally did, and it made the biggest difference. try to get at least a 17" any model [they just stopped supporting earlier product with the new mac os - the forums were rioting]. I recently got a 13HD and its the same res as the companion you have I believe, I really get tired of drawing small and zooming in and out. the 21" at home lets me concentrate on drawing better, and I had a kiosk type  17" at the office for years I got cheap off ebay  which the 13HD replaced, and boy I miss the real estate. I might start looking for a super cheap surface 2 next year to max out ram, but thats this devices only limitation for my needs.

  • Like 1

Hey thanks for the informative reply! I think the usb keyboard or a gaming mouse would work well for shortcuts if art dock is not an option but you were mentioning theres no palm rejection.  Not even with the expensive touchbase drivers? For that money there better be palm rejection and my dishes better be done.  This can be worked around with an art glove but its not ideal.  I might give it a go and do the install again this weekend. 

 

I hear you about shuffling devices. I recently bought the asus note 8 for $190 on amazon because I wanted something super portable.  I love it so far. Im actually selling my cintiq companion on craigslist because, while its amazing, its also heavy and not practical I really rarely use it. I will write up a blog post soon about cheaper cintiq alternatives such as the ativ 700t and asus note 8 even and compare them.  I would hackintosh the asus note 8 but I dont think osx will run on baytrail.  The 700t is really a great device especially considering it can be had for around $400 now days. 

I haven't retried the touch base drivers with pen enabled since I got everything working, Im letting the wacom driver handle it. If I get a chance over the weekend I will try an alt with them on to see. Their drivers for pen were not working well with corel in mavericks so I shied away from them for pen support. Palm rejection would be great.

 

I really only got them for multi-touch when Im traveling. I am also a huge fan of the samsung, and was hoping they'd continue the line, but other than an expensive refresh out there of the same unit theres no 2014 model. hell I only paid 610 new for this thing last fall, and felt like it was a good deal.

 

one quick question to folks on this type build in this thread, is anyone continuing/putting their DSDT in the clover efi folder? I only have a dsdt from that old thread on [tonyM] site thread where we were all previousl talking about the ML build, Ive used that one throughout all ATIV OS X builds until switching to the efi/clover system, that might be where my audio patch is failing. the power management seems to work sometimes but I can't see a pattern.

 

the asus sounds cool - Id stick win8 and photoshop CC on it and forget about os x for that one.

For everyone wondering about the pen/stylus drivers - installing the latest cintiq companion driver for mac from here:

 

http://us.wacom.com/en/support/drivers/

 

works alongside just the basic kexts at the beginning of this thread (at least for my bamboo stylus feel pen and the stock samsung stylus), but disables the touch. I have my install on the internal SSD (OSX 10.10) - At first pen and touch seemed to work natively if you boot from the install on USB, but with SSD boot at first I had no pen, only touch. But at least with this its simple you don't have to mess with anymore kexts making things unstable or losing your USB 3.0. The generic one someone mentioned earlier from sourcceforge gave me a kernel panic after I deleted the previous GenericUSB kext and AppleUSB kext plugin inside IOfamily. :)

 

Hope this helps those graphic artists out there like me.

  • 2 weeks later...

regarding the wacom drivers, I had to use the [MacOSX - Driver 5.3.5-4 (10.7x - 10.10x)] version with the samsung screen. I did the 10.10.1 update, after doing a little reading, everything went fine but I had to remove this plugin again

 

http://www.insanelymac.com/forum/topic/298815-guide-samsung-ativ-700t-yosemite/page-2?do=findComment&comment=2047954

 

So I took the laptop on vacation and it worked great, but I still don't have working audio and I thought Id reach out to see what combination others on this board are doing to get working audio, I only get it through airplay etc. I used to get it working through the patched dsdt from that thread on ML over in txnyXX with a patched applehda kext from the same source. this has worked until I switched to a clover boot. Ive tried the patch in the config, using the voodoo driver included in the mactabletman kext pack. Ive tried putting the dsdt back into the patched folder in efi and swapping back in my patched applehda but that didn't work either. This + messages are my last hurdle, and I can live without the messages [i get notifications about facetime and calls etc, so I can't figure out why thats not resolved yet but off topic]

 

anyway, anybody got working audio, please post your combination to get it there, thanks!!

happy holiday weekend

K

Amazing! So.. is this tablet worth buying after all? I have my Vaio laptop and I want a hacked tablet other than M$'s overpriced junk! And I can change the card to an AR5B195 and it will do the work ;)

  • 2 weeks later...
×
×
  • Create New...