Jump to content

Guide Samsung Ativ 700t (Yosemite)


192 posts in this topic

Recommended Posts

Oh! Im sorry, i dont have that tablet (yet?) Im looking for one to use it for school, and try those anyway, it should work, and for battery, rehabman have a patch for that, and for brightness slider, go to display in preferences panel ;)

@mactabletman

 

could you please share your postprocess files from your guide?

The files are not in your package anymore. I dont get the brightness control working.

The slider is in the preference, but nothing happens when I move it. Also the

volume rockers on the side of the tablet are not working. Any idea?

 

I dont install genericusbxhci.kext, because the pen is not working anymore.

Without this kext, usb, touch and pen are working fine. Do I need them?

 

Best regards

 

Dicker182

 

Samsung Ativ700t OsX 10.10 Dp1 Guide

14wq0dj.jpg

 

For this install I will be using two USB drives, one as an installer the second to install to.  Alternatively you could create two partitions on the installer USB if its big enough (16gb or larger) and install to the second partition this however will slow down the install.  Later when I have the install stable enough I will extend this guide to make it an internal multi boot guide.

 

 

_______SHOW HIDDEN FILES_____

In terminal copy and paste these commands

   defaults write com.apple.finder AppleShowAllFiles -boolean true

   killall Finder

 

 

_____Creating USB INSTALLER_____

 

Step 1——

Right click Install OS X 10.10 Developer Preview.app and go to show package Contents/ Contents/ Shared Support/  then mount InstallESD.dmg. Rightclick BaseSystem.dmg click open to mount OS X Base System as well.

 

Step 2——

In Disk Utility partition a usb hard drive or thumb drive as Mac osx extended journaled with a GUID partition table. 

 

Step 3——

click “OSX Base System” under “BaseSystem.dmg” in the left side of DiskUtility then click Restore.  Drag USB partition you just created into the Destination slot. (OS X Base System should be in the “source” slot).  Click Restore at the bottom. Give it time to transfer.

 

Step 4——

Your drive will now be renamed “OS X Base System”, right click it and select reveal “OS X Base System” in finder.  Now right click OS X Base System and go to Get info.  In info rename it to “Installer”.

 

Step 5——

In the right side of DiskUtility, right click OS X Install ESD and open it, there should be a folder called Packages.  Copy the Packages folder to your “Installer” drive that you just made 

in the folder System > Installation.  Delete the “Packages” alias in the same folder.  

 

Step 6——

Back in Disk Utility reopen the original OS X Install ESD,  copy BaseSystem.chunklist and BaseSystem.dmg to from there to the external “Installer” partition. 

 

Step 7——

Now open Clover_v2k_r2703.pkg click Continue > Continue > Change Install Location

Select the “Installer” partition. 

Click Customize

Select Install for UEFI booting only

select a theme

Under Drivers64UEFI select 

   -EmuVariableUefi-64

   -OsxAptioFixDrv-64

  -PartitionDxe-64

 

Then click install.

 

Step 8——

When its finished you will notice a new mounted partition called EFI

Navigate to EFI > EFI > CLOVER > kexts > Other 

Paste all the kexts from the Preboot folder of the downloaded Ativinstallpack into the Other folder.

 

Step 9——

Once finished eject your newly made installer usb drive and plug it into one of the ports on the ativ.  Keep in mind the top port is the only 3.0 version and in theory should install the quickest.  Boot the device holding volume down, once the boot menu appears select the UEFI version of your usb installer.  (ex: UEFI:Sandisk ) hit enter. 

Once inside clover select your usb drive and hit enter again then wait of the installer to load.  

Click Continue > Continue > Agree and select the second partition you want to install to.  For me this is another USB drive.  

 

Step 10——

When the install is finished the computer will restart.  Now repeat steps 7 and 8 on the newly made drive where you installed yosemite to install clover and the pre boot kexts to that drive.

 

Boot the new drive, go thru the initial setup and then use kext wizard to install the kexts in the “POSTBOOTSTANDARD” folder of the ativ pack.  After that repair caches and restart.  You should now have brightness with slider, battery icon (no accuracy), and volume rocker (still without sound).

 

I also included a postboot with macpwn folder in the kext pack incase you used the macpwn method because you will actually have working battery.  But I will not include a macpwn guide because its pretty straight forward.  This guide is more bare bones for anyone to use.  

 

 

Also I want to give credit to shad0whack3r  his guide can be found here. http://www.insanelymac.com/forum/topic/298477-how-to-install-os-x-yosemite-on-a-macintosh-using-clover/

 

 

Please, Where are the folders "Ativinstallpack" and "POSTBOOTSTANDARD" ? The link you post is a folder with kexts. I am trying with these kexts with no success :( . I have a kernel panic telling that there is no kexts for this platform. I tried with the DP1 and with the App Store yosemite too. :( :( :(

Help me please!

post-556600-0-54316800-1419787983_thumb.jpg

post-556600-0-54861400-1419788085_thumb.jpg

Please, Where are the folders "Ativinstallpack" and "POSTBOOTSTANDARD" ? The link you post is a folder with kexts. I am trying with these kexts with no success :( . I have a kernel panic telling that there is no kexts for this platform. I tried with the DP1 and with the App Store yosemite too. :( :( :(

Help me please!

Remove all DSDT patches in Clover config.plist, then try to reconfigure your config.plist, and btw, if I had this tablet, I would really love to recheck all these stuff put on this tutorial :) and see what can be fixed too :D just I don't have money, and I'm looking for some similiar/better tablet :) can anyone recommand one for me? (NO SURFACE PLEASE! and if it has a removable back panel like this one, it's preferable cuz I can change WiFi card for a compatible one :) )

Update on my ativ setup, finally figured out how to reinstall a working windows 8.1 with uefi yesterday, after months of no windows on that unit, was overwhelmed with figuring it out post chameleon/legacy windows. Hurray!

 

still no working audio at all, boo! tried the latest voodoo, re-read this thread to see if any others had specific successes, but nobodies mentioned a working arrangement. anybody here try injecting a fix through the clover config for the audio? anybody with the actual device here that has sound working, please post your specifics, thanks!

 

 

one last thing,  people trying the wacom pen after going through the steps in this thread and not seeing any pen reaction, you have to launch the wacom pref panel and calibrate - the pen is unresponsive and appears broken until you launch the calibrate. it seems broke until this stage.

Kenny - happy new year!!

@kwjenkins, thanks for this infi, but do you recommand me this tablet, or should I look for another one, I'm looking fo a hackable tablet/convertible that I can change its wifi card like this samsung :)

what codec btw? (im in the chat room if you need me, tho I dont have the tablet :P )


Are you sure? I found cheaper ASUSes and I'm pretty sure they're hackable as this, so far, what are the working stuff and "pending fixes" on the nonworking/halfworking stuff? I can't see that on the first post :(

thanks for the replies, quickly,   today while still on vacation I'm running myself through a CPU/IGPU management guide for fun to see if I can get some dependable battery info [works then doesn't work then works] thought Id try to improve it although it doesnt really affect anything workflow wise.

 

1) thanks for the info dicker182, I'm using the voodoo too but it doesn't work at all internally. I used to use a patched DSDT but only use clover these days, currently the only audio is through bluetooth or airplay, but thats with any config.

2) midi. —for me this has been a dependable computer used as a home studio driving a wacom screen, and on the road as a travel computer.

your milage may vary, the only limitation Ive got with the hardware is the ram limit of 4G. I havent been looking for alternatives however other than the surface 2 [with the wacom pen] no other options.

3) the audio on the hardware is Intel series 7/C210 I currently have no idea if theres a ALC corrilation I thought that was only realtek audio.

anyway, goofing on my setup this afternoon, still very stoked about getting a real windows install running

I don't think windows is a real struggle, just boot it up as UEFI from clover or yout internal FW, select your partition, remove it, select the blank space left, hit continue, it should install, if not then follow my guide here: http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/?p=2098291 and to fix clover, either go to your UEFI FW management software (the BIOS as we say, and it's not the real word btw, it's the UEFI FW) then IF POSSIBLE add Clover as First Boot entry and windows as second, if not use EasyUEFI to make a new Clover entry and make it first in the list (add it as a Linux UEFI boot entry) OR the least way and the one that work 8000% is to remove any bootx64.efi from /EFI/Boot/ and to copy cloverx64.efi to that boot folder, rename it to bootx64.efi then go to /EFI/Microsoft/Boot/ and rename bootmgfw.efi to bootmgfwA.efi (or anything else, just keep that naming in mind) then add a new entry in Clover like this:

Screenshot%202015-01-02%2023.03.15.png?d

OR

<key>GUI</key>
	<dict>
		<key>Custom</key>
		<dict>
			<key>Entries</key>
			<array>

				[........]

				<dict>
					<key>Disabled</key>
					<false/>
					<key>FullTitle</key>
					<string>Windows</string>
					<key>Hidden</key>
					<false/>
					<key>Hotkey</key>
					<string>w</string>
					<key>Ignore</key>
					<false/>
					<key>Image</key>
					<string>os_vista</string>
					<key>Path</key>
					<string>\EFI\Microsoft\Boot\bootmgfw.efi</string> <--- Here change bootmgfwA.efi with renaming you did, and delete this (the explanatory sentence  be smart  )
					<key>Type</key>
					<string>Windows</string>
				</dict>

				[........]

			</array>
		</dict>
		
		[........]
		
	</dict>

Good luck, and please use AIDA to get the real codec naming or DPCIManager :) I'm in chat if you need any help, and why don't you guys go there, it's just typing chat and you're not really forced to talk (we usually want to keep calm, but hey, you learn a lot from there :P )

thanks for the reply and suggestions. I wasnt asking for windows uefi help, I got it working myself as mentioned in my initial post today. I was polling owners about their audio configurations, since mines still not working. Regarding chat, I like the paper trail that a forum provides. thanks again though for the info,

I use both the internal wacom and an external wacom device, as for why have the internal wacom drivers, in practical experience, when you update the OS and have to reapply the usb patch mentioned in this thread [http://www.insanelymac.com/forum/topic/298815-guide-samsung-ativ-700t-yosemite/page-2?do=findComment&comment=2047954], you need to be able to calibrate to get the usb to see the wacom pen to respond.

 

as far as the surface and its needs, I don't own one, I was only replying to your enquiry about alternative hardware options, thats the only other cheap device that popped up on my radar, being that it has better installable user ram, and is also wacom still. I don't know anything about the hardware and touchbase drivers.

hope this is helpful, I was using chameleon up until nov, so Im only beginning to learn to exploit clovers uses, thats why windows wasn't happening before.

hmm, ok, so for now:

- this samsung is a bit better than surface since it's easily hackable

- there are issues with the battery brighness and audio

- it supports ONLY 4GB of ram ? (I have a 8GB ram, if it's possible I want to use it)

my questions:

How cheap it is? is it sold with the keyboard in the box? and is the battery life good enough for portablity and a day usage? (I'm university student, and I need a tablet along side with my laptop, in desctiption, which have i7 and more ram and better graphics, I only need a tablet for school work and presentations, maybe AutoCAD showing not editing (even if HD4k is good at AutoCAD, not bad at least with my experience) )

Thanks :)

Hi, guys! I have a problem with resolution change on my 700t. When i change a resolution to, for example, 1600x900, screen got weird. How to solve it? May someone share his clover config plist with working resolution or it's framebuffer problem?

fpiUJAUfYG8.jpg Weird

×
×
  • Create New...