Jump to content

Guide Samsung Ativ 700t (Yosemite)

192 posts in this topic

Recommended Posts

Samsung Ativ700t OsX 10.10 Dp1 Guide



For this install I will be using two USB drives, one as an installer the second to install to.  Alternatively you could create two partitions on the installer USB if its big enough (16gb or larger) and install to the second partition this however will slow down the install.  Later when I have the install stable enough I will extend this guide to make it an internal multi boot guide.




In terminal copy and paste these commands

   defaults write com.apple.finder AppleShowAllFiles -boolean true

   killall Finder



_____Creating USB INSTALLER_____


Step 1——

Right click Install OS X 10.10 Developer Preview.app and go to show package Contents/ Contents/ Shared Support/  then mount InstallESD.dmg. Rightclick BaseSystem.dmg click open to mount OS X Base System as well.


Step 2——

In Disk Utility partition a usb hard drive or thumb drive as Mac osx extended journaled with a GUID partition table. 


Step 3——

click “OSX Base System” under “BaseSystem.dmg” in the left side of DiskUtility then click Restore.  Drag USB partition you just created into the Destination slot. (OS X Base System should be in the “source” slot).  Click Restore at the bottom. Give it time to transfer.


Step 4——

Your drive will now be renamed “OS X Base System”, right click it and select reveal “OS X Base System” in finder.  Now right click OS X Base System and go to Get info.  In info rename it to “Installer”.


Step 5——

In the right side of DiskUtility, right click OS X Install ESD and open it, there should be a folder called Packages.  Copy the Packages folder to your “Installer” drive that you just made 

in the folder System > Installation.  Delete the “Packages” alias in the same folder.  


Step 6——

Back in Disk Utility reopen the original OS X Install ESD,  copy BaseSystem.chunklist and BaseSystem.dmg to from there to the external “Installer” partition. 


Step 7——

Now open Clover_v2k_r2703.pkg click Continue > Continue > Change Install Location

Select the “Installer” partition. 

Click Customize

Select Install for UEFI booting only

select a theme

Under Drivers64UEFI select 





Then click install.


Step 8——

When its finished you will notice a new mounted partition called EFI

Navigate to EFI > EFI > CLOVER > kexts > Other 

Paste all the kexts from the Preboot folder of the downloaded Ativinstallpack into the Other folder.


Step 9——

Once finished eject your newly made installer usb drive and plug it into one of the ports on the ativ.  Keep in mind the top port is the only 3.0 version and in theory should install the quickest.  Boot the device holding volume down, once the boot menu appears select the UEFI version of your usb installer.  (ex: UEFI:Sandisk ) hit enter. 

Once inside clover select your usb drive and hit enter again then wait of the installer to load.  

Click Continue > Continue > Agree and select the second partition you want to install to.  For me this is another USB drive.  


Step 10——

When the install is finished the computer will restart.  Now repeat steps 7 and 8 on the newly made drive where you installed yosemite to install clover and the pre boot kexts to that drive.


Boot the new drive, go thru the initial setup and then use kext wizard to install the kexts in the “POSTBOOTSTANDARD” folder of the ativ pack.  After that repair caches and restart.  You should now have brightness with slider, battery icon (no accuracy), and volume rocker (still without sound).


I also included a postboot with macpwn folder in the kext pack incase you used the macpwn method because you will actually have working battery.  But I will not include a macpwn guide because its pretty straight forward.  This guide is more bare bones for anyone to use.  



Also I want to give credit to shad0whack3r  his guide can be found here. http://www.insanelymac.com/forum/topic/298477-how-to-install-os-x-yosemite-on-a-macintosh-using-clover/

Ativ Yosemite pack v1 6-14-2014.zip

Share this post

Link to post
Share on other sites

nice to see a new guide here in the tablet section, welcome.

btw i suggest you to use another cleaner way to create the usb installer, similar to the one you can find in the surface pro guide...


Niresh's MacPwn is one of those tools that are not supported by insanelymac.

Share this post

Link to post
Share on other sites

Oh ok, thanks for the quick response and friendly welcome! I was actually wondering about that and was considering finding a new way as I dont think its really necessary just seemed easiest for beginners.  I like that you addressed it the way you did.  In other forums I get posts deleted for even mentioning other software hence why I came back here.  I will work on another boot method now and have it updated shortly! 

Share this post

Link to post
Share on other sites

Exactly! The tonymac forum was the one I was referring to being nazis about posts thats why I was surprised by the friendly way you guys responded.  I didnt want to say the other forum by name partly because they dont deserve the mention.  It blows my mind that someone would try to start an incredibly restricted website based on hacking.  Anyway back on topic. I rewrote the entire thing from scratch without using any tools and got it to install, now for some reason when I install my kext pack it breaks it.  Im sorting it out now and trying to pin point the kext responsible and will have a new guide up soon. Is it okay that I leave the macpwn method up for now?  Dont know much about the site and im not affiliated with Niresh, but his tools seem legit and have been very helpful in making the process faster for now.

Share this post

Link to post
Share on other sites

if you really want to know what's in there, you should extract the whole Niresh pkg using tools such pacifist...

this is the only way to really understand what's it installing and where...

hope you find whats causing the issue and post the new steps soon :D

Share this post

Link to post
Share on other sites

Hey thanks for the tip Jah, But I already tried that.  All the contents are protected somehow as "bom" files. Maybe im too new but I have no idea how to get at the contents.  Ive figured out a way without it but the battery isnt working, its strange.


Nevermind, i figured it out.  But it shouldnt really matter what the contents are as it just makes the bootdrive but who knows. Will keep you posted.

Share this post

Link to post
Share on other sites

bom files aren't protected, they aren't meant to be opened, they are just instructions for the installer. Bom stands for Bill of Materials.

Share this post

Link to post
Share on other sites

Okay, so here are my results:


Wifi: NO GO, I looked into it, it would take more programming than it was worth to pull an old PCIe wifi card out of a dead laptop and rig it in.

(Note: Got Wifi working after pulling an atheros chip from an old laptop, bluetooth worked before doing this, it's interesting that the intel chip was wifi+bt and that it only worked for bt.)


Graphics: YES QE/CI


Power: Has a few bugs with reporting my battery as 0%, plugging it in, and unplugging it (or vice versa) usually fixes this. Sleep, shutdown, restart = YES Brightness = YES

(Note: Cannot change brightness using keys, it brings up the interface, but doesn't actually change.


G-Sensor/Accelerometer: Not yet tested, I turned it upside down and sideways and the screen didn't rotate, but that's probably because apple doesn't have any computers that do so, probably would work with some fancy programming.


App Store/iCloud: YES (with nullethernet.kext)


iMessages/Facetime: NOT YET (Still working through all the hoops to get it)


Audio: YES (However volume rocker does not work, volume does change with keys)




Currently installing DP2 update. Will keep you posted.

Share this post

Link to post
Share on other sites



OsX don't support automatic screen rotation and there isn't any kext that actually enable accelerometer... btw If you want you can search for screen rotator for menubar to manually rotate.


if AppStore is working you probably need to create a proper serial and smbios to fix iMessage...


have fun and good hack!

Share this post

Link to post
Share on other sites

look forward to getting this running on mine as soon as the final is out, mavericks is running pretty great these days, but to have the touch and pen fixes built in would be a real plus.

Share this post

Link to post
Share on other sites

Does the touch and pen work with any kext injecting or swapping?  I imagine you would be able to install the actual wacom software and get palm rejection and calibration if that is the case. In Yosemite the pen and touch work OOB but the wacom software is not compatible which makes it kind of pointless as there is neither palm rejection or calibration (even tho the pen is very accurate and has pressure).

Share this post

Link to post
Share on other sites

the touch and pen works OOB, don't install touch base drivers unless you have purchased the full version, otherwise you end up recalibrating and you don't get multitouch on their evaluation. (OS X doesn't have native multitouch for this *yet*)


I'm trying to see if they will discount the drivers for it, but I've only just sent the email last night, we'll see.


BTW: the install for the beta 2 failed, but shows up as successful, however the software number didn't change, and none of the new features/apps show up. I'm going to try a fresh install from the beta 2 app instead of updating through the app store.


UPDATE: After reinstalling DP1, I was able to use software update. iMessage/Facetime is still broken, at this point I click Sign in and it sits for infinity with the spinner doing nothing.. No multitouch from the update (Was I expecting it? no :( but a boy can dream)

Share this post

Link to post
Share on other sites

The battery manager works fine for me as does FaceTime. You say you have sleep and sound tho?  What kexts/process did you use, please share so i can try it and add it to the guide. thanks!

Share this post

Link to post
Share on other sites



If your Software Number don't change, the Dp2 installation wasn't installed correctly...


about the TouchBase driver, it works perfectly under maverick even with multitouch gestures, now on Yosemite it (the gesture manager app) crashes, but their fix will be ready when the public beta starts.


Have a fun Hack :)

Share this post

Link to post
Share on other sites

The battery manager works fine for me as does FaceTime. You say you have sleep and sound tho?  What kexts/process did you use, please share so i can try it and add it to the guide. thanks!

I followed your guide.


The sound output was simply set to the headphone jack, going into prefs and setting it to speakers is all I needed. Sleep works out of box

Share this post

Link to post
Share on other sites

Awesome, thanks for the response.  Ive switched gears a bit and have devoted the past couple days to hacking my cintiq companion and hope to put up a guide for that at some point soon as well.  I will get back to the ativ soon as it seems way less picky.  I swear every bit of freetime i get goes into hackintoshing whatever i can and eventually it starts to get frustrating and mind numbing.  Its good to step away for a minute.  Im also trying to write up some content for the new samsung forum section. 

Share this post

Link to post
Share on other sites

I installed the public beta of Yosemite and it strangely seems to have the touch feature taken away while pen is still supported and accurate.  I find this odd because I installed it on my cintiq as well and it still has both touch without click, and pen without accuracy.  So im really curious which kexts/frameworks are behind controlling these features and why they still cater to the pro cintiq digitizer layer and not the lower end ativ.  

Share this post

Link to post
Share on other sites

i first installed Yosemite public beta to an external harddisc. then i cloned the installation to a partition on the SSD using SuperDuper. strangely, i only have the touch but not the pen. the pen seems to be detected by the os as the Ink preference pane is visible in the system preferences. but the pen does not do anything.

Share this post

Link to post
Share on other sites

I managed to get both the pen and the touch working. you have to disable USB 3.0 support to get both of them. Delete GenericUSBXHCI.kext (if you have installed it) and AppleUSBXHCI.kext from the folder


(better if you move them to some other folder in case you might need them later), rebuild kernel cache and reboot.

Share this post

Link to post
Share on other sites

Finally managed to get this working  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim: (Yosemite Beta)


But no WiFi - can anyone please let me know how I can set this up??


Thanks in advance

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vhviveiros
      Hello guys!
      I'm using a Samsung ativ book 2 np270e5g-xd1br, with i5-3230m/HM75, and everything is working fine, except by sleeping and wifi connection (the Hackintosh internet speed is about 10% of the windows/Linux, and sometimes It downs randomly).
      I've tried a lot of tutorials but nothing solved my problem.
      Hope you guys could help me
      obs: I also figured that if I left the laptop for some minutes, It sometimes reboot.
      Send me MacBook-Pro.zip
    • By renandesouza
      Hi guys, I recently installed OS X 10.10 Yosemite on my PC, everything was fine in the installation, video card already configured and working perfectly, the sound also had no problems, but I just can not connect to the internet, no connection with ethernet etc ... I tested some kex but it did not work.
      Asus P5GC-MX/1333
      Core 2 Duo E8400 3.0 GHz 
      2GB DDR2 
      ATi HD 5450
      Realtek ALC883 HD Audio
      Atheros L2 Fast Ethernet 
      Network Screen Prints:

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
        Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Install Clover in USB stick UEFI mode https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace Folder CLOVER INSTALLATION.zip   --Install System and boot with USB STICK! --Install Clover in UEFI mode and replace with my folder  Mavericks / Yosemite CLOVER Mavericks-Yosemite.zip El Capitan / Sierra CLOVER El Capitan-Sierra.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches! If you need DSDT edit... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generate in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609    --DSDT My DSDT DSDT.Asus Z97M-PLUS.zip   Patches  -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -EHCx -DARWIN -LPC -XHCI -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -HDMI -ALS0 -SHUTDOWN -LAN -PNLF --SSDT Generate your SSDT Power Management, use ssdtPRGen Piker-Alpha https://github.com/Piker-Alpha run in terminal curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh chmod +x ~/ssdtPRGen.sh sudo ~/ssdtPRGen.sh ssdtPRGen.command.zip
      --SSDT i74790K
      SSDT.i7 4790K.zip
      Clear NVRAM, Purge and Kextcache Olarila.command.zip   stock coolerand Rio 40º    --FakeSMC http://www.hwsensors.com/releases --Audio http://www.insanelymac.com/forum/topic/314406-voodoohda-289/ --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/304235-intelmausiethernetkext-for-intel-onboard-lan/   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
    • By iTahaMe
      But i have a single problem, My graphic card Radeon x1950 Pro not working, It used to work good on Snow Leopard but now its not on Yosemite i don't know why ... any kext needed ??
      Here the kext used to work good for me on Snow Leopard
      Any Help ? 

    • By fusion71au
      This is a brief guide on how to create a vanilla El Capitan (also same process for Sierra) OS X Installer USB with an updated prelinked kernel containing FakeSMC.

      It is tailored for those users who want to understand the “nuts and bolts” of how to create an installer and also to help brush up on their terminal skills (rather than have one made for them with the numerous automated “tools” available or even Apple’s createinstallmedia) :
      Specifically, it is also a “Proof of Concept” which shows that installation is possible without even having to rely on boot loader kext injection.

      Existing Yosemite installation (or Mavericks - see post#4 for steps 7,8) “Install OS X El Capitan.app" downloaded to the Applications folder Pacifist FakeSMC.kext - Slice or Kozlek branch Bootloader - Clover or Chameleon 8GB or larger USB drive (16GB recommended), formatted HFS+ (MBR or GUID) named “Installer”  
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Open OS X terminal and type the following lines, followed by <Enter> after each line.
          The image restore and file copying may take a while to complete, and at the end of the process, the Installer volume is renamed to “OS X Base System"....
      sudo -s hdiutil attach /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg asr restore -source /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg  -target /Volumes/Installer -erase -format HFS+ -noprompt -noverify rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages cp -av /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/OS\ X\ Base\ System/System/Installation cp -av /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg /Volumes/OS\ X\ Install\ ESD/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System diskutil unmount /Volumes/OS\ X\ Install\ ESD exit 3.  Right click on the “OS X Base System” Volume and click “Get Info”

      4.  Click on the lock icon and untick “Ignore ownership on this volume”

      5.  Extract/Copy the El Capitan Kernels folder into /System/Library/ of the USB with Pacifist.  NB It is found in the "Essentials.pkg" in /System/Installation/Packages

      6.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel —> OG.prelinkedkernel

      7.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of the installer USB using Finder.

      8.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel…..
      sudo -s chmod -R 755 /Volumes/OS\ X\ Base\ System/Library/Extensions chown -R 0:0 /Volumes/OS\ X\ Base\ System/Library/Extensions touch /Volumes/OS\ X\ Base\ System/System/Library/Extensions kextcache -u /Volumes/OS\ X\ Base\ System exit Any errors should be noted but the output below is normal e.g.

      9. Install your Bootloader targeting the OS X Base System volume
      10.  Boot your system with the USB without injected kexts into the OS X Installer GUI....
      Post Install
      The original prelinked kernel in a fresh install of El Capitan will also lack FakeSMC ie it will only be linked to Apple signed kexts.  In order to boot into El Capitan the first time around without boot loader kext injection, the PLK needs to be rebuilt for the El Capitan volume like we did for the installer:
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel for the El Capitan volume —> OG.prelinkedkernel
      3.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of El Capitan using Finder
      4.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel.  In this example, the El Capitan volume is named "El_Capitan" - change if you have named it something else...
      sudo -s chmod -R 755 /Volumes/El_Capitan/Library/Extensions chown -R 0:0 /Volumes/El_Capitan/Library/Extensions touch /Volumes/El_Capitan/System/Library/Extensions kextcache -u /Volumes/El_Capitan exit 5. Install your Bootloader targeting the El Capitan volume.  This step is only necessary if you are installing El Capitan on a new drive without existing boot loader (not required if installing on a disk with existing boot loader beside Yosemite).
      6. Reboot your system without injected kexts into El Capitan!
      Other links
      The All-In-One Guide to Vanilla OS X for beginners
      Updates for Sierra and High Sierra   Custom Prelinkedkernel Generator Tool I have made a custom prelinkedkernel generator "PLK.tool" for Sierra + El Capitan.  Instructions:   1.  Download and extract the attached BaseSystem_PLK.tool.zip into your ~/Downloads folder.   2.  Copy any extra kexts necessary for booting your hack to ~/Downloads/BaseSystem/ExtraKexts (e.g. FakeSMC, VoodooPS2Controller), making sure SIP is disabled. 3.  Copy BaseSystem.dmg to ~/Downloads/BaseSystem  4.  Open terminal and run the following commands... cd ~/Downloads/BaseSystem chmod +x PLK.tool ./PLK.tool ---> supply your admin password ---> will place your new custom prelinkedkernel on the desktop.       macOS High Sierra bypass Firmware and MBR checks in post#13.
      BaseSystem_PLK.tool_Mojave.zip (need to run in Mojave to avoid dependency errors)