Jump to content

Guide Samsung Ativ 700t (Yosemite)


192 posts in this topic

Recommended Posts

Samsung Ativ700t OsX 10.10 Dp1 Guide



For this install I will be using two USB drives, one as an installer the second to install to.  Alternatively you could create two partitions on the installer USB if its big enough (16gb or larger) and install to the second partition this however will slow down the install.  Later when I have the install stable enough I will extend this guide to make it an internal multi boot guide.




In terminal copy and paste these commands

   defaults write com.apple.finder AppleShowAllFiles -boolean true

   killall Finder



_____Creating USB INSTALLER_____


Step 1——

Right click Install OS X 10.10 Developer Preview.app and go to show package Contents/ Contents/ Shared Support/  then mount InstallESD.dmg. Rightclick BaseSystem.dmg click open to mount OS X Base System as well.


Step 2——

In Disk Utility partition a usb hard drive or thumb drive as Mac osx extended journaled with a GUID partition table. 


Step 3——

click “OSX Base System” under “BaseSystem.dmg” in the left side of DiskUtility then click Restore.  Drag USB partition you just created into the Destination slot. (OS X Base System should be in the “source” slot).  Click Restore at the bottom. Give it time to transfer.


Step 4——

Your drive will now be renamed “OS X Base System”, right click it and select reveal “OS X Base System” in finder.  Now right click OS X Base System and go to Get info.  In info rename it to “Installer”.


Step 5——

In the right side of DiskUtility, right click OS X Install ESD and open it, there should be a folder called Packages.  Copy the Packages folder to your “Installer” drive that you just made 

in the folder System > Installation.  Delete the “Packages” alias in the same folder.  


Step 6——

Back in Disk Utility reopen the original OS X Install ESD,  copy BaseSystem.chunklist and BaseSystem.dmg to from there to the external “Installer” partition. 


Step 7——

Now open Clover_v2k_r2703.pkg click Continue > Continue > Change Install Location

Select the “Installer” partition. 

Click Customize

Select Install for UEFI booting only

select a theme

Under Drivers64UEFI select 





Then click install.


Step 8——

When its finished you will notice a new mounted partition called EFI

Navigate to EFI > EFI > CLOVER > kexts > Other 

Paste all the kexts from the Preboot folder of the downloaded Ativinstallpack into the Other folder.


Step 9——

Once finished eject your newly made installer usb drive and plug it into one of the ports on the ativ.  Keep in mind the top port is the only 3.0 version and in theory should install the quickest.  Boot the device holding volume down, once the boot menu appears select the UEFI version of your usb installer.  (ex: UEFI:Sandisk ) hit enter. 

Once inside clover select your usb drive and hit enter again then wait of the installer to load.  

Click Continue > Continue > Agree and select the second partition you want to install to.  For me this is another USB drive.  


Step 10——

When the install is finished the computer will restart.  Now repeat steps 7 and 8 on the newly made drive where you installed yosemite to install clover and the pre boot kexts to that drive.


Boot the new drive, go thru the initial setup and then use kext wizard to install the kexts in the “POSTBOOTSTANDARD” folder of the ativ pack.  After that repair caches and restart.  You should now have brightness with slider, battery icon (no accuracy), and volume rocker (still without sound).


I also included a postboot with macpwn folder in the kext pack incase you used the macpwn method because you will actually have working battery.  But I will not include a macpwn guide because its pretty straight forward.  This guide is more bare bones for anyone to use.  



Also I want to give credit to shad0whack3r  his guide can be found here. http://www.insanelymac.com/forum/topic/298477-how-to-install-os-x-yosemite-on-a-macintosh-using-clover/

Ativ Yosemite pack v1 6-14-2014.zip

  • Like 4
Link to comment
Share on other sites

nice to see a new guide here in the tablet section, welcome.

btw i suggest you to use another cleaner way to create the usb installer, similar to the one you can find in the surface pro guide...


Niresh's MacPwn is one of those tools that are not supported by insanelymac.

  • Like 2
Link to comment
Share on other sites

Oh ok, thanks for the quick response and friendly welcome! I was actually wondering about that and was considering finding a new way as I dont think its really necessary just seemed easiest for beginners.  I like that you addressed it the way you did.  In other forums I get posts deleted for even mentioning other software hence why I came back here.  I will work on another boot method now and have it updated shortly! 

  • Like 1
Link to comment
Share on other sites

Exactly! The tonymac forum was the one I was referring to being nazis about posts thats why I was surprised by the friendly way you guys responded.  I didnt want to say the other forum by name partly because they dont deserve the mention.  It blows my mind that someone would try to start an incredibly restricted website based on hacking.  Anyway back on topic. I rewrote the entire thing from scratch without using any tools and got it to install, now for some reason when I install my kext pack it breaks it.  Im sorting it out now and trying to pin point the kext responsible and will have a new guide up soon. Is it okay that I leave the macpwn method up for now?  Dont know much about the site and im not affiliated with Niresh, but his tools seem legit and have been very helpful in making the process faster for now.

Link to comment
Share on other sites

if you really want to know what's in there, you should extract the whole Niresh pkg using tools such pacifist...

this is the only way to really understand what's it installing and where...

hope you find whats causing the issue and post the new steps soon :D

Link to comment
Share on other sites

Hey thanks for the tip Jah, But I already tried that.  All the contents are protected somehow as "bom" files. Maybe im too new but I have no idea how to get at the contents.  Ive figured out a way without it but the battery isnt working, its strange.


Nevermind, i figured it out.  But it shouldnt really matter what the contents are as it just makes the bootdrive but who knows. Will keep you posted.

Link to comment
Share on other sites

Okay, so here are my results:


Wifi: NO GO, I looked into it, it would take more programming than it was worth to pull an old PCIe wifi card out of a dead laptop and rig it in.

(Note: Got Wifi working after pulling an atheros chip from an old laptop, bluetooth worked before doing this, it's interesting that the intel chip was wifi+bt and that it only worked for bt.)


Graphics: YES QE/CI


Power: Has a few bugs with reporting my battery as 0%, plugging it in, and unplugging it (or vice versa) usually fixes this. Sleep, shutdown, restart = YES Brightness = YES

(Note: Cannot change brightness using keys, it brings up the interface, but doesn't actually change.


G-Sensor/Accelerometer: Not yet tested, I turned it upside down and sideways and the screen didn't rotate, but that's probably because apple doesn't have any computers that do so, probably would work with some fancy programming.


App Store/iCloud: YES (with nullethernet.kext)


iMessages/Facetime: NOT YET (Still working through all the hoops to get it)


Audio: YES (However volume rocker does not work, volume does change with keys)




Currently installing DP2 update. Will keep you posted.

Link to comment
Share on other sites



OsX don't support automatic screen rotation and there isn't any kext that actually enable accelerometer... btw If you want you can search for screen rotator for menubar to manually rotate.


if AppStore is working you probably need to create a proper serial and smbios to fix iMessage...


have fun and good hack!

  • Like 1
Link to comment
Share on other sites

Does the touch and pen work with any kext injecting or swapping?  I imagine you would be able to install the actual wacom software and get palm rejection and calibration if that is the case. In Yosemite the pen and touch work OOB but the wacom software is not compatible which makes it kind of pointless as there is neither palm rejection or calibration (even tho the pen is very accurate and has pressure).

Link to comment
Share on other sites

the touch and pen works OOB, don't install touch base drivers unless you have purchased the full version, otherwise you end up recalibrating and you don't get multitouch on their evaluation. (OS X doesn't have native multitouch for this *yet*)


I'm trying to see if they will discount the drivers for it, but I've only just sent the email last night, we'll see.


BTW: the install for the beta 2 failed, but shows up as successful, however the software number didn't change, and none of the new features/apps show up. I'm going to try a fresh install from the beta 2 app instead of updating through the app store.


UPDATE: After reinstalling DP1, I was able to use software update. iMessage/Facetime is still broken, at this point I click Sign in and it sits for infinity with the spinner doing nothing.. No multitouch from the update (Was I expecting it? no :( but a boy can dream)

Link to comment
Share on other sites



If your Software Number don't change, the Dp2 installation wasn't installed correctly...


about the TouchBase driver, it works perfectly under maverick even with multitouch gestures, now on Yosemite it (the gesture manager app) crashes, but their fix will be ready when the public beta starts.


Have a fun Hack :)

Link to comment
Share on other sites

The battery manager works fine for me as does FaceTime. You say you have sleep and sound tho?  What kexts/process did you use, please share so i can try it and add it to the guide. thanks!

I followed your guide.


The sound output was simply set to the headphone jack, going into prefs and setting it to speakers is all I needed. Sleep works out of box

  • Like 1
Link to comment
Share on other sites

Awesome, thanks for the response.  Ive switched gears a bit and have devoted the past couple days to hacking my cintiq companion and hope to put up a guide for that at some point soon as well.  I will get back to the ativ soon as it seems way less picky.  I swear every bit of freetime i get goes into hackintoshing whatever i can and eventually it starts to get frustrating and mind numbing.  Its good to step away for a minute.  Im also trying to write up some content for the new samsung forum section. 

Link to comment
Share on other sites

  • 1 month later...

I installed the public beta of Yosemite and it strangely seems to have the touch feature taken away while pen is still supported and accurate.  I find this odd because I installed it on my cintiq as well and it still has both touch without click, and pen without accuracy.  So im really curious which kexts/frameworks are behind controlling these features and why they still cater to the pro cintiq digitizer layer and not the lower end ativ.  

  • Like 1
Link to comment
Share on other sites

i first installed Yosemite public beta to an external harddisc. then i cloned the installation to a partition on the SSD using SuperDuper. strangely, i only have the touch but not the pen. the pen seems to be detected by the os as the Ink preference pane is visible in the system preferences. but the pen does not do anything.

Link to comment
Share on other sites

I managed to get both the pen and the touch working. you have to disable USB 3.0 support to get both of them. Delete GenericUSBXHCI.kext (if you have installed it) and AppleUSBXHCI.kext from the folder


(better if you move them to some other folder in case you might need them later), rebuild kernel cache and reboot.

Link to comment
Share on other sites


  • Create New...