Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
janek202

New HDA Wizard for Mountain Lion 10.8 (beta)

24 posts in this topic

Recommended Posts

I finally updated my tool for Mountain Lion.

It was designed for quick sound repair after update, without any rollbacks.

 

It helps to install Platforms, layout and Info files.

It supports multi-line binpatches.

Now it also has convert feature: helps to quick compress and decompress xml and xml.zlib files. Based on zlib.pl made by RevoGirl.

Bonus: Patching AppleRTC to prevent CMOS resets after sleep.

 

It will not create any files, it will only help you install them.

 

You still need a DSDT patch, or HDAEnabler.kext with proper LayoutID.

 

It's still beta version, some binpatches might be old. I can't test them all. If you have any new binpatches, please post them.

 

Mountain Lion 10.8 only.

 

Download link: https://dl.dropbox.c...L/download.html

 

ss_ml.png

Share this post


Link to post
Share on other sites
Advertisement

It doesn't matter if you have PC or notebook for this app. If you have supported codec, it should work.

I have a notebook myself.

 

@Mohamed Khairy

Added.

Thanks for explanation.

Share this post


Link to post
Share on other sites

When I try to to a custom string I get an Error box that is blank; and the notification says patching started please wait. I also didn't get asked for the root password.

Could you add the VIA VT2021 the string is 's|\x84\x19\xd4\x11|\x41\x04\x06\x11|g'. A suggestion how hard would it be to make it so we can edit the patches.plist file in resources, right now no matter what I do it looks like it get regenerated on every run.

Share this post


Link to post
Share on other sites

Hi, can you add 's|\x84\x19\xd4\x11|\x51\x50\xf1\x14|g' (conexant 20561) works in appleHDA Lion... but in Mountain Lion i think not work. confirmed works in Mountain Lion too. Tested in AppleHDA 2.3.1f2. Please add :thumbsup_anim:

Share this post


Link to post
Share on other sites

hello Janek202

Congratulations for the work.

Looking into the APP saw that binpatch ALC887 codec ALC885 about this being corrected.

ALC887 will not work well if corrected ALC885 on it has to be corrected on ADI1984b.

's|\x8b\x19\xd4\x11|\x87\x08\xec\x10|g'

Share this post


Link to post
Share on other sites

hello Janek202

Congratulations for the work.

Looking into the APP saw that binpatch ALC887 codec ALC885 about this being corrected.

ALC887 will not work well if corrected ALC885 on it has to be corrected on ADI1984b.

's|\x8b\x19\xd4\x11|\x87\x08\xec\x10|g'

 

 

Hello Mirone!

Do you have an ALC887 fully working? Even the MUTE key? If so, could you please, send me the PLATFORMS / LAYOUT / INFO files? Need to check the BINPATCH box?

Mine is ALC888b, but I think is the same ALC887.

Thank you!

Share this post


Link to post
Share on other sites

I don't know if I'm using your tool 'the good way'.

 

Selected Realtek ALC892 ats Binpatch option and clicked on Patch: Error

 

Thanks

Share this post


Link to post
Share on other sites

Hello,I get the same empty error message. Looking into the console, here is a more detail of the error one gets:

 

 

3/11/13 12:37:02.937 PM coreservicesd[39]: Application App:"HDA Wizard" [ 0x0/0x1a01a] @ 0x0x7ff448c94740 tried to be brought forward, but isn't in fPermittedFrontASNs ( ( ASN:0x0-0x1d01d:) ), so denying.

 

3/11/13 12:37:02.937 PM WindowServer[80]: [cps/setfront] Failed setting the front application to HDA Wizard, psn 0x0-0x1a01a, securitySessionID=0x186a5, err=-13066

 

Hope that helps...

 

Kind regards,

Lorenzo

Share this post


Link to post
Share on other sites

I get those as well + the empty error dialog.

 

There's a little spinner (similar to the boot spinner) on the HDA Wizard GUI that keeps going, like it can't finish what it's doing.

 

I used Ermac's plist/xml files + DSDT HDEF device from here for AD2000B.

 

It shows in System Information with correct ID 99 and everything but in the sound preference pane i see only my Saffire 6 USB.

 

/EDIT

 

...grabbed Ermac's pre-patched AD2000B AppleHDA for 10.8.3 and that works just fine.

Share this post


Link to post
Share on other sites

Hey man any chance you still have the Platforms.xmllayoutxxx.xml, and info.plist for IDT 92HD87B1/3?

the same as you please help us with  IDT 92HD87B1/3 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×