Jump to content

x86 Xbench Results Thread

1,168 posts in this topic

Recommended Posts

Now this is weird. I would've thought TPS would have the ideal kit for osx86. His score is 39.93.


How does ZX81 get a 48.15 with almost half the cpu speed?




I ran Xbench twice on a Mac Mini 1.4x at the Apple store last night and both times got 47.xx. Those Minis are perky little boxes and I would cobble together an x86 box if I thought it would be comparable. 


Maybe this question belongs in its own thread but are there advantages in 64-bit and/or Hyper-threading with osx86?

OSX86 isn't compiled with 64bit compat. Also, some people report that disabling hyperthreading gives you a better xbench score. Not too sure about general performance though as I dont have a HT enabled CPU (its a 1.8ghz crudbox).

Quit using xbench to compare x86 to ppc.  It is an invalid comparison on this benchmark.  xbench is farely useless in general really, but people like numbers I guess. :)

Yeah, it was supposed to be just a general 'Post your X86 OS X results' thread.. but then PPC people joined the bandwagon! Not that its a problem at all :D

P4 2.4Ghz 400 FSB

512MB RAM DDR2100

ATI 9000 PRO 128MB

The hd it is installed is 8GB UDMA66!!!!!

results below.

You know whats funny about that... The fact that you've got a completely doodle hard drive, and your hard drives scores are BETTER than the mac mini :mellow:

hello there,


after having a couple of nightmares and a lot of trial and error moments (more error moments though) i managed to install deadmoo's image and it almost ran perfect for me (almost !!)



sure i felt great about it and did an Xbench test to see what I have (although i have no idea what this score actually means)..


First my specs :



06.09.2005 18:51





Hardware Overview:


Machine Name: Mac

Machine Model: Intel® Pentium® M processor 1.80GHz

CPU Type: Intel® Pentium® M processor

Number Of CPUs: 1

CPU Speed: 1.8 GHz

L2 Cache (per CPU): 2 MB


Memory: 512 MB

Bus Speed: 533 MHz

Boot ROM Version: R1.03 (Insyde Software Corporation)




Built-in Ethernet:


Type: Ethernet

Hardware: Ethernet

BSD Device Name: en0

IPv4 Addresses:



Configuration Method: DHCP

Interface Name: en0


Subnet Masks:


Configuration Method: Automatic


Server Addresses:

DHCP Server Responses:

Domain Name Servers:

Lease Duration (seconds): 0

DHCP Message Type: 0x05

Option Overload: 0x03


Server Identifier:

Subnet Mask:


FTP Proxy Enabled: No

FTP Passive Mode: Yes

Gopher Proxy Enabled: No

HTTP Proxy Enabled: No

HTTPS Proxy Enabled: No

RTSP Proxy Enabled: No

SOCKS Proxy Enabled: No


MAC Address: 00:40:d0:6a:3c:49

Media Options: Full Duplex

Media Subtype: 100baseTX




System Software Overview:


System Version: Mac OS X 10.4.1 (8B1025)

Kernel Version: Darwin 8.1.0

Boot Volume: tiger-x86

Computer Name: tiger-x86

User Name: restlessone (restlessone)




ATA Bus:




Capacity: 55.89 GB

Model: ST960821A

Revision: 3.05

Serial Number: 3LF0A80E

Removable Media: No

Detachable Drive: No

BSD Name: disk0

Protocol: ATA

Unit Number: 0

Socket Type: Internal

OS9 Drivers: No

S.M.A.R.T. status: Verified



Capacity: 6 GB

Available: 1.37 GB

Writable: Yes

File System: Journaled HFS+

BSD Name: disk0s1

Mount Point: /


Capacity: 49.89 GB

Available: 39.28 GB

Writable: Yes

File System: Journaled HFS+

BSD Name: disk0s2

Mount Point: /Volumes/Files


ATA Bus:





Revision: 1.01

Serial Number:

Detachable Drive: No

Protocol: ATAPI

Unit Number: 0

Socket Type: Internal


Disc Burning:


MAT{censored}A UJDA760 DVD/CDRW:


Firmware Revision: 1.01

Interconnect: ATAPI

Burn Support: Yes (Unsupported)

Profile Path: None

Cache: 2048 KB

Reads DVD: Yes

CD-Write: -R, -RW

Burn Underrun Protection CD: Yes

Write Strategies: CD-TAO, CD-SAO, CD-Raw

Media: No




FireWire Bus:


Maximum Speed: Up to 400 Mb/sec






Type: VGA-Compatible Controller

Bus: PCI

Vendor: ATI (0x1002)

Device ID: 0x4e50

Revision ID: 0x0000

Kernel Extension Info: No Kext Loaded



Resolution: 1024 x 768

Depth: 32-bit Color

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported




DRAM Slot 0/Banks 0/1:


Size: 256 MB

Type: DRAM

Speed: Unknown


DRAM Slot 1/Banks 2/3:


Size: 256 MB

Type: DRAM

Speed: Unknown




System Power Settings:


AC Power:

System Sleep Timer (Minutes): 10

Disk Sleep Timer (Minutes): 10

Display Sleep Timer (Minutes): 10

Sleep On Power Button: Yes




USB High-Speed Bus:


Host Controller Location: Built In USB

Host Controller Driver: AppleUSBEHCI

PCI Device ID: 0x24cd

PCI Revision ID: 0x0003

PCI Vendor ID: 0x8086

Bus Number: 0xfd


USB Bus:


Host Controller Location: Expansion Slot

Host Controller Driver: AppleUSBUHCI

PCI Device ID: 0x24c2

PCI Revision ID: 0x0003

PCI Vendor ID: 0x8086

Bus Number: 0x1d


USB Bus:


Host Controller Location: Expansion Slot

Host Controller Driver: AppleUSBUHCI

PCI Device ID: 0x24c4

PCI Revision ID: 0x0003

PCI Vendor ID: 0x8086

Bus Number: 0x3d


USB Device:


Version: 0.00

Bus Power (mA): 500

Speed: Up to 1.5 Mb/sec

Product ID: 0x0001

Vendor ID: 0x062a





and here is the test result :



Results 38.27

System Info

Xbench Version 1.2

System Version 10.4.1 (8B1025)

Physical RAM 512 MB

Drive Type ST960821A

CPU Test 24.44

GCD Loop 229.25 12.08 Mops/sec

Floating Point Basic 32.36 768.78 Mflop/sec

vecLib FFT 8.98 296.22 Mflop/sec

Floating Point Library 58.81 10.24 Mops/sec

Thread Test 79.68

Computation 69.63 1.41 Mops/sec, 4 threads

Lock Contention 93.10 4.01 Mlocks/sec, 4 threads

Memory Test 54.50

System 63.56

Allocate 150.20 551.57 Kalloc/sec

Fill 56.71 2757.35 MB/sec

Copy 43.66 901.75 MB/sec

Stream 47.71

Copy 44.63 921.74 MB/sec

Scale 45.61 942.20 MB/sec

Add 50.64 1078.67 MB/sec

Triad 50.60 1082.40 MB/sec

Quartz Graphics Test 50.24

Line 43.15 2.87 Klines/sec [50% alpha]

Rectangle 39.25 11.72 Krects/sec [50% alpha]

Circle 41.81 3.41 Kcircles/sec [50% alpha]

Bezier 82.99 2.09 Kbeziers/sec [50% alpha]

Text 67.08 4.20 Kchars/sec

OpenGL Graphics Test 31.50

Spinning Squares 31.50 39.97 frames/sec

User Interface Test 56.02

Elements 56.02 257.12 refresh/sec

Disk Test 24.03

Sequential 38.82

Uncached Write 56.62 34.76 MB/sec [4K blocks]

Uncached Write 53.70 30.38 MB/sec [256K blocks]

Uncached Read 20.84 6.10 MB/sec [4K blocks]

Uncached Read 53.31 26.79 MB/sec [256K blocks]

Random 17.40

Uncached Write 5.83 0.62 MB/sec [4K blocks]

Uncached Write 35.04 11.22 MB/sec [256K blocks]

Uncached Read 63.69 0.45 MB/sec [4K blocks]

Uncached Read 70.57 13.10 MB/sec [256K blocks]



even though i know that i have to be extremely happy about managing it to run on a 1,8GHz machine well with only SSE2, i also have some problems... and to some problems i just found my own solutions (to one problem, to be specific).


- touchpad works, tapping does not (i dont really need it, buttons work)

- network card functioned right away

- USB optical mouse works (wheel too but wheelbutton doesnt)

- graphics: 1024x768 (i read some stuff about ATI cards but i am kinda overloaded right now to deal with it. anybody got a simple explanation?)

- memory card reader (havent checked yet)

- firewire (havent checked yet)

- keyboard (works well.... but... the image is english, my keyboard is turkish. the choices in system preferences under keyboard dont have ''turkish notebook keyboard'' )

- wireless intel (i guess will never function, maybe i should get a usb wireles thing, what dou say?)


one of the biggest problems was that DDing the image on to the drive took very long. My first trial was over a network. as i only have a notebook and no usb drive, i tried to installit using knoppix live cd connected to another xp machine via samba. of course the filesize limitation caused failure every time. after 4 nights in a row with no sleep, i gave up because i have to work and earn a living, too. then a good friend of mine gave me his usb drive and the party began.


i tried the usual methods. started with knoppix and changed drive specs and partitions using cfdisk (after so many samba tries one starts to do it with closed eyes!!) and started the famous dd bs=1048576 command.... then i read one could also write bs=10M or even 1G ! i tried the latter but failed as i only have 512mb memory. so i stuck with 30M and let the notebook dd the image a complete night long (no {censored}! i left it at the office and it was finished when i got back the next morning. i left my office at 2 o'clock in the morning, by the way)


then i started the system using -x and changed deadmoo's stuff and made my own and deleted his. feeling a little scared about deleting those ATI files, i tried to start my system a new and met this famous error message telling me i have to restart which i of course did and then applied MAXXUSS patch for SSE2>SSE3 and deleted the ATI files and all started making sense and fun all of a sudden.


i read about a million posts about resizing the install partition... which i almost didnt understand at all...so what i did was to pop in my knoppix cd once again and call cfdisk and changed the file type of the remaining fortysomething GBs into AF which i then erased and made available using disk utility.


at the moment the only two problems are ATI (because i like my 1280x800) and wireless. apart from that i have to admit i am very pleased with the general performance. all software works ! itunes, iphoto, iIdontknowwhat, etc...everything... most probably everything else i shall install shall function, too.


one trick i came across while reading stuff on the internet :


if you dont really really really need them : uninstall Dashboard and Spotlight as they slaughter your RAM real bad ! and if you dont feel fit about resizing the install partition, just do what i did and keep using it as a second disc (yes, it is automatically mounted and yes you can install your software on it, too)


well this would be the happy end of my story...


i would like to thank :






for their precious help and suggestions while i was struggling with installation over network via samba (didnt work, sorry guys !).


i would also like to thank :





for looking like as they would help but actually doing nothing but confusing a newbie.


if anyone has an idea about how i could fix these mentioned two problems, i'd be more than all ears !


thank you all !




(god its been a long post !)




I got 40.66


2.4GHz Sempron (754, 2800+)

Gigabyte K8NS

512MB Muskin PC3200 2-2-2



I have been running OSX on this machine for about 3 days now and I am very pleased. Sound works, I have a network connection (cheap D-link card), and it runns pretty smooth. I am going to see how long I can last before I go back to WinXP.

Here are my results:


Results 32.87

System Info

Xbench Version 1.2

System Version 10.4.1 (8B1025)

Physical RAM 1024 MB

Model ACPI

Drive Type MAXTOR 6L060J3

CPU Test 28.46

GCD Loop 94.66 4.99 Mops/sec

Floating Point Basic 44.96 1.07 Gflop/sec

vecLib FFT 10.84 357.50 Mflop/sec

Floating Point Library 64.59 11.25 Mops/sec

Thread Test 63.48

Computation 44.49 901.32 Kops/sec, 4 threads

Lock Contention 110.75 4.76 Mlocks/sec, 4 threads

Memory Test 47.48

System 38.74

Allocate 179.74 660.05 Kalloc/sec

Fill 30.47 1481.62 MB/sec

Copy 25.60 528.82 MB/sec

Stream 61.32

Copy 57.87 1195.24 MB/sec

Scale 58.37 1205.91 MB/sec

Add 64.96 1383.89 MB/sec

Triad 64.81 1386.52 MB/sec

Quartz Graphics Test 28.92

Line 27.44 1.83 Klines/sec [50% alpha]

Rectangle 18.20 5.43 Krects/sec [50% alpha]

Circle 21.07 1.72 Kcircles/sec [50% alpha]

Bezier 65.97 1.66 Kbeziers/sec [50% alpha]

Text 53.05 3.32 Kchars/sec

OpenGL Graphics Test 35.15

Spinning Squares 35.15 44.58 frames/sec

User Interface Test 22.28

Elements 22.28 102.25 refresh/sec

Disk Test 30.21

Sequential 79.08

Uncached Write 64.48 39.59 MB/sec [4K blocks]

Uncached Write 67.43 38.15 MB/sec [256K blocks]

Uncached Read 134.24 39.28 MB/sec [4K blocks]

Uncached Read 78.17 39.29 MB/sec [256K blocks]

Random 18.67

Uncached Write 5.64 0.60 MB/sec [4K blocks]

Uncached Write 64.07 20.51 MB/sec [256K blocks]

Uncached Read 84.42 0.60 MB/sec [4K blocks]

Uncached Read 106.02 19.67 MB/sec [256K blocks]



Hope this is good!!!!

here are my results for the following system:


celeron d 330j 775 (533 FSB)

asrock 915-dual board

512 MB ddr400

xbench: 24.95


same system with the FSB oc'd to 600

xbench: 35.95


my mac mini (G4 PPC 1.25/512 MB/stock configuration): 28.09

Dell 8400

P4 3.2Ghz

OSx86 on 36.7G WD Raptor SATA

Ati X800XT (what does this really matter ATM)




Results 50.86

System Info

Xbench Version 1.2

System Version 10.4.1 (8B1025)

Physical RAM 1024 MB

Model ADP2,1

Drive Type WDC WD360GD-00FNA0

CPU Test 20.17

GCD Loop 96.64 5.09 Mops/sec

Floating Point Basic 68.30 1.62 Gflop/sec

vecLib FFT 6.25 206.15 Mflop/sec

Floating Point Library 75.01 13.06 Mops/sec

Thread Test 98.81

Computation 87.17 1.77 Mops/sec, 4 threads

Lock Contention 114.04 4.91 Mlocks/sec, 4 threads

Memory Test 89.57

System 69.86

Allocate 108.28 397.62 Kalloc/sec

Fill 69.14 3361.88 MB/sec

Copy 51.96 1073.22 MB/sec

Stream 124.79

Copy 123.12 2542.92 MB/sec

Scale 123.02 2541.52 MB/sec

Add 127.15 2708.51 MB/sec

Triad 125.98 2694.95 MB/sec

Quartz Graphics Test 77.01

Line 86.61 5.77 Klines/sec [50% alpha]

Rectangle 69.55 20.77 Krects/sec [50% alpha]

Circle 72.20 5.89 Kcircles/sec [50% alpha]

Bezier 94.00 2.37 Kbeziers/sec [50% alpha]

Text 68.92 4.31 Kchars/sec

OpenGL Graphics Test 44.81

Spinning Squares 44.81 56.85 frames/sec

User Interface Test 65.77

Elements 65.77 301.83 refresh/sec

Disk Test 61.52

Sequential 87.32

Uncached Write 103.73 63.69 MB/sec [4K blocks]

Uncached Write 101.65 57.51 MB/sec [256K blocks]

Uncached Read 98.72 28.89 MB/sec [4K blocks]

Uncached Read 61.73 31.02 MB/sec [256K blocks]

Random 47.49

Uncached Write 16.81 1.78 MB/sec [4K blocks]

Uncached Write 113.64 36.38 MB/sec [256K blocks]

Uncached Read 112.15 0.79 MB/sec [4K blocks]

Uncached Read 142.38 26.42 MB/sec [256K blocks]

here r mz resoults:


Results 36.85

System Info

Xbench Version 1.2

System Version 10.4.1 (8B1025)

Physical RAM 512 MB

Model ACPI

Drive Type WDC WD200BB-32CFC0

CPU Test 27.67

GCD Loop 65.92 3.47 Mops/sec

Floating Point Basic 48.77 1.16 Gflop/sec

vecLib FFT 10.93 360.50 Mflop/sec

Floating Point Library 57.50 10.01 Mops/sec

Thread Test 64.37

Computation 49.00 992.74 Kops/sec, 4 threads

Lock Contention 93.79 4.03 Mlocks/sec, 4 threads

Memory Test 58.20

System 44.10

Allocate 211.58 777.01 Kalloc/sec

Fill 33.84 1645.41 MB/sec

Copy 29.62 611.88 MB/sec

Stream 85.56

Copy 81.94 1692.49 MB/sec

Scale 81.82 1690.34 MB/sec

Add 89.85 1914.02 MB/sec

Triad 89.30 1910.37 MB/sec

Quartz Graphics Test 53.30

Line 41.96 2.79 Klines/sec [50% alpha]

Rectangle 50.84 15.18 Krects/sec [50% alpha]

Circle 49.94 4.07 Kcircles/sec [50% alpha]

Bezier 85.61 2.16 Kbeziers/sec [50% alpha]

Text 53.72 3.36 Kchars/sec

OpenGL Graphics Test 38.57

Spinning Squares 38.57 48.92 frames/sec

User Interface Test 62.74

Elements 62.74 287.95 refresh/sec

Disk Test 16.54

Sequential 12.89

Uncached Write 9.88 6.07 MB/sec [4K blocks]

Uncached Write 11.85 6.71 MB/sec [256K blocks]

Uncached Read 18.92 5.54 MB/sec [4K blocks]

Uncached Read 13.94 7.00 MB/sec [256K blocks]

Random 23.07

Uncached Write 12.56 1.33 MB/sec [4K blocks]

Uncached Write 20.90 6.69 MB/sec [256K blocks]

Uncached Read 72.10 0.51 MB/sec [4K blocks]

Uncached Read 31.20 5.79 MB/sec [256K blocks]


still havent fixed my slow hdd speed :(

  • Create New...