Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


DFE's BOOT-132 Resources Thread

152 posts in this topic

Recommended Posts

Well, lets try to make a thread compiling different ISO, INITRD or EXTRA folders made by users who want to share them.

Even if it's not "on demand", you can request for one but be very precise about your Motherboard/Computer, maybe somebody already done it.


If you wish to upload your precious, just few tips to follow:

- State what is the Motherboard/computer targeted

- Enumerate kexts provided

- Describe what is not working.


To make your Own ISO:

1- Galaxy's slimbuilt: http://forum.insanelymac.com/index.php?showtopic=129834

2- SuperHai method: http://forum.insanelymac.com/index.php?sho...mp;#entry803725

3- HMBT Auto-Patch for edit image: (Beta) http://homepage.mac.com/f41qu3/.Public/CDBoot_RC2.sh



- Original ISO with project kexts: http://www.mediafire.com/?uwd9dtttjfk

- If you had problems, need advice, and other help type, go here: http://forum.insanelymac.com/index.php?---showtopic=114651

- Original New Releases and Updates thread: http://forum.insanelymac.com/index.php?showtopic=113288

- Front Page thread: http://forum.insanelymac.com/index.php?showtopic=114013

- Run Patched kernel on retail DVD: http://forum.insanelymac.com/index.php?showtopic=123841

- Make your own GUI for Boot 132: http://forum.insanelymac.com/index.php?sho...115428&st=0

- Enable sound from /extra/extensions.mkext http://forum.insanelymac.com/index.php?showtopic=129058

- Plist only method: http://forum.insanelymac.com/index.php?showtopic=129279



- Chameleon for Hard Disk: http://tinyurl.com/6je4eh

- PC-EFI V9 installer (HD only): http://forum.insanelymac.com/index.php?showtopic=142628

- Boot from EFI partition: http://forum.insanelymac.com/index.php?showtopic=127330[/b]


How-to Repack an Extensions.mkext:

1. software:

- mkextMaker: http://forum.insanelymac.com/index.php?showtopic=140647

- MKext Tool: http://######.com/index.php?option=...1&Itemid=48


2. Manually:

- Open terminal

- Extract content:

sudo mkextunpack -a i386 -d path-to-destination-folder path-to-Extensions.mkext/Extensions.mkext

- Remove/Add/modify desired kexts

- Repair permissions:

sudo chmod -R 755 path-to-destination-folder

sudo chown -R root:wheel path-to-destination-folder

- Create new Extensions.mkext:

sudo kextcache -a i386 -m path-to-New-Extensions.mkext/Extensions.mkext path-to-destination-folder

- Replace the old one



Generic_ISO: http://www.mediafire.com/?1ne1zbl4znv (by f41qu3)


Multisupport_ISO (include various ISO selection with GUI): http://forum.insanelymac.com/index.php?sho...st&p=934112 (by Hagar)


Gigabyte GA-965P-DS3_ISO v2 (P965 chipset): http://www.mediafire.com/?1rw5fnxdmtg (by Sabr)


Another Gigabyte GA-965P-DS3_ISO : http://forum.insanelymac.com/index.php?sho...st&p=819870(by CheN NiaN)


Gigabyte EP35-DS3 (P35 chipset): http://forum.insanelymac.com/index.php?sho...t&p=1015242 (by Ximekon)


Gigabyte GA-P35-DS3L_ISO (P35 Chipset): http://rapidshare.com/files/130047075/p35.iso.html


Gigabyte GA-P35-DS4_ISO (P35 chipset): http://www.mediafire.com/?0g8v3pxntz4 (by Elastic)


Gigabyte GA-EP35-DS3R_ISO with Nvidia/sound support + GUI (P35 chipset): http://forum.insanelymac.com/index.php?sho...st&p=917398


Gigabyte GA-EP45-DS3R_KEXTS: http://www.mediafire.com/?zzz53ltyxoq (by PM!)


Gigabyte GA-EP45-DS3L_KEXTS-ISO: http://www.insanelymac.com/forum/index.php...t&p=1106015 (by Memfys)


Gigabyte GA G33m DS2R_KEXTS (G33 Chipset): http://www.mediafire.com/?nxzggymymjd (by Xinux)


new Gygabyte EP45-UD3R/UD3P_KEXTS (P45 Chipset): http://forum.insanelymac.com/index.php?sho...t&p=1044710 (by WinstonAce)


Gigabyte GA-X38-DS5_ISO (x38 chipset): http://forum.insanelymac.com/index.php?sho...st&p=998506 (by Atomic903)


Asus p5w dh deluxe_ISO (975X chipset) with nvidia support: http://forum.insanelymac.com/index.php?sho...st&p=811773 (by macita)


another Asus p5w dh deluxe_ISO with Nvidia/sound support + GUI: http://www.mediafire.com/download.php?kdwjjyibilo


Asus P5K_ISO (P35 chipset): http://forum.insanelymac.com/index.php?sho...st&p=870159 (by Lisacat)


Asus P5K Deluxe_ISO (P35 Chipset): http://forum.insanelymac.com/index.php?sho...st&p=848752 (by Viper.BR)


Asus P5B-v2_ISO (P965 chipset): http://forum.insanelymac.com/index.php?sho...st&p=859515 (by toto1234)


Asus PSE-VM HDMI_ISO (G35 chipset): http://forum.insanelymac.com/index.php?sho...st&p=866994 (by Nomade)


Asus P5E _Mkext (X38 chipset) with sound support: http://forum.insanelymac.com/index.php?sho...st&p=983470 (by ptitoine)


Dell e520_DMG (p965/g965 chipset): http://forum.insanelymac.com/index.php?sho...mp;#entry808784 (by blkhockeypro19)


updated Dell_Inspiron_6400/9400_ISO with Nvidia/sound/ support + GUI: http://www.mediafire.com/download.php?3mvzghmwym0


Intel DP35DP_ISO (P35 Chipset): http://www.mediafire.com/download.php?hoatvdgqyzy


Intel D945GCLF2_ISO (Intel 945GC Chipset) include guide and pack : http://www.mediafire.com/download.php?ztnmnyfzj5u (by iSynapse)


Lenovo ThinkPad T60: http://www.mediafire.com/download.php?ux4zhtzttcm (by Joel)


Lenovo Y530A-PSE: http://forum.insanelymac.com/index.php?sho...st&p=989485 (by CheN NiaN)


Acer Travelmate 5620: http://forum.insanelymac.com/index.php?sho...t&p=1005803 (by Atomic999)


Edited by sonotone

Share this post

Link to post
Share on other sites

OSx86 on P45 and ICH10


I have very new motherboard GA-EP45-DS4P (quad core CPU) that is based on P45 + ich10, so I did not expect that using boot-132 method would work without tweaking, however grub-dfe.iso (grub-dfe.iso) worked without any mods, so I was able to install the 10.5.1 retail DVD. I tried other ISOs floating around but they did not work for me.


Note that the grub-dfe.iso contains only 4 extensions:







The BIOS had to be set to use AHCI for SATA interface. SATA DVD is required. I was able to do full install, reboot and update to 10.5.4. I was expecting trouble with SATA & ich10, however ich10 is displayed as "Unknown AHCI Standard Controller" in System Profiler and seems to be working fine.


Another P45 thread deals with ASUS P45 based mobo.


Missing stuff: Nvidia 8600 GT acceleration and ALC889A sound.



Share this post

Link to post
Share on other sites

Ok, here's my GA-965P-DS3 v2 ISO: http://www.mediafire.com/?1rw5fnxdmtg


Has some improvements: support for Rev 1.0/Rev 2.0/Rev 3.3 Onboard LAN support. Includes Disabler.kext too. Also I bumped up the version numbers of the kexts so that they aren't replaced by the ones on the DVD. Haven't actually tested it with the retail DVD, but the extensions are working with my Retail DVD OS X install, so I presume it works ok.



Share this post

Link to post
Share on other sites

Sorry guys. I can't seem to figure out how to link to a post! *blush*


Here is the link to the file, with all the props to a guy called K.I.S.S


Good luck!!



Share this post

Link to post
Share on other sites

Got it working on Asus Maximus Formula:


1. Get Fillip's generic boot-132 download




2. Add kexts to generic.iso/ISOEN/INITRD.IMG/initrd/Extra/Extensions/ form my current Kalyway install /System/Library/Extensions:


a. kexts for your GPU (recognized My Nvidia 6200 w/o adding kexts)

b. Network card (modded IONetworkingFamily.kext)

c. sound card (I use a Diamond Xtreme Sound CMI8738PCIAudioDriver.kext)


for details see Superhai Method to edit image: http://forum.insanelymac.com/index.php?sho...mp;#entry803725


3. Burned a cd (use cd-rw incase you need to make mods) NOTE: tried with USB stick but no success.


Finder -> Services -> Disk utitlity -> (MD-5) -> File -> Open Disk Image -> generic.iso -> Burn


4. Boot with the cd, then at prompt hit Esc.


boot device should be defaulted to (df)


5. insert Mac OS X Leopard Retail DVD,


6. hit enter, it will start installing from Mac OS X Leopard Retail DVD.


I hope this works for you. From what other people suggested, I did not have to fiddle with 80 or 81 settings to boot from DVD drive, just hitting (df) worked.


7. Get intenet working and update to 10.5.4. as it will undo a lot of kexts that you may need to fix. Then fix the kexts.


8. To boot without the cd, I installed Chameleon:http://tinyurl.com/6je4eh


Then replace the root BOOT file with the one in the generic cd above. (you may need to show hidden files, delete current boot, and paste new boot)

Also copy the entire "Extra" folder inside the initrd.img to root or let chameleon loader handle it.




1. So far my QE/CI and Quartz Exterme is not supported on my 6200. (updated with Zephyroth Nvidia Universal Installer, QE now working!)


2. Vuze keeps giving me kernel Panics.


3. Kept getting error:


" _CFGetHostUUIDString: unable to determine UUID for host. Error: 35"


in the /Library/Logs/CoreRaid.log then (LOG Files/system.log). I assume Vuze (Azureus) caused it??? solved the problem by _CFGetHostUUIDString Final Extension FIX



My hardware:

Asus Maximus Formula, Nvidia GF 6200, Diamond Xtreme Sound 7.1, Q6600 G0 stepping, 4G Corsair XMS2, Sata HD and DVDrw. Shutdown not working. No sound after coming back from sleep.



Share this post

Link to post
Share on other sites
Since sabr was lazy and didn't help me much out... I bought a USB keyboard (16 bucks and quality is {censored}). I modified his iso to support PS/2 keyboards and mice (no, you don't have to use them at the same time) ... I believe it works fine also for other isos. And it's here :)




What are you talking about? Are you serious?


I spent at least 2 hours talking with you on IRC and making a whole new ISO just to try and help with your PS2 problem... That's a whole lot more than most others on this forum would devote just to one person. If that's your definition of lazy - what else did you expect of me?


what does the disabler.kext actually do?


Put simply, the Disabler.kext disables certain specified kext's (listed in the Info.plist) from loading.

Share this post

Link to post
Share on other sites

Updated 1.21/09

Enjoy the Speed.


another iso for GA-965P-DS3 3.3

with, PS/2, ICHx, Jmb36x, Ethernet(8056) support. Put NVdarwin and EHCIsleepenabler to your extensions folder. Most importantly, they're in mkext***Boost Speed! :P ***


initrd v5.0

Share this post

Link to post
Share on other sites

I was able to install Retail 10.5 and upgrade to 10.5.4 without any problem. My setup consists of an Asus mobo P5K-V and intel core 2 quad cpu. I just used the generic iso.

Share this post

Link to post
Share on other sites
Custom ISO for the GA-P35-DS3l


This fixes the issue of losing QE when updating to 10.5.4.


Use this iso. Update, install NvKush to the HD (It can not be on the disc) and that's it. You will have audio, QE, etc all working.






BTW, This should handle audio on both 883 and 888.


THANX for that ISO worked perfectly....


I Installed this on the RIG in my signature labled 2nd RIG


Here's what i did.....


-Burn your ISO...Boot with it...


-Switch for retail Leopard 10.5 (in my case Burned DL-DVD) hit enter / make sure not to have any usb devices plugged gave me an issue


-Install on hard drive I previously formatted to GUID ....install took round 20-30 minutes

Leopard boots with 800x600 crapy resolution due to no nvidia compatability


-Installed 10.5.4 combo update....reboot with -v -f


-Install AppleHDA and HDAenabler for alc888 with Kext Helper use OSX86tools for quick extension cache clear and permissions...reboot


-Install Nvinstaller.52...used vanilla option for 256 (don't know Y he didn't just name it 256?)

Use OSX86tools once again for quick cache clear and extension permissions...reboot


-Install Chameleon...delete the boot file that it places on root and place the boot file that is on the P35.iso

onto your root.... place "extra folder" from P35.iso on the root as well


reboot without CD


U got yourself a 10.5.4 Mac....


My last tiny issue is my reboot sometimes gets hung up..not a big deal just gotta get off my butt and press the button

Shutdown works though. I hear that the appleapciplatform.kext needs to be replaced for a new one that is floating around here in the forum.

Gonna replace the one in my "extra" folder and try that when i get home...

If anybody has any ideas let me know......

Share this post

Link to post
Share on other sites



Boot cd for retail dvd install and update,


2x boot cds for post install and update to 10.5.4


KExts pack for the kalyway Chameleon_DFE_for_Hard_Disk.zip



Share this post

Link to post
Share on other sites

Success - Asus P5k-vm rev 1.02g with core 2 duo 2.2ghz fully working retail leopard install updated to 10.5.4 - 9.4 kernel (generic 132)


patched IONetworkingFamily.kext sorted the Lan. Then able to sort out nvidia card with nvinject 2.0, ALC883 sound (5.1 surround) sorted with a couple of kext's from P5K-vm install thread:


http://forum.insanelymac.com/index.php?sho...%20vm&st=20 (post 26 for sound & network kexts) Thanks to Allsop


Only thing to sort now is booting from direct from HDD instead of the CD - I'm struggling with this and have tried a few times with the Kaly app & osx86tools app but cannot make it work as yet.


Though no response to my post many thanks go to all the wizards and genius throughout the forum who impart their knowledge.

Share this post

Link to post
Share on other sites

Prepared for Asus P5K Deluxe (may work also on P5K-E and P5K Premium)


Working: Onboard ethernet, shut down/restart


Not working: Wireless, onboard audio


Kexts provided:








Link: http://www.mediafire.com/?aaaaaaawqaa

Share this post

Link to post
Share on other sites
So I've gotten this to work on a GA-EP35C-DS3R with the GA-P35-DS4 iso. You have to use ahci mode and do some other BIOS tweaks (can't really remember what I did). Everything is working fine.


hi, i have tryed the same model and iso, but the installer didn´t shows the IDE hard drives, had you notice same thing?


can i only do it with a sata HD?


Edit: done with a sata hd, but i can't see the ide drives. sound card is dead, so how can i install the kext? same method than in a "standard" hackintosh?


EDIT 2: All done, audio is ok with alcinject, IDE drives found with JMicronATA.kext. Gonna try 10.5.4


EDIT 3: All ok after update to 10.5.4, after reinstall parangon and alcinject / AppleHDA kext

Share this post

Link to post
Share on other sites

Got my p0s system to install leopard retail 10.5.0 with the KABYL iso and dsmos from the genric.iso(made in windos)(somehow generic.iso didnt work for me) and booting thru the chameleon bootloader. Currently updating to 10.5.4.

my GF8400gs isnt getting recognized even after nvkush for some reason...so no QE/CI/Resolution only 1024x768....


mb = ASUS P5GCMX-1333

cpu = PENTUIM E2160 DUAL


HDD = 160 SATA


inbuilt atheros l2 dosent work so i got a RTL8139 that works after installing the driver

Audio is stereo only using AppleAzalia.kext in bootloader

usb kb+ms

one question: can i install efi from the installer that was included with chameleon on the current config?



Share this post

Link to post
Share on other sites
This is probably a very newbie question...but can anyone guide me to where I can get a dual boot guide with this BOOT-132 method. Right now i am running Kalyway with chain0 method. Can I still use the chain 0 method or will I have to do something different. Any input will be very helpful. Thanks.

Chain0 is working fine here. I used the one from the chameleon package. Not sure if there's any difference but if you find it doesn't work, try replacing your chain0 with that one.

Share this post

Link to post
Share on other sites

UPDATE 2008-08-18: ASUS-P5B-v2, does not require -f anymore





e225d55095a371215d2db7078c1934a8 ASUS-P5B-v2.iso



c39d8cb3df50540a40a3f81c29c3ec37fd10774b ASUS-P5B-v2.iso




This iso has been fully tested on an ASUS P5B motherboard, with

all devices working (Gigabit LAN, onboard audio, SATA, JMicron IDE,

PS/2 keyboard and nVidia 8800 GTS card) from OS X 10.5.0 to 10.5.4.


To install Mac OS X you'll need:


* Retail install DVD (not the restore DVD you get with Apple hardware)

* Any SATA or USB DVD drive, IDE drives do not work at the moment.


When you see the Darwin prompt, insert the OS X DVD and press Enter

a few times.


After installation is complete, you can install NVkush (in PostInstall/)

if you have an NVidia card. Use Chameleon_DFE_for_Hard_Disk.dmg to boot

from the HD directly:


* Open the dmg and copy both .pkg and "Extra Contents" on the Desktop

* Copy the folder "Extensions" from the CD to "Extra Contents"

* Run Chameleon_DFE_for_Hard_Disk.pkg


In the zip I have also included the build.sh script used to create

this boot-132 CD. It depends on Linux, because for some strange reason

I prefer to use Linux on my MacBook and OS X on my regular PC :-)




Now here's a short explanation of what each kext is for:


* dsmos - source: BOOT-KABYL-BUMBY+dsmos.kext


This kext is required if you run Mac OS X on non-Apple hardware,

it decrypts several critical binaries (Finder, Dock, etc.).


* ACPIPS2Nub - source: http://forum.insanelymac.com/index.php?showtopic=114578


Required if you have a PS/2 keyboard or mouse/trackpad. It's an updated

version provided by Chun-Nan, which works from 10.5.0 to 10.5.4.


* ApplePS2Controller - source: original BOOT-KABYL-BUMBY


Required for PS/2 keyboards and mice. To make the mouse work I had to

change the following in the ApplePS2Mouse / ApplePS2Trackpad plist:


<string>Safe Boot</string>





* IntelCPUPMDisabler - source: original BOOT-KABYL-BUMBY


This disables AppleIntelCPUPowerManagement.kext, and gets rid of

the "Package 0 didn't get an HPET" error message.


* SMBIOSEnabler - source: original BOOT-KABYL-BUMBY


Provides generic information to get the hardware recognized.


* AppleAzaliaAudio - source: http://forum.insanelymac.com/index.php?showtopic=97201


Provides support for SoundMAX onboard audio (output only).


* IOAudioFamily and OSvKernDSPLib - source: Mac OS X 10.5.4


Original kext from 10.5.4, both are required by AppleAzaliaAudio.


* IO80211Family-[AirPortAtheros] - source: Mac OS X 10.5.4


Original kext from 10.5.4, with a class of devices [168c:001x] added to the

plist and the version number increased.


* IONetworkingFamily-[AppleYukon2] - source: Mac OS X 10.5.4


Original kext from 10.5.4, with one device [11ab:4364] added to the plist

and the version number increased.


* AppleIntelPIIXATA - source: Mac OS X 10.5.4


Original kext from 10.5.4, with several ICH devices added to the plist

and the version number increased.


* JMicronATA - source: Mac OS X 10.5.4


Original kext from 10.5.4, with a class of devices [197b:236x] added to the

plist and the version number increased.


Share this post

Link to post
Share on other sites

P5E-VM HDMI Install instructions


Here is how;


Kexts i used; (NOTE: not all those are required for boot, *=minimum requirement)
















Not all might be necessary but it did not hurt me to have those, only those for me.


BIOS Settings;


Well, I have configure AHCI and jMicron, worked fine for me, that is all i can say.

Some said it worked only with IDE, again, yours to try whatever is best for you.


Tools you will need;

  • Chameleon DFE for Hard Drive (see 1st post)
  • EFIStudio (for the Graphics) ONLY USE AFTER 10.5.4 IS INSTALLED otherwise your system might not boot.

I used my modified version of CDBoot_RC2.sh to allow me to run everything from a subdirectory instead of having files at the root level, I also used the BOOT-KABYL-BUMBY.iso image as I did not had the image referenced in the script.

In my script I also make sure that all kext are own by root:wheel, again not sure it is a necessary step.



Now you are ready;

  1. Burn the image and boot it
  2. at the prompt install the retail and install with whatever option you wish. I selected to install on the same disk that I am using as I had not enough space to backup my Users directories.
  3. Boot again with the cd and select the drive you installed on (80, 81, 82 or whatever)
  4. Install Chameleon DFE for Harddrive found on the 1st post.
  5. Install the update (I used 10.5.3Combo then 10.5.4Update as I did not had 10.5.4Combo). I also did not install GraphicsUpdates 1.0 as it did not let me do it for some reasons.
  6. once booted in 10.5.4, you can now use EFIStudio to generate the gfxstring for your card and modify the com.apple.Boot.plist


  • AppleHDA sound problem;
    Had to copy ALCinject.kext and AppleHDA into the /System/Library/Extensions/ folder of the system disk.
    I had them into the /Extra/Extensions which get loaded by the Chameleon boot loader, but unfortunately those did not. probably because there is something missing at that point in time.
  • Waiting for boot device UUID ADC743-0973-3E9C-9162-4F23590BF36C
    Well, I had forgotten to install Chameleon_DFE for Hard Drive before the 10.5.3 update...
    I had to boot from another OS X disk (my test environment) then install Chameleon on that Leopard disk, then copy manually the /Extra from test to production. Then it booted ok without the CDROM. then did the 10.5.4 updates.
  • Quick fix to stop the Partition boot prompt delay that force you to press enter
    Edit the "/Library/Preferences/SystemConfiguration/com.apple.Boot.plist"
    add a section for Timeout as follow;
    This will give you a 1 second delay before booting the default, which should be your Retail Leopard install.

I've attached my version of the BIOS 604 (604LOGO) with Apple Boot Logo.

Also attached my CMOS to run at 3.81GHz with a E7200 proc.





Here are the attachments/files mentioned above; Enjoy






Edited by Nomade

Share this post

Link to post
Share on other sites

Prepared for Asus P5K


This iso has been fully tested on an ASUS P5K motherboard, from OS X 10.5.0 & 10.5.4.


Working: Onboard ethernet, shut down/restart, PS/2 keyboard & mouse, JMicron IDE


Not working: Onboard audio


Kexts provided:












Link: http://www.mediafire.com/?dgktomnx2gc

Share this post

Link to post
Share on other sites

o hai...


turns out you can also include an alternative KERNEL on the ramdisk image, and boot the retail disc with that kernel...


that means that pre-Core SSE3 machines like mine (ie Pentium D, later Pentium 4 and Celeron D) *CAN* boot the retail DVD.




I can see this thread becoming a lot bigger as people start releasing pre-made ISOs with various kernels... :)

Share this post

Link to post
Share on other sites
o hai...


turns out you can also include an alternative KERNEL on the ramdisk image, and boot the retail disc with that kernel...


that means that pre-Core SSE3 machines like mine (ie Pentium D, later Pentium 4 and Celeron D) *CAN* boot the retail DVD.




I can see this thread becoming a lot bigger as people start releasing pre-made ISOs with various kernels... :D

Nice contribution munky! :D

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.