Jump to content

Clover General discussion

Bootloader EFI Clover

  • Please log in to reply
6520 replies to this topic

#841
kyndder

kyndder

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
  • Gender:Male
  • Location:Brazil

If you weren't confused before you will be now, in short I mixed them up and am not sure which was which, on starting from new I could not find your link...., and was interested to know whether shiecldk had made any changes. So are you saying that mixed profile are not a good idea?


Hi Tony,

Mixing profiles definitely is a good idea...

What I meant was that using the new profiles may not bring any benefits for desktop processors as on the tests that I made
I didn't found any difference when using them...

The best stepping that I have is when I'm using the

StepContextDict of a Macmini5,1 (same as

the new Mac-66F35F19FE2A0D05 "MacBookAir5,1")...

16 > 20 > 23 > 25 > 29 > 30 > 31 > 32

I also have a good stepping when using MacPro3,1 profile, but with a huge gap between the steps...

16 > 17 > 19 > 20 > 29 > 30 > 31 > 32

This is the one that I'm currently using (MacPro5,1 + Macmini5,1) > http://dl.dropbox.co...ro5_1.plist.zip

[EDIT]

Remember that I'm using Turbo states, so, when not using Turbo this difference will
be smaller...

#842
tonydickinson

tonydickinson

    InsanelyMac Geek

  • Donators
  • 190 posts
  • Gender:Male
  • Location:Singapore
Hi @Kyndder - Thank you - it is now saved and labelled correctly so I will not mix them up again - will experiment in the morning. Just about to become 2nd January here and off to bed... Thanks.

#843
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 560 posts
  • Gender:Male
Full translation into German attached.

I hope the encoding doesn't screw up the umlauts. :boxing:

Attached File  clover_i18n_de.zip   20.08KB   15 downloads

#844
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,202 posts
  • Gender:Male
  • Location:Moscow
But Clover already have German. Locale ge

#845
~anima

~anima

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 748 posts
  • Gender:Male
Hi there,

I recently updated to Clover rL970 and it works great on my non-efi machine. Don't need DSDT, just Clover and 5 kexts to get everything working. I went from 952 to 970 and strangely the option "HideAllUEFI"=No in the config.plist doesn't work anymore. I've tested every other option like HideAllRecovery, HideAllWindows and so on and they work and hide the correct partitions.
Did someone else notice this too?

Peace

#846
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Cracow, Poland
HideAllUEFI doesn't work any more. Now we have 3 new options: HideOpticalUEFI, HideInternalUEFI and HideExternalUEFI

#847
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 560 posts
  • Gender:Male
ACPI -> DoubleFirstState: Helps enable SpeedStep on Ivy Bridgy systems
ACPI -> DropBGRT: Drops the Boot Graphics Resource Table. Precaution

#848
beta992

beta992

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male

ACPI -> DoubleFirstState: Helps enable SpeedStep on Ivy Bridgy systems
ACPI -> DropBGRT: Drops the Boot Graphics Resource Table. Precaution

Thanks, will add them to the list. :)

One question about DropBGRT: what I read on other sites is that it has something to do with resolution patching, is this right? Why should it be dropped?

#849
~anima

~anima

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 748 posts
  • Gender:Male

HideAllUEFI doesn't work any more. Now we have 3 new options: HideOpticalUEFI, HideInternalUEFI and HideExternalUEFI

Cool thx. Someone should update the instructions thread as this bit seems quite missable in the changelogs (read them for every commit and probably missed that part)

#850
tonydickinson

tonydickinson

    InsanelyMac Geek

  • Donators
  • 190 posts
  • Gender:Male
  • Location:Singapore

ACPI -> DoubleFirstState: Helps enable SpeedStep on Ivy Bridgy systems
ACPI -> DropBGRT: Drops the Boot Graphics Resource Table. Precaution


Hi K3nny,

Thanks for reminding me about these changes.

Off topic - regarding your ATI AMD7870 - I am using HD4000 now as i ditched my 6870 due to some dry joint issues and consequently disabled CSM and am running UEFI on my Z77 Sabertooth.

I was considering the ATI PowerColor version as they supposedly support UEFI BIOS, and comments you might have would be appreciated.

#851
tdtran1025

tdtran1025

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 358 posts
I used to use Clover back in the days when making transition from SL to Lion because Chameleon wasn't getting the job done. I am back trying Clover again to see if I can boot MLion from USB. I remember then I had to put FakeSMC kext in kexts folder. So I did that with the latest version of Clover and tried to boot from USB. Well, I got the white boot screen with spinning beach ball. From my experience, it means that the loader can't find FakeSMC to boot successfully. Am I wrong? If so, how do I boot MLion from USB? Thank you in advance to anyone.

#852
~anima

~anima

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 748 posts
  • Gender:Male

I used to use Clover back in the days when making transition from SL to Lion because Chameleon wasn't getting the job done. I am back trying Clover again to see if I can boot MLion from USB. I remember then I had to put FakeSMC kext in kexts folder. So I did that with the latest version of Clover and tried to boot from USB. Well, I got the white boot screen with spinning beach ball. From my experience, it means that the loader can't find FakeSMC to boot successfully. Am I wrong? If so, how do I boot MLion from USB? Thank you in advance to anyone.

Did you put the FakeSMC.kext to the EFI/kext folder or to /System/Library/Extensions? For me it only works when put in /S/L/E. Don't forget to boot without caches.

#853
lisai9093

lisai9093

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts
  • Gender:Male
I am wondering if <key>HideAllUEFI</key> is disabled in Clover 980. Even if I set it to YES, it still shows the UEFI volumes. After I switched to 954 version it works smoothly. Any suggestion?

#854
kyndder

kyndder

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
  • Gender:Male
  • Location:Brazil

I am wondering if <key>HideAllUEFI</key> is disabled in Clover 980. Even if I set it to YES, it still shows the UEFI volumes. After I switched to 954 version it works smoothly. Any suggestion?


Now you should use HideOpticalUEFI for Optical Devices, HideInternalUEFI for Internal HDD's/SSD's and HideExternalUEFI for External Devices like USB Stick, etc...

You can find more information here > Clover - Project OS X Forums

#855
el_charlie

el_charlie

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 221 posts
  • Gender:Male
  • Location:Maracaibo, Venezuela
Excellent bootloader.

However, I can't boot into Windows 8 with this bootloader.

I have Win8 installed on a separate hardrive with its own BCD bootloader and when I select the "System Reserved" partition (the one I have to select with Chameleon) I get an error saying that BCD is corrupted or missing. In chameleon/chimera it works fine.

I hid the other two partitions on that drive (the actual OS partition and another to store data) because with chameleon I have to select the first one (System reserved).

Please help.

I'm currently testing this on a USB stick until I manage to boot windows alongside OSX.

Cheers!

#856
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Cracow, Poland
This is not the place to discuss ! This is: http://www.insanelym...ral-discussion/

I have Win8 installed on a separate hardrive with its own BCD bootloader and when I select the "System Reserved" partition (the one I have to select with Chameleon) I get an error saying that BCD is corrupted or missing. In chameleon/chimera it works fine.
Cheers!


Take your Win8 DVD Installer, set in config.plist:
<key>Volumes</key>
<dict>
<key>HideOpticalUEFI</key>
<string>No</string>
<key>HideInternalUEFI</key>
<string>Yes</string>
<key>HideExternalUEFI</key>
<string>Yes</string>
<key>HideAllLegacy</key>
<string>Yes</string>
</dict>
Boot from Clover and you will see Win8 DVD. Start Installing Windows from dvd, reformat the drive and install Windows from scratch. In this way it's installed in a GPT drive in UEFI mode. After instalation Clover boot into Windows normally !

Attached File  after.jpeg   27.45KB   33 downloads

#857
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Cracow, Poland
@lisai9093 HideAllUEFI can't work because it's disabled in code right now.

#858
Stevil

Stevil

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi guys,

I dont know if this problem has already been covered. I need the fix for iMessage and already made the needed Clover USB-Stick. My system is z77n-hackintosh and it runs stable with the chimera bootloader and Mountain Lion.

But when I try to boot with the clover USB-Stick it does not show my "Mountain Lion"-HDD, just some strange icon with "Boot Legacy" under it. By choosing that it starts the chimera bootloader instead of booting up Mountain Lion directly.

What am I doing wrong
?

Edited by Stevil, 10 January 2013 - 11:36 AM.


#859
magnifico

magnifico

    The Special One

  • Donators
  • 2,566 posts
  • Gender:Male

Hi guys,

I dont know if this problem has already been covered. I need the fix for iMessage and already made the needed Clover USB-Stick. My system is z77n-hackintosh and it runs stable with the chimera bootloader and Mountain Lion.

But when I try to boot with the clover USB-Stick it does not show my "Mountain Lion"-HDD, just some strange icon with "Boot Legacy" under it. By choosing that it starts the chimera bootloader instead of booting up Mountain Lion directly.

What am I doing wrong?

Screenshot over here: #####


:hammer: man edited your post..here dont speak

on this site you've linked

#860
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 274 posts
  • Gender:Male

Hi guys,

I dont know if this problem has already been covered. I need the fix for iMessage and already made the needed Clover USB-Stick. My system is z77n-hackintosh and it runs stable with the chimera bootloader and Mountain Lion.

But when I try to boot with the clover USB-Stick it does not show my "Mountain Lion"-HDD, just some strange icon with "Boot Legacy" under it. By choosing that it starts the chimera bootloader instead of booting up Mountain Lion directly.

What am I doing wrong?

You have probably started Clover in UEFI mode, but you did not installed required drivers for UEFI boot in /EFI/drivers64UEFI folder. You can:

1. Do BIOS Clover boot: when selecting USB stick to boot, do not choose "UEFI: <the name of the stick>", but "<the name of the stick option>" from BIOS selection screen
- this should give you Clover menu and all OSX entries

or

2. Do UEFI Clover boot ("UEFI: <the name of the stick>"), but for this you need:
2.1 to add slide=0 in config.plist
<key>SystemParameters</key>
<dict>
<key>boot-args</key>
<string>-v slide=0</string>
...
</dict>
2.2 and you need some drivers in /Efi/drivers64UEFI folder: FSInject-64.efi, HFSPlus.efi, OsxFatBinaryDrv-64.efi, OsxAptioFixDrv-64.efi
- start installer again, choose "Customize" and then select "Drivers64UEFI" option and install it to USB stick over existing install
- then delete all from that /Efi/drivers64UEFI folder except FSInject-64.efi, OsxFatBinaryDrv-64.efi, OsxAptioFixDrv-64.efi
- and then search the web for HFSPlus.efi driver, for example: from here and put it to /Efi/drivers64UEFI
2.3 and then try starting from USB with "UEFI: <the name of the stick>"





Also tagged with one or more of these keywords: Bootloader, EFI, Clover


6 user(s) are reading this topic

0 members, 6 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy