Jump to content

[Guide] The all-in-one guide to Vanilla OS X (including Chameleon + DSDT) for beginners (updated for Yosemite!)

Mountain Lion Vanilla OS X Chameleon DSDT Beginner Guide How-to Yosemite 10.10

  • Please log in to reply
851 replies to this topic

#481
tej720

tej720

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hello sir,

 

I Followed the steps carefully but when i boot with -v mode i got this problem can anyone help me.... :(

Attached Files



#482
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 540 posts
  • Gender:Male
@tej720:
You need to do step 1.C.2 - install the NullCPUPowerManagement kext. If you do not want it, you need to patch the AppleIntelCPUPowerManagement kext (see "Kernel extensions in backtrace").

#483
tej720

tej720

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Thanks for the help,

 

I have patched the AppleIntelCPUPowerManagement.kext

 

Now i got a black sreen what should i do.

 

Please tell me.....

 

my system Config :

 

INTEL DH77KC

I7 3770 Proccessor

Zotak gt630 4GB Graphic Card

Seagate 2TB Hard disk

Zion 8GBx2 Ram



#484
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

try to boot

 

-v GraphicsEnabler=No

 

good hack



#485
tej720

tej720

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Thanks for the help

 

Tried to boot with

 

-v GraphicsEnabler=NO

 

This is also not working

 

but

 

-v GraphicsEnabler=YES

 

make it to installation screen but not responding.... please help....



#486
zarvox

zarvox

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Hi all (sorry for my poor english),

 

My config :

 

Intel Core i7 2600K

ASUS P8H61 R2

4 Gb DDR3

GeForce GTX 660

SSD Samsung 840 Pro 256 Gb

 

I found this guide for moutain lion install well documented and I've followed every steps for creating the USB Installer.

 

Everything seems to bo ok but when I boot on the USB I've a kernel panic after several minut of grey screen.

 

I used the -v flag to boot in verbose mode and after system halt the line is :

 

ACPI_SMC_PlatformPlugin::Start - waitforService(resourceMatching(AppleIntelCPUPowerManagement) timed out

IOBluetoothControler - start



#487
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

maybe graphics ... have u disable the onboard graphics ?

 

try to boot

 

-v GraphicsEnabler=No

 

and post photo of the boot

 

good hack



#488
zarvox

zarvox

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

I'll try it now and no luck  :(

 

pfhv.th.jpg



#489
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

remove from installer all GeForce* NVDA*

 

boot

 

-f -v GraphicsEnabler=No

 

good hack



#490
zarvox

zarvox

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

It works !   :D

 

But after installation, stuck at grey screen  :(

plk7.th.jpg



#491
falco05

falco05

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Mexico, D.F.
I had the same, check if it is installed already, try to boot with the same flags into the installed partition.

#492
zarvox

zarvox

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
I'm stupid! I've forgotten 3B (copy of 2 kexts from USB to HDD).

Now it boot and I restore an old backup (applications/data from a previous hackintosh).

#493
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

nice to hear.. u forgot the fakesmc (kext mandatory to run mac os x in a hack)

 

good hack



#494
mtotho

mtotho

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 714 posts
  • Interests:[img]http://i11.photobucket.com/albums/a198/mtotho/Signature-Mtotho-1.png[/img]

I am having some issue booting to the usb installer.

 

Attached is a snapshot of where the installer is getting stuck.

 

For your convenience, the last few lines read:

 

**AppleSMBusPCI ::start failed to get acpi path for provider

Previous Shutdown Cause: 3

ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(ApplIntelCPUPowerManagement) timed out

DSMOS has arrived

[IOBluetoothHCIController][start] -- completed

 

I am trying to install Mac OSX 10.8 ML.

 

I am running an Asus u35jc laptop which includes:

Intel® Core™ i3 370M 2.4 GHz

Intel® HM55 Express Chipset

The system info said most of my hardware was supported

 

For the premade smbios I chose a MacBook Pro (8,1) - Core i5/i7 (Sandy)

 

I followed each step of the guide. I consider myself an advanced computer user so I do not think I am making any dopey mistakes.  

 

Do the errors mentioned above (and in attached) suggest I did something wrong during the setup? My hardware not supported? or perhaps a bios setting is out of whack?

 

Any help is greatly appreciated. Thanks in advance,

 

Mike



#495
zarvox

zarvox

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Try GraphicsEnabler=No.

#496
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

u should use smbios mbp6,1

 

u don't have a sandy cpu

 

delete all appleintelhd*.*

 

-f -v graphicsEnabler=No

 

and read this to after install

 

http://www.insanelym...-graphics-qeci/

 

good hack



#497
mtotho

mtotho

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 714 posts
  • Interests:[img]http://i11.photobucket.com/albums/a198/mtotho/Signature-Mtotho-1.png[/img]

hello

 

u should use smbios mbp6,1

 

u don't have a sandy cpu

 

delete all appleintelhd*.*

 

-f -v graphicsEnabler=No

 

and read this to after install

 

http://www.insanelym...-graphics-qeci/

 

good hack

Thanks for the suggestions.

 

I have deleted the appleintelhd* from extensions. It appears that the smbios isn't actually saving from the chameleon wizard.. I hit edit->select the proper premade-> save as and when I save it I do not see the file. Even running an "ls -a" I don't see it. I've tried saving to my desktop and it still doesn't show up. Has anyone experienced this?

 

Either way I tried booting again with the flags you suggested and now I get "Still waiting for root device"  in the verbose output.

 

I either need someone's smbios file or help getting mine to save. 

 

 

EDIT: I played around with more settings. The I Opened the Chameleon package and copied the SMbios manually (though I do not know if the format stayed proper). I was able to boot into the installer but now my mouse and presumably keyboard do not work :(

 

EDIT2: Plugged in an external mouse and hit next. I get the error "Mac OS X can't be installed on this Computer"

 

EDIT3: Finally It is installing - I still have no keyboard or mouse functionality. I will update if I can get them to work after installation is completed

 

Thanks,

Mike



#498
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

that error is from smbios... u don't have a proper smbios

 

u can use also macbookpro6,2

 

must be in /Extra

 

insert also in boot

 

USBBusFix=Yes

 

have u install in voodoops2 for the mouse and keyboard ?

 

good hack



#499
mtotho

mtotho

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 714 posts
  • Interests:[img]http://i11.photobucket.com/albums/a198/mtotho/Signature-Mtotho-1.png[/img]

hello

 

that error is from smbios... u don't have a proper smbios

 

u can use also macbookpro6,2

 

must be in /Extra

 

insert also in boot

 

USBBusFix=Yes

 

have u install in voodoops2 for the mouse and keyboard ?

 

good hack

I finally got it to boot using smbios 6,1 

 

USBBusFix=Yes doesn't fix anything. I am in the OS with usb keyboard and mouse plugged in and working (but not trackpad/kb). I will look into this voodoops2



#500
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,666 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

post installation

 

http://olarila.com/f...php?f=28&t=1716

 

good hack







Also tagged with one or more of these keywords: Mountain Lion, Vanilla OS X, Chameleon, DSDT, Beginner, Guide, How-to, Yosemite, 10.10


11 user(s) are reading this topic

2 members, 9 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy