Jump to content

OpenCL Oceanwave & Bandwidth Bench - 07. March 2013

OpenCL AMD NVIDIA

  • Please log in to reply
343 replies to this topic

#1
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Attached File  Bildschirmfoto 2013-03-07 um 19.32.58.jpg   171.12KB   62 downloads

EDIT: March 07. 2013,update to 1.61
- updated UI
- OceanWave benches now 15 sec - no need for ESC key anymore
- added option to run in fullscreen mode - no need for key f anymore. But submit / post at least windowed (default!), because fullscreen fps vary between the different screen resolutions much!! (1440x900 has much more FPS than 1900x1200 on SAME GPU! = less comparable as fixed windowed mode.
- added option for multisampling ON (AA ON) - higher OpenGL load = less OpenCL power, less fps
therefor multisampling/AA OFF as default now! Old values (AA was ON) are not comparable to AA OFF
- added new result tabs for AA OFF and bandwidth. filled with first results
- no more lots of (useless) OpenCL compiler warnings in the log tab
- bandwidth results are comparable with V 1.5.0+


Attached File  OpenCL_OceanWave_Bandwidth_V161.zip   3.34MB   1869 downloads
Download : Link above

Please test and report if work (should look like the screenshoot) and how fast (FPS). LION ONLY (compiled for LION, X64), but may also run, at least Nvidia gpus, on Snow Leopard 10.6.8
HOW TO:
The app starts up and will first measure the bandwidth (takes 1-3 sec). bandwidth speed will be shown
First two benched bandwidth values should be >= 1 GB/sec, otherwise PCIe transferspeed is wrong (Lanes <8,...)
Then BENCHMARK .

OceanWave RESULTS (NEW >= 1.6.1!!, AA = OFF, old values >= 130 fps can be compared)
Macs benched by robart / http://www.barefeats.com/index.html
On the 2010 Mac Pro hex-core 3.33GHz with Radeon HD 5870, I get 246 fps.
On the 2011 iMac quad-core 3.4GHz with Radeon HD 6970, I get 315 fps.
On the 'late 2011' MacBook Pro 2.5GHz with Radeon HD 6770, I get 143 fps.


2012 iMac

OS X 10.8.2 Intel® Core™ i7-3770 CPU @ 3.40GHz 3400 MHz

GPU GeForce GTX 680MX 0 MHz 283.2 fps

Bandwidthes: device>host:8090.6MB/s host>device:5351.9MB/s device >device:65785.4MB/s


2012 Retina MacBook Pro 15"
OS X 10.8.2 Intel® Core(™) i7-3820QM CPU @ 2.70GHz 2700 MHz
GPU GeForce GT 650M 0 MHz 145.3 fps

Bandwidthes: device>host:6092.7MB/s host>device:5847.6MB/s device >device:35775.6MB/s

Mac benched by others:
2010 Mac Pro 6-core

OS X 10.8.2 Intel® Xeon® CPU W3680 @ 3.33GHz 3330 MHz

GPU GeForce GTX 285 1476 MHz 130.7 fps

Bandwidthes: device>host:4615.4MB/s host>device:5569.4MB/s device >device:76426.2MB/s

Mac Pro 6-core (2010)
OS X 10.8.2 Intel® Xeon® CPU W3680 @ 3.33GHz 3330 MHz

GPU Quadro 4000 950 MHz 218.7 fps

Bandwidthes: device>host:6191.4MB/s host>device:5520.8MB/s device >device:53334.2MB/s


iMac12,2 i5-2500S CPU @ 2.70GHz GPU ATI Radeon HD 6770M 725 MHz 170.32 fps
iMac 27" i5 16 GB AMD Radeon HD 6770M 512 MB 10.7.1 165 fps
iMac mid 2011,i5 2,5 GHz, 8GB RAM, AMD Radeon HD 6750 M 150 fps
iMac12,1 i5-2400S CPU @ 2.50GHz GPU ATI Radeon HD 6750M 597 MHz MAX= 148.01 fps

Mac Pro 2,66 GHz NVIDIA GeForce GT 120 - OS X 10.7.1 51 fps
Mac Mini Mitte 2010 mit GeForce 320M 31 FPS
MacBookPro5,1 Intel® Core™2 Duo CPU P8600 @ 2.40GHz GeForce 9600M GT 1250 MHz MAX= 18.22
MacBook 9400M 15 fps

Hackintosh:

HACKINTOSH i7 Mac OS X AMD 7970 FPS= 1140 :superman:
AMD 7970 FPS = 718
GeForce GTX 580 OCed FPS= 700
HACKINTOSH MacPro3,1 Mac OS X GeForce GTX 580 FPS= 629
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q8300 @ 2.50GHz MHz GPU GeForce GTX 460 0 MHz FPS= 591.72 / 615 with 10.7.3 (same HW with smbios MacPro5,1 = only 44 fps = AGPM problem!)
HACKINTOSH iMac11,3 Mac OS X 10.7.2 i7 CPU 860 @ 4100 MHz GPU GeForce GTX 580 0 MHz FPS= 584.58

HACKINTOSH MacPro3,1 Mac OS X 10.7.2 i7-2600K CPU @ 3.40GHz GPU GeForce GTX 570 0 MHz FPS= 579.87
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 i7-2600K CPU @ 3.40GHz GPU GeForce GTX 570 0 MHz FPS= 565.71
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7-2600K CPU @ 3392 MHz GPU GeForce GTX 580 0 MHz FPS= 539.60
HACKINTOSH MacPro5,1 i7 CPU 950 @ 4180 MHz OpenCL GPU GeForce GTX 570 1375 MHz MAX= 516.16 fps

HACKINTOSH OS X 10.8.2 Intel® Xeon® CPU X5355 @ 2.66GHz 2660 MHz GPU GeForce GTX 570 1540 MHz 512.9 fps
iMac12,2 Mac OS X 10.7.2 i5-2500K CPU @ 4100 MHzGPU GeForce GTX 480 0 MHz FPS= 486.44
HACKINTOSH OS X 10.8.3 Intel® Core™ i7-2600K CPU @ 3.40GHz 3410 MHz GigaByte Radeon HD 7870 OC 482.2 fps
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7 CPU 930 @ 2.80GHz GPU GeForce GTX 570 0 MHz FPS= 466.43
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7-2600K CPU @ 3.40GHz GPU GeForce GTX 560 Ti 0 MHz FPS= 421.95
Asus GTX580 Direct CU II 10.7.2 (11C62) 417.48 fps

AMD 6870 403 fps
ASUS EAH6870 1GB (stock clock) 0.7.2 Build 11C73 402 fps
HACKINTOSH MacPro3,1 i7 CPU 920 @ 3000 MHz GPU GeForce GTX 470 0 MHz MAX= 380.12 fps
HIS 6870 378 fps

HACKINTOSH OS X 10.8.3 Intel® Core™ i5-2500K CPU @ 3.30GHz 3309 MHz GPU GeForce GTX 660 1110 MHz 373.6 fps
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7 CPU 860 @ 2.80GHz GPU GeForce GTX 285 1476 MHz FPS= 373.57
AMD Radeon HD 6870 (MSI brand, 1GB VRAM) 10.7.2 372 fps
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q9550 @ 2.83GHz GPU ATI Radeon Barts XT 900 MHz FPS= 366.47
HACKINTOSH iMac12,2 Mac OS X 10.7.2 i5-2500K CPU @ 3.30GHz MHz GPU ATI Radeon Barts PRO 6970 820 MHz FPS= 361.69

HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7-2600K CPU @ 4.20GHz GPU GeForce GTX 560 Ti 0 MHz FPS= 354.47
HACKINTOSH MacPro4,1 Mac OS X 10.7.2 CPU Q6600 @ 3197 MHz GPU GeForce GTX 560 Ti 0 MHzFPS= 350.93

HACKINTOSH OS X 10.8.2 Intel® Core™ i5-2500K CPU @ 3.30GHz 3300 MHz GPU GeForce GTX 560 Ti 1660 MHz 349.8 fps

HACKINTOSH iMac12,2 Mac OS X 10.7.2i7-2600K CPU @ 3.40GHz GPU GeForce GTX 560 Ti 0 MHz FPS= 300.47 (OCed CPU: 354 fps - on very fast gpus cpu speed has some effect, but not to midrange / slow gpus)

HACKINTOSH OS X 10.8.2 Intel® Core™ i5-2500K CPU @ 3.30GHz 3300 MHz GPU GeForce GTX 560 Ti 1660 MHz 275.2 fps
HACKINTOSH iMac11,3 Mac OS X 10.7.2 i7 CPU 870 @ 2.93GHz GPU ATI Radeon HD 5870 850 MHz FPS= 274.36
Gigabyte GTX460 OC2 10.7.1 271 fps
HACKINTOSH iMac12,2 Mac OS X 10.7.2 i5-2500K CPU @ 3.30GHz GPU ATI Radeon HD 5870 850 MHz FPS= 267.87
HACKINTOSH MacPro4,1 Mac OS X 10.7.2 i7 CPU 950 @ 3.07GHz MHz GPU ATI Radeon HD 5870 850 MHz FPS= 264.25

HACKINTOSH iMac9,1 Mac OS X 10.7.2 CPU E8200 @ 2.66GHz GPU GeForce GTX 460 SE 0 MHz FPS=262.49
HACKINTOSH iMac11,3 10.6.8 CPU i7 CPU 870 @ 2.93GHz ATI Radeon HD 5870 MHz MAX= 253.9 fps
HACKINTOSH iMac9,1 Mac OS X 10.7.2 INtel 6420 @ 2800 MHz GPU GeForce GTX 550 Ti 0 MHz FPS= 224.10
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 i7-2600K CPU @ 3.40GHz GPU 2: GeForce GTX 570 0 MHz FPS= 207.57 - maybe something wrong with AGPM, normally much faster
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7 CPU 960 @ 3.20GHz GPU ATI Radeon Barts XT 915 MHz FPS= 203.94
HACKINTOSH iMac12,2 Mac OS X 10.7.2 i5-2500K CPU @ 4200 MHz GPU ATI Radeon Cypress PRO Prototype 400 MHz FPS= 177.71
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q9300 @ 3300 MHz GPU GeForce GTX 260 1348 MHz FPS= 172.39
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7 CPU 920 @ 3200 MHz GPU GeForce GTX 275 1404 MHz FPS= 166.09
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q8200 @ 2.33GHz GPU GeForce GTX 260 1350 MHz FPS= 164.9
GTX 560M 3GB/ Asus Notebook 155.60 fps - great for mobile gpu!
Sapphire Vapor-X HD4890 1GB 155 fps
Gigabyte HD5970 ( single GPU enabled ) 153 FPS
Nvidia GTX 285 151 fps / 154 fps new version
HACKINTOSH MacPro4,1 Mac OS X 10.7.2 i7 CPU 920 @ 3600 MHz GPU GeForce GTX 260 1296 MHz FPS= 151.75

HACKINTOSH OS X 10.8.2 Intel® Core™ i7-3770K CPU @ 3.50GHz 3510 MHz GeForce GTX 260 1408 MHz 151.2 fps

HACKINTOSH OS X 10.8.2 Intel® Core™ i7 CPU 860 @ 2.80GHz 2800 MHz GPU ATI Radeon HD 5770 850 MHz 144.0 fps

Nvidia Quadro FX 4600 on Q9550@3,4ghz = 140,58 FPS
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 E8400 @ 3.00GHz 3600 MHz GPU Radeon HD 4870 750 MHz FPS= 138.87
HACKINTOSH iMac10,1 Mac OS X 10.7.2 CPU E8500 @ 3420 MHz GPU Radeon HD 4870 750 MHz Mac FPS= 138.83
Palit Radeon 4870 1GB Sonic 10.7.1 138 fps

HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q6600 @ 2924 MHz GPU Radeon HD 4870 750 MHz Mac FPS= 132.02
HACKINTOSH MacPro3,1 Mac OS X 10.7.3 CPU E8400 @ 3.00GHz GPU Radeon HD 4870 750 MHz Mac FPS= 131.58

HACKINTOSH iMac12,2 Mac OS X 10.7.2 CPU E6550 @ 2800 MHz GPU ATI Radeon HD 5770 875 MHz FPS= 131.27
HACKINTOSH iMac12,2 Mac OS X 10.7.2 i7-2600 CPU @ 3.40GHz GPU ATI Radeon HD 5770 850 MHz FPS= 124.60

Asus G73sx GTX 460M 122 fps

HACKINTOSH MacPro3,1 Mac OS X 10.7.2 i7-2600K CPU @ 3.40GHz GPU ATI Radeon HD 5770 850 MHz FPS= 121.76
HACKINTOSH MacPro5,1 Mac OS X 10.7.3 CPU E8400 @ 3.00GHz GPU Quadro FX 3700 1600 MHz FPS= 116.34

MacPro3,1 Mac OS X 10.7.2 CPU Q6600 @ 2.40GHz GPU GeForce 8800 GT 1715 MHz FPS= 112.05
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 Q9300 @ 2.50GHz GPU GeForce 9600 GT 1800 MHz FPS= 111.03
HACKINTOSH MacPro5,1 Mac OS X 10.7.2 i7 CPU 920 @ 2.67GHz GPU Radeon HD 4850 750 MHz FPS= 110.68
HACKINTOSH MacPro4,1 Mac OS X 10.7.2 i7 CPU 920 @ 2672 MHz GPU Quadro FX 3800 1204 MHz FPS= 108.79
(?Hack?) MacPro3,1 Mac OS X 10.7.2 CPU Q6600 @ 2.40GHz 2405 MHzGPU Radeon HD 4870 750 MHz FPS= 105.44

HACKINTOSH iMac11,1 Mac OS X 10.7.4 CPU E7300 @ 3000 MHz GPU GeForce 9600 GT 1680 MHz FPS= 92 fps // 55 FPS fullscreen 1280x1014
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q9550 @ 2.83GHz GPU GeForce 9600 GT 1625 MHz _FPS= 99.71
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q9400 @ 3400 MHz GPU GeForce 9800 GT 1500 MHz FPS= 98.68

HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q6600 @ 2997 MHz GPU GeForce 9800 GT 1500 MHz FPS= 98.68
HACKINTOSH OS X 10.8.3 Intel® Core™ i5 CPU 760 @ 2.80GHz 2798 MHz Quadro FX 3700 1600 MHz 92.9 fps
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q9400 @ 3000 MHz GPU GeForce GT 240 1340 MHz FPS= 83.87
HACKINTOSH OS X 10.8.2 Intel® Core™2 Duo CPU E6550 @ 2.33GHz 2327 MHz GPU GeForce GT 430 1400 MHz 91.2 fps
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q6600 @ 2.40GHz GPU GeForce GT 430 0 Mhz FPS= 80.97(with non working AGPM only 20 FPS!)
HACKINTOSH OS X 10.8.2 Intel® Core™ i5-2520M CPU @ 2.50GHz 2500 MHz GPU ATI Radeon HD 6630M 485 MHz 78.3 fps
HACKINTOSH MacBookPro5,4 Mac OS X 10.7.2 CPU T9500 @ 2.60GHz GPU Quadro FX 3600M 1250 MHz FPS= 75.78
HACKINTOSH OS X 10.8.3 Intel® Core™ i7-2635QM CPU @ 2.00GHz 2000 MHz ATI Radeon HD 6490M 150 MHz 74.0 fps
HACKINTOSH OS X 10.8.2 Intel® Core™ i5-2520M CPU @ 2.50GHz 2500 MHz GPU ATI Radeon HD 6630M 485 MHz 70.2 fps
HACKINTOSH MacBookPro6,1 Mac OS X 10.7.2 i7 CPU Q 720 @ 1.60GHz GPU GeForce GT 230M 1100 MHz _FPS= 65.97 - AGPM works - if not only 14.38 fps!
HACKINTOSH MacPro2,1 Mac OS X 10.7.2 CPU Q6600 @ 2.40GHz GPU GeForce GT 220 FPS=57.19

AMD Phenom x6 / HD 4850 1024 FPS= 56.50
HACKINTOSH MacPro3,1 Mac OS X 10.6.8 CPU i5-2500 CPU @ 3.30GHz GPU GeForce 8800 GS 1438 MHz FPS= 55.81
(?Hack?) MacBookPro8,3 Mac OS X 10.7.2 CPU E8400 @ 3.00GHz MHz GPU ATI Radeon Caicos PRO Prototype (AMD 6450/6470 ???) 625 MHz FPS= 47.84
GeForce GT 520 FPS= 45,3
HACKINTOSH iMac12,2 i5-2500 CPU @ 3.30GHz 3292 MHz GPU ATI Radeon 6450 MAX= 44.80 fps
HACKINTOSH MacPRO 4,1 GeForce GTX 260 1296 MHz CPU Q9400 @ 2.66GHz MAX= 42.08 (something wrong: GTX260 should have 140-170 fps!)
HACKINTOSH MacMini3,1 Mac OS X 10.7.2 CPU T6400 @ 2.00GHz MHz GPU GeForce 9600M GS 1075 MHz FPS= 42.02
HACKINTOSH MacBookPro5,1 Mac OS X 10.7.2 CPU T9400 @ 2.53GHz GPU GeForce 9600M GS 1075 MHz FPS= 41.61
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q9550 @ 2.83GHz MHz GPU Radeon HD 4870 750 MHz FPS= 37.38 (very less fps for 4870!)

HACKINTOSH iMac12,2 Mac OS X 10.7.2 CPU Q6600 @ 2.40GHz GPU ATI Radeon 5450 FPS= 39.11 fps

HACKINTOSH OS X 10.8.3 Intel® Core™2 Duo CPU T6500 @ 2.10GHz 2094 MHz GPU GeForce 9600M GS 1075 MHz 35.2 fps
HACKINTOSH MacPro3,1 Mac OS X 10.7.2 CPU Q6600 @ 2.40GHz MHz GPU GeForce 9400 GT 1700 MHz FPS= 33.38
HACKINTOSH OS X 10.8.2 Intel® Pentium® Dual CPU E2180 @ 2.00GHz 2000 MHz GPU GeForce 210 1402 MHz 29.0 fps
HACKINTOSH MacBookPro5,1 Mac OS X 10.7.2 T9300 @ 2.50GHz GPU GeForce 8600M GT 950 MHz Mac FPS= 20.19
HACKINTOSH MacBookPro8,3 Mac OS X 10.7.2 i7 CPU Q 720 @ 1.60GHz GPU GeForce GT 230M 1100 MHz FPS= 14.38 - same Hackintosh gets 65 fps by changes in the AGPM!!



FERMI/KEPLER OpenCL patch : In general OpenCL don't work or may produce errors on patched OpenCL drivers. May be fixed if Apple realize Mac Fermi GPUs like GTX 460/ 560 / 580 /680 in the future. Or use some user patched drivers. look GTX 460 in list.
EDIT: Some user posted HOW TO PATCH drivers for fermi

sudo perl -p -i.old -e '$c+=s/\x8b\x81\x1c\x0c\x00\x00\xeb\x06\x8b\x81\x20\x0c\x00\x00/\xb8\x02\x00\x00\x00\x90\xeb\x06\xb8\x00\x00\x00\x00\x90/; END { printf "%s: %d substitution%s made.\n",($c==1 ? "Success" : "Error"),$c,(!$c || $c>1 ? "s" : ""); $?=($c!=1); } ' /System/Library/Extensions/GeForceGLDriver.bundle/Contents/MacOS/libclh.dylib



You can also use LUXMARK, OpenCL Benchmark raytracing on GPU to bench your OpenCL GPU.
http://www.luxrender...uxMark#Download DL Mac OS X version.
Uses even more complex OpenCL code, but has much higher CPU load as OceanWave benchmark, so CPU speed does matter in that bench - the faster the gpus the more Luxmark is cpu bound.
LUXMARK uses all working OpenCL gpus (up to 8!), OceanWave "only" the first / one in the system.
There is already an results list for LUXMARK here (you can compare OS X results, but there are only a few ones, from 100 to 4000):
http://www.luxrender...LuxMark_Results

Edited by mitch_de, 08 March 2013 - 02:19 PM.


#2
eject

eject

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 261 posts
  • Location:germany; BW
works, but it is a slow card anyway

8500GT 256mb

Starting event loop...
ESC key abort / [GPU] Compute: 56.59 ms Display: 17.67 fps


scho deutlich lahmer wie deine, wer hätts dacht

#3
Regi Yassin

Regi Yassin

    Who am I ?

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Not Telling
Mac OS X Lion 10.7.2 11C57 Fresh Install.
ASUS EAH6870 1GB

I get 370,48 FPS with AMD Radeon 6870 (ASUS EAH) 1GB 10.7.2 11C57

EDIT: try to tes in Snow Leopard 10.6.8 10k549

Attached Files



#4
proteinshake

proteinshake

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Germany
Lion 10.7.1 (11B26), I'm at 124 FPS with ATI 5770 at default clocks

#5
Cyrus the Great

Cyrus the Great

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:tehran
ati mobility radeon hd 4650 1 gb ram
256 mb opencl ram (ati 4670)
64 fps

#6
DarkUser89

DarkUser89

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male
  • Location:Germany / Saarbrücken

Multiple GPUs found
Using device[0] for compute: NVIDIA GeForce GTX 560 OpenCL 1.1
Using device[0] for rendering: NVIDIA GeForce GTX 560 OpenCL 1.1
-------------------------------------------------------------------------------
Connecting to NVIDIA GeForce GTX 560...
-------------------------------------------------------------------------------
Building compute program...
-------------------------------------------------------------------------------
Building compute kernels...
OpenCL Warning : clBuildProgram failed: could not build program for device[0] 0x7fd843844ae8 (GeForce GTX 560) (err:-44)
[CL_BUILD_ERROR] : OpenCL Build Error : Compiler build log:
Error getting function data from server

FFT program build log on device GeForce GTX 560
Error getting function data from server
[CL_INVALID_PROGRAM_EXECUTABLE] : OpenCL Error : Failed to create kernel! Could not find a device with a built executable for this kernel.
Failed to create fft plan!
Failed to initialize CL



#7
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,219 posts
  • Gender:Male
ooppps

GTS 450 oc2


[CL_INVALID_DEVICE] : OpenCL Error : Failed to create context from share group! No CL device found!

Failed to initialize CL
logout

#8
sbg

sbg

    InsanelyMac Protégé

  • Donators
  • 66 posts

Hi,
in the past the Apple OpenCL Demo Ocenwave made troube with ATI gpus.
Crashed or doenst display ocean waves correct.
Perhaps now, at least with latest Lion 10.7.2 dev builds it may also work an ATI 4 / 5 / 6 GPUs.

Please test and report if work (should look like the screenshoot) and how fast (FPS). LION ONLY (compiled for LION, X64)


I get 94 FPS with Nvidia 9600 GT 10.7.2 C57 ( with 10.6.8 it was around 66 FPS only!).

HOW TO:
extract the zip somewhere (desktop, ...)
start the terminal
type cd (drag& drop the folder of the app into the terminal window) ENTER
drag & drop OpenCL_OceanWave into the terminal window ENTER
If you don't make cd (change working directory) the app will complain some missing files.

Here is what I get:
[GPU] Compute: 10.92 ms Display: 91.58 fps
with my 512MB 9800GT

#9
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
THANKS - i will collect all submitted results (FPS) on the first posting.

#10
Regi Yassin

Regi Yassin

    Who am I ?

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Not Telling
how to fix this mitch_de "AMD/ATI does not produce correct output, some content missed like waves" ?
is it an error from my pc or ?

#11
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany

how to fix this mitch_de "AMD/ATI does not produce correct output, some content missed like waves" ?
is it an error from my pc or ?

Its not fixable. It runs well on your ATI 68xx with Lion and not with Snow Leopard, because OpenCL drivers (framework to be exact) from Lion above can do this / get further developed. No chance for 10.6.8 without any 10.6.9 (better OpenCL framework) from Apple.

#12
mindlessmissy

mindlessmissy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 100 posts
  • Gender:Male
Nvidia GeForce GT 120M 1024MB (Laptop)

[GPU] Compute: 96.40 ms

Display: 10.38 fps

#13
Regi Yassin

Regi Yassin

    Who am I ?

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Not Telling

Its not fixable. It runs well on your ATI 68xx with Lion and not with Snow Leopard, because OpenCL drivers (framework to be exact) from Lion above can do this / get further developed. No chance for 10.6.8 without any 10.6.9 (better OpenCL framework) from Apple.

so the result is fair with the one that without having error?

hopes you will understand my english, my eng isnt good enough

#14
HFW

HFW

    InsanelyMac Protégé

  • Members
  • PipPip
  • 84 posts
  • Gender:Male
  • Location:England
OS X Lion 10.7.1
MSI R6870 HAWK 1GB

349FPS

Attached File  Screen_Shot_2011_09_19_at_11.04.07.png   3.53MB   164 downloads

EDIT: and that goes to show how much attention I show... You've already got results from a 6870 lol

#15
amit_talkin

amit_talkin

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
[GPU] Compute: 4.21 ms Display: 237.73 fps

On my HD5970 ( single GPU enabled ). Is it any good?

#16
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany

OS X Lion 10.7.1 MSI R6870 HAWK 1GB 349FPS

EDIT: and that goes to show how much attention I show... You've already got results from a 6870 lol

results may vary, even on same major GPU type. GPU clk + VRAM clk + GPU Powermanagement + (much less) CPU diffs.
So all can post results even same gnu type already listed. Don't forget in this case submit the OS X version (Bxx, CXX if dev builds).

At this time it looks like Nvidia can't bet AMD - maybe some Nvidia GTX 285 owner get in that FPS area. Fermi would but OpenCL framework breaks winning :huh:

#17
amit_talkin

amit_talkin

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
[GPU] Compute: 4.21 ms Display: 237.73 fps

Sorry, I forgot to mention, above score was on 10.7.1 for HD5970.
I would like to see HD5870 score of someone, as single GPU enabled 5970=5870.

#18
Simania_NL

Simania_NL

    Insanely Mac Man

  • Members
  • PipPipPipPip
  • 177 posts
  • Gender:Male
to bad i'm on a Asus 6870 (reference design) with 10.7.1
following error:
[codebox]-------------------------------------------------------------------------------
Multiple GPUs found
Using device[0] for compute: AMD ATI Radeon Barts XT Prototype OpenCL 1.1
Using device[0] for rendering: AMD ATI Radeon Barts XT Prototype OpenCL 1.1
-------------------------------------------------------------------------------
Connecting to AMD ATI Radeon Barts XT Prototype...
-------------------------------------------------------------------------------
Building compute program...
-------------------------------------------------------------------------------
Building compute kernels...
OpenCL Build Warning : Compiler build log:
<program source>:213:5: warning: unused variable 'c'
fftKernel8(a+0, dir);
^
<program source>:61:9: note: instantiated from:
float2 c; \
^
<program source>:276:5: warning: unused variable 'c'
fftKernel8(a+0, dir);
^
<program source>:61:9: note: instantiated from:
float2 c; \
^
<program source>:339:5: warning: unused variable 'c'
fftKernel8(a+0, dir);
^
<program source>:61:9: note: instantiated from:
float2 c; \
^
<program source>:192:15: warning: unused variable 'r'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:18: warning: unused variable 'indexIn'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:27: warning: unused variable 'indexOut'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:37: warning: unused variable 'index'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:44: warning: unused variable 'tid'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:49: warning: unused variable 'bNum'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:55: warning: unused variable 'xNum'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:61: warning: unused variable 'k'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:192:64: warning: unused variable 'l'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:193:9: warning: unused variable 's'
int s, ii, jj, offset;
^
<program source>:195:22: warning: unused variable 'ang1'
float ang, angf, ang1;
^
<program source>:506:1: warning: unused variable 'c'
fftKernel8(a + 0, dir);
^
<program source>:61:9: note: instantiated from:
float2 c; \
^
<program source>:507:1: warning: unused variable 'c'
fftKernel8(a + 8, dir);
^
<program source>:61:9: note: instantiated from:
float2 c; \
^
<program source>:352:15: warning: unused variable 'r'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:352:37: warning: unused variable 'index'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:353:9: warning: unused variable 's'
int s, ii, jj, offset;
^
<program source>:353:12: warning: unused variable 'ii'
int s, ii, jj, offset;
^
<program source>:353:16: warning: unused variable 'jj'
int s, ii, jj, offset;
^
<program source>:353:20: warning: unused variable 'offset'
int s, ii, jj, offset;
^
<program source>:355:16: warning: unused variable 'angf'
float ang, angf, ang1;
^
<program source>:580:15: warning: unused variable 'r'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:580:37: warning: unused variable 'index'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:580:61: warning: unused variable 'k'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:580:64: warning: unused variable 'l'
int i, j, r, indexIn, indexOut, index, tid, bNum, xNum, k, l;
^
<program source>:581:9: warning: unused variable 's'
int s, ii, jj, offset;
^
<program source>:581:12: warning: unused variable 'ii'
int s, ii, jj, offset;
^
<program source>:581:16: warning: unused variable 'jj'
int s, ii, jj, offset;
^
<program source>:581:20: warning: unused variable 'offset'
int s, ii, jj, offset;
^
<program source>:582:12: warning: unused variable 'w'
float2 w;
^
<program source>:583:11: warning: unused variable 'ang'
float ang, angf, ang1;
^
<program source>:583:16: warning: unused variable 'angf'
float ang, angf, ang1;
^
<program source>:583:22: warning: unused variable 'ang1'
float ang, angf, ang1;
^
<program source>:584:20: warning: unused variable 'lMemStore'
__local float *lMemStore, *lMemLoad;
^
<program source>:584:32: warning: unused variable 'lMemLoad'
__local float *lMemStore, *lMemLoad;
^


Illegal instruction: 4[/codebox]
Some kind of kernel panic.....

#19
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Ask other ATI/AMD 6870 users which kind of injection (chameleon, ATI INIT,...) they use.

#20
jsl

jsl

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts
Asus EAH5850 1 GB in Lion 10.7.2 (11C37)
Processor: 3.6 GHz Intel Core 2 Duo

Starting event loop...
ESC key abort / [GPU] Compute: 4.41 ms Display: 226.95 fps





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy