Jump to content

Full solution for Zotac IONITX Atom 330 for 10.6.x SL


  • Please log in to reply
457 replies to this topic

#21
CPT_MAC

CPT_MAC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
Thank you guys, this is more than brilliant!!!!!!!!!!!!!

First I had some difficulties, but this was my fault, not following the rules (steps) which in deed ended up in KP.

First I downloaded a chamelon boot loader from a different place and the install failed. Downloaded the one you suggested installed perfectly.

My next fault was, to test with 10.6.0 without updating and kernel exchange, so of course now I know got KP.

Than I updated and swapped the kernel with the modified one, and voila it's working nicely.

On thing, I had to assign a manual IP. Fully DHCP has given a self assigned wrong IP. For a desktop unit it's not a problem.

After that I had to run the network diagnostic to connect to my ISP.

Auto sleep and wake up works HDMI I will test next, also digital out.

I am not sure does eugene k2 mean his guide under known issues, digital sound does not work, or digital sound via HDMI does not work.

As long digital sound work, on many home theater receiver like my Yamaha RX-V2400 I can connect a HDMI cable, but feed the sound via coax or optical. One other possibility I can think of is to use a HDMI adapter, open this adapter and solder a little cable to it, which fits in coax output. I had recently to adjust a HDMI TO DVI Adapter mechanecly to fit to my graphic card and I was surprised how easy this little adapter fall apart and how old fashioned it was inside made with wirer.

Thanks again for this wonderful guide!!!!!!!!!!

#22
CPT_MAC

CPT_MAC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
update

HDMI 1080 works fine

Digital out coaxial works, but PCM 2 channel only !!

Would be very nice to have dolby 5.1. But, I don't wand ask for too much tonight.

I love this little machine now.

I wonder if snow server will run with the same installation guide? I will try on one off the next days. I guess it will.

#23
hiroo

hiroo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts

update
Digital out coaxial works, but PCM 2 channel only !!

Would be very nice to have dolby 5.1. But, I don't wand ask for too much tonight.


I think standard digital out (optical or coax) can only support PCM 2-channel out unless the bitstream is Dolby Digital or DTS encoded. I don't think Mac OS has ever supported Dolby or DTS output of standard system audio. I'm not sure if a particular app, like the DVD player, can output Dolby or DTS. If so, then Plex or other apps can output the existing Dolby stream from an HD broadcast over the digital out.

#24
CPT_MAC

CPT_MAC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
For sure dolby 5.1 pass thru is supported under OSX, at least using VLC or Boxee for play back on a real Mac and also on an Hackintosh.

mpeg, img or the real disk with AC3 sound, all works.

The standard DVD player in OSX might not support dolby, it's a long time I used that application, so I am not sure.

I think the problem is, the digital pass thru does not pass the dolby sound to digital out. Maybe kext or DSDT has to be modified accordingly. To have no sound via HDMI output does not bother me at all. Just one more tiny cable to run.

#25
robinbouc

robinbouc

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi,
i'm french (so sorry for my bad english), and i have a Zotac ION ITX MB, so i'm very interested on installing SL on it.
But i'm really a newbie in "hackintoshing", and don't really understand how to install SL ... :blink:
I've got not idea on how to make a Chameleon USB bt key (boot CD maybe ?)

I've got :
- an USB key made bootable using syslinux (syslinux -ma e:)
- a SL 10.6 Retail DVD image in dmg format. I've converted it in ISO format using UltraISO
- downloads : everything in the first post

Is there someone here kind enough to give me a step-by-step guide ? :rolleyes:

Thx

#26
JoeyKing

JoeyKing

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Hello

to get this thing running you already need to have a PC or Mac running snow leopard: from this computer you can install to a new disk, following the instructions from Michael Glass in this thread. Then install Chameleon as in the first post plus the modifications.
I am not aware (and did not manage...) how to install to the Zotac from pure DVD.

Regards
Joey

#27
robinbouc

robinbouc

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
OK. So if I understand well, i have to :
- install SL using Boot-132
- under SL, install Chameleon (latest)
- put files (thread 1) in appropriate folders
That's all ?

#28
CPT_MAC

CPT_MAC

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
@ robinbouc

You don't need a boot 132 disk and you also don't need a bootable usb stick.

You need an real mac, or an hackantosh with snow as operating system.

Than you hook up the hardisk, which you want to use later in your ion via USB to your real mac, or direct to your hackintosh.

Now you install from your running computer snow to your new drive. With my dmg "snow" I got an error, so I had to burn first a disk. Maybe different with yours and you can mount and install.

When installation has finished you can install chameleon, but be care full to install to the new disk and not to your running system.

Than you copy all the files you need from post #1 to the new disk.

Do all the setup in your ION BIOS, and start yourION with the new disk. Thats all

#29
Son_Of_Mole

Son_Of_Mole

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi, this question is all that have this board working in OSX.

Can you got the HD playback to work 100%... Or does it skip or the like. I would like to use this in part as a media center and having smooth playback is a must!

Thanks guy, if I got for this setup I will report back on how all is going.

Thanks,
CM

#30
StillCantGetIt

StillCantGetIt

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I haven't been able to get smooth playback on the ion. When I boot with the xbmc live cd, I can play 1080p mkv files from a network share without any frameskipping. Trying the same with either plex or boxee results in choppy playback. It seems to be that not too much processing is hitting the gpu in OSX.

#31
theotherone

theotherone

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male

I haven't been able to get smooth playback on the ion. When I boot with the xbmc live cd, I can play 1080p mkv files from a network share without any frameskipping. Trying the same with either plex or boxee results in choppy playback. It seems to be that not too much processing is hitting the gpu in OSX.


The same here. On my new MacBook unibody i get absolute smooth playback and didn't have any problems, if i understand the grapicchip should be the same in both machines, maybe the faster and better core 2 duo in the macbook makes the difference.

So, if you want smooth playback of mkv-files with the ion you need to go the ubuntu/xbmc road...

#32
Son_Of_Mole

Son_Of_Mole

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Thanks for your quick reply guys... Will keep an eye out just in case this is fixed.. :)

#33
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Italy
Hi can anyone help me about my alc662 audio chipset on a Asrock ion 330Pro? didn't found any working kext for it... in System profiler i see 0x18495890 ID AUDIO:662. if i modify the alc662 kext provided here with this id it will probably work? i have snow leopard 10.6.2 installed with a boot123 disc, original DSDT created. tnx in advance for your suggestions and sorry for english :D

Keep the great work you all!

EDIT: the sound chipset isn't the alc662 (mac profiler is wrong). unboxing the ion330 i see that the chipset is realtek890b.... hope this will be supported soon... or maybe someone alredy have the solution....

#34
MplsMacWright

MplsMacWright

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:Minneapolis, MN, USA
Anybody successfully install SL on the IONITX D-E board?

Upon installation a I get is a kernel panic on startup. I followed Michael Glass' instructions. What am I missing, they should be basically the same motherboard? Can anybody help?

#35
banini_jeque

banini_jeque

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts

Anybody successfully install SL on the IONITX D-E board?

Upon installation a I get is a kernel panic on startup. I followed Michael Glass' instructions. What am I missing, they should be basically the same motherboard? Can anybody help?


I have the D-E and it works great on mine. As is mentioned I helped (a little bit) to get it working. I think Shoarthing also has the D-E. My guess is that you have hyper-threading turned on and haven't installed the hacked kernel or something.

#36
mac_swamy

mac_swamy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Anybody successfully install SL on the IONITX D-E board?

Upon installation a I get is a kernel panic on startup. I followed Michael Glass' instructions. What am I missing, they should be basically the same motherboard? Can anybody help?


Removing AppleIntelCPUPowerManagement.kext, should solve the problem.
:)

#37
JoeyKing

JoeyKing

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
Hi

does sleep really work? I mean, how do you wake him up again? double clicking the mouse does nothing. How else?

Thanks
Joey

#38
eurodj

eurodj

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
OK well i got it up and running so fr but shutdown isnt working well pc doesnt shutdown sleep i havent tested but will other than that normal usage ok still have to test 1080p playback

#39
eurodj

eurodj

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Ok tested most of it...it runs ok, not like one of my macbooks but overall ok 720p playback on vlc sucks on plex more acceptable but not all that definitely think the rig needs an os that can take better advantage of the ION chipsets capabilities like ubuntu or even windows 7 might go that route just for testing. Overall great guide for those that want to run osx yet the experience is a bit hampered by the fact that the atom is not up to par with the OS.

#40
theotherone

theotherone

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts
  • Gender:Male

I love this little machine now.

I wonder if snow server will run with the same installation guide? I will try on one off the next days. I guess it will.



update: I successfully installed 10.6.2-SL-Server on this beauty. Runs very well.

Make sure to install SL-Server this way (Source: this thread):

Mount your Server Install Disk. Now to install the server packages. Mount your Server Install DVD and then Cmd+Shift+G in Finder. Type /Volumes/Mac OS X Server Install Disc/System/Installation/Packages to navigate to the individual packages. Install in this order onto your intended partition.

Install 5 packages, this time, in this order:

a) OSInstall.mpkg
b.) ServerEssentials.pkg
c) ServerAdminTools.pkg
d) ServerSetup.pkg
e) QuicktimeStreamingServer.pkg (if you need it)

Make sure you have a working internet connection via ethernet before proceeding to install. On reboot via usb stick, set your server up as per normal.

----------------------

After that, install OSX Server combo update 10.6.2 from APPLE.

After that, proceed with chameleon and all the files like Michael Glass said in Post #10 in this thread.

Happy Serving! ;) ; and again: thanks to the original posters for the work on this nice little board!

Question for eugenek or shoarthing: Could we safely use the new chameleon RC4 instead of RC3?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy