Jump to content

Official Unofficial Cider Game thread


243 posts in this topic

Recommended Posts

I am trying to get Sins of a Solar Empire running under Cider 1770. I have everything working except the fonts. The fonts display as total gibberish, random symbols in the text fields. I have looked up on Wine and other sources and have been unable to find a fix, this isnt the miss sized fonts issue documented widely. This is the only show stopping bug between me and a perfectly stable and running SoaSE on mac. :wacko:



here are some pictures:

[see attached]


Link to comment
Share on other sites

  • 3 weeks later...

I'm having trouble porting the following games and don't know where I'm going wrong. All they do is bounce in the dock and quit.


I know you have to install with Windows/Crossover and drag and drop your game's folder into the transgaming/c_drive/Program files of Cider, and I know you have to edit the info.plist to the location of the folder & the location of the game.


The games are:

Dead Space


FarCry 2




I'm pretty sure my computer can handle these games, with 256MB VRAM 4GB Ram, and 2.4GHz dual core.

Link to comment
Share on other sites

Anyone here have Call of Duty World at War running with Cider? I know my family is getting that game for me on Christmas :thumbsup_anim: I would like to have it run under Mac OS X and not have to boot into Boot Camp. A tutorial would be nice if anyone has that game running.

Link to comment
Share on other sites

Read the damn forum! All those games require DX9/Shader Model 3.0 and the current version of Cider doesn't support that yet.


I read and printed out the whole thread, but I was not able to port any game. ;)


I made it as written in the CARBON thread, with the cracked framework from HoMV 1.4 and the cider version from HoMV 1.4 I was able to get a starting CARBON version, but only in 640x480 resolution.


If I change the framework files or the cider version, nothing is working anymore.


This seems the most active cider community on the net, so helping the newbies would be fine. :P


I can offer a big PC-Games collection, with many DX7/DX8 games. Would be nice to see them on the mac.


What I have done until now: Heroes of Might and Magic - German - Version 1.6. Working perfect.


I installed the original german PC version using Parallels.

I installed all patches up to 1.60.


I bought on the black friday the english online version from Heroes of Might and Magic V and installed it with all the MAC-Patches, then replaced the files with the PC-Install. :P


Tried to fix some other games that are avaible on the net, but using the HoMV framework or any newer cider version I was not able to start a game anymore.


How to fix the icon is easy, you cannot take the icon from the pc, you have to load it into an icon editor and to save it as mac native icon again.

Link to comment
Share on other sites

Using the cracked HoMV framework and a newer cider version is not working: You will get the message that a hack was found inside the framework.


What we would need is a framework that has no copy protection inside. I think so.


Would be nice to found someone that can help me getting my NFS CARBON working with the newest cider version.

Tried many frameworks and many cider version, but it is only working with the mentioned files in this thread and then only in 640x480...


I also inserted the registry strings from windows. But it is no more starting now... ???


Tried to get working the following games:


Metal Fatigue (DX8)

Rollcage Stage 2 (DX7) but very fast and nice...

Runaway (DX8)

Vice City (DX9)


Always the same error -> they are not starting...

Link to comment
Share on other sites

I attached my changed files for NFSCarbon. Maybe someone can explain me how to get it work, with which framework and which ciderversion. As I said before, I was able to get it running in 640x480 resolution only and with the hacked framework from HoMV 1.4. If I use the other framework or any other cider version it will not work.


I think I understand how to setup a package, now I need to know how to get it running. ;)


I attached 2 screenshots and the files I changed...


Link to comment
Share on other sites



I do not know what I have changed on my system, but my NEED FOR SPEED CARBON is now working with latest Spore Framework and with latest Spore Cider version. I can change resolution and settings inside the menu, this was not working before... really crazy. :(


Any idea how I can change language settings inside cider?


NFSC is running in German with Parallel 4.0, but only in English with Cider.

Link to comment
Share on other sites

Got my bought GERMAN NFS Carbon running in German language perfect on my new Macbook Pro. :blink:


Used latest files from Spore and exported registry files from windows version. :)


With this new knowledge I will try again the other games...

Link to comment
Share on other sites

  • 2 weeks later...

So I've tried to get some games working with the 2060 cider posted here:




Unofortunately, so far result has always been the same: the icon bounces once in the dock then exits without any error messages.


Do you guys have any idea why this might be happening?


And yes, I set everything correctly in info.plist

Link to comment
Share on other sites

Well after adding the f_drive, it still didn't launch so in the info.plist I changed this:


<string>-- cohupdater.exe -test</string>


to this:


<string>-- hl2.exe -test</string>


hl2.exe because the game I'm currently attempting to get fully working is Half-Life 2 with all the advanced graphics (like HDR). I thought this cider would have true DirectX 9 support but even though HDR is working, I can't see any water...


I guess I'll have to wait some more...

Link to comment
Share on other sites


  • Create New...