Jump to content

[pre-release] macOS Monterey


1,947 posts in this topic

Recommended Posts

3 hours ago, Slice said:

Monterey since beta 7 has no Nvidia graphics drivers. You may use Chris111 solution but this is the end for Nvidia in macOS.

That's good news...I haven't caught up with all the backlog so I will have to read up on the solution...just got in last night and set the PC on autopilot. Thanks for the information :)

Link to comment
Share on other sites

1 hour ago, Slice said:

RX560

The supported AMD R7/R9 cards would be more in par with the low-end/entry-level Kepler GK208 GeForce GT710/720/730 cards. RX560 is a much more powerful card and may not be suitable for light desktop PCs with a limited power supply (<300W) given that it requires some 75W or so. It may not even physically fit though I understand some single-slot low-profile RX560 models do exist..

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

On 9/22/2021 at 4:52 PM, chris1111 said:

I use my  Kext-Install.app with the patch Binaries files

Install done Reboot 

Test on DELL Optiplex 790 Sandy bridge system i5 2500K UEFI booting OpenCore 0.7.3  Works well :rofl:

1453711347_ScreenShot.png.18e05e94a5da4b38fd1e80a60ffaf7b4.png

Hi Chris1111, I would really like to use your kext-install.app but when I try to download it, Github has a note that it's been temporarily removed because of Big Sur issue. This is the page I landed on - is it the right page? https://github.com/chris1111/Kext-Install/releases/tag/V1. The other question I have is do I install all the kexts in /12-Monterey/Extensions/Graphics-Acceleration/Nvidia-Kepler/ or just GeForce.kext? Many thanks in advance.

Link to comment
Share on other sites

52 minutes ago, chris1111 said:

@sonicthehedgehog2

See my repos  GeForce Kepler Patcher

Bad news. GeForce Kepler Patcher not working for me. I caught a Kernel Panic. Not sure what the issue is...I've ensure csrutil disable and csr-active-config were set as required. Gatekeeper was disabled. Here's a photo of my screen. I'll leave my pc for now. Let me know if you need me to get more info.

 

IMG_0415.thumb.JPG.346c239c5fb48ede554d6ff8b44fb230.JPG

Link to comment
Share on other sites

34 minutes ago, sonicthehedgehog2 said:

Bad news. GeForce Kepler Patcher not working for me. I caught a Kernel Panic. Not sure what the issue is...I've ensure csrutil disable and csr-active-config were set as required. Gatekeeper was disabled. Here's a photo of my screen. I'll leave my pc for now. Let me know if you need me to get more info.

 

 

Your probably not follow the guide corectly

anyway 

1789564991_ScreenShot2021-09-25at9_50_17AM.png.5d0c6de34b8761f0a393fb654b7cffed.png

Edited by chris1111
Link to comment
Share on other sites

9 minutes ago, sonicthehedgehog2 said:

By guide, do you mean your video at the bottom of the page? I followed that to the letter. I will give it another try and report back

148298231_ScreenShot2021-09-25at9_50_17AM.png.0d86a87f09160d7bd9ea95a9a1804fe4.png

For help its on github your of topic here, geforce patcher as nothing to do with the topic here

Edited by chris1111
Link to comment
Share on other sites

1 hour ago, miliuco said:

Thanks. All RX560 are polaris? If it the case, it's one of the cheaper cards atm for the hacks, even if it has a high price compared with a few months ago.

 

I have the ROG-STRIX-RX560-O4G-GAMING, polaris 21, with external power, 4Gb DDR5 at 7Mhz, with a consumption of 80 watt, it works correctly in Monterey so far.

 

ASUS_90YV0AH0-M0NA00_ICECAT_21481899.jpg.29d3f8417f991e0a65f0bb1b786dfb1c.jpg

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

2 hours ago, miliuco said:

Thanks. All RX560 are polaris? If it the case, it's one of the cheaper cards atm for the hacks, even if it has a high price compared with a few months ago.

It can be Ellesmere (as mine) also compatible from HighSierra to Monterey.

 

Other cheep cards may be R7 240-260, 350, 430 Oland family. Compatibility is questionable.

And new card RX630 I don't know what is it

  • Thanks 1
Link to comment
Share on other sites

RX 630 is a laptop part, you cannot purchase such a GPU to put into a desktop PC.

And performance sucks too, it is a very low-level, entry powerful (powerless? :) ) card.

Edited by Naki
  • Thanks 1
Link to comment
Share on other sites

51 minutes ago, Naki said:

RX 630 is a laptop part, you cannot purchase such a GPU to put into a desktop PC.

And performance sucks too, it is a very low-level, entry powerful (powerless? :) ) card.

There are OEM cards for PCIe slot for desktop soldered with the mobile chip. It's a pity I can't find it in markets.

  • Thanks 1
Link to comment
Share on other sites

6 hours ago, sonicthehedgehog2 said:

Bad news. GeForce Kepler Patcher not working for me. I caught a Kernel Panic. Not sure what the issue is...I've ensure csrutil disable and csr-active-config were set as required. Gatekeeper was disabled. Here's a photo of my screen. I'll leave my pc for now. Let me know if you need me to get more info.

https://github.com/chris1111/Geforce-Kepler-patcher/issues/1

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

I had more time to do the Script much better

Now you can select InstallAssistant.pkg from anywere

See script spoiler

Spoiler
#!/bin/bash
# script for making installer Monterey Beta 7
# by chris1111 
# Vars
TempPath="/Private/tmp"
apptitle="Install macOS Monterey"
version="1.3"
# Set Icon directory and file 
iconfile="/System/Library/CoreServices/Finder.app/Contents/Resources/Finder.icns"
# Select Install Media
response=$(osascript -e 'tell app "System Events" to display dialog "Select your Apple Package InstallAssistant
Cancel for Exit" buttons {"Cancel","InstallAssistant"} default button 2 with title "'"$apptitle"' '"$version"'" with icon POSIX file "'"$iconfile"'"  ')

answer=$(echo $response | grep "InstallAssistant")


 #  If user Cancel
  if [ ! "$answer" ] ; then
    osascript -e 'display notification "Script closing" with title "'"$apptitle"'" subtitle "User cancelled"'
    echo "Script closing User cancelled"
    Sleep 2
    exit 0
  fi


  # Get input of InstallAssistant
  InstallAssistantPath=`/usr/bin/osascript << EOT
    tell application "Finder"
        activate
        set Filerpath to choose file default location "$HOME/Downloads" with prompt "Choose your InstallAssistant.pkg "
    end tell 
    return (posix path of Filerpath)
  EOT`


echo "
**************************************************** 
       ****** Install macOS Monterey ******* 
****************************************************"

sudo rm -rf /Applications/"Install macOS Monterey beta.app"

sudo rm -rf $TempPath/InstallAssistant

sudo installer -verboseR -pkg /$InstallAssistantPath -target /

echo "Expand Package Please Wait. . . "

pkgutil --expand $InstallAssistantPath $TempPath/InstallAssistant

Sleep 1
echo "Attach Image . . . "
echo " "
hdiutil attach -nobrowse $TempPath/InstallAssistant/SharedSupport.dmg

sudo mkdir /Applications/"Install macOS Monterey beta.app"/Contents/SharedSupport

echo "Copying Resources Please Wait. . . "

sudo cp -R /Volumes/"Shared Support"/* /Applications/"Install macOS Monterey beta.app"/Contents/SharedSupport

echo " "
Sleep 1
sudo rm -rf $TempPath/InstallAssistant
hdiutil Unmount /Volumes/"Shared Support"
osascript -e 'display notification "Done " with title "'"$apptitle"'" subtitle "Successfully complete"'
echo "Done. "


 

Attaching V3

create_app-V3.zip

Enjoy

 

1358541077_ScreenShot2021-09-25at8_32_02PM.png.b0adb336da5c867365c2389d273e79ec.png

 

Edited by chris1111
  • Like 5
  • Thanks 6
Link to comment
Share on other sites

4 hours ago, SavageAUS said:

Can somebody please explain to the steps to get the full beta 7 installer. 

 

Link to download that was given a few pages back. You do need to have a working older macOS Monterey Beta, or maybe an older macOS version will work too. (such as Big Sur/etc)

It's a Package installer though, so if you want a DMG it is not that.

Edited by Naki
Link to comment
Share on other sites

30 minutes ago, Naki said:

 

Link to download that was given a few pages back. You do need to have a working older macOS Monterey Beta, or maybe an older macOS version will work too. (such as Big Sur/etc)

It's a Package installer though, so if you want a DMG it is not that.

I have scrolled back but i am unable to find. I have a copy of all installers so far for Monterey up to beta 6.

All i need is to know how to create a working beta 7 usb installer.

Link to comment
Share on other sites

2 hours ago, SavageAUS said:

I have scrolled back but i am unable to find. I have a copy of all installers so far for Monterey up to beta 6.

All i need is to know how to create a working beta 7 usb installer.

Use this script 

Make sure using Imac 17.1 / SecureBootModel must be j160

If you have Laptop try to find the good Platform Infos and Securebootmodel for the machine

Because every machine is so differant for this Beta 7 its Crazy. . . especially for laptops

 

Then Create Install Media

after the install you have the secound stage Install, complete the stage 2

Put of the PC then Put SecureBootModel Disable

Complete other steps installations

 

This is work for me on any PC"s Laptop using latest OpenCore 0.7.4

 

Personal experience on my Probook 6570b I am use MacBook Pro 13.1  Securebootmodel j215 after installation in the macOS installer
I shut down the laptop and put Securebootmodel back to disable and it will work immediately for all the next steps (Install Stage)

Edited by chris1111
Personal experience
  • Like 1
Link to comment
Share on other sites

1 hour ago, chris1111 said:

Use this script 

Make sure using Imac 17.1 / SecureBootModel must be j160

If you have Laptop try to find the good Platform Infos and Securebootmodel for the machine

Because every machine is so differant for this Beta 7 its Crazy. . . especially for laptops

 

Then Create Install Media

after the install you have the secound stage Install, complete the stage 2

Put of the PC then Put SecureBootModel Disable

Complete other steps installations

 

This is work for me on any PC"s Laptop using latest OpenCore 0.7.4

 

Personal experience on my Probook 6570b I am use MacBook Pro 13.1  Securebootmodel j215 after installation in the macOS installer
I shut down the laptop and put Securebootmodel back to disable and it will work immediately for all the next steps (Install Stage)

Thanks but i have never used the installassistant pkg before, where do i get it?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...