Jump to content
wmchris

[GUIDE] Dell XPS 15 (9550) Mojave 10.14.x Quick Installation

1,407 posts in this topic

Recommended Posts

 

 

This tutorial has been updated on GITHUB to 10.14

the tutorial on insanelymac got too fragmented for a simple forum thread and will not be updated, but still be used for discussion and hints, tips and tricks

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Dell XPS 15 (9550, Version of 2016) Sierra 10.13.1 Tutorial

post-19619-0-96849400-1486167401_thumb.png

 


 

 

 

 

 

Before we start:
this installation includes real time DSDT/SSDT patching from within clover. This is pretty easy to install. But it is NOT suited for people with no or only few knowledge in Hackintosh Systems. If you only know how to copy commands in your shell and you dont know what they're doing, then stop the tutorial and revert to windows or buy a real mac. Even if you get it running: this system is not failsafe and will be broken multiple times in its usage time, where you have to fix it without a tutorial.
Optional steps are marked in GREEN, System dependent steps are BLUE

English is not my mother-tongue and i'm writing this without proof reading, so please forgive my bad spelling :)

If you've questions or something doesn't work: first check if you've done all steps of this tutorial! If yes: please read the whole thread (doesn't matter how long it is) before asking to prevent multiple questions. Additionally do a search in google and this forum.


Credits:
Many knowledge of "how to hackintosh a dell in the first place" by the tutorial of @Gymnae http://www.insanelymac.com/forum/topic/319766-dell-xps-9550-detailled-1011-guide/
Using many kexts and solutions from @RehabMan


What's not working:

  • Hibernation (works somehow, but high chance to destroy your whole data), Sleep works fine!
  • SD-Card reader
  • Killer 1535 Wifi (rarely used, need replace)
  • nVidia Graphics card (Intel works)
  • FileVault 2 (full HDD encryption)

Requirements:

  • one working MAC OS X Enviroment
  • 16GB USB Stick (larger is sometimes not bootable and/or requires advanced partitioning)
  • MacOS High Sierra 10.13.1 installation file from the app store (redownload, just in case)
  • Knowledge in PLIST editing
  • USB Harddrive for backup - you'll loose all data on your computer!

Step 1: Prepare Installation
Use the existing Mac to download the Sierra installer from the App Store and create a bootable USB stick with CLOVER. You can do this with the App "Pandora's Box" of insanelymac (use google for download link), which is pretty easy to use.
Optional: check if your SSD can be switched to 4k sector size. This prevents NVMe corruption. See https://github.com/wmchris/DellXPS15-9550-OSX/blob/10.13/4k_sector.md

After you've finished you need to download the Dell XPS 15 specific configurations for clover.
Link: https://github.com/wmchris/DellXPS15-9550-OSX/archive/10.13.zip
and unzip this file or checkout git directly:

git clone https://github.com/wmchris/DellXPS15-9550-OSX.git

You only need the folder 10.13, you can delete the 10.11. I'll refer to this folder by "git/"
Now mount the hidden EFI partition of the USB Stick by entering

diskutil mount EFI

Inside the terminal. Mac OS will automaticly mount the EFI partition of the USB stick, but just in case: make sure it really is
Overwrite everything in the CLOVER folder of the partition EFI with the content of git/10.13/CLOVER.
If your PC has a Core i5 processor, you'll have to modify your config.plist in EFI/EFI/CLOVER/: search for the Key ig-platform-id: 0x191b0000 and replace it with 0x19160000.

If you could use the 4k sector patch, replace the config.plist with the 4kconfig.plist. 
If you use a hynix device and you didnt do the 4k sector switch, you'll have to add the following patch to your config.plist

<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Hynix SSD patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>9sEQD4UcAQAA</data>
<key>Name</key>
<string>IONVMeFamily</string>
<key>Replace</key>
<data>9sECD4UcAQAA</data>

Go into the EFI Configuration (BIOS) of your Dell XPS 15:

 

Quote

In order to boot the Clover from the USB, you should visit your BIOS settings:
- "VT-d" (virtualization for directed i/o) should be disabled if possible (the config.plist includes dart=0 in case you can't do this)
- "DEP" (data execution prevention) should be enabled for OS X
- "secure boot " should be disabled
- "legacy boot" optional
- "CSM" (compatibility support module) enabled or disabled (varies)
- "boot from USB" or "boot from external" enabled

Note: If you get a "garbled" screen when booting the installer in UEFI mode, enable legacy boot and/or CSM in BIOS (but still boot UEFI). Enabling legacy boot/CSM generally tends to clear that problem.
In my case I left VT-d and Fastboot as they were. Also, update your 9550 to the latest BIOS.

Don't forget to set mode to "AHCI" in the sub-menu "SATA Operation" of "System Configuration". It's mandatory.

Also disable the SD-Card Reader to reduce the power consumption drastically. Insert the stick on the Dell XPS 15 and boot it up holding the F12 key to get in the boot-menu and start by selecting your USB-Stick (if you've done it correctly it's named "Clover: Install macOS Sierra", otherwise it's just the brandname of your USB-Drive). You should get to the MacOS Installation like on a real mac. If you're asked to log-in with your apple-id: select not now! Reason: see Step 5.


Step 2: Partition and Installation
INFORMATION: after this step your computer will loose ALL data! So if you haven't created a backup, yet: QUIT NOW!

Dont install macOS yet. Select the Diskutil and delete the old partitions. Create a new HFS partition and name it "OSX". If you want to multiboot with Windows 10, then you'll have to create a second partition, too (also HFS! Dont use FAT or it will not boot! You have to reformat it when installing Windows). Make sure to select GUID as partition sheme.
Close the Diskutil and install OSX normally. You'll have to reboot multiple times, make sure to always boot using the attached USB stick. So dont forget to press F12. After the first reboot you should see a new boot option inside clover, which is highlighted by default. Just press enter. If you only see one, then something went wrong.



Step 3: Make it bootable
After a few reboots you should be inside your new macOS enviroment. You can always boot into it using the USB stick. Remove the USB drive after successful bootup. Enter

diskutil mount EFI

in your terminal, which should mount the EFI partition of your local installation.

install git/Additional/Tools/Clover_v2.4k_r4003.pkg. Make sure to select "Install Clover in ESP". Also select to install the RC-Scripts. This should install the Clover Boot System. Now copy everything from git/10.13/CLOVER to EFI/CLOVER like you did before by creating the usb stick. (if you had to modify the config.plist in step 1, do it here, too). Your system should be bootable by itself. Reboot and check if your system can boot by itself.


 
Step 4: Post Installation
Because all DSDT/SSDT changes are already in the config.plist, you dont need to recompile your DSDT (albeit i suggest doing it anyway to make your system a lil bit more failsafe, see gymnaes El-Capitan tutorial for more informations). So we can skip this part and go directly to the installation of the required kexts. Open a terminal and goto the GIT folder.

sudo cp -r ./Post-Install/LE-Kexts/* /Library/Extensions/
sudo mv /System/Library/Extensions/AppleACPIPS2Nub.kext /System/Library/Extensions/AppleACPIPS2Nub.bak 2> /dev/null
sudo mv /System/Library/Extensions/ApplePS2Controller.kext /System/Library/Extensions/ApplePS2Controller.bak 2> /dev/null
sudo ./AD-Kexts/VoodooPS2Daemon/_install.command

Now you'll have to replace the config.plist. Because you'll install modified kexts you'll HAVE TO replace the config.plist in your installation. Otherwise your PC will not boot anymore.

diskutil mount EFI

replace EFI/CLOVER/config.plist with git/Post-Install/CLOVER/config.plist. Again: if your PC has a Core i5 processor, search the config.plist for the Key ig-platform-id: 0x191b0000 and replace it with 0x19160000.

OPTIONAL (in case you've audio problems):
AppleHDA has some problems after Wake-Up. You'll have to plug in a headphone to get your speakers working again. You can use VoodooHDA instead, which breaks the headphone jack most of the time, but makes the rest much more stable.

sudo rm -r /Library/Extensions/CodecCommander.kext
sudo rm /EFI/EFI/CLOVER/ACPI/patched/SSDT-ALC298.aml

then remove from your config.plist from the key "KextsToPatch" the elements "AppleHDA#1" to "AppleHDA#7". Install the package: git/Post-Install/AD-Kexts/VoodooHDA-2.8.8.pkg
i also suggest moving some of the kext from EFI/CLOVER/kexts/10.13 to /Library/Extensions. It's just more stable.

Finalize the kext-copy by recreating the kernel cache:

sudo rm -rf /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
sudo rm -rf /System/Library/PrelinkedKernels/prelinkedkernel
sudo touch /System/Library/Extensions && sudo kextcache -u /

sometimes you'll have to redo the last command if your system shows "Lock acquired".
OSX 10.12.2 removed the posibility to load unsigned code. You can enable this by entering

sudo spctl --master-disable

If you're using the 4K monitor, you'll have to copy the UHD enabling kexts to your clover directory:

sudo cp ./Post-Install/AD-Kexts/UHD-Kexts/* /EFI/EFI/CLOVER/kexts/10.13/

To enable GPU acceleration: Edit your clover config file again and remove the following block from it:

Quote
<key>FakeID</key>
<dict>
<key>IntelGFX</key>
<string>0x12345678</string>
</dict>

 

 

To prevent getting in hibernation (which can and will corrupt your data), just set the default sleep mode to "suspend to ram" (sleep) instead of "suspend to disk" (hibernation)

sudo pmset -a hibernatemode 0

To get HDMI Audio working:
Search for your Boarrd-ID in the config.plist and open /S/E/AppleGraphicsControl.kext/contents/plugin/AppleGraphicePolicy.kext/contents/info.plist with a texteditor. Search for your board-id in there and change the value of it from "Config2" to "none"
 
OPTIONAL (alternative power management):
the whole power management is done by intels speed step technology (HWP), which is enabled in the clover config. If you want to let OSX manage the power management, you'll have to do these steps:

sudo cp ./Post-Install/CLOVER/ACPI/optional/SSDT.aml /EFI/EFI/CLOVER/ACPI/patched/

then open the config.plist (/EFI/EFI/CLOVER/config.plist) and change <key>HWPEnable</key><true/> to <key>HWPEnable</key><false/>.
 
Step 5: iServices (AppStore, iMessages etc.)
 

WARNING! DONT USE YOUR MAIN APPLE ACCOUNT FOR TESTING! It's pretty common that apple BANS your apple-id from iMessage and other services if you've logged in on not well configured hackintoshs!

If you want to use the iServices, you'll have to do some advanced steps, which are not completly explained in this tutorial. First you need to switch the faked network device already created by step 4 to be on en0. Goto your network settings and remove every network interface.

sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

Reboot, go back in the network configuration and add the network interfaces (LAN) before Wifi.

You also need to modify your SMBIOS in the config.plist of Clover in your EFI partition with valid informations about your "fake" mac. There are multiple tutorials which explain how to do it like "http://www.fitzweekly.com/2016/02/hackintosh-imessage-tutorial.html".

It's possible you have to call the apple hotline to get your fake serial whitelisted by telling a good story why apple forgot to add your serial number in their system. (aka: dont do it if you dont own a real mac). I personally suggest using real data from an old (broken) macbook.



Step 6: Upgrading to macOS 10.13.2 or higher / installing security updates
Each upgrade will possibly break your system!
(Update: after the latest updates in this tutorial the system should be update-proof.) 

 

Step 7: Fixes / Enhancements / Alternative Solutions / Bugs

See: https://github.com/wmchris/DellXPS15-9550-OSX/blob/10.13/Tutorial_10.13_Step7.md

 

Afterword and fixes
as i said before: this is not a tutorial for absolute beginners, albeit it's much easier then most other tutorials, because most is preconfigured in the supplied config.plist. Some Dells have components included, which are not supported by these preconfigured files. Then i can only suggest using Gymnaes tutorial which explains most of the DSDT patching, config.plist editing and kexts used in detail and use the supplied files here as templates.

Tutorial Updates

  • 27. March 2017: UHD Kexts added, replaces perl command
  • 23. March 2017: 4k sector tutorial against NVMe corruption added  
  • 7. March 2017: Suggestion to disable the SD Card Reader for reduced power consumption
  • 4. February 2017: Dell SMBIOS Truncation workaround added
  • 23. January 2017: Hynix SSD fix added
  • 31. December 2016: USB-C Hotplug Fix and USB InjectAll Removed
  • 28. December 2016: NVMe SSDT Spoof precreated, FakeID already preset in installation config.plist. VoodooHDA added as alternative to SSDT-ALC298 patch as well as color coding in tutorial
  • 22. December 2016: FakeSMBios added

Accessories Appendix:

  • The official Dell adaptor DA200 (http://accessories.euro.dell.com/sna/productdetail.aspx?c=at&l=de&s=dhs&cs=atdhs1&sku=470-abry) works completly on Sierra 10.2.2. You can use the Network, USB, HDMI and VGA. Everything is Hot-Pluggable
  • a cheap 3rd party noname USB-C -> VGA adaptor didnt work
  • you can charge the Dell with a generic USB-C Power Adaptor, but USB-C has only a maximum power of 100W, so it's either charging OR usage, not both. Dont forget you need a special USB-C cable (Power Delivery 3.0) for charging.
Edited by wmchris

Share this post


Link to post
Share on other sites
Advertisement

I decided to join you, it's me, Gymnae.

I left a goodbye not on the other forum. Such stupid rules

 

Glad to see you in insanelymac.Thanks for your work on XPS 15 9550.

 

@wmchris

I have some question.

 

1、Does Clover r3899 support native nvram works on skl platform or just use nvram.plist?

2、My XPS 15 9550 have a usb bug,all the external devices can work perfectly expect my removable disk.When i plug in the mobile hard disk drive it have no effect or no reaction and it doesn't show in my usb devices,but usb mouse,usb keyboard and usb disk either usb2.0 and usb3.0 works fine.it can be solved by plug in the mobile hard disk drive when boot up and it will show in the usb devices and works fine.I want to know what cause it and how to solve it.

Share this post


Link to post
Share on other sites

Glad to see you in insanelymac.Thanks for your work on XPS 15 9550.

 

@wmchris

I have some question.

 

1、Does Clover r3899 support native nvram works on skl platform or just use nvram.plist?

2、My XPS 15 9550 have a usb bug,all the external devices can work perfectly expect my removable disk.When i plug in the mobile hard disk drive it have no effect or no reaction and it doesn't show in my usb devices,but usb mouse,usb keyboard and usb disk either usb2.0 and usb3.0 works fine.it can be solved by plug in the mobile hard disk drive when boot up and it will show in the usb devices and works fine.I want to know what cause it and how to solve it.

3899 doesnt have native nvram support, but the nvram emulator works.

your external hdd problem sounds more like a power consumption problem. did you check that the controller used in this hard drive advertises itself for higher power submission? most cheap controllers dont do it properly and require an Y USB cable. Just tried by myself with two different 2,5" external HDDs (one original apple oem sata drive in an enclosure ;)) and it worked fine.

Share this post


Link to post
Share on other sites

your external hdd problem sounds more like a power consumption problem. did you check that the controller used in this hard drive advertises itself for higher power submission? most cheap controllers dont do it properly and require an Y USB cable. Just tried by myself with two different 2,5" external HDDs (one original apple oem sata drive in an enclosure ;)) and it worked fine.

 

I use a external hdd box with usb3.0 output and works fine in windows and fine in 10.11.x but can't work properly in 10.12.x and i found it may be need additional current.

 

However when i plug in the box when start up it works fine but when i plug off and plug in again it disappear again and it very strange.

 

Ps:my external hdd box is standard usb port and it can't use Y USB cable...

Share this post


Link to post
Share on other sites

can you try it on a regular macbook to check if it's incompatible with OSX 10.12 or a problem with your setup?

Can you try using it with the USB-C port and the latest hotplug hack i uploaded? This port uses a different USB hardware.

Share this post


Link to post
Share on other sites

Okay guys i want your input. Is it worth installing Sierra or shoud we stay on El Capitan? I know I have to wipe my ssd before installing Sierra. Otherwise it wont install

Share this post


Link to post
Share on other sites

Sierra is much more stable and offers more hardware compatibility than el.cap. No drawbacks - only improvement (except with guijiangs hdd)

Okay. Is is better to fresh install Sierra or can I upgrade El Capitan to Sierra?

 

Sent from my VS986 using Tapatalk

Share this post


Link to post
Share on other sites

You can safely upgrade from el cap - but be sure to have working kexts and patches at hand

I have tried to upgrade to Sierra using el Capitan, but nothing gets upgraded. Sorry about this question. Am I missing something?

 

After trying to upgrade from El Capitan to Sierra without success. I decided to do a clean install. I successfully  installed Sierra now. But I am in the process of patching my system the way it was before.

Edited by hackedWifi

Share this post


Link to post
Share on other sites

one problem is that the installer often wants to add some computer specific patches first - most likely firmware updates. if these fail it will not continue the setup. I had this problem all the time even with normal security updates, most likely because i use an old, unpatched (and valid original) MacBookPro9,1 SMBIOS.

Share this post


Link to post
Share on other sites

Trying to get swiping with 2 fingers on trackpad forward & backward in Safari to work.  Other gestures work fine.

 

Thanks for a great guide!

 

Happy New Year

Share this post


Link to post
Share on other sites

Good to see you back, @wmchris.

 

But, it seems every time I ask, the thread gets deleted. I'm still trying to get usb-c working. My problem is now that I get a KP with the Macbook9,1 smbios as generated by clover. It worked under Macbook Pro 13,3 but even that won't boot now and I'm back on the iMac smbios that came in the post-install.

 

Any advice.

Share this post


Link to post
Share on other sites

HDMI & audio don't work. But thank you so much fot this post I got a lot further now.

You'll need to change your smbios for the HDMI. Macbook9,1 is apparently the best, but I've been having issues.

 

I've had problems with audio. Booting with headphones plugged in has helped in the past.

 

Sent from my Nexus 6P using Tapatalk

Share this post


Link to post
Share on other sites

You'll need to change your smbios for the HDMI. Macbook9,1 is apparently the best, but I've been having issues.

 

I've had problems with audio. Booting with headphones plugged in has helped in the past.

 

Sent from my Nexus 6P using Tapatalk

Managed to get HDMI working.

>Found my board ID

>Searched it in /S/E/AppleGraphicsControl.kext/contents/plugin/AppleGraphicePolicy.kext/contents/info.plist

>The line under my Board id I changed "Config2" to "none"

 

Rebuilded kextcache & rebooten.

Shoutout tot Goodwin

Share this post


Link to post
Share on other sites

Hi, for everyone who have a problem with Thunderbolt 3/USB 3.1 Type C port and its hotplug function I have working solution created by dpassmor. Luckily I managed to apply his patch with ssdt to mine config.plist before entire thread has been deleted.

 

Add the following to ACPI/DSDT/Patches:

<dict>
<key>Comment</key>
<string>rename _RMV to XRMV</string>                                        
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
X1JNVg==
</data>
<key>Replace</key>
<data>
WFJNVg==
</data>
</dict>

Then under ACPI/DropTables add following:

<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>xh_rvp10</string>
</dict>

And it’s last adjustment to the config.plist. You need to add this under KernelAndKextPatches/KextsToPatch:

<dict>
<key>Comment</key>
<string>10.12.2 fudge USB 3.1 device ID</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<string>30783135623638303836</string>
<key>InfoPlistPatch</key>
<true/>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<string>30783135623538303836</string>
</dict>

The last step it is to compile SSDT-TB and add it to your ACPI/Patched folder, then reboot.

 

Now I can confirm that my HooToo thunderbolt3 to hdmi, usb and microsd card reader adapter works fine thanks for dpassmor.

SSDT-TB.dsl.zip

Share this post


Link to post
Share on other sites

Hi, for everyone who have a problem with Thunderbolt 3/USB 3.1 Type C port and its hotplug function I have working solution created by dpassmor. Luckily I managed to apply his patch with ssdt to mine config.plist before entire thread has been deleted.

 

Add the following to ACPI/DSDT/Patches:

<dict>
<key>Comment</key>
<string>rename _RMV to XRMV</string>										
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
X1JNVg==
</data>
<key>Replace</key>
<data>
WFJNVg==
</data>
</dict>
Then under ACPI/DropTables add following:
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>xh_rvp10</string>
</dict>
And it’s last adjustment to the config.plist. You need to add this under KernelAndKextPatches/KextsToPatch:
<dict>
<key>Comment</key>
<string>10.12.2 fudge USB 3.1 device ID</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<string>30783135623638303836</string>
<key>InfoPlistPatch</key>
<true/>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<string>30783135623538303836</string>
</dict>
The last step it is to compile SSDT-TB and add it to your ACPI/Patched folder, then reboot.

 

Now I can confirm that my HooToo thunderbolt3 to hdmi, usb and microsd card reader adapter works fine thanks for dpassmor.

This gives you hot-plug on the type C port?

 

What smbios are you using?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Teress
      In this short tutorial I will show you how to monitor your GPU performance in macOS High Sierra and macOS Mojave HACKINTOSH and absolutely FOR FREE !!!
       
    • By spec3
      hi,
       
      Is someone using ultrawide monitor 75hz whit hackintosh?
       
      I would like to buy LG 34UC99 (resolution 3440x1440 and freq: 75hz)
       
      will it work for you?
       
       
    • By BugsB
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook/ MacBook does not go to into power saving mode automatically on very low battery but just powers down coldly: “SOLB”, a small and low load footprint AppleScript based utility that checks the battery level every 2 minutes. You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6. Please feedback if this utility also works in Mojave.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2018-11-10:
      1.0 (initial version)
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      SleepOnLowBattery (SOLB) by BugsB v.1.0 (2018-11-10).zip
    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
    • By spec3
      ciao, 
       
      ho un problema con un monitor Dell p2715q 4k, funziona bene a prima vista, ma quando lavoro su programmi piu' pesanti, ho qualche problemino , del tipo che su certe azioni risulta rallentato a livello grafico. Invece se ridimensionato il monitor alla risoluzione nativa (3840x2160), sembra che questo problema sparisca. In pratica ho problemi solo nelle dimensioni intermedie. sapete se si puo' fare qualcosa? Il problema credo sia dovuto al monitor e non alla scheda video, perche' su un monitor full hd non ho problemi di rallentamento. 
       
      Per ora sto usando solo Lilu e wahtervergreen , senza questi il monitor nemmeno si accende.
       
      Se avete idee sono bene accette, 
       
      Grazie!
       
×