Jump to content

El Capitan UEFI Clover on Sony Vaio S


johnrey
 Share

152 posts in this topic

Recommended Posts

so... is everything working great right now? :D

 

I will reattempt my installation from scratch soon. It doesn't boot anymore anyway... blackscreen then return to clover or reboot.

 

I hope I'll achieve to disable my discrete card and wake/sleep this time...

 

@midi are you still available to look at my file to disable my discrete card.. There's no option in my bios to disable it (I have the windows 7 model)

Link to comment
Share on other sites

so... is everything working great right now? :D

 

I will reattempt my installation from scratch soon. It doesn't boot anymore anyway... blackscreen then return to clover or reboot.

 

I hope I'll achieve to disable my discrete card and wake/sleep this time...

 

@midi are you still available to look at my file to disable my discrete card.. There's no option in my bios to disable it (I have the windows 7 model)

Sorry cloud, it's been a while I haven't touched a SSDT :P This quick return to clover is maybe a config.plist file, Clover driver64uefi is missing drivers OR the usb installer/ OS X installation is damaged. Try to check those. Good luck, send me (like upload it here, not PM) your ACPI > origin folder (remove MSDM.aml!!!!!!)

Link to comment
Share on other sites

thanks for wonderfull guide...i have sony vaio e-series and successfully installed E.C alongside 

 

windows 10 i follow the guide carefully but still can't get to boot menu without usb...

 

pls. kindly help me thanks in advance...

Link to comment
Share on other sites

i already fix bout directly boot into clover boot menu...

 

i try to get dsdt / ssdt by pressing f4 on clover boot menu but 

 

​i didn't see any dsdt.dsl / ssdt-2 /ssdt-7 on efi/clover/acpi/origin...

 

how do i get those file? :( sorry I'm new on clover

 

KYu2PTJ.png

Link to comment
Share on other sites

i already fix bout directly boot into clover boot menu...

 

i try to get dsdt / ssdt by pressing f4 on clover boot menu but 

 

​i didn't see any dsdt.dsl / ssdt-2 /ssdt-7 on efi/clover/acpi/origin...

 

how do i get those file? :( sorry I'm new on clover

 

KYu2PTJ.png

it's not DSDT.dsl, it's DSDT.aml. ;)

Link to comment
Share on other sites

  • 2 weeks later...

Solucionado Brightness control for Vaio Fit SVF15A1C5E.

 

Volume Mute = Fn+F2

 

Volume up = Fn+F4

Volume Down = Fn+F3

 

Brightness Down = Fn+F5

Brightness Up = Fn+F6

 

GUIDE Linz

 

 

Looking solution for the key, trackpad disabled ( Fn+F1) now works with Fn + PrtSc.

 

IZVq9iw.jpg?1

 

into method label _Q1D replace_content
begin
// Brightness Down\n
Notify(\_SB.PCI0.LPCB.PS2M, 0x0205)\n
Notify(\_SB.PCI0.LPCB.PS2M, 0x0285)\n
end;
into method label _Q1C replace_content
begin
// Brightness Up\n
Notify(\_SB.PCI0.LPCB.PS2M, 0x0206)\n
Notify(\_SB.PCI0.LPCB.PS2M, 0x0286)\n
end;

 

Change the variable _Q1D/_Q1C as per the log. In my Vaio keyboard is _Q8F=Down, _Q8E=Up.

  • Like 1
Link to comment
Share on other sites

Solucionado Brightness control for Vaio Fit SVF15A1C5E.

 

Volume Mute = Fn+F2

 

Volume up = Fn+F4

Volume Down = Fn+F3

 

Brightness Down = Fn+F5

Brightness Up = Fn+F6

 

GUIDE Linz

 

 

Looking solution for the key, trackpad disabled ( Fn+F1) now works with Fn + PrtSc.

 

IZVq9iw.jpg?1

 

into method label _Q1D replace_content

begin

// Brightness Down\n

Notify(\_SB.PCI0.LPCB.PS2M, 0x0205)\n

Notify(\_SB.PCI0.LPCB.PS2M, 0x0285)\n

end;

into method label _Q1C replace_content

begin

// Brightness Up\n

Notify(\_SB.PCI0.LPCB.PS2M, 0x0206)\n

Notify(\_SB.PCI0.LPCB.PS2M, 0x0286)\n

end;

 

Change the variable _Q1D/_Q1C as per the log. In my Vaio keyboard is _Q8F=Down, _Q8E=Up.

Thankies. Ill try that now!

Link to comment
Share on other sites

Hi, I have no audio input. 

Please, can you guys help me?

 

Thanks a lot

 

Vaio SVE15 - El Capitan 

 

***********************************************************************

 

 AppleHDA , not work on my Vaio SVF.

delete AppleHDA.Kext , and install VoodooHDA 2.8.8  Download

 

VoodooHDAPrefPane.jpg

 

My Vaio with VoodooHDA 2.8.8 it has worked properly. wiki.osx86SonyVaio SVF

Hope this can help you.

 

 

Link to comment
Share on other sites

Hi, I have no audio input. 

Please, can you guys help me?

 

Thanks a lot

 

Vaio SVE15 - El Capitan 

 

 

 

 

Lemme guess, 10.11.4 update right?

 

http://www.insanelymac.com/forum/files/file/496-applehda-patcher/

 

Use this, open it, Choose your Mobile Codec, hit patch, it will make a folder in your desktop with your codec patches, open it, go to Clover folder there, you'll find a "config.plist" and a "aDummyHDA.kext". Delecte DummyHDA.kext from your system (found in /S/L/E) then install this one, reboot after fixing caches/perms. Audio should be back :) No Voodoo required for this experiment, no need to sacrifice your sound!

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Does anyone wants to share his dsdt with me,i need one from Vaio SVE and one from vaio SVS,i need it to compare them with my SVE dsdt,as i'm trying to make some universal patches regarding Fan speed showing up,already patched  dsdt's are welcome 

Link to comment
Share on other sites

Ok guys!

for AppleHDA problem, I updated (later, a lot later) OS X to 10.11.4 and I had this audio problem and use the AppleHDA Patcher app as I told you but for me it didn't work.

For some reason the Platforms.xml.zlib in the generated Dummy doesn't work for us, so what I did is copy it from the original DummyHDA (check #1) then paste it under <aDummy.kext>/Contents/Resources/ and replace the old one. ATM I'm contacting Mirone to check what's the problem and he'll sure try to fix it.

 

@Onestyle 

Does anyone wants to share his dsdt with me,i need one from Vaio SVE and one from vaio SVS,i need it to compare them with my SVE dsdt,as i'm trying to make some universal patches regarding Fan speed showing up,already patched  dsdt's are welcome 

 

here is my SVS (the same as OP's, latest bios) DSDT_midi.zip

What I applied:

[As in #1] + 0x0D USB patch and maybe AR9285 patch.

  • Like 1
Link to comment
Share on other sites

Why don't you use http://www.rugarciap.com/turbo-boost-switcher-for-os-x/ to disable and enable turbo boost when ever you want,that is the only thing I use to enable and disable it.

I've been using it for quite a while but after that i found myself in no need for TB (mostly just watching online videos and doing basic word processing and presentations). My load demanding works is mostly done on windows (thanks to the ssd the switch is waaaay faster now). I am ok with this program, people who care about performance/efficiency on OSX should mostly use this instead of Clover's way!

  • Like 1
Link to comment
Share on other sites

Guys, I can't get my _QXX Variables for brightness, for some reason. I get nothing in syslog (no ACPIDebug output, and if it is it's just random and wont work). Any help?

 

If you used the dsdt i've sent you,it doesn't have those variables defined (look for them and you'll see they aren't there)

Link to comment
Share on other sites

 Share

×
×
  • Create New...