Jump to content

[GUIDE] Samsung Ativ Smart Pro XE700T1C 10.10.x and 10.11.0 [100%]


duduclx
 Share

312 posts in this topic

Recommended Posts

Sorry guys for butting in again :blush:

The first time I ran the installer I successfully got into the installer interface and formatted the SSD and stuff, but after it rebooted to continue the install, it got through an error (probably a corrupted installer, since my other hack ran into the same error) so I dled again a new installer, tried it on my other hack, it's fully functional, but since then, the tablet wont boot the installer interface, (note that I kept the FW that it worked on it the first time) and gets stuck on the Apple logo, the loading bar and the spinning pointer! I left it for more than 15 mins, still no signe! am I missing something (I can upload the config I'm using riight now, it's exactly as provided on the OP post).

Try putting the fakesmc in 10.10, 10.11 and other folders and look in the guide of Page 4 the options in clover configs for more compatibility
  • Like 1
Link to comment
Share on other sites

thanks. i not have any third party usb kernelextentions an  in clover only fakesmc and the cloverconfig i do not check any usb fix y try to repatch the dsdt. about the multitouch gestures uninstall the upped and wacom drivers and reboot reinstall the wacaom driver and reboot and for last reinstall the uppd and he is working.

 

i was never able to get wacom properly recognized, see pic. tho the pen input works via touch-base so i didnt really mind. any idea where to look for wacom issue?

post-226869-0-02867900-1445157682_thumb.png

Link to comment
Share on other sites

Uninstall uppd to test the wacom drivers. If the wacom drivers work correctly reinstall uppd and If not work correctly uninstall the wacom drivers ánd reinstal ir. Only after working correctly the wacom drivers install uppd.

When instal uppd the wacom app not work anymore and all the config forma the Pen ánd touch its in the touchbase app.

Link to comment
Share on other sites

ok, so I successfully installed OS X (using guide in page 4), so far got most stuff working (including wacom) BUT I ran into some problems: 

  • the kyb power led keeps flashing (I think you must have the same thing too)
  • the touchscreen driver seem not working: I dont have gestures nor right click
  • Sleep works, but on wake, I really dont know why it doesn't wake on a simple click, it's like when I'm powering the tablet on (1 sec press) and I have to press it a second time to wake the screen
  • Sleep works, but sometimes it hangs and the fan start spinning at an incredible speed, until I press the power button and it wakes "as if it was from sleep"
  • The battery is showing me 100% all the time, that's DSDT for sure! (I'll try repatching it from scratch)

For Audio, I would like you to provide me with the patches applied to the AppleHDA to make a DummyHDA + Clover Patching + Inject, this will keep the audio working even after updates/upgrades. If it's generic patches that Mirone/Toleda made, then just tell me I'll make a DummyHDA + Clover and post it here :)

Thanks for the guide both of you :)

 

Other than that, none of you seem talking about trim, I enabled it using trimforce command (10.11 ONLY)

sudo trimforce enable

A notice will appear, read it, accept it if you want to proceed, then it will reboot the device after enabling it. :)

Link to comment
Share on other sites

ok, so I successfully installed OS X (using guide in page 4), so far got most stuff working (including wacom) BUT I ran into some problems: 

  • the kyb power led keeps flashing (I think you must have the same thing too)
  • the touchscreen driver seem not working: I dont have gestures nor right click
  • Sleep works, but on wake, I really dont know why it doesn't wake on a simple click, it's like when I'm powering the tablet on (1 sec press) and I have to press it a second time to wake the screen
  • Sleep works, but sometimes it hangs and the fan start spinning at an incredible speed, until I press the power button and it wakes "as if it was from sleep"
  • The battery is showing me 100% all the time, that's DSDT for sure! (I'll try repatching it from scratch)

For Audio, I would like you to provide me with the patches applied to the AppleHDA to make a DummyHDA + Clover Patching + Inject, this will keep the audio working even after updates/upgrades. If it's generic patches that Mirone/Toleda made, then just tell me I'll make a DummyHDA + Clover and post it here :)

Thanks for the guide both of you :)

 

Other than that, none of you seem talking about trim, I enabled it using trimforce command (10.11 ONLY)

sudo trimforce enable

A notice will appear, read it, accept it if you want to proceed, then it will reboot the device after enabling it. :)

 

-for the kyb led press caps lock.

 

-uninstall touch base and wacom driver and reboot. after reboot install wacom drivers for bamboo tablets and reboot. and look if the wacom app in system preferences its working correctly. you can install the touch base provided in the guide of page 4 whit multitouch gestures after the wacom drivers works correctly.

 

-about the sleep issues here is the same.(I've researched about this issues but i don't find what cause the issue because i am too noob im OS X.)

 

-the battery percentage here its working correctly try patching dsdt extracted whit clover f4.

 

-the audio i don't know how its working because the kext and dsdt patch its @keiner99 who post it.

 

-about the trim i enable whit the same command but forgot to include in the guide.

  • Like 1
Link to comment
Share on other sites

ok for DSDT, I suggest adding "AC Adapter Fix" since I found out (thanks to HWMonitor) that OS X percentage refresh rate is so slow and inaccurate, this will fix it.

moreover, the UPDD driver breaks Wacom Drivers, if you could, please upload the driver without the Wacom Drivers so that they wont interfere with the Bamboo drivers, I tried removing the device from UPDD but the app hangs and the touchscreen freezes (I used the trackpad after that).


and the brightness doesn't work for me, I applied the patch you pointed to but still, I tried a patch that I use on my other hack (since they are both HD4000) same result.

  • Like 1
Link to comment
Share on other sites

ok for DSDT, I suggest adding "AC Adapter Fix" since I found out (thanks to HWMonitor) that OS X percentage refresh rate is so slow and inaccurate, this will fix it.

moreover, the UPDD driver breaks Wacom Drivers, if you could, please upload the driver without the Wacom Drivers so that they wont interfere with the Bamboo drivers, I tried removing the device from UPDD but the app hangs and the touchscreen freezes (I used the trackpad after that).

and the brightness doesn't work for me, I applied the patch you pointed to but still, I tried a patch that I use on my other hack (since they are both HD4000) same result.

the updd assume the management of touch screen because this the wacom app not work anymore after install updd. but i don't understand who is the error whit updd. the gestures not work? or whats the error?.

 

i attached my clover folder to this post. they have boot dsdt (patched and original). compare with your dsdt to find the differences. or try these solution.

CLOVER.zip

  • Like 1
Link to comment
Share on other sites

the updd assume the management of touch screen because this the wacom app not work anymore after install updd. but i don't understand who is the error whit updd. the gestures not work? or whats the error?.

 

i attached my clover folder to this post. they have boot dsdt (patched and original). compare with your dsdt to find the differences. or try these solution.

weird!

My DSDT looks EXACTLY as yours (I used the disassembled DSDTs and compared them with DiffMerge) and I even tried your DSDT instead of mine (something that I wouldn't recommend tho) and the brightness didn't work. I tried that kext same thing, I tried with and without BIOS Auto-brightness, still... weird! the slider works anyway and at the lowest level the screen becomes black.

and for the touch driver, don't reinstall it, just recalibrate it and it will give you 100 other clicks, after 24 hours, you can reinstall it :)

Link to comment
Share on other sites

Weird thing about the brigthnes. Try disabling auto brigthnes in bios and install Windows in dual boot and install the Samsung update whit all updates and disable the auto brigtnes in Samsung setting and look if in Windows the brigthnes Keys work

  • Like 1
Link to comment
Share on other sites

now i found a AppleHDA which is perfectly working with autoswitch function in 10.10.5 :D

 

add this to HDEF in DSDT:

            Method (_DSM, 4, NotSerialized)
            {
                Store (Package (0x06)
                    {
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }, 

                        "layout-id", 
                        Buffer (0x04)
                        {
                            0x1C, 0x00, 0x00, 0x00
                        }, 

                        "PinConfigurations", 
                        Buffer (Zero) {}
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
        }

and install the attached AppleHDA to S/L/E with any kext installer!

to have sound again after sleep, you have to use Audio Reset, its attached ;)

 

Could you please post the patches you applied on the AppleHDA, I will make a DummyHDA + Clover patching, so that audio will still work even after upgrades! Thanks 

Link to comment
Share on other sites

ok here ya go: DSDT.aml


btw, I just discovered some stuff:

  • if you keep pressing power button for 2 to 3 secs, the power dialog will appear (I found it because of my habit on my android tablet :P )
  • The touch has a considerable delay! When I touch something, there is at least 500ms delay to be really touched, is it normal or it's my configuration?
  • The UPDD Console hangs when I try to remove Wacom Driver after disabling it (weird, I hope someone send us the same installer with no Wacom drivers so that we work with the original drivers)

That's all for now.

Link to comment
Share on other sites

ok here ya go: DSDT.aml

btw, I just discovered some stuff:

  • if you keep pressing power button for 2 to 3 secs, the power dialog will appear (I found it because of my habit on my android tablet :P )
  • The touch has a considerable delay! When I touch something, there is at least 500ms delay to be really touched, is it normal or it's my configuration?
  • The UPDD Console hangs when I try to remove Wacom Driver after disabling it (weird, I hope someone send us the same installer with no Wacom drivers so that we work with the original drivers)

That's all for now.

ok i try your dsdt and battery, brightness and all its working only the sound is not working because the hde patch and dtgp patch is missing but after apply this patches all its working. what version of bios you got? the mine is P10AAT. and you try the samsung settings and the patch of brigthnes in windows?. 

 

about the touch later i upload a video of the response of the touch to compare. and i think the updd kidnap the wacom driver and uses it because this the updd don't work whitout the wacom driver. he depends of him.

 

edit: link of the video whit your dsdt 

Link to comment
Share on other sites

Touch base and wacom are two different pci device.

If you have no supported tablet found, please install the provided plist as explain in the guide.

No delay here.

See your touch base driver configuration.

 

Cheers

Link to comment
Share on other sites

i know it's different, I tried patching the kext (by removing the wacom ids) but the app hangs and the touch is blocked! 

and for touch delay, try touching a folder to select it, between the time that you pressed and the response time that the driver gave there is a lag, it's not visible while swiping or dragging, just when you try to touch something, and that makes the keyboard unusuable, since some letter may not be touched and ignored, other may be touched repetitively!

for bios, yes I have the latest version, I think I may downgrade it later (if anyone got P09AAT) thanks :)

Link to comment
Share on other sites

ok I fixed the touch delay by disabling double tap function in Gestures app, the brightness is still the same no matter what, if you want to, could you send me your bios dumb so that I try it on my device and check, im sure it's bios fw related! And for audio I will make it happen no matter what :P

Link to comment
Share on other sites

 Share

×
×
  • Create New...