Jump to content

[GUIDE] Samsung Ativ Smart Pro XE700T1C 10.10.x and 10.11.0 [100%]


312 posts in this topic

Recommended Posts

Yes in my laptop osx 10.11 the multitouch gestures its working fine. Try whit the wacom driver and uppd provided in my Lasts posts to test

 

edit: my sleep its working the first time after reset they sleep just fine but if i power off the laptop after sleep they power off the screen but the power led and fans don't power off. the second sleep after reset the power less don't go off and if i undock and dock the laptop the sleep broken.

Thanks , Ill try again with the touchbase drivers...  again... and again...

 

Do you have any Third Party USB KernelEXTions? If so, remove them. Use only stock OS. Check S/L/E & your EFI/Clover/Kexts/...  Clover Config DO NOT CHECK any USB fix. Try the dsdt patch USB3_0x0D again. 

  • Like 1

Thanks , Ill try again with the touchbase drivers...  again... and again...

 

Do you have any Third Party USB KernelEXTions? If so, remove them. Use only stock OS. Check S/L/E & your EFI/Clover/Kexts/...  Clover Config DO NOT CHECK any USB fix. Try the dsdt patch USB3_0x0D again. 

thanks. i not have any third party usb kernelextentions an  in clover only fakesmc and the cloverconfig i do not check any usb fix y try to repatch the dsdt. about the multitouch gestures uninstall the upped and wacom drivers and reboot reinstall the wacaom driver and reboot and for last reinstall the uppd and he is working.

hey guys, the tablet I got was second hand and it got UEFI password, and after I opened the device it seems there is no reset button or whatsoever, the CMOS battery resets the settings only, and the password looks like is stored on an eeprom chip, isnt there anyway to reset it or read the password from it? The FW seems to have Secureboot enabled by default so I cant get to clover and it's UEFI only (CSM is disabled too). I know some may be against answering me so that's fine (btw I already asked the owner, he told me that he had the tablet for so long he forgot the password, too bad, and he doesnt accept returns).

@midi The password 99.9% is stored on NVRAM, dump/backup your current BIOS and start digging..

Other option you have is to get a full(8MB) BIOS dump(you may find on rusian sites) and flash on yours using eeprom programmer.

Good luck!

ok now the sleep working 100% the guilty is of the voodops2controller because the laptop detects 2 ps2 devices and cause conflict i don't know where is the native ps2 kext in elcapitan to delete them.

@midi The password 99.9% is stored on NVRAM, dump/backup your current BIOS and start digging..

Other option you have is to get a full(8MB) BIOS dump(you may find on rusian sites) and flash on yours using eeprom programmer.

Good luck!

Thanks, clearing NVRAM will not work then, unless I use an eeprom programmer :( ok I think i'll send it to a repair guy, he got one of those and maybe he can help. (I tried flashing all blocks from the cap file I got from samsung but still)

If you open your backup BIOS you will see that there are 2 NVRAM entries, a NVRAM reset will not wipe the second.

If you extract the rom from .cap you will see that it has only one NVRAM entry.

You can flash with Intel ME_tools_8.1.10.1286 the rom you extracted from Samsung BIOS update capsule (P10AAT.cap), be aware that you will also lose all private SMBios data, you can add those back later(make backup bios from original!)...

  • Like 1

ok I downloaded IME_8.1_r6 (I hope it's what I'm looking for) I have the cap, and I've read a description about Intel Falsh Image tool 8.1.10.1286, what should I do next, (I opened fitc.exe and it's showing me some regions), what should I do next?

 

A pic of what I got so far http://i.imgur.com/JVaHuav.png (FYI: I changed the chipset model to HM76, it was HQ77)

1:Backup BIOS

post-53345-0-73609900-1445000891_thumb.png

2:Extract ROM from CAP

post-53345-0-43187000-1445000966_thumb.png

3/4: COMPARE NVRAM entries

post-53345-0-99968000-1445000989_thumb.pngpost-53345-0-33424900-1445000993_thumb.png

5:Flash Extracted ROM from CAP in cmd: fptw64 -f YOURBIOSNAME.ROM -bios

post-53345-0-37419100-1445001328_thumb.png

 

Good luck and you know if you brick your device bla bla bla...

  • Like 2

1:Backup BIOS

attachicon.gifBackupRom.png

2:Extract ROM from CAP

attachicon.gifExtractRomFromCap.png

3/4: COMPARE NVRAM entries

attachicon.gif1NVRAM.pngattachicon.gif2NVRAM.png

5:Flash Extracted ROM from CAP in cmd: fptw64 -f YOURBIOSNAME.ROM -bios

attachicon.gifFlashRom.png

 

Good luck and you know if you brick your device bla bla bla...

 

Thank you, can I PM you (just 1 PM nothing more ;) )?

about bios flash and issue, please, open a specific tread.

thanks

Sorry for that :)

 

UPDATE : IT WORKED :D :D :D :D

I lost some stuff such as MSDM (hopefully I backed it up) I'll look on how to put it back

THe KiNG you are the best :D i took your tutorial and backup my bios, used uefi pmpatch, flashed it and now i can use the original apple powermanagement without any patch :D because samsung official bios had a locked MSR 0xE2 register

  • Like 1

@midi sorry I was afk, good to see you sorted the stuff.

As I said I bet the BIOS password is in one of those 2 NVRAM, extract them and start digging.

For MSDM check al SMBIOS modules and raw files around them on original dump, you will know soon what to put back ;)

 

@duduclx So, I was on topic after all... ;)

Yes with this kind of stuff you can do whatever you want to the BIOS, unlock registers like E2, set/hide advanced menus, set stuff as default with AMIBCP and so on.

Maybe one day I will show you guys my one double click tutorial :D

OK IM TOTALLY LOST NOW :o WHAT SHOULD I BE LOOKING AT????

FORGET ABOUT IT! I DID IT!!!!!!! (just extracted all of the volumes (2 volumes) and the second padding from the old ROM and replaced them in the new one! I almost had a heart attack after the reboot :o )

Update: Got SN/UUID back B)

i found a kext for AppleHDA Audio after Sleep :) u dont need audio reset programm anymore.. works perfect under yosemite 10.10.5 install the attached kext to S/L/E and have fun :D

Tested and working here in el capitan 10.11( boom app working pertly after sleep) added to the guide in page 4 thank you very much.

@keiner99 i have a question  in 10.10.5 the sleep working fine?. here in 10.11 the sleep working fine but in the second sleep cycle the power led don't go off and the keyboard in wake only work after undock and dock the tablet. and when power off the laptop the power led don't go off until press the power button.

Sorry guys for butting in again :blush: 

The first time I ran the installer I successfully got into the installer interface and formatted the SSD and stuff, but after it rebooted to continue the install, it got through an error (probably a corrupted installer, since my other hack ran into the same error) so I dled again a new installer, tried it on my other hack, it's fully functional, but since then, the tablet wont boot the installer interface, (note that I kept the FW that it worked on it the first time) and gets stuck on the Apple logo, the loading bar and the spinning pointer! I left it for more than 15 mins, still no signe! am I missing something (I can upload the config I'm using riight now, it's exactly as provided on the OP post).

×
×
  • Create New...