Jump to content

IntelMausiEthernet.kext for Intel onboard LAN


981 posts in this topic

Recommended Posts

I'm expereincing some very strange behavior with the physical onboard LAN.

 

Auros Z370 Motherboard

OpenCore (lastest Dec update)

Catalina (latest update)

Machine boots fine, LAN connects normally.  Speed test is great.  (I have 1GB Internet and see about 800MB speed)
However, after about 2-3 minutes, the LAN starts connecting and disconnecting.  It constantly cycles.  Additionally, I see that the hadware sometimes auto-sets itself to 10M.  The only entries in the logs just show connection up and connectoion down.

I have tested this LAN connetdion with a Linux laptop and it works perfect.  So, no problems with router or cable.

Any idea why this would happen? 

Thanks!

@Mieze thank you for the continued updates to this driver/kext.  I've been following this thread and updating whenever you release updates.

 

Unfortunately my machine experiences an issue which seems to affect many other users too.  When "Wake for network access" is enabled, the machine will wake from sleep with very slow/poor WiFi performance and speeds.  Disabling that option either in system preferences or via pmset directly makes this issue disappear.  Problem is, I would like to utilize wake on LAN with this machine so I need this option enabled (which works great with your kext, by the way).

 

Have you ever heard about this issue or experienced it? I'm unsure if there's a way we can disable that option in preferences while still utilizing the WOL feature.  I've also done some testing, and I believe if I wake the machine and then let it sit idle for a few seconds/minutes before actually using the machine, the WiFi speeds are normal?!? I need to test this more to see if this is just a coincidence, but if it isn't, then maybe I could implement some sort of kext that prevents the machine from fully waking for x amount of seconds after the initial wake? Seems a bit hacky, but I can't think of any other solutions at this point.

 

EDIT: Nevermind - this problem has been solved!  Even though my card is native and does not need any third party kexts, by installing AirportBrcmFixup, it will disable the WOL specifically for the WiFi adapter.  This allows me to keep "Wake for network access" enabled but without the slow WiFi upon wake from sleep!

Edited by CoBrA2168
On 1/5/2021 at 11:20 PM, noah977 said:

I'm expereincing some very strange behavior with the physical onboard LAN.

 

Auros Z370 Motherboard

OpenCore (lastest Dec update)

Catalina (latest update)

Machine boots fine, LAN connects normally.  Speed test is great.  (I have 1GB Internet and see about 800MB speed)
However, after about 2-3 minutes, the LAN starts connecting and disconnecting.  It constantly cycles.  Additionally, I see that the hadware sometimes auto-sets itself to 10M.  The only entries in the logs just show connection up and connectoion down.

I have tested this LAN connetdion with a Linux laptop and it works perfect.  So, no problems with router or cable.

Any idea why this would happen? 

Thanks!

Bump
@Mieze

  • 2 weeks later...

@CoBrA2168 There is absolutely no connection between IntelMausiEthernet and Wifi. Both driver's operate independently and in case there is a Wifi performance issue after wakeup, it's up to Apple to fix it. With regard to WoL, the OS calls the driver to enable WoL before going to sleep and calls it to disable it after wakeup. The driver's responsibility is to program the hardware according to this setting.

 

@noah977 Sounds like a hardware issue. Try to select the medium manually. Try one without flow control and EEE as those options sometimes cause trouble. Also consider that there might be dust on the connector?

 

Mieze :cat:

On 1/26/2021 at 6:52 PM, Mieze said:

@CoBrA2168 There is absolutely no connection between IntelMausiEthernet and Wifi. Both driver's operate independently and in case there is a Wifi performance issue after wakeup, it's up to Apple to fix it. With regard to WoL, the OS calls the driver to enable WoL before going to sleep and calls it to disable it after wakeup. The driver's responsibility is to program the hardware according to this setting.

 

@noah977 Sounds like a hardware issue. Try to select the medium manually. Try one without flow control and EEE as those options sometimes cause trouble. Also consider that there might be dust on the connector?

 

Mieze :cat:

@Mieze thank you for the reply.  Not sure if you saw the "EDIT" in my post, but I realized that this particular WiFi issue has been solved already via AirportBrcmFixup.kext (a Lilu extension).  Basically this driver, by default, will disable WOL for any matching WiFi adapters.  This allows me to keep WOL enabled so I can use it over Ethernet with your kext, but without the nasty side affect of having broken WiFi after sleep.

 

I figured I'd keep my initial question/post here just in case someone else stumbles upon this very issue in the future :)  Also thanks again for your continued work on this kext.  I use it on both of my hackintosh machines and it works beautifully on both!

  • 2 months later...

Hello -

 

I am building a hack using ASUS Z490 Gaming TUF Plus which has Intel i219-v chipset for Ethernet. I am unable to get the Mac to see the Ethernet port using either IntelMausi or IntelMausiEthernet kexts. I can confirm that the extension is loaded. I see an error that "IOACPIPlatformDevice is not serializable" in IOReg. I've used IntelMausi 1.0.5 and IntelMausiEthernet 2.5.3d1. 


What am I doing wrong? Thanks in advance!

Screen Shot 2021-03-31 at 4.13.52 PM.png

Screen Shot 2021-03-31 at 4.25.23 PM.png

config-mod.plist

iMac.ioreg

Edited by nagha
added IOReg dump
×
×
  • Create New...