Jump to content

[Guide] Yosemite 10.10.X - Dell Optiplex 780 (760)


pepto
 Share

468 posts in this topic

Recommended Posts

Try this DSDT.aml instead of the current one in /EFI/CLOVER/ACPI/patched :

I disabled "InjectATI" with Clover Configurator. I saw there is the verbose (-v) option and I swichted that on.

I placed your DSDT in folder /EFI/CLOVER/ACPI/patched of the installation usb-stick and rebooted.

But nothing changed (I get some scrolling text, but it goes to fast to see wat ihe last line is).

Then the screen darkens and activity on the usb-stick stops.

 

Edit: I made movie with my iPhone and was able to catch the last moment, line says something like:

"SuperIODevice: [fatal] found unsupported chip!" (see attachment)

 

Few days ago I tested the Radeon HD5450 with windows 7 and made a screen dump of the specs as shows by 'speccy'.

See attachment. Maybe AMD is using a different chipset or rom than the ones who are working without problems?

 

post-373584-0-72406800-1447589641_thumb.jpg

post-373584-0-54433200-1447590143_thumb.jpg

Link to comment
Share on other sites

Well according to your screenshots, seems like you have the same exact "problem" than member jakeyg1.

 

Your Radeon HD 5450 is NOT a 5450. Look here then you can see that it's more likely a Radeon HD 6450 model. And as I said, this card is natively supported on OS X.

 

But the Generic DSDT I pointed out should have solved the problem. Don't worry about messages in verbose mode, they don't really matters. It's just FakeSMC's GPU Plugins that complains it can't identify your model.

 

Try with InjectATI=true AND with the Generic DSDT. Also, tell me what video connectors and display you're currently using (HDMI/DVI/VGA) ad post your config.plist too.

Link to comment
Share on other sites

Try with InjectATI=true AND with the Generic DSDT. Also, tell me what video connectors and display you're currently using (HDMI/DVI/VGA) ad post your config.plist too.

Didn't help. After a few seconds the Apple logo disappears and installation halts.

See attachment for my config.plist.

Maybe can send me the whole EFI-folder (about 8 MB), there is so much discussion about merging, replacing or deleting the Clover-folder... ;-)

config.plist.zip

Link to comment
Share on other sites

Remove Shrike in Clover Configurator > Graphics > FB Name.

 

Maybe can send me the whole EFI-folder (about 8 MB), there is so much discussion about merging, replacing or deleting the Clover-folder... ;-)

 

May be helpful yes. BTW, did you edit any AMD kexts ?

Link to comment
Share on other sites

Good, but I need to know what connectors/Display you're using.

 

Your whole EFI folder is OK and I'm pretty sure there's no problem with it. The only reason I can see why your Monitor goes black is that there's an issue with the way you connect it to the Optiplex.

 

HDMI/DVI is prefered though it should work fine in VGA too. Have you tried others video ports on your "Radeon 6450 disguised in 5450" ?

Link to comment
Share on other sites

I used the DVI until now, the VGA is on a seperate connector on the Radeon 6450/5450 but I was able to use it via a opening in the housing (I'm using a Optiplex smal form factor).

But it doesn't solve the problem... Installation starts, I see the logo few seconds and then the screen go black.

 

I give up, gonna look for a different video card...

Link to comment
Share on other sites

The provided DSDT is designed for AMD Radeon 5450 Series. I'm not really sure of this but I think the AMD Radeon 6450 Series works OOB and don't need any DSDT patch. Please, run this in a teminal window and post report.spx here (it's on your Desktop) :

system_profiler -detailLevel mini -xml > ~/Desktop/report.spx

Meanwhile, you can try this Generic DSDT.

 

The generic DSDT worked a treat! Thank you so much. The only thing I don't have working now is audio. But I'm going to jump straight to 10.11 before I try getting that working. Thanks again for all of your hard work.

Link to comment
Share on other sites

hallo everyone, first of all thanks for your guide, I have been able to install YOSEMITE on my dell optiplex 780 with a 120Gb SSD and a sapphire Radeon 5450 graphic card.

I have WI-FI working on a €2 usb adapter (with dwa-140 system) only problem at every reboot have to go on it and reconnet (but stay connected if wake from sleep mode)

only 2 little problems... with an €1 bluetooth adapter have been able to connect the Apple Wireless Keyboard but it seems there is a problem due that it does not work always.... but on bluetooth preferences there are 2 devices (one as adman's keyboard and the other as c8-e0-eb-12-99-73) but both devices are the same keyboard... and anywise it doesn't work.

Second problem , I bought a monitor LG 25UM57 (with maximum resolution 2560x1080) but I am not able to switch to this resolution, it works at 1920x1080, I tried to use SwitchResX but .... no result.. hope you can help me... and hope I am not posting on the wrong place...

 

Regards

 

HI, anyone read this and can help me ??

 

Regards

Link to comment
Share on other sites

  • 3 weeks later...

WLAN:

TP-Link TL-WDN4800 N900 Dualband-Adapter (PCIe, 450 Mbit/s) ——> works OOB with my Optiplex 780

 
Bluetooth:
try another BT stick
 
graphic:
What is the Monitor connect ??? HDMI?
I think with HDMI is only 1920x1080. The HD5450 can not there more with HDMI.

post-1358580-0-41754800-1449397610_thumb.jpg

Link to comment
Share on other sites

  • 1 month later...

I found this guide and was excited to repurpose an old computer for my nieces to use FaceTime and iMessage with family, but ran into some issues.

 

Has anyone had any issues with YouTube videos/ certain pages not loading?

 

Once in a blue moon a YouTube video will load. Majority of the time, I just get a spinning wheel ontop of a black screen.

 

Funny thing is that the YouTube ads will load without any hesitation at all.

 

I've tried different browsers, updating the Flash Player, as well as fiddling around with MTU on my network settings, but nothing seems to fix it.

 

I did do the El Capitan build and YouTube videos and all pages load perfectly fine, but I was never able to get audio working properly even after following the provided instructions, which is why I reverted back to Yosemite.

 

I am currently running a Core 2 Quad Optiplex 780 with a HD5450 512mb video card. Everything works great except the YouTube and loading of web pages.

 

I have no special firewall rules or anything. I'm inclined to think it's some type of network issue causing it to act funny. Any help would be as I've been scouring the forums for several weeks trying to perfect this build for the girls. Thanks.

 

EDIT: I noticed with my USB wifi, I didn't have this problem, so it had to be something with the network. I installed the AppleIntelE1000 v3.2.4.2 kext and it fixed it. All my pages load properly and YouTube videos pop up instantly.  :thumbsup_anim:

Edited by bienvenidos
Link to comment
Share on other sites

  • 3 months later...

EDIT: Cancel below I used the link from post #2 and it unzipped just fine

 

Thanks for the lovely guide!

 

I downloaded the Clover_780.zip file and tried to unzip it using Apple Unarchive Utility on an actual Mac but It gives me this error:

 

Unable to expand

Error 2 - No such file or directory

 

Any ideas? Or does anybody have the files they can post? I'd sure appreciate it.  :)

Link to comment
Share on other sites

  • 4 months later...

I've just noticed there's a problem with terminal commands at the end of the step 5.

 

Instead of this :

 

5. Prepare Bootable USB Drive

This step extracts the OS X Installer contents, then installs clover bootloader to the USB stick.

Make sure to backup the files that are already on your USB flash drive:

  • Insert the USB drive.
  • Open up /Applications/Utilities/Disk Utility.
  • Highlight the USB drive in the left column.
  • Click on the partion tab.
  • Click Current and choose 1 Partition.
  • Click Options...
  • Choose GUID Partition Table.
  • Under Name: type USB (you can rename it later)
  • Under Format : choose Mac OS X Extended (Journaled)
  • Click Apply then Partition.
  • Go to Applications and find the OS X Yosemite installer.
  • Right click on the installer and choose show package contents
  • Navigate to Contents/Shared Support and double click on the InstallESD.dmg, the .dmg should now mount and appear on your desktop.
  • Open Terminal and type the following command: open /Volumes/"OS X Install ESD"/BaseSystem.dmg
  • Now, open the disk utility and restore the volume you previously named "USB" with the mounted BaseSystem.
  • Once done, you will end up with two "OS X BaseSystem". Rename your USB drive to Yosemite. (not the dmg) You can tell which drive is the USB from the size.
  • Type the following commands in Terminal:
  • 	 -cp "/Volumes/OS X Install ESD/BaseSystem.dmg" /Volumes/Yosemite/
    	- cp -a "/Volumes/OS X Install ESD/BaseSystem.chunklist" /Volumes/Yosemite/
    	- rm /Volumes/Yosemite/System/Installation/Packages
    	- cp -a /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/Yosemite/System/Installation/Packages
    	

You should read this :

 

cp "/Volumes/OS X Install ESD/BaseSystem.dmg" /Volumes/Yosemite/
cp -a "/Volumes/OS X Install ESD/BaseSystem.chunklist" /Volumes/Yosemite/
rm /Volumes/Yosemite/System/Installation/Packages
cp -a /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/Yosemite/System/Installation/Packages
There's no '-' before each command.
Link to comment
Share on other sites

  • 1 year later...

Sorry to bring up an old thread, but I've got a 760 (also tried on a 780) that I've been trying to get working.  When I get to the disk utility for setting the computer hd, the only thing listed is the flash drive.  I've tried another hd and it did the same thing.

I've formatted the drive as ntfs and also exfat and neither show up.

Drives are:

Seagate Barracuda 80gb 7200

WD 160gb 7200

 

Any ideas?

Edited by porcupike17
Link to comment
Share on other sites

  • 1 year later...

Hi, I need a little help. I managed to install Yosemite, Dell 790 i5 2400, gtx 1060. Everything works, except the gtx1060 video card. I installed nvidia web driver, it loads it but it has no graphics acceleration. El Capitan, Sierra, High Sierra do not manage to install them. I have attached the EFI file, maybe someone can help me make my DSDT. The files are extracted to the origin folder.

 

https://mega.nz/#!k9JHHIaZ!JmuzVfcB6I5QPsbq1FBTUKYZycMBTR2lEXKxv1naw3Y

 

https://mega.nz/#F!lwAxVAoJ!XckwbahrS71yXIxxTpUZTQ

 

20200318_204813.jpg

20200318_204749.jpg

20200318_204733.jpg

20200319_102118.jpg

20200319_102041.jpg

20200319_102010.jpg

Link to comment
Share on other sites

 Share

×
×
  • Create New...