Jump to content
luki1979

Patch enabling Handoff for non Apple BT4 devices.

130 posts in this topic

Recommended Posts

On some other forums people claiming to enable Handoff for BT4 USB dongles with this Clover kext patch:

 

Credit to Dokterdok.

 

<dict>

<key>Comment</key>

<string>Handoff Fix</string>

<key>Find</key>

<data>i4eMAQAA</data>

<key>Name</key>

<string>IOBluetoothFamily</string>

<key>Replace</key>

<data>uA8AAACQ</data>

</dict>

 

If no joy try:

Find: 8B878C010000

Replace: B80F00000090

 

Below new patch from dokterdok:

Hello,

Here below is a refreshed patch that allows 3rd party Bluetooth 4.0 LE devices to work with Continuity, now on OS X 10.10.2 beta as well as the previous versions.Filename: IOBluetoothFamily

Find: 48 85 C0 74 5C 0F B7 48

Replace: 41 BE 0F 00 00 00 EB 59

A few notes:

  • You don't need to apply my previous Handoff binary patch to make this one work
  • You need Broadcom Wi-Fi hardware that runs with the Brcm4360 kext
  • The patch skips internal compatibility checks, and therefore might incorrectly flag Bluetooth 1/2/3 hardware as Continuity compatible (Handoff / Instant Hotspot)
  • After the patch is applied and your system rebooted, log out and log in iCloud on OS X. It can take a few minutes for your iOS device and system to do the Continuity handshake.
Non Clover guys:

Code:

# Patch IOBluetoothFamily for Instant Hotspot / Hand-off

sudo perl -i.bak -pe 's|\x8B\x87\x8C\x01\x00\x00|\xB8\x0F\x00\x00\x00\x90​|sg' /System/Library/Extensions/IOBluetoothFamily.kext/Contents/MacOS/IOBluetoothFamily

 

Edit. It does work for some USB and Wi-fi/BT4 combo cards.

You must add kext-dev-mode=1 to boot and sign out from your ICloud, after reboot sign in.

 

 

Confirmed devices working with correct smbios:

BCM94352 /AzureWave AW-CE123H combo card (this card is the one working the best with this patch)

Orico BTA-402 USB BT Adapter firmware 8891 (confirmed on macbook pro smbios and BCM4322 but Hotspot unreliable )

USB devices with 20702A3 chip but only with Broadcom 943xx Wi-Fi and mainly on MacBook smbios

BCM20702 Internal cards based on 20702A3 firm.v14 c4096 confirmed to work

 

 

EDIT 2

I just got Orico BTA-402 and it doesn't work for me on MacPro 3.1 smbios and Atheros 9280. Conclusion is that your smbios probably should be white listed for handoff and perhaps you also need Broadcom Airdrop compatible Wi-Fi card

 

EDIT 3

It seems that people using MacBook Pro smbios got lucky with this patch

 

Edit 4

 

White list argument is invalid, handoff works even on Mac Pro 3,1 with corect Wi-Fi/BT4 card

 

If you got it working please post name of your device, chipset and firmware from System Report and please state what smbios you using (e.g. MacPro 6.1) and your Wi-Fi card.

Many thanks

Share this post


Link to post
Share on other sites
Advertisement

Nope.  Matter of fact, it killed my Bluetooth altogether.  Where'd you see that someone got it working?  I haven't seen that at all.  Only working fix I've found is buying all new hardware.  

Share this post


Link to post
Share on other sites

On Russian forums ppl posted actual pictures of this patch working. I can't speak Russian so didn't quite get all the conversation just the code. It doesn't seem to be any good for me.

 

Ps. Try using kext-dev-mode=1 flag. 

Share this post


Link to post
Share on other sites

It is better to post the original thread link.

 

The Handoff toggle appeared without any functionality.

System log shows that "Stopping Handoff scanning", which is different from a real Mac.

 

FYI: My USB Bluetooth Adapter is BTA-402 (CSR chip)

The following attachment is the log from Console.

post-1432100-0-94761600-1415330791_thumb.png

 

Update: Instant Hotspot also doesn't work.

Share this post


Link to post
Share on other sites

I found the original post, it is:

https://applelife.ru/threads/wi-fi-bluetooth-airdrop-handoff-i-instant-hotspot-v-os-x-10-10.42443/page-10

 

Also, I can confirm this patch works on my bcm94352 combo cards. Handoffs now fully functional. One trick though, if you cannot use handoff after toggle it on, is to sign out and back in your iCloud account. Hope it helps. =D

Share this post


Link to post
Share on other sites

Wow that's great guys. I think firmware plays the role too.

AustereJ is your bta-402 Orico brand?

 

What chipset and firmware you got showing in System Report?

 

So I can edit main post with devices confirmed working. Many thanks

Share this post


Link to post
Share on other sites

Wow that's great guys. I think firmware plays the role too.

AustereJ is your bta-402 Orico brand?

 

What chipset and firmware you got showing in System Report?

 

So I can edit main post with devices confirmed working. Many thanks

 

Yes, it is Orico band.

The following attachment is the System Report.

post-1432100-0-51878700-1415344725_thumb.png

 

In general, my adapter is BCM4322 Wireless Adapter + Orico BTA-402 USB BT Adapter.

Handoff works fine. Instant hotspot partially works.

 

P.S

I can only find my cell phone in the Personal Hotspot part of wifi list.

When I tried to connect to my hotspot, the system returned an error message dialoge "Failed to enable Personal Hotspot on XXX".

post-1432100-0-92277300-1415345766_thumb.png

After this dialoge, I can no longer find my phone in the wifi list, unless I restart the computer or replug in the BT adapter.

 

FYI, the console returns two error msgs when trying to activate and connect to the hotspot.

SDHotspotBrowser::sendMessage:toDeviceWithID:isRequest:messageID:error: Sending from device ID to destination = self-token:4DD0E6B6A0EC19DAF200EF56166D68BDAAC9FA4B30E5F8F8434C2D6926570739/mailto:<HERE IS Apple ID, hidden>, with identifier = C826436C-6C7E-4900-8822-6186D842316D, message = {
    HotspotBrowserMessageType = 0;
    HotspotMessageVersion = 1;
}, 
SDHotspotBrowser::retrieveTimerFired: Called handler with timeout error (identifier = 57CB89BD-26A9-4ECD-91A6-0671DEF63925)

and the console returns the following error msg when trying to find the phone:

SDActivityAdvertiser::continuity:didFailToStartAdvertisingOfType:withError: TetheringTargetPresence (The operation couldn’t be completed. (com.apple.identityservices.error error 200.))

Share this post


Link to post
Share on other sites

hello

 

nice discover

 

07/11/14 08:58:41,330 sharingd[381]: 08:58:41.330 : Device Capabilities (Handoff:YES, Instant Hotspot:YES, AirDrop:YES, Legacy AirDrop:YES, Remote Disc:NO)

 
BCM94352 HMB/AzureWave AW-CE123H
 
thanks 
 
good hack

Share this post


Link to post
Share on other sites

BCM94352 worked 

 

Before patched

 sharingd[299]: 00:28:42.514 : Device Capabilities (Handoff:NO, Instant Hotspot:NO, AirDrop:YES, Legacy AirDrop:YES, Remote Disc:YES)

 

After patched

sharingd[295]: 00:33:09.221 : Device Capabilities (Handoff:YES, Instant Hotspot:YES, AirDrop:YES, Legacy AirDrop:YES, Remote Disc:YES)

Share this post


Link to post
Share on other sites

Nice!  It worked on my BCM20702 Bluetooth card.  (My laptop has separate slots for bluetooth and wifi.  Although I have two combo cards in my laptop, only bluetooth works in the bluetooth slot and only wifi works in the wifi slot.)  My wifi card is the BCM94322.

 

BTW, the code at the top did not work for me.  I had to use the following:

 

Find: 8B878C010000

Replace: B80F00000090

 

I can also confirm that I have received notifications in the dock about activities taking place on my phone.

Share this post


Link to post
Share on other sites

awwww hell. doesn't work for me. even logged in and out of icloud

time to order another BT adapter

 

  Manufacturer: Broadcom

  Transport: USB

  Chipset: 20702A3

  Firmware Version: v14 c4096

Share this post


Link to post
Share on other sites

GREAT! was waiting for this! ;)

 

Running Hackintosh on my HP 2570p, with 4352 for WIFI, and 20702A3 on FW v14 c5512 for Bluetooth. 
My Mainboard doesn't support combo cards.

 

Works for me!

Share this post


Link to post
Share on other sites

Confirmed not working :(

IOGear, Belikn and other BCM20702 USB dongles based on 20702A3 chip and running v14 c4096 firmware. (Apparently devices with v14 c5575 firmware works but not yet 100% confirmed)

 

If you got it working please post name of your device, chipset and firmware from System Info

 

You might want to hold off on saying that the BCM20702A3 chipset with v14 c4096 firmware is confirmed not to work.

 

post-270804-0-10789400-1415431560_thumb.png

Share this post


Link to post
Share on other sites

Hmm. ^^^

Same firmware as mine USB dongle, obviously your device is internal.

You also got different Product ID, Composite Class Of Device and Device Class (Minor) rest is the same. 

I think device class(minor) must be 0x03 and I got 0x01, not sure

 

Happy that it works for you.

 

PS: It might be that patch only works for laptops? Can anybody with desktop smbios can confirm USB dongle working with this patch?

ta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×