Jump to content

Asus EAH6450 Video BIOS UEFI GOP Upgrade (And GOP UEFI binary in .efi for many ATI cards)


142 posts in this topic

Recommended Posts

Hello.

 

Thanks, first, for all the effort everyone is putting into this: I've spent a few hours reading the various posts and trying things out and I have learned quite a bit!

 

Unfortunately, I have not learned enough to "roll my own". At least, not 100% successfully... :-(

 

Part of the problem is probably that most forum attachments do not download for me, for some reason. Maybe because I just joined...? But the error message does not indicate that. Another issue, I expect, is that I do not have a Mac so the scripts I managed to get (DropBox links work!) are not applicable. Even the Maker v4 script which's supposed to run on Windows is complaining about missing tools: grep, etc.

 

So my last resort is to hope that someone might be able and willing to help! A summary of my situation:

 

I have a couple of video cards and I would like to get both or either of them working with UEFI GOP:

 

* XFX Radeon HD 6850 (HD-685X-ZNFC).

* ASUS GT 640 (GT640-DCSL-2GD3).

 

Their BIOSes are here.

 

I have tried to get a BIOS from ASUS without success. And the XFX is really too old to expect any effective support for it; so I didn't even try to ask them. I did, however, try to manually make a BIOS for it using UEFI modules I found attached to the 6850 BIOSes posted here. I first tried the 6850 BIOSes already there (Gigabyte doesn't POST. XFX and PowerColor require CSM). I then tried to create my own BIOS using the UEFI modules from them and the legacy module from the original BIOS; but again the results required CSM...

 

:-(

 

And this is where I am right now. Any help, pointers or ideas would be very appreciated and most welcome!

 

And thanks for reading this far... :-)

 

Edit: Hmmm... I seem to have managed to get a functioning UEFI GOP BIOS for the 6850 concocted using the UEFI module from this post. So that's less urgent, now. In fact, everything is so much less urgent, now! Though I would still very much appreciate any help as I would rather get my GT 640 and its quad-monitor output support working.

 

Edit: Success at last! UEFI GOP firmwares for both of my cards are now included in the DropBox shared folder linked to earlier. Maybe they'll be of some use to someone. And hopefully they'll save someone the pain of dealing with ASUS tech support; the most incompetent support team I have had the displeasure of dealing with in my ~20 years in IT: it took them 26 days to check their own website and tell me they have nothing but what's on there, even though I clearly pointed out that I already checked the site. Naturally, the files are provided without warranty of any kind, etc.

  • 2 weeks later...

Someone from pcbeta.com have made a UEFI GOP VBIOS by using AMD-UEFI-GOP-MAKERV4 for me.

 

My “6770” is 5770 with two “MCuC”s, so the second MCuC will be overridden by 6450GOP. This will lead to a fail cold start.

 

SO, I insert the second MCuC to the end of VBIOS made by MD-UEFI-GOP-MAKERV4, and modify the offset indicating the second MCuC

 

Anyone can check my modified bios? I don’t know if my mind and steps are right and I don’t know how to fix checksum

 

my modified bios is 140K

 

I will replace onboard M25P10(128K) to M25P20(256K), if my bios works I will flash it into M25P20,which is big enough, if it don’t work, original bios still can be flashed into M25P20

6770.zip

attach_MCuC.zip

 

I finally make a working 5770 rom (Resolution works without black borders, full uefi boot without cms support)  but rom works only 1 time. i can reboot many times without any problem but if shutdown the computer 5770 never comes again until reflash it with original rom.

After searching about my rom i found many posts from netkas about MCuC instance in this rom. Maybe that rom needs different modding from others card.

Anyone ant idea?

 

 

Maybe i found the problem:

After reading netkas notes about 5770-5870 and 4xxx roms i note coz MCuC instance must be 2 times in rom

 

 

3a. Move the mcuc section (last part of the BIOS) to make room for the EFI.At this stage you can trash the modified myrom.rom that only has one "MCuC". Open the original myrom in 0xed. Scroll down to the end, it should show a long string of "F". Select a large part of it. Cut. Look for "mcuc" (text search field) and locate the 2nd instance, near the end of ROM. Note its offset, as indicated at the bottom of the window. It should be 1A000 (hex). You can switch between decimal and hexadecimal by double clicking on the "dec" or "hex" text on the bottom left. Upward "mcuc" is a long string of "F" where the EFI should be inserted. Put the cursor anywhere in that string. Switch to insert mode ("edit" menu) and paste. Note the new offset of "mcuc". If the offset hasn't changed, or if you have lost the 2nd instance of mcuc, close the ROM without saving and do these steps again. Save a copy of myrom.rom (with this name) in your home directory.Then redo steps 2a and 2b. If only one instance of mcuc found, you're screwed. You cannot make a custom ROM with your original BIOS.
After that must set the new offset of MCuC on first MCuC instance:

 

If 2 instances are found...3b. Correct the new offset of mcuc in myrom. Say it has changed from 1A000 to 1A200 (if you have pasted a 512-Byte string of Fs). In 3 Bytes, this new offset is written 01 A2 00. In BIOS code, bytes are written backwards: 00 A2 01. To find where to indicate this offset, locate the first instance of mcuc. 8 Bytes upward (16 chars) you should see the original offset 00 A0 01. Go to overwrite mode and replace this with the new offset. Save myrom.rom in your home directory.
After that must fix checksums and indicator (using fixrom.py).

The problem of all that is not enough space exist for 2 MCuC instances and uefi, rom file goes 140kb.

I cropped the last lines of 2 MCuC instance but im not sure if that works.

I will checked home and i will report back.

 

If finally that works i will edit your script for 5770 support.

 

UPDATE: UEFI BIOS isnt possible to works on 5770 because 5770 rom not have enough space to keep UEFI.

5770 BIOS: 62.904KB

MCuC Table: 22.944KB

UEFI: 59.849KB

5770 BIOS SIZE: 128kb

UEFI+BIOS+MCuC= 145.697KB

 

(MCuC table is code for GDDR5 Initialization)

 

 

Would you plz make a lager 6770 ROM for me

 

i will replace EEPROM

 

See thread above

  • 3 weeks later...

Thanks for the great thread and information. I just registered to site to be able to download links, even after registering I'm not able to download anything (other than dropbox links). Any ideas? I'm trying to make uefi bios for my Asus HD6870, do the tools work on win10 preview? Thanks a lot in advance for any help.

  • 1 month later...

You need this little tool which I just uploaded.

Dump your VBIOS, put in roms directory.

Run script.

Flash under Windows with NVFlash.

Reboot, enjoy UEFI GOP ;)

EDIT: But please be careful, there are many models of the GT210, wrong model might make card useless...

 

 
Thanks a lot in advance for this awesome tool and your help!
 
 

When I run it under ArchLinux with jdk7 and latest python installed, I get:

 

cannot execute binary file: Exec format error

File "fixrom.py", line 100

print "Usage: %s <infile> <outfile>\n" % sys.argv[0]

 

SyntaxError: Missing parentheses in call to 'print'

Your 'new' UEFI rom is ready at uefi.rom

 

 

Edit: after fixing the parenthesis myself I run into this one:

 

cannot execute binary file: Exec format error

File "fixrom.py", line 103, in <module>

f=file(sys.argv[1])

NameError: name 'file' is not defined

Your 'new' UEFI rom is ready at uefi.rom

 

 

Edit2: after replacing file with open for python v3, I get this error:

 

cannot execute binary file: Exec format error

File "fixrom.py", line 103, in <module>

f=open(sys.argv[1])

FileNotFoundError: [Errno 2] No such file or derectry: 'uefi.rom'

Your 'new' UEFI rom is ready at uefi.rom

 

Edit3: It looks like that ./Efirom simply does not run on my x64 system, while it should:

EfiRom: Mach-0 64-bit x86_64 executable.

 

Edit4: Nevermind, I now see that Mach-0 is of course a Mac executable, not linux.

 

Edit5: A friend used converter version 2 for me, and the atiflash tool under dos starts but doesn't give output on the cmd line.

 

Can you please convert my rom for me? I put it here: http://www.filedropper.com/100268d8

 

My card is a 0x68D8 from Sapphire btw.

 

Edit6: AMD v1 tool worked for me! Succesful flash and non-CSM UEFI support now!

 

Edit7: After a cold reboot the screen remains black... how to fix this? (besides orig rom flash)

 

Edit8: The card seems bricked. Atiflash and ati-win-flash both do not recognize the card being present in the system at all.

 

Is there another way to overwrite the VBIOS back to original? I have made a backup of the rom of course.

  • 4 weeks later...
  • 3 months later...
  • 2 months later...
  • 1 month later...

hi everybody...

 

Do you think it's possible to add UEFI Gop in a gainward GTX 660Ti 2048 Mb please ? (not phantom edition)

I hope it's not a stupid question...

 

This is my BIOS, extracted with NVFlash :

http://dl.free.fr/ja8JknpU0

 

(gainward never made such bios for this card, instead of asus with the GTX660 TI-DC2-2GD5 whose UEFI bios can be found here : 

http://dlcdnet.asus.com/pub/ASUS/vga/ASUS_VGA_UEFI_VBIOS_Update.zip?_ga=1.13678193.737018812.1457445151)

 

Thanks a lot...

 

MyGuyzmo

Here's one I made with GOPupd 1.9.1. See if it works OK.

 

Yessss Riley ! It's working like a charm  :thumbsup_anim:  :thumbsup_anim:

Thank's, thank's a lot, you're a great man...

 

I don't know this tool (GOPUpd), so now i'm trying to understand it...

 

Now i can boot in Ultra fast mode with my Gainward GTX 660Ti and Asrock Z77 Extreme6, it's very pleasant  :yes:

 

Thanks, may the force be with you Riley, and for all members of this forum too !

  • 4 weeks later...

Hello, I made the bios modification on a video card from Gigabyte "GV-R785OC-1GD" with the member of the tutorial "Tedascuen".

It's working perfect in UEFI, I have not tested the "fast boot".
But when I'm browsing the motherboard BIOS options, it has a certain slowness in transitions, mouse arrow "breaking" the movements. Type "drop frames" in the BIOS.
Do you have any way to increase that speed and improve the flow?
Tutorial that followed was this:
 
My BIOS:
 
Original BIOS:  Pitcairn.rom.zip
 
UEFI BIOS modified: 7850UEFI.rom.zip
 
Thank you friends

I haven't had any issues like that when navigating the BIOS menus. Try this one and see if there's any improvement.

 

You should always dump the rom from your card when modding. Never rely on a bios downloaded from elsewhere because it may not be as compatible as it claims. Especially if you start seeing weird behaviour after modding.

Pitcairn_updGOP.zip

I haven't had any issues like that when navigating the BIOS menus. Try this one and see if there's any improvement.

 

You should always dump the rom from your card when modding. Never rely on a bios downloaded from elsewhere because it may not be as compatible as it claims. Especially if you start seeing weird behaviour after modding.

 

Friend with that his solution was a little better.

Thanks and thank you.
  • 4 weeks later...

Ok guys I have strange one here.  When I look at the database my EVGA bios should be a 178k bios but when I use gpu-z its only 92K.

 

 

Here is the link to my Card.

 

http://www.techpowerup.com/vgabios/130178/evga-gt640-2048-120511

 

Its the 2 gig card.  I know I need at least 128K to update to GOP.

 

 

Basically the same cards as the two gig card in the photo

 

 

http://www.macvidcards.com/store/p36/Nvidia_GT_640_1_GB%2C_2_GB_or_4_GB.html

It doesn't matter what size your card bios is. Once you add the GOP segment it should work.

 

There's no need for the resulting BIOS to be at least 128k, although if it's smaller you may have to force flash it in some cases (like ATI).

 

My original GT210 bios was 62.5k and 122k after adding the UEFI support and it flashed and worked without a hitch.

No way really I have a GT210 Im dying to try but I'm afraid!.  I really need another uefi graphics card laying around for trouble shooting and bootcamp!  Going to try the EVGA first.  Fingers crossed.

 

 

 

snakeman

 

 

 

Update:  It worked in windows 7 "gpu-z"  has a check mark on the UEFI square wow.

 

I used this tool to create my GOP.

 

"Awesome! GOPupd is another tool for adding GOP support to video cards. I mentioned it earlier in the thread."

 

 

Thanks Andy Vandijck Thanks Riley and everyone that risked their cards.

 

 

New Update:   GT218 did not work for me.

 

Error: rom image to large for eeprom  :(

Thanks, I have a few more cards lying around to try;  GF119 hmmmmm.  I checked online for some cards, thanks again.

 

Now to update my motherboard bios to see if fast boot actually works.

 

ozmosis or clover???

 

 

Report back later.

 

 

 

Update:  My GF119 works so far.  Its a Zotac 610 1 gig card.  Wow, very happy with that one, very surprised.

 

Here is the exact card.

 

https://www.zotac.com/us/product/graphics_card/gt-610-zone

×
×
  • Create New...