Jump to content

10.9 Mavericks Simple Vanilla Hackintosh Install Guide

167 posts in this topic

Recommended Posts

Success on Asus K53e with I3 Processor.

Followed the instructions and copied my extra folder from my ML install. 

Just sound, keyboard and trackpad not yet working but hopefully [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] will have a solution for those.

I can't seem to copy the kexts over to the System/Library/Extensions folder, as it is locked. Using a MacBook Pro running OS X 10.9 Mavericks to prepare everything. Pacifist can't copy it, same goes for Finder. The machine to be Hackintoshed is running an Intel Core i5 unlocked Haswell. My first time doing a Hackintosh, so please don't jump all over my newbieness!

The installation I managed to do it with -v -x. After I followed the steps to copy FakeSMC and NullCPUPowerManagement, but when trying to boot from the hdd appears ''MISSING BLUETOOTH CONTROLLER TRANSPORT'' and then ''RESETING IOCATALOG''


What can be happening?


My PC:

Gigabyte Z77M-D3H

Intel Core i5 3330

Gigabyte GTX 650

8 gb ram


Sorry for my English :blush:

I have the 7970 installed and working with Mavericks.  The only thing it requires for a successful boot is use of "GraphicsEnabler=No".  System info still shows 7xxx 3072 MB

For me it is not working. Fine with 10.9 DP (any version) but now finally i have not full QE/CI, but my card shows as 7xxx and 3096 MB RAM. I can't fix this.

So I installed Mountain Lion on vmware workstation 10 on my Dell Inpsiron 7720.
Downloaded Mavericks
Setup bootable USB
Created a new Virtual machine
Installed Mavericks
All went well
Only thing I cannot get working is iMessage?

I have tried the fixes but dont think they work in a virtual machine?

I suspect that under "About this Mac" I need to see hardware specs like at the moment it says Mac and thats it!

just finished installing Mavericks 13A603 GM , added five kexts a well sorted extras folder and chameleon 2265 job done gotta love this mobo Asus p5k-vm worked flawlessly since 10.5.6

It works good here, except constant and random freezes, no kernel panic, but I have to reset from button when freezes. I tried everything, including ApplePCIIDE.kext (the freezes are more rare, but they still happen randomly). I am totally illiterate in editing dsdt (I don't understand anything in these lines).

I attach my dsdt here, can you see it and help me?


My installation works without the dsdt, but in this case, I have no audio (AppleHDA.kext not loaded even the original one), the internal drives appear orange and the freezes occur more frequent. I mention the freezes occur especially when something load the CPU to 80-100% for 10-30 seconds, even some seconds after the CPU loading peak is gone. I put a new and bigger CPU heat sink over the CPU and even a cooler over the north bridge radiator, touching the CPU radiator it is not very hot, but the north bridge was really hot after 30 minutes of working Mavericks. I still not suspect a hardware malfunction, because it happens the same with the 2nd p5k-vm I have. I suspect something wrong in my dsdt or in my dsdt/kexts combination. I attach a screenshot with my kexts in Extra/Extensions.


Hi everyone, i get a error on bootloader.

Not boot to OS X or WIndows if USB not stick usb drive.

Boot0: done

And PC not reponse, i have to press the reset button.

While have USB PC boot dual with WIndows 8.1 and OS X Mavericks ( Windows and OS X install on same HDD, two partition ).


Help me with error.


1. Last release of Chameleon doesn't support  kexts are in the extra/extension. You need to copy essential kexts (FakeSMC, NullCPUPowerManagement) to /System/Library/Extensions on your USB stick

essential software & kexts + org.chameleon.Boot.plist + dsdt + smbios are in /Extra

Chameleon-2.2svn-r2246 who is in the attachment of the guide


How do you mean it doesn't support kexts in Extra\Extensions folder? I've just installed Mavericks and FakeSMC version 5.2.655 straight from the source (HWmonitor works) and associated plugins are in that folder (chameleon installed in system drive) I also have AHCI_3rdParty_eSATA and IOAHCIBlockStorageInjector there with Chameleon version: 2.2-r2266


I've got everything working  in my system (GA X58-UD4P_ATI5450) except shutdown sleep and restart, all kexts load fine (IntelCPU, AppleLPC) patched AppleRTC as well, but to no avail.

Thanks , great guide ... But i have a big problem .

During the installation from the usb stick , everything works great until the welcome screen comes ... Then i have no mouse , no keyboard ! , i see the welcome screen scrolling with different languages ... But there is no input device working to continue the installation ,

I'm using hp dv6 i7 laptop ... Was working fine with ml 10.8.2

Can i use a fix for kb/mouse ?

How ?


Hi XanthraX your kexts are different to mine your issue my be related to that nullcpu management kext I don't know what that is I don't use it

I have attached the files that I use  kexts to use my DSDT, which is patched a bit plz try them get back to me

P5K VM pack.zip

Hi. I have a Dell computer without ahci mode in the bios (only RAID And ATA). My usb stick with Mavericks installation does not see my hard drive where I want to install Mavericks in both raid and ata modes.

Now I have Lion installed, and I have added from it ACHIPORTIJECTOR.KEXT in the s/l/e folder of the pendrive in order to make it recognize the drive. But infortunatly I cannot repair permission of the s/l/e folder of the usb drive.. If I use disk utility the option il disabled, And with the terminal even by superuser the permission remain set as "unknown".


How can I modifie usb permissions or how can I Made my usb drive recognize my drive?

I still had 2 freezes, but more rare than before. I suppose they are fermi freezes due to my nVidia GeForce 9400 GT. I ordered another videocard based on AMD HD 5670 and I am sure the freezes will be gone.

If you want sleep you have to have a proper patched AppleIntelCPUPowerManagement.kext (AICPM) and to get rid of NullCPUPowerManagement.kext (NCPM). I have no idea what to edit at AICPM and it is very risky, because you should install it back in /System/Library/Extensions after every system update. Or put away NCPM and install it in /Extra/Extensions before every system update, then replace AICPM with the patched one in /System/Library/Extensions and remove NCPM from/E/E.

Any idea why i am getting this in installation:



Mac OS X can't be installed on this computer.

OS X Mavericks cannot be installed on this computer.

If you want to restore your system from Machine backup, clisk "Restore from Backup"


Hi gsxb. I seem to find the source of the random freezes. It was the wrong RAM modules pairing. I changed the modules and now it seems to work fine. It was not because the graphic card. I still testing because it wasn't anything specific to generate those freezes, but I use now the computer from more than 4 hours and no freeze occurred. 

  • Create New...