Jump to content

MNSiw

Members
  • Content count

    133
  • Joined

  • Last visited

  1. Right Click downloaded 'Install macOS High Sierra Beta.app' and select 'Show Package Contents' Now navigate to 'Contents/SharedSupport' and mount 'InstallESD.dmg' Run 'Core.pkg' from 'Packages' folder and install High Sierra When it finish installing, navigate to 'Contents/SharedSupport' once again and mount 'BaseSystem.dmg' Navigate to 'System/Library/CoreServices' and copy 'boot.efi' and paste it to same path on your installed High Sierra HDD or SDD Now reboot and enjoy This installation method will not update your Recovery HD to High Sierra and it will not show any option to convert target partition / drive to APFS during setup. I tried APFS on my SDD by installing High Sierra twice using 'Core.pkg', it works, but there's no noticeable performance difference for me and it makes re-partitioning the drive bit complicated, so for now I prefer HFS+
  2. MNSiw

    Mac os High sierra installation attempts

    Have you copied boot.efi to CoreServices? Sent from my XT1060 using Tapatalk
  3. Installing High Sierra form working Sierra is lot easier with Core.pkg Sent from my XT1060 using Tapatalk
  4. Hi I have working Sierra 10.12.6 on SSD, latest Clover with default settings, FakeSMC.kext, NullCPUPowerManagement.kext and Patched_10.9_AppleRTC.kext, my system does not boot without these three kexts. Now if I install High Sierra to an empty partition on same SSD using Core.pkg and copy boot.efi to System/Library/CoreSerivces, it boot perfect and everything work as expected. But when I create High Sierra USB with createmedia and use same Clover and kexts settings, it show progress bar, then blue screen, then progress bar again and freeze there, it's just before language selection screen. It is same if try to install High Sierra from Sierra, on first reboot it freeze on same screen. Tired different Clover arguments, removing kexts, different Clover versions, re-downloaded High Sierra app, nothing worked, don't show any error on Verbose Mode, need expert opinion / advise, what it load on last stage that make it freeze.
  5. MNSiw

    Mac os High sierra installation attempts

    Thanks Traveling I tried these arguments, your EFI / Clover with your kexts and then with my kexts, nothing worked. Not sure but most probably it is not related to Clover but some kext because if I install High Sierra with Core.pkg, it boot and work fine with same Clover setting that I use for Sierra.
  6. MNSiw

    Mac os High sierra installation attempts

    Just tried, no luck, same result. This APFS thing is bit complicated for now, like I have SSD with three partitions, 2 HFS+ and 1 APFS, now want to resize APFS partition, but there's no easy way, Disk Utility doesn't support resizing it for now.
  7. MNSiw

    Mac os High sierra installation attempts

    Yeah bro, I installed to an other free partition, it still shows convert to apfs option, tried with it and them with hfs+, not showing language selection screen, tried -v and it boots up without showing any error and them freeze just before language selection screen.
  8. MNSiw

    Mac os High sierra installation attempts

    Run Install macOS High Sierra Beta from Sierra, choose convert to APFS, added apfs.efi to Clover, on reboot it freeze just before language selection screen, if I use -v then it show white screen with black Apple logo, otherwise it's white logo on black, otherwise no difference.
  9. And with this kext from 10.12 it booted and installed? Sent from my XT1060 using Tapatalk
  10. MNSiw

    Mac os High sierra installation attempts

    High Sierra Public Beta showing 'Waiting' for last 10 minutes, while connection is stable and fast. What should I do? Please advise.
  11. MNSiw

    Mac os High sierra installation attempts

    Old createmedia + Clover + kexts method isn't working (dp1 or 2) for me, now going to try it with public beta. On last try I waited quite longer, finally installation window showed up, it took only 2 minutes to copy or install High Sierra to selected disk but after first reboot it freeze on blue screen (the one with tiny language selection flag at top right). Sent from my XT1060 using Tapatalk
  12. MNSiw

    Mac os High sierra installation attempts

    I have two disks, HDD and SSD, unplugged HDD coz its just for data. SSD has three partitions, Sierra, High Sierra DP1 on HFS+ (installed using Core.pkg from Sierra), now if I format third empty partition as APFS and install High Sierra DP2 using Core.pkg, it runs perfect with all hardware working. But High Sierra DP2 USB installer cause this slow / unusable setup, now going to try your method Sent from my XT1060 using Tapatalk
  13. MNSiw

    Mac os High sierra installation attempts

    Deleted apfs.efi, rebooted, it's same, slow like a hell, experimenting with adding removing kexts, sofar no success, not getting what making it slow while with Sierra USB it boot smooth and show disks in a second. Sent from my XT1060 using Tapatalk
  14. MNSiw

    Mac os High sierra installation attempts

    New seed, dp3? Sent from my XT1060 using Tapatalk
  15. MNSiw

    Mac os High sierra installation attempts

    High Sierra Beta 2, created USB using create media and installed Clover 4099, copied working Sierra kexts, same problem as Beta 1. It boot to macOS Utilities, now its extremely slow here, Disk Utilities show Loading disks forever, Terminal response too slow. How you guys solved this, please share. Sent from my XT1060 using Tapatalk
×