Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
theconnactic

AMD issues with nVidia cards running Lion 64-bits/Mountain Lion [DON'T ASK HELP HERE, THE HELP TOPIC IS THERE FOR YOU]

175 posts in this topic

Recommended Posts

The topic title is self explanatory: let's post here descriptions of our problems and possible solutions. Try to describe using the most details you can, posting complete specs, kernel, boot flags, pics and videos.

 

P.S.: ATI users also have been experiencing some issues, yet they actually have an usable system. Since it's not the case with nVidia users, let's keep this particular thread about nVidia-specific problems with Mountain Lion and Lion 64-bit legacy kernels. Thank you.

Share this post


Link to post
Share on other sites

Have you tried switching to an Imac SMBIOS? Ive always had good luck with Imac 12,2 with my GTX550 TI however some reason typing in a SMBIOS manually doesnt change the system for me.

 

I suppose you could always just mess with the applegraphicspowermanagement.kext and manually add your card in for whatever your system is being read as.

Share this post


Link to post
Share on other sites

Can your AMD system boot 10.8.2 with a nVidia card without -x? That's amazing, because you must be the only one, seriously. Congrats.

 

I did some experiences using nVidia kexts rollback both to 10.6.8's stock kexts and 10.7.5's.

 

With 10.6.8 nVidia stock kexts (i installed all of them, regardless if they are specifically for my G210 or not), i could boot without -x, but i got no QE/Ci, only native resolution (in my my case, 1080p). The System Information and System Report both reported my card correctly as a G210 1024MB, and told me the drivers were up and running, yet i had no graphics acceleration, much like as i boot in safe mode. Here's some pics:

 

Screen Shot 2013-01-05 at 4.11.46 AM.png

 

Screen Shot 2013-01-05 at 4.13.10 AM.png

 

Screen Shot 2013-01-05 at 4.14.00 AM.png

 

Screen Shot 2013-01-05 at 4.15.47 AM.png

 

Screen Shot 2013-01-05 at 4.15.59 AM.png

 

Screen Shot 2013-01-05 at 4.21.10 AM.png

 

With 10.7.5's stock kexts, my system boots straight to a white screen with the mouse pointer cursor frozen at the top left corner of the screen, plus a pin wheel spinning at the center of the screen (not to be confused with that rainbow colored Beach Ball of Death, this one is the same that appears on a white/blue screen when you start or shut down the system). Obviously no pics here.

 

In both cases, i was using the latest amd_kernel from Andy Vandjick with this org.chameleon.Boot.plist:

 

Screen Shot 2013-01-07 at 1.48.43 AM.png

 

One perhaps useful information: every time, with every kernel or kext set i used, that i tried to boot without GraphicsEnabler or with it set as "No", i boot straight to a black screen. That happened regardless i used safe boot (-x) or not (maybe the kernel or something else is not reacting properly to the boot flags at all, who knows?).

Share this post


Link to post
Share on other sites

Here are my observations from an XFX nVidia GeForce 7600GS 256MB.

 

Mac OS X 10.6.8 32-bit kernel 64-bit userland: QE/CI works perfectly.

Mac OS X 10.6.8 64-bit kernel 64-bit userland: Untested.

 

Mac OS X 10.7.5 32-bit kernel 32-bit userland: QE/CI works perfectly.

Mac OS X 10.7.5 64-bit kernel 64-bit userland: frozen cursor on white screen.

 

OS X 10.8.2: hangs before loginwindow.app opens.

Share this post


Link to post
Share on other sites

Can your AMD system boot 10.8.2 with a nVidia card without -x? That's amazing, because you must be the only one, seriously. Congrats.

 

[...]

 

No, sorry for the confusion. Mine, much like your machine also has issues. My post was just an idea to get it to work and to see if your system would respond to a SMBIOS change(as mine doesnt) then in that case possibly you could test it and post your findings....Im not sure about your video card but for mine with lion there was edits with AppleGraphicsPowerManagement.kext that could be put in for proper QE/CI.

 

Now as for my findings in detail...

 

I can only boot with -x, when doing so I have full native resolution, also 1080p in my case, but no QE/CI. It lags and chops between screen animations such as launchpad and showing notification center(shows quite a bit of red)

 

When doing "GraphicsEnabler=No" its supposed to be Vanilla, and it should work for us(at least me, im not sure how your card works in ML and I cant speak for all) and it should run just fine, so there is a communication error between the kext and the kernel.

 

So until that is...fixed...we have to use Yes.

 

I see that Spakk has the same video card as me and they posted in the Working builds section a ML kext for our cards...i reached out to them to see if it is worth messing with or if they are in the same situation I am still in (only can boot -x, GraphicsEnabler=Yes, no QE/CI[even though the card is recognized and natively supported, however Is there QE/CI in safe boot? im not sure?])

 

Anyway, thats my ramblings.

 

Edit:

Hey quick question, when you boot with GraphicsEnabler=No what happens? mine loses signal to my monitor.

 

EDIT2: I see you have a wake parameter...what is that exactly? do you have sleep working properly? I thought that would have to be re-done with sleepenabler since ML on AMD is so new. Does an old one work with this? Sleepenabler works great with ML on my system.

Share this post


Link to post
Share on other sites

Lol, posting about ATI @ NVidia thread :D

 

The NVidia is more critical IMO, they can't even boot without safemode. :D

I feel sorry for them. :D

 

Has anyone tried Lion with ATI / NVidia and the x86_64 kernel? Same issues?

Share this post


Link to post
Share on other sites

Has anyone tried using the gfx drivers and bundles from Lion on ML?

10.7.5 has the same graphics family as ML so it could work.

For NVidia users that are the NV and Geforce parts...

Share this post


Link to post
Share on other sites

Has anyone tried using the gfx drivers and bundles from Lion on ML?

10.7.5 has the same graphics family as ML so it could work.

For NVidia users that are the NV and Geforce parts...

 

Yes, like theconnactic tried with the 10.7.3, I also tried using Spakk's linked GTX550 TI kexts in the AMD working build thread which is a collection of Nividia and geforce kexts. I looked them over for differences, they were a bit different but they didnt work any better than the stock kexts.

Share this post


Link to post
Share on other sites

Has anyone tried using the gfx drivers and bundles from Lion on ML?

10.7.5 has the same graphics family as ML so it could work.

For NVidia users that are the NV and Geforce parts...

 

Tryed that on ATI Drivers ended up switching form a white to a black screen !

Share this post


Link to post
Share on other sites

After what i found inside NVDAResman.kext, i'm almost sure the nVidia issues are cupid-related. What a joke, since all macs have Intel CPUs...

What about IOGraphicsFamily?

Have you tried switching that and the IONDRV one,also?

Share this post


Link to post
Share on other sites

Didn't understand, Andy: you mean switch from ML IographicsFamily and IONDRV kexts to Lion's ones? Do you think this by itself can be a solution, or it should be done alongside replacing ML nVidia kexts by Lion ones?

 

I think the best solution, perhaps, would be replacing the CPUID instructions inside NVDAResman by nop instructions, but i confess i don't have that much experience with binpatching, so i'll try your idea first.

 

Best regards!

Share this post


Link to post
Share on other sites

Also the bundles and graphics kexts (NV* and Geforce*)

It could work...

I'll check the use of cpuid in NVDAResman later..

Share this post


Link to post
Share on other sites

First test (only -f): the desktop never arrives;

 

Second test (-v -f): i cannot see any sign of the NVDA kext loading, console output continues forever, no desktop;

 

Third test (-v -f GraphicsEnabler=Yes): panic with kextd. As it happens randomly, i'll perform the same test again. Done: same as above;

 

Fourth test (-x -v): as extensively described before, the system cannot reach the desktop without the graphics kexts even in safe mode with AMD ML kernels.

 

Now i'm going to try the following: since i installed the Lion kexts on the ML HDD when running Snow Leopard, i'll boot again, repair permissions in the ML HDD (one step i missed before trying to boot) and perform the same tests again. Done, no luck.

Share this post


Link to post
Share on other sites

well i had another test on ati with all kext from 10.7.5 http://cl.ly/2s021m3S0q1T

 

got in this time (cause i forgot some on the 1st go )

 

only non Lion bit in ATI is the new Accelerator !! .. :king: but GUI probs havent changed sadly

 

not ment to spam the nvidia forum

 

rite did another test with Lion kexts got rid of the AMDRadeonAccelerator.kext

 

device in Slot 1 was back at boot :)

 

and i got in without qe ci but full resolution wich didnt work on ML kexts !

Share this post


Link to post
Share on other sites

Hi Guys, first post to tell you this:

 

If you can achieve full resolution in Safe Mode with NVIDIA card, try the following with stock 10.8.2 or NVIDIA 304.00.05f02 kexts:

 

Disable (or remove from /S/L/E) GeForceGA.plugin and GeForceGLDriver.bundle, e.g. using

 

cd /S/L/E

sudo mv GeForceGA.plugin GeForceGA.plugin.dis

sudo mv GeForceGLDriver.bundle GeForceGLDriver.bundle.dis

sudo touch /S/L/E

sudo reboot

 

Doing this with my GTX 560 Ti gives me Normal Mode with Software-OpenGL, i.e. like Safe Mode, but just a bit better...

 

Phenom II x4 965 with Andy's rc4 Kernel (thanks a lot btw)

 

Background: on my system WindowServer crashes in Normal Mode because of GeforceGLDriver calling bzero$VARIANT$sse2, which in turn causes an EXC_BAD_ACCESS with KERN_INVALID_ADDRESS. This is from the first WindowServer crash log after a Normal Boot.

 

Since bzero() is just about the simplest function one can imagine, it either gets called with incorrect parameters, which would point to something bad happening inside GeforceGLDriver, or in itself creates an invalid access, which would indicate that this bzero function fails in some way. Is it possible that this "sse2 variant" fails because of the AMD kernel? Maybe cpuid related in any way?

Share this post


Link to post
Share on other sites

Hi, Rob!

 

Your workaround worked, thank you very much indeed. It's a relief to boot normally, even to a system that's not fully working. About the cpuid issues: well, i found quite a lot of cpuid instructions by disassembling NVDAResman with otool. I don't remember if i also searched GeForceGLDriver for cpuids, so i'll disassemble it later. Perhaps we're on the verge of isolate the problem, the first step towards finding an actual solution. Thank you very much for your answer and welcome onboard! :D

 

Best regards!

Share this post


Link to post
Share on other sites

Nice find rob! I can also confirm it works. Its nice not being stuck with safe modes limitations! so does this point to one or both of those kext's being the culprit? Im currently installing lion on a friends netbook.. but when I am done I am going to try to swap just those two kexts from lion and see what happens.. prob fail but worth a shot so I will report back in a bit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×