Jump to content

wastez

Members
  • Content Count

    235
  • Joined

  • Last visited

Everything posted by wastez

  1. Hello, I installed sierra on my Ivy-Bridge Laptop and had to realize that the -xcpm flag was removed in 10.12 which allowed to use the XNU Kernel CPU Powermanagement on a Ivy System. Because i don´t want to use the old AppleIntelCPUPM i searched for a solution and i found it. Thx to pike who wrote here about xcpm for haswell-e cpus: https://pikeralpha.wordpress.com/2016/07/26/xcpm-for-unsupported-processor/ I used his informations about the kernel structure to create this patch. So here is the patch for Clover: Add it in KernelAndKextPatches --> KernelToPatch: Comment: xcpm bootstrap Find: 83C3C483 FB22 Replace: 83C3C683 FB22 Comment: Reboot fix for xcpm Find: 554889E5 41574156 41554154 53504189 D64189F7 4889FB45 85FF0F84 Replace: C34889E5 41574156 41554154 53504189 D64189F7 4889FB45 85FF0F84 You can check if xcpm is active with the following terminal command: sysctl -n machdep.xcpm.mode If it is 1 then xcpm is working as it should. Clear i´ve to say that everything else need to be correct that it work as it should. (ssdt with xcpm mode enabled and also the FrequencyVectors need to be setted in the X86PlatformPlugin) But this isn´t other then in older OS. Hope it will help somebody. Edit: If there are problems else with the powermanagement use a new Version of ssdtprgen to create a new ssdt.
  2. The 14.2 smbios is setted already for xcpm. So if you want to keep this setting it would be good to activate xcpm as i wrote in post 1. If you want to keep AppleIntelCPUPM it would be good to use a file for X86PlatformPlugin which has no FrequencyVectors (every model before haswell) in it.
  3. Tested it right now and seems pkg msrs triggered the panic (on my system). (with enabled Kernel PM patch in Clover) Now my System is booting without disabling all msrs.
  4. wastez

    Sierra: No wake from hibernate! Help

    Then disable also the autopoweroff and standby setting via pmset.
  5. wastez

    Sierra: No wake from hibernate! Help

    Just check which hibernatemode you are using. I guess you have mode 3, because this mode is a hybrid mode which does exactly that what you describe. So you can check it in the terminal: pmset -g If you want normal sleep (Data stays in ram) you have to do the following: sudo pmset -a hibernatemode 0
  6. wastez

    Clover General discussion

    No it's a cosmetic bug, just wanted to inform you.
  7. wastez

    Clover General discussion

    @ Slice Something different: On my mainboard (GA-Z87X-D3H) the memory slot numbers are wrong. Slot 1 = Slot 4 Slot 2 = Slot 3 Slot 3 = Slot 2 Slot 4 = Slot 1
  8. wastez

    Clover General discussion

    So ASPM isn´t working on hackintosh at all? Even if the kernel log displays the following? AppleLPC::notifyPlatformASPM ASPM callback registered
  9. wastez

    Clover General discussion

    You just need CSM if your graphicscard has no UEFI GOP vbios. CSM is a compatibiliy Mode for older cards. It's only pure UEFI Mode if it is disabled.
  10. So lets hope Apple will not switch to ARM totally, would be the end for the hackintosh scene. (without special kernels)
  11. wastez

    Clover General discussion

    Its an Option in the setup. You need to activate the scripts First and the you can choose it in Optional RC Scripts.
  12. wastez

    Clover General discussion

    It´s not a bug..... it´s a feature , mdnsresponder does this every hour i think (before it was 2 hours) to support wake on demand. But there is a fix for it. Just install the "disable sleep proxy client" via clover.
  13. wastez

    Clover General discussion

    That is only working if you flash the vbios on the graphicscard. But as i said clover can do that for you. Use PatchVBiosBytes and do the same like on the Rom. Find: The bytes from the 1280x1024 Replace: The bytes from 1920x1080
  14. wastez

    Clover General discussion

    @ pkdesign If PatchVBios isn´t working automaticly you can have a look on your vbios, find the correct entry and patch it on the fly via the key PatchVBiosBytes. @ Slice Have you seen this post: http://www.insanelymac.com/forum/topic/284656-clover-general-discussion/page-578?do=findComment&comment=2309338 I posted it because since 10.12 a custom hibernatefile isn´t working.
  15. wastez

    macOS 10.12.1 is out!

    For hibernate (mode 25) there is a fix. As far as i can say something has changed in 10.12.1. Just install the last clover which installs the new efi driver (including smchelper) and hibernate wake will work again. Just for information: I boot in pure uefi mode, doesn´t tried it in legacy mode.
  16. wastez

    Clover General discussion

    @ pkdesign If the EDID is correct it could be that your graphicscard doesn´t has the correct VESA Mode in vbios. The easiest way to solve it would be to use on the fly patching via clover. First you can try to use the automatic mode, the keys name is PatchVBios.
  17. wastez

    Clover General discussion

    Not default sleep (mode 0), just on hibernate (mode 25) and also just if a custom path for hibernatefile is used on 10.12. As i said on post #11559 i think it is because it take the prefs for hibernatefile from the wrong plist on 10.12.
  18. wastez

    macOS 10.12.1 is out!

    If somebody has still problems with hibernate wake, smchelper will fix it.
  19. wastez

    Clover General discussion

    @ Clover Developers Since 10.12 it´s not possible to use a custom hibernate file path. (Clover will not load it) I saw in the Clover log that it took the hibernate preferences from /Library/Preferences/com.apple.PowerManagement.plist, what could be the reason why it can´t find the setting for "hibernatefile". hibernatefile is stored in /Library/Preferences/com.apple.PowerManagement.XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX.plist since 10.12. Would be great if somebody can have a look on it.
  20. wastez

    macOS 10.12.1 is out!

    I also used Hands off! so i upgraded to 10.12.1 and deleted the software and the app problem is solved. Hibernate is still not working, just normal sleep.
  21. wastez

    Clover General discussion

    So just AppleKeyMapAggregator is enough? Because savvamitrofanov before wrote that a lot more drivers are needed.
  22. wastez

    macOS 10.12.1 is out!

    I installed it yesterday and had also the Problem that the first opened app will not start before it is forced to close. Also hibernate wasn't working anymore. So i reverted back to 10.12.0. Today i will test to upgrade again, maybe something went wrong during the upgrade. Sierra is the buggiest Apple OS i can remember.
  23. wastez

    Clover General discussion

    Really great you implemented it so fast, thanks so much.
  24. wastez

    Clover General discussion

    Just use the driver in the attachment and delete the vboxhfs driver. @ slice Can you tell me which additional modules are needed for FileVault2? I know hfsplus must be the hfs driver for it to work. HFSPlus.efi
  25. wastez

    Clover General discussion

    @ nicozan If you really boot in UEFI mode: I saw you have vboxhfs in your efi driver folder on the screenshot above, which is slower. Did you try to use hfsplus.efi? Default the clover setup deletes hfsplus.efi and copies vboxhfs into your driver folder, because hfsplus isn´t free. Maybe thats your "slow" boot problem.
×