Jump to content

Lion installation via USB stick using Chameleon


MaLd0n
1,466 posts in this topic

Recommended Posts

thanks . i am checking it out.

 

also i think i am facing a kernel panic .

 

http://imageshack.us/photo/my-images/202/img0726ud.jpg/

 

it say " no hpets found......." and then it is mentioning applecpupowermanagement ....

 

this is happening when i paste the extra folder and i am not running dsdt auto patcher. after i get an aml file will this error go ??

 

Is HPET enabled in BIOS?

http://olarila.com/forum/viewtopic.php?f=17&t=134

To prevent KP you can use:

NullCPUPowerManagement.kext

Almost the last download file on bottom of post.

 

Hardware?

Link to comment
Share on other sites

perfect in:

 

intel dx58so

intel core i7 920 2.7ghz

realtek alc 8889

nvidia gforce8500gt 1024mb

6gb ddr3 1066mhz

usb wifi netway nano 150mb/s

 

configuration:

 

extra folder only extra

chimera 1.5.4.1

dsdt autopatcher

 

kext utility:

AHCIPortInjector.kext

IOAHCIBlockStorageInjector.kext

NullCPUPowerManagement.kext

multibest lion:

voodoohda.kext last

 

GraphicsEnabler yes in chamaleon.boot.plist

 

rlt8188cus driver for lion http://www.realtek.com.tw/downloads/downlo...;Downloads=true

 

i have work sound 2 out 2 in 2 spdif

tv in 1680 x 1050

shutdown ok

reboot ok

 

update to 10.7.2 combo update ok ni issues

thanksssssss

Link to comment
Share on other sites

Is HPET enabled in BIOS?

http://olarila.com/forum/viewtopic.php?f=17&t=134

To prevent KP you can use:

NullCPUPowerManagement.kext

Almost the last download file on bottom of post.

 

Hardware?

 

 

done with the install . i enabled hpet in bios . nice work maldon. thanks everyone for the help.

 

now to add sound and ethernet

 

one question.

 

what is extra/extensions and system/library/extensions.

 

if i want to install i have to do at both locations? also s/l/e has ati ati 4800.kext . i have ati 4850 and i am not able to change my resolution . has the kext been installed?

Link to comment
Share on other sites

I followed your post Maldon, exactly what you've said for 3 times but everytime I see the same screen:

 

img0051tq.jpg

 

I've tried many installation methods-

1. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]+[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

2. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

3. iAtkos s3 v2

4. iAtkos l1

But none of them are working for me, I even can't see the installation sceen, which boot cd should I use, I've tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Legacy, rBoot LE, Empire EFI, Empire EFI Legacy, Nawcom's boot cd(mod cd), I am so eager to install Mac OS X on my laptop but I am frustated now, Please help.(Seriously Needed) :P

 

Here are my specs:

 

Processor: i3 2330M

Graphics: Intel HD 3000

Chipset: Intel HM 65

(Sony Vaio VPCEG25EN)

Link to comment
Share on other sites

Thanks MaLd0n Lion 10.7.2 installed fine on DX58SO.

 

--->This is how i Installed OSX lion on DX58SO @@@@THANKS TO MaLd0n@@@@

 

1. Mount base system of InstallESD.dmg

open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg

2. Restore on 8gb drive formated journaled guid

3. Open System/Installation/ on usb drive and delete the Packages link and create a folder with the same name, Packages.

open /Volumes/Mac\ OS\ X\ Install\ ESD/Packages

4 Copy all packages on Install/ESD/Packages to System/Installation/Packages

5. Run installer extra lion and Chameleon RC5 select USB and install

6. Install MAC OSX lion on hdd and after reboot, BOOT with usb coz no bootloader on HDD

7. Install new installer extra folder and also select mac pro 4,1 for core i7 on HDD

8. Install Chameleon-2.0-RC5 (into Lion partition)with prefpane,

9. Run DSDT Auto-Patcher and copy the DSDT generated in the desktop to the Extra folder

10.Change com.apple.Boot.plist to org.chameleon.Boot.plist

11.Install IntelE1000e for network

12.Check Graphics Enabler in prefpane for Graphics

13 i use Bose companion 5 USB audio so i don't need any patch for audio.

 

DONE :)

Link to comment
Share on other sites

I'm still a newbie in herne. Guys please help me to install Mac OS X Lion on Intel DG43GT Classic

Specs:

Intel Core 2 Quad Q6700 2.66 GHz

4.0 GB DDR II 667 MHz

500 GB Segate Barracuda SATA II AHCI Mode

ASUS ENGT440 1.0 GB GDDR 5

 

I'v tried a lot of ways to install, but no luck. PCI Configuration Begin hangs up, even npci=0x2000, npci=0x3000, use PCI Oleg's PCI Configuration Fix in iATKOS L1 but still no luck. Now I'm stuck in Hazard 10.6.6i (very bugy) and I need to install Lion. Please Help

Link to comment
Share on other sites

First I would like to say that this is an excellent and thorough guide, but I've run into a snag.

 

I'm running an Asus G74, and I'm trying desperately to get this install to work, I've gone through the process to the letter, but I keep getting "Mac OS X Cannot Be Installed On This Computer". I've tried replacing the OSInstall.mpkg in the packages folder, but with the same results. I've also tried the iATKOS_L1 disk and it ends the same way.

 

The only thing I can think of is that I'm trying to install on the second hard drive that's in the notebook, would that cause a problem?

 

Or do I have to boot a certain way into the USB to get it to install properly?

 

Advice would be greatly appreciated,

 

Thanks.

Link to comment
Share on other sites

I created the boot disk as instructed. However I get KP on boot from it.

 

I'm using a HDD not a USB drive as the boot disk.

 

Chameleon V2.1 r1700

 

GIGABYTE GA-EG41MFT-US2H with Q8300

 

I have tried various combinations of kexts and Boot.plist settings but I don't know for sure which ones will work for my motherboard on lion, so I'm guessing.

 

KP happens just after loading appleFScompressiontypeZlib although with some combinations of kexts and setting it happens just before or after that point.

 

KP.jpg

 

Can anyone suggest what I need to change?

 

EDIT, I turned off built in firewire in the bios, and this problem above is solved, now I just have the dreaded Unable to open /var/db/Bootcache.playlist problem same as everyone else.

 

Installing PC EFI plus replacing the boot file didn't work for me.

Link to comment
Share on other sites

This guide is very useful. But can you elp me to get that Lion 10.7 on my mainboard

DG43GT

4.0 GB DDR II

500 GB Segate Barracuda SATA II

ASUS ENGT440 1.0GB GDDR V

I set it in SATA mode.

Every time I try to install Lion / iATKOS L1, it always hangs up at "PCI Configuration Begin". Tried with:

npci=0x2000

npci=0x3000

Oleg's PCI COnfiguration Fix in iATKOS L1 DVD

but still no luck. Now I'm stuck at Hazard 10.6.6i Legacy kernel with no VGA support. Can everyone help me ???

Link to comment
Share on other sites

This guide is very useful. But can you elp me to get that Lion 10.7 on my mainboard

DG43GT

4.0 GB DDR II

500 GB Segate Barracuda SATA II

ASUS ENGT440 1.0GB GDDR V

I set it in SATA mode.

Every time I try to install Lion / iATKOS L1, it always hangs up at "PCI Configuration Begin". Tried with:

npci=0x2000

npci=0x3000

Oleg's PCI COnfiguration Fix in iATKOS L1 DVD

but still no luck. Now I'm stuck at Hazard 10.6.6i Legacy kernel with no VGA support. Can everyone help me ???

 

@wusa

 

Have you tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]?

I have almost the same config as you and that method worked the best for me

Link to comment
Share on other sites

@wusa

 

Have you tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]?

I have almost the same config as you and that method worked the best for me

 

I've used. It cannot boot into my DVD+ RDL OS X 10A432. Hnags at EBOIS Read Error. I've burned using ultraiso on Windows with 4x. I've tried a lot of ways but still no luck. Please help me to install Lion 10.7.2.

Link to comment
Share on other sites

  • 4 weeks later...

Alright, so here goes... I have a Dell OptiPlex 755 (Ultra Small Form Factor) with an Intel E6550 Core 2 Duo, Intel GMA 3100 graphics, 2GB RAM. Using the steps here I successfully installed OSX 10.7.1. I used the iMac 9,1 extra file, and now need to get the following things working:

 

- Network Adapter (Intel 825xx Gigabit Ethernet)

- Audio (ADI 198x Integrated HD Audio)

- Graphics (Intel GMA 3100) (I currently have a GUI at the default 1024x768 though)

 

So far everything else is working great though. I have this attached to my 55" LG TV and plan to use it to feed movies and such of a shared drive. I'm just having trouble locating the right kext files. Also, will they go in the /Extra/Extensions/ folder, or in /System/Library/Extensions/ or...?

 

~Aaron

Computer Network Defense Analyst, United States Navy

Net+, Sec+, CEH.

Link to comment
Share on other sites

Can you help me please ?????

I'm Having trouble with my Mobo

Intel DG43GT

4.0 GB RAM

500 GB SATA II

ASUS ENGT440 1.0 GB GDDRV

I can't install retail DVD or Lion. Always stuck at PCI COnfiguration Begin. I've even tried npci=0x2000 npci=0x3000 10.6.7 Kexts but ti still stuck at PCI COnfiguration Begin. I very need Mac OS X Lion for Graphics Performance QE/CI. Help me [please .....

Link to comment
Share on other sites

@Maldon

 

Would you be able to help?

I have a nVidia 8600 GT 512 video card with HDMI output.

Every time i plug in HDMI it freezes, and it gets stuck on the apple grey screen when i start up with it on

I thought having a dsdt that works would fix that. will it?

 

 

Macri

send_me.zip

Link to comment
Share on other sites

Alright, so here goes... I have a Dell OptiPlex 755 (Ultra Small Form Factor) with an Intel E6550 Core 2 Duo, Intel GMA 3100 graphics, 2GB RAM. Using the steps here I successfully installed OSX 10.7.1. I used the iMac 9,1 extra file, and now need to get the following things working:

 

- Network Adapter (Intel 825xx Gigabit Ethernet)

- Audio (ADI 198x Integrated HD Audio)

- Graphics (Intel GMA 3100) (I currently have a GUI at the default 1024x768 though)

 

So far everything else is working great though. I have this attached to my 55" LG TV and plan to use it to feed movies and such of a shared drive. I'm just having trouble locating the right kext files. Also, will they go in the /Extra/Extensions/ folder, or in /System/Library/Extensions/ or...?

 

~Aaron

Computer Network Defense Analyst, United States Navy

Net+, Sec+, CEH.

 

I've worked with the Optiplex 755 before, and unfortunately I don't think that there are any working kexts for the GMA 3100 or the ADI 198x. I wasn't able to get either working over the course of a week. You might be out of luck :/

Link to comment
Share on other sites

Hi, awesome guide, I got my usb drive made and tried to boot from it and it gave me this error

 

 

/Extra/com.apple.Boot.plist is depreciated.

Please yse the file /Extra/org.chameleon.Boot.plist instead.

Press a key to continue...

 

I searched around to try to find a copy of this file and couldn't, and even if i did i wouldn't know for sure where to put it, any help?

 

Thanks

Link to comment
Share on other sites

Hi, awesome guide, I got my usb drive made and tried to boot from it and it gave me this error

 

 

/Extra/com.apple.Boot.plist is depreciated.

Please yse the file /Extra/org.chameleon.Boot.plist instead.

Press a key to continue...

 

I searched around to try to find a copy of this file and couldn't, and even if i did i wouldn't know for sure where to put it, any help?

 

Thanks

 

 

Rename com.apple.Boot.plist to org.chameleon.Boot.plist

Link to comment
Share on other sites

Sorry if I get on people's nerves here, I'm very new to this and might need a lot of help

 

I got it working by renaming the file I mentioned before, then had a /mach_kernel problem but found a fix to that. Now it looked like it was booting fine but then went into just a blank white screen no cursor or anything. any help?

 

Thanks

Link to comment
Share on other sites

I got it working by renaming the file I mentioned before, then had a /mach_kernel problem but found a fix to that. Now it looked like it was booting fine but then went into just a blank white screen no cursor or anything. any help?

 

I had this problem yesterday, although I did see a spinning beach ball for a while.

Have you added fakesmc.kext?

Link to comment
Share on other sites

×
×
  • Create New...