Jump to content

PCI Configuration Begin

86 posts in this topic

Recommended Posts

I am trying to install DP2 on GT5408 gateway core2duo (I had no problem with DP1). I am stalled at "pci configuration begin". I have tried numerous fixes including putting NVEnabler in S/L/E and deleting PlatformSupport.plist in com.apple.recovery.boot. No luck so far. Anyone have a fix ?

it's fragging on your Video drivers. swap your card and try again. I had the same problem with a GTX 470 and a 9800GT the 9800GT works like a Dream, the GTX470 hangs @ [ pci configuration begin ]



I don't have a fix either, but I can assure you my GTX 570 or most other nvidia cards that device ids had been added to NVDAGF***.kext and using ATY_Init.kext are likely to work.

I have tested it with NVEnabler.kext briefly, but had no luck and it even simply rebooted in the middle of the process sometimes.


Make sure ATY_Init.kext is in System/Library/Extensions

Depending on your bootloader it won't get loaded properly.

And don't forget to

sudo su

chown –R 0:0 ATY_Init.kext

chmod –R 755 ATY_Init.kext


To get beyond PCI config I usually have to delete


as well. That was very important because every time Lion reboots a cache is written and causing to hang my machine.


Then PCI config begin will show up again and hangs........but wait!!

1 minute later the screen changes to black, grey and blue and voila there is the Lion desktop. :P


I think what really happens there the screen is actually freezed. You can test it when you press space or enter key. Usually you can see moving the cursor.


However if it hangs at PCI config more than 2 minutes I usually give up and do a reboot.

I have a dual GPU set up and I figured out on my machine it really hangs here:

nstat lookup entry failed: 2

nspace-handler-set-snapshot-time: 1303230505


...when it seems to "hang" on PCI config:


Does anybody know what that could mean? :(

I'm also stuck at the PCI Configuration begin error with DP2. And i'm sure it's related to my Sparkle GTX 470. DP2 installs fine with an ATI HD4870 and switching cards after installation results in PCI Configuration begin. So neither booting the installation or booting the os itself works with a GTX 470.


It seems like lion actually boots in some way, my HDD leds flash like crazy and i can hear sound from the harddrive. Just no image.


the other relevant parts of my computer are the following:

ASUS P6t deluxe v2

Intel Core i7 920

use one video card

if u have 2 remove it.

just delete System/Library/Caches folder sudo rm -rf System/Library/Caches ,repair permission for S/L/E

and move a irrelevant file to System/Library rename it to "Caches". I use a alias file in /Users/myname name "send registration"

sudo chmod 755 Caches

sudo chown 0:0 Caches

work perfectly for me ,using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 1.7

  • 2 weeks later...

If none of these methods work for you, replace AppleACPIPlatform.kext and IOPCIFamily.kext with older, working versions. Replace both, otherwise you panic early during boot.


You will probably need to do this after every major software update (the lion developer updates have all included new versions of these kexts so far) so make sure you can replace again them if your Lion becomes unbootable.


Thank you



Thank you


Did both of those things and am now booting with GTX-470


I also needed to add bootflag:



and for that to work I had to move kexts in /E/E to /S/L/E and repair permissions.


Thanks for the info.




btw. failed to boot first couple times but using -x -v got me in so I could make the necessary changes.

Is there any other fix? And, can I put my 460 back in after the install? (I do have a 8800GTX I can swap in for the install). I am having the same issue as the OP.


My systems work with Chameleon RC5 r769. I have a NVIDIA 9500 GT video card.






Gigabye E7AUM-DSx

4mB Ram

PNY NVIDIA 9500 GT, 512mB ram

I had the same problem as you on 11A444 ...

I tried to correct in many ways but I could not ...


works well in release 11a459b


I could not install original DP2 build (11a419); how did you install the 11a459e build as it is an update ?

I could not install original DP2 build (11a419); how did you install the 11a459e build as it is an update ?


yes.. you can find it on any "bay" around you...

I could not install original DP2 build (11a419); how did you install the 11a459e build as it is an update ?


You can apply the LionSWUpdate.pkg files to the installation media beforehand using a Snow Leopard install/VM.

I had a working Lion DP 2, when I updated to the latest DP 3 which released about 5 days ago, i did get this message "PCI Configuration Begin". I have a 9500 GT nVidia graphic card.


I'm able to get into the Lion, but I can do nothing because there is not any icon or menu i can click on. I get a loop of reading my hard drive and then resting for about 10 secs, and then reading my hard drive and then no sound from my hard drive again. and I'm stuck at the blue screen after Lion boots up just before the wallpaper wants to be displayed.


Any solutions ?

  • Create New...