Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
maya77

Qoopz 9.8.0 v2 kernel - based on Voodoo

Recommended Posts

Advertisement

Introduction:

 

The Voodoo XNU kernel is a fork of the XNU kernel shipped with Apple®

Darwin operating system – the open-source foundation of Mac OS X.

Voodoo kernel aims to expand the range of processors supported by XNU, and

provide technologies to enable Darwin and associated applications to run on a

variety of x86 platform combinations. Technologies included in the Voodoo kernel

range from emulation of SSE3 instructions, to on-the-fly patching of loadable

binaries. The kernel also fixes issues with multi-processor timing synchronization,

SpeedStep™ support and sleep/resume.

Share this post


Link to post
Share on other sites

Tested, working perfectly here. I have installed it since yesterday, and I hadn't have any problem with it. Previously I used qoopz 9.7 kernel and I needed this one to have a complete 10.5.8 upgrade.

Share this post


Link to post
Share on other sites

I used qoopz 9.7.0 kernel from iATKOS v7 and Parallels Desktop & VMWare causing Kernel Panic.

I have to downgrade my kernel back to 9.5.0 to make them work.

Is this new release address this issue?

Share this post


Link to post
Share on other sites

I had no problems with qoopz 9.7.0 and qoopz 9.8.0 with parallels. Are you using this kernel as mach_kernel or is it named differently (I've heard about some problems with vmware when the kernel has a different name than mach_kernel).

Share this post


Link to post
Share on other sites
I had no problems with qoopz 9.7.0 and qoopz 9.8.0 with parallels. Are you using this kernel as mach_kernel or is it named differently (I've heard about some problems with vmware when the kernel has a different name than mach_kernel).

 

Exactly.  Parallels kernel panics when the kernel is not named mach_kernel.

 

 

 

 

Exciting stuff, huh?

Share this post


Link to post
Share on other sites
Qoopz 9.8 diff patch is released with the kernel, is it what you are looking for?

 

Oops missed it. Thanks for pointing it out.

Share this post


Link to post
Share on other sites

Tried on AMD too. Everything went perfect until I tried to run the Dropbox application. I was prompted to enter the admin password and voila - kernel panic :)

 

Here's the screenshot: http://dl.getdropbox.com/u/442960/DSC00622.JPG

 

BTW I tried to install Qoopz 9.8.0, AnV 9.7.0 and even Voodoo 9.5.0 and it's still absolutely the same :( I use iDeneb v1.6.

 

Can be something done about that? Or can it be caused by some other extension or fix installed during the installation of iDeneb?

Share this post


Link to post
Share on other sites

man i have the same thing. it started after 10.5.6 update and switching to voodoo kernel, so it seems that problem in it. i don't know, how to fix it to avoid the kp, so used to delete dropbox, though it's rather useful app.

Share this post


Link to post
Share on other sites

No need to delete Dropbox. Go in to

 

/Applications/Dropbox/Contents/Resources/

 

and delete the file FinderLoadCM. If you can't do this on startup because Dropbox starts up before you can delete the file, you will have to delete it in single user mode (-s boot flag).

Share this post


Link to post
Share on other sites
Exactly. Parallels kernel panics when the kernel is not named mach_kernel.

I run the voodoo2 kernels and both Paralels and VMware-Fusion. The method I use to get around this issue is a symlink. It also has the advantage of protecting you if an apple update replaces mach_kernel.

 

For example, assuming your kernel is named mach_kernel.voodoo2 You can do the following:

sudo -s
password
cd /
rm mach_kernel
ln -s mach_kernel.voodoo2 mach_kernel

 

On my system it looks like this:

root ~ # ls -al /mach_kernel*
lrwxr-xr-x@ 1 root  admin		23 Aug 23 17:11 /mach_kernel -> mach_kernel.voodoo2
-rw-r--r--@ 1 root  wheel  10822172 Jul 15 19:57 /mach_kernel.ctfsys
-rwxr-xr-x@ 1 root  admin   5075716 Aug 23 17:10 /mach_kernel.voodoo2

 

Then, edit your com.apple.Boot.plist and change the kernel name to mach_kernel.voodoo2

 

That should help Parallels or VMware-Fusion run and if apple updates the kernel the worst you should need is to rebuild the symlink.

Share this post


Link to post
Share on other sites
same here boots up but it's stuck at apple logo . it doesn't log in. i had to put back vanilla.

 

i have had problem going from 9.5 and higher. Parrallels crashes. And kp at startup, but i have always be able to get in the desktop by using cpus=1, than you can reinstall or whatever you have to fixed.

 

hopefully this helps

Share this post


Link to post
Share on other sites
I used qoopz 9.7.0 kernel from iATKOS v7 and Parallels Desktop & VMWare causing Kernel Panic.

I have to downgrade my kernel back to 9.5.0 to make them work.

Is this new release address this issue?

 

i had the same problem, and i found out why. iATKOS boots with /custom for the kernel, i fixed it for myself by following the symlink post made in this thread after i copied the kernel "custom" and renamed it mach_kernel.voodoo2 and then there's no need to edit booting or anything, and it ran right off the bat! hope that helps better with the iATKOS install! :rolleyes:

Share this post


Link to post
Share on other sites
i have one question. etqw and call of duty 4 1.7 single player cracked work on amd machine?

on all voodoo kernel i don't have working crack for call of duty 4 for single player((

Share this post


Link to post
Share on other sites

Quick question...I am using xnu 9.6.0 and OS X 10.5.7

I am upgrading the OS X to 10.5.8 and installing the xnu 9.8.0

on an Intel P4 w/HT. What System.kext and Seatbelt.kext do I need?

Share this post


Link to post
Share on other sites

Thanks Maya 77!

 

Im on a AMD with Nvdia MP65 Chipset - OSX 10.5.8.

Almost everything is working, except sleep (never worked) and USB 2.0 (it was working with voodoo kernel 9.5.0)

But im very satisfied with this kernel, it made my system to work realy fast and stable!

I'm still testing it, and i can tell you there's no more "kernel_Task" consuming my CPU.

 

Quick question...I am using xnu 9.6.0 and OS X 10.5.7

I am upgrading the OS X to 10.5.8 and installing the xnu 9.8.0

on an Intel P4 w/HT. What System.kext and Seatbelt.kext do I need?

 

I was seaching for those files and i found one on this topic

 

http://www.insanelymac.com/forum/index.php?showtopic=148566

 

this solved my problem mounting DMG files, but i'm still searching for a System.kext to make my USB to work properly.

If someone find a solution let us all to know.

Share this post


Link to post
Share on other sites

Newbie question. I've googled, searched the forum, but can't figure it out. How does one upgrade the kernel from 9.7.0 to 9.8.0 v2? The documentation PDF reads "The best way to install the Voodoo kernel is to run the included installer package." - but there isn't an installer package in the download.

 

There are manual instructions, but a host of problems noted with them so I'd much rather use the other way which fixes all of those.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×