Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
omni

omni driver for ATI with QE/CI/GL

163 posts in this topic

Recommended Posts

Here's the screenshot from my Apple Cinema Display 20" in DVI-D mode, 1680x1050x32 resolution showing clearly that there is TEARING in the image (look at the middle of the screen, across all the topics), and it's coming from Apple's IOAccelerator and not my driver. If I dont load the accelerator, there's no tearing in the image.

 

The accelerator itself could need some additional parameters or it depends on something else, no idea at the moment, and it's not really important to me right now. Everyone lived with tearing before - you will learn to live with it again until a final solution is made...

 

P.S. it was JaS who figured out to edit the ATIRadeon9700GA.plugin's Info.plist and match my framebuffer instead of IONDRVFramebuffer to get this to work, credits to him for that.

post-3389-1144806316_thumb.jpg

Share this post


Link to post
Share on other sites

Man, I am salivating. There is nothing like running a 23" Cinema Display at 1280x1024 for a month or two to make you really appreciate accurate resolution above all else.

 

Thanks Omni! We're cheering for you!

Share this post


Link to post
Share on other sites

nice! i cant wait for the final!!!

 

i think i know the answer but will QE/CI will work with radeon 7500 to radeon 9250 or it will work only with card that was working before?

Share this post


Link to post
Share on other sites
Here's the screenshot from my Apple Cinema Display 20" in DVI-D mode, 1680x1050x32 resolution showing clearly that there is TEARING in the image (look at the middle of the screen, across all the topics), and it's coming from Apple's IOAccelerator and not my driver. If I dont load the accelerator, there's no tearing in the image.

 

The accelerator itself could need some additional parameters or it depends on something else, no idea at the moment, and it's not really important to me right now. Everyone lived with tearing before - you will learn to live with it again until a final solution is made...

 

P.S. it was JaS who figured out to edit the ATIRadeon9700GA.plugin's Info.plist and match my framebuffer instead of IONDRVFramebuffer to get this to work, credits to him for that.

 

 

Thanks omni, JaS, hopefully this will allow me to change resolution/settings in games, when it's released :)

Share this post


Link to post
Share on other sites

Great news man... I've got a feeling once the driver is working, the tearing issue might become a much easier problem to solve. Especially since you know where the issue lies.

 

You're efforts are greatly appreciated.

 

Twinkikabuki: What is this slow quartz on nForce3 you speak of?

Share this post


Link to post
Share on other sites

I don't care about QE and CI....since I use my laptop for work, not leisure....

 

I do care about wide screen resolutions.....

 

Way to go Omni, you rock.....

Share this post


Link to post
Share on other sites

Just thought I would post a pic of it working here as well,yes i am running mousepose so I don't have to worry about the tearing

 

atframebufferciqe3sc.jpg

Share this post


Link to post
Share on other sites

Omni, JaS -- great work!

 

 

Here's a question: Does this driver impact (improve) powermanagement, in terms of the screen actually going to sleep?

My Radeon mobility refuses to sleep (display stays active) regardless of the setting in power options.

Share this post


Link to post
Share on other sites
Omni, JaS -- great work!

Here's a question: Does this driver impact (improve) powermanagement, in terms of the screen actually going to sleep?

My Radeon mobility refuses to sleep (display stays active) regardless of the setting in power options.

 

try this out for your problem,please test it and report back

 

http://s44.yousendit.com/d.aspx?id=1S4FZKO...0P0DVBYL2BE66K4 <-- test this is a port of radeonTool(http://fdd.com/software/radeon/)

Share this post


Link to post
Share on other sites
nice! i cant wait for the final!!!

 

i think i know the answer but will QE/CI will work with radeon 7500 to radeon 9250 or it will work only with card that was working before?

 

i thought that Core Image was only available for 9600 cards and up and 5200 series cards and up for nVIdia.

Share this post


Link to post
Share on other sites

What does this driver accomplish? Does it allow you to change resolutions? Or is this just for power savings per 'http://fdd.com/software/radeon/'. What is the installation procedure? I have an ATI x800 VendorID x5b621002.

Share this post


Link to post
Share on other sites
ry this out for your problem,please test it and report back

 

http://s44.yousendit.com/d.aspx?id=1S4FZKO...0P0DVBYL2BE66K4 <-- test this is a port of radeonTool(http://fdd.com/software/radeon/)

 

The RadeonTool is loading properly... and it kind of working for me, only the cursor disappear when going in standby.

 

Here's my system log:

 

Apr 11 16:56:13 localhost kernel[0]: radeonTool:Initializing

Apr 11 16:56:13 localhost kernel[0]: radeonTool:Probing

Apr 11 16:56:13 localhost kernel[0]: radeonTool iomemory length: 0x10000 @ 0xf3000000

Apr 11 16:56:13 localhost kernel[0]: radeonTool virt: 0x2a573000 physical: 0xf3000000

Apr 11 16:56:13 localhost kernel[0]: radeonTool IRQ: 16, Vendor ID: 1002, Product ID: 4b4b

Apr 11 16:56:13 localhost kernel[0]: radeonTool:Starting

Apr 11 16:56:13 localhost kernel[0]: radeonTool:PowerManagement setting power state:1

Apr 11 16:56:13 localhost kernel[0]: Reading RADEON_LVDS_GEN_CNTL

Apr 11 16:56:13 localhost kernel[0]: The radeon backlight looks off

Apr 11 16:56:13 localhost kernel[0]: writing RADEON_LVDS_GEN_CNTL (2d0) -> 0008ff41

Apr 11 16:56:13 localhost kernel[0]: Reading RADEON_DAC_CNTL

Apr 11 16:56:13 localhost kernel[0]: The radeon external DAC looks on

Apr 11 16:56:13 localhost kernel[0]: writing RADEON_DAC_CNTL (58) -> ff002102

 

edit: Had to add my card in info.plist

Share this post


Link to post
Share on other sites
doesn't work JaS

 

try adding your device ids to the kext,also this is just to help with sleep not res and refresh... thats not ready for release yet.

 

Omni is the one working on the ATI driver so when he says its ready you will know.

 

I was just lucky to get to try it out,and I tried to link the GA kext to his framebuffer and not IONdrv luckily it worked :D

Share this post


Link to post
Share on other sites
try adding your device ids to the kext,also this is just to help with sleep not res and refresh... thats not ready for release yet.

 

Omni is the one working on the ATI driver so when he says its ready you will know.

 

I was just lucky to get to try it out,and I tried to link the GA kext to his framebuffer and not IONdrv luckily it worked ;)

 

do you think this might work for macvidia????

Share this post


Link to post
Share on other sites
try adding your device ids to the kext,also this is just to help with sleep not res and refresh... thats not ready for release yet.

 

Omni is the one working on the ATI driver so when he says its ready you will know.

 

I was just lucky to get to try it out,and I tried to link the GA kext to his framebuffer and not IONdrv luckily it worked ;)

 

Jas:

 

It didn't work for me either. All what happens is that the cursor dissapear when the screen is supposed to sleep. I've opened the Info.plist in the RadeonTool package but I can't find a place where to put my device ID at. Would you mind to elaborate a bit more about this step?

 

Thanks a lot in advance!

Share this post


Link to post
Share on other sites

Way to go Omni and JaS ;)

 

Finally I will get rid of the ugly stretched widescreen desktop (just in time cause my eyes are getting worse every day while using it like this)

 

Tiburon: no, there are currently no drivers available for download until Omni decides to release them...

 

Take care,

Tek_No

Share this post


Link to post
Share on other sites

isnt a beta release the purpose of having bug and repair them? omni u make us tease !

OMNI i do have my idea to get rid of the tearing if u know how to make an invisible mouse cursor we can finish with it! pm me

 

isnt the RadeonTool only for notebook? i was wishing to make it work with my LCD but without success

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×