Jump to content


246 posts in this topic

Recommended Posts

I tried reinstalling Leopard this time to the same drive as Windows XP, but on a different partition. This time I couldn't get leopard to boot at all. It does the same boot0: error thing.


I followed some instructions to try to set the partition to active with the disk utility but all I see (even on my first install) is an NTFS partition (XP) and an Extended DOS partition which is where Leopard is supposed to be. This is in the fdisk utility. If I use diskutil list command it will show the Apple_HFS partition correctly.


After setting the MBR with the disk utility I instead get boot: MBR followed by boot: done and it just sits there.



EDIT: I ended up resorting to chain0 method to get my dual boot working. What occurs now on start up is the XP Bootloader asks whether to boot xp or mac os x. I select os x and it goes to the darwin boot loader. I have to press a key to get the startup options and select the osx partition manually. Otherwise, it will default to the windows partition and loop back to the xp boot loader. It works for now.


The only issue I still have is getting my WUSB54GS wireless adapter to work.


I also get the boot0: error thing, however, that is with my SATA set to AHCI


If I set it to IDE, it's OK.


But, I really want AHCI, and I haven't yet figured out how to replace the stage 1 bootloader. I don't dual boot.

Link to comment
Share on other sites


Well, both of my HD are actually IDE including my DVD drive. As I said, mine is booting using the windows xp bootloader which transfers to Darwin to boot osx. It has been running fine for two days, but I really need to go out and buy a compatible wireless card. It seems the usb adapter I have is totally incompatible based on forum searches and google.

Link to comment
Share on other sites


Did you already install the DVD? You say it hangs during boot but I'm not sure if you mean initial boot or POST installation. If you are talking about POST install, did you remember to go into Customize and check the Nforce chipset drivers in the installation options?

Link to comment
Share on other sites

I'm a PC guy and when one of my PC friends told me they got a Mac and loved it, i had to see what it was all about. Thanks to the incredible work of Lawless here, i'm able to get my feet wet in mac-land.


Posting my success here. Thanks to all the helpfull posts here I was able to get Lawless great release to run on a second drive on my hardware. freakin awsome.


The only trouble I had was my dumbfault. I installed first going click crazy and not customizing to my chipset. Then tried again (after reading post)... but instead thought.. "well maybe I should just load ALL of these drivers", in a shotgun approach :P . I got the "you need to turn off you computer" graphic that has the message repeated in several languages. Then I read another post revealing my error, and reinstalled selecting only the driver for nvidia and also nfts file support (hoping I could find music on other drive after install). At each attempt I re-partitioned the target drive using the drive utility after DVD boot. Relativly, a roaring success. :P


I still need to get the audio and network to work... and I'd like to get Mac to see the music files on the Vista drive. It see's some files and folders, but no music.. maybe i'm not looking in the right place.




Asus M2N32 sli deluxe

Athlon 64 x2 5600+

Northbridge NVIDIA SPP190 (C51XE) rev. A2

Southbridge NVIDIA nForce 570 SLI rev. A3

(2) XFX 8800 gt

250G Maxtor SATA; 500G WD SATA.

Link to comment
Share on other sites

hey, i'm new in this forum... today i tried to install Leo4allV3 10.5.2 i think, and it install fine, as much as i doubted it, restarts, then, when darwin is loading the modules needed to run OSX (i guess.) it hangs in the end, but i can ear a song, which i believe, is the startup one or from a video (if theres a video at the begining).


My sys specs are :


Processor : AMD 64 +3500 @ 2.2Ghz - It's a Single core.

Memory : 2x512MB DDR 400Mhz

Graphics : Nvidia Geforce 6600 TD 256MB (more than enough i guess).

2 HD's with NTFS : which don't give me errors at boot (doesn't give me an error like NTFS (X,X) not mounted or wtvr)





For sound, i use both cards i have, and they seem to be working fine, which are


- The integrated one, AC97 i believe and a CMEDIA USB Soundcard, which is assumed as the MAIN soundcard, cause i only ear the music from this source...


PS : i know this release is not Leo4all, but you might have an answer to me :D btw : Processor doesn't handle SSE3, but it handles SSE2 and SSE)... if this release, is better than Leo's, i might download it... if i find a link... if u have one PM me please :)




EDIT : bah, tried with the f :P cking SATA devices, and extra IDE's not connected, which it doesn't work too... and i only get sound output if using USB Soundcard... please someone has a clue on this, answer me please.

Link to comment
Share on other sites

Hey just installed and running this bad boy..

Works great.. except NVinject was in the dvd, thought NVKush was preferred nowadays?

Also, the kernel 9.4.0 found in lawlessppc is from who ? modbin ? etc ?

I previously installed the iatkos 4a (9.4.0 modbin, 9.2.0 ToH kernel) noticed that about this mac shows my cpu opteron 165 @ 1.75ghz , but when I version myself on xchat says the true cpu speed 2.7ghz.. my cpu is oc'ed to 2.7, stock speed is 1.8ghz ..


But on lawlessppc, about this mac says Unknown in the main screen, but when i click more info it says dual core opteron, but 1.75ghz still shows and when i version or throw a sysinfo on xchat it says 1.75ghz still. other than that, also wondering my nvidia card is listed as this ..

Graphics by NVIDIA:


Chipset Model: Graphics by NVIDIA

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 256 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0295

Revision ID: 0x00a1

ROM Revision: NVinject 0.2.0


Display Connector:

Status: No display connected

Acer AL1916W:

Resolution: 1440 x 900 @ 60 Hz

Depth: 32-bit Color

Core Image: Hardware Accelerated

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Rotation: Supported


with NVKush it gives the name, but I guess with NVinject just says that generic name.

I couldn't find no help on irc since most users are all Intel ..

Link to comment
Share on other sites

Installed it on AMD Athlon 64 X2 6000+, Gigabyte 690g SB600 and everything works great, but where's itunes? Not even older version. Anyway it's not a problem (available to download), but quite odd - Mac OS X install without iTunes.


Also i wanted to thank for not changing the original mac os x look, no modification of license/logos/background it feels like you're installing it on a real mac, not like ideneb or iatkos with modifications of installer and "about this mac" logos.

Link to comment
Share on other sites

I noticed there was no iTunes, I just ran software update and it installed it.


I have tweaked some settings in my BIOS and have now noticed that it shuts down properly :( hehe.


I am going to attempt some stuff tonight and if it works then I have a perfect work OSX :( YAY. If not I might need some assistance :P

Link to comment
Share on other sites

Okay I have, once again, reloaded my Mac with this release.


What is working:

  • Ethernet (works without need for extra drivers)
  • Audio (required ALC889a audio kext)
  • Shutdown
  • Sleep
  • Restart
  • Time Machine
  • Games
  • Keyboard/Mouse




I had to download SB600 kexts, the ones provided (VIA/SBXXX) Cause it to Panic when copying large amount of data, unzipping large files from compressed archives and when listening to lots of music and moving data.



I cannot burn data successfully, if I use Toast it will sometimes burn and sometimes Panic, same happens with DVDs, Music CDs. ANY Data really. It NEVER burns DVD Movies to disc, it ALWAYS panics. I might pop in a SATA DVD and see if that fixes my problem later.



I have an eVGA 8500GT 512MB, I can play games fine, I can watch movies, I get the correct resolution from the beggining and everything seems to work great, but after a while I start to get graphics corruption in finder (seems to be the only thing with corruption) this gets worse after time, if I restart the machine it is all fixed for a bit and then starts to get worse again.




Then goes to this:



and then even worse:



Loading graphics heavy applications like Logic Studio, and then adding a video causes the program to close down. All works fine in Linux and Windows, so the card is fine.


--EDIT-- Loaded Logic Studio last night and added a video to final cut pro and it seemed to work :/. still got graphics corruption though.


--EDIT2-- Okay I have just successfully burnt an Audio CD and burnt an Image to a DVD, will next try to burn a movie to DVD and see if that works. If so just the graphics left to fix and I have a working Mac :lol:


--EDIT3-- Just burnt a DVD movie without problems ;)


ANY Ideas??



Thanks, James

Link to comment
Share on other sites

Got this installed and running rather easily.


My System specs:

MSI K9A2 Platinum Mobo

AMD Athlon 64 x2 5600+ (Socket AM2)

4GB DDR2 RAM (Generic atm, hard to get quality RAM where I live)

Evga Nvidia GeForce 8800GTS (320MB)

SATAII Seagate HDD (250GB)


Software Config:

Partition 1: 50GB NTFS booting Windows Vista ultimate x64

Partition 2: 50GB HFS+ booting LawlessPPC AMD/Phenom 10.5.4 Leopard

Partition 3: 132GB NTFS storage. Will likely convert this to an FS that supports (natively or via 3rd arty programs) sharing files between both OSes


Other HDD's not currently in use by the Mac Os X Side as they're RAID volumes. Will Possibly reconfigure those later.


System Profiler & Install Log attached


-- Did not install any of the provided Ethernet drivers, didn't see mine in the list; but net is working properly without them. Disabled DHCP in favor of a manual (static) configuration.


-- The audio/video drivers with this release didn't seem to work properly. Had no audio initially, video was locked to a very low resolution (1024x768)


-- Used the ALC888Audio package found HERE. Sound is now working properly (both input and output)


-- Used the Video Driver Package found HERE. Downloaded the "10.5.5 9f9 drivers and EFIStudio installer". Installed EFIStudio as well, will give you a list of video cards supported, choose yours and will install properly.


-- Installed OSX86Tools_1.0.148 found HERE. Used this to properly set the "About this Mac" info, as well as to enable Quartz GL. This tool also has various other nice utilities as well.


-- Installed SteerMouse found HERE. This was needed to resolve some sluggishness issues with my usb mouse. Works great.


-- Also installed PCGenUSBEHCI_303.4.5.kext found HERE. Not really sure if this was needed, but I actually installed this before SteerMouse in hopes to resolve the mouse issues I was having. Saw no need to remove.


I believe this is all I needed to do to get my Hackintosh up and running. Will update this post as needed if I come across something else I needed to do.


End Result: Darwin Bootloader works flawlessly between Windoze Vista & This release. Boot up on the OSX side is a little sluggish, but nothing I can't live with.


So far, everything is running stable and very smoothly. I haven't run into any problems, aisde from those listed above. The only other minor issue I'm having is OSX attempting too mount my windows LDM volumes on boot. This isn't a problem so much, moreso a minor annoyance. I'm sure once i figure things out more I'll resolve this issue.


Many thanks and kudos to every single one of you who make this possible. :)


Hopefully this proves to remain stable once I put some strain on the system. My overall goal is to show my clients that Mac is better for the work I do (video/graphics creation). If I'm able to accomplish this I sense a real Mac in my very near future :)


Once again, many thanks to lawlessPPC for this fine release. Many thanks to those who wrote the apps linked above. Last but not least, thanks to all of you in the Hackintosh community for making this all possible. :P


Simply Amazing.


@LawlessPPC, if there's any other info I haven't provided that you'd like, please let me know and I'll get it to you. I'll be attempting to install this release on 2 more PCs here at my office (both with different hardware) and will update as needed with any problems/issues/successes I have.


Link to comment
Share on other sites


  • Create New...