Jump to content

Gigabyte GA-965P-DS3 Leopard How-to (Updated 1/10)


  • Please log in to reply
411 replies to this topic

#1
Conroe Mac

Conroe Mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 505 posts
  • Location:USA
  • Interests:Beer, fast cars/women, and kicking babies.
**1/10 Added a link to idividebyzero's 965P-S3 iatkos thread

iATKOS Install

Note: You may install pc-efi emulation from iATKOS disc. In order to install emulation, you MUST have a Core or Core 2 Duo processor. iATKOS is Intel processors only.

1. Boot up iATKOS disc

2. Open the utilities file menu and format the partition you would like to use as HFS Journaled

3. Open the utilities file menu and run the Darwin boot script. You must select the partition which you are installing OS X on. If the partition is disk0s3, then enter "1" for disk and "3" for partition. Lastly, select whether you are going to use pc-efi emulation and the vanilla kernel.

4. Select the partition you will use in the installer. Go to the installation options. Select any options you may need for other hardware. Make sure to select the vanilla kernel if you are installing vanilla kernel and using pc efi emulation. If you are running EFI, you should probably choose "EFI Emulation" and "AppleSMBios.kext Netkas"

5. Install (Should take about 20 minutes)

Please see this thread from idividebyzero. It is for the GA-965P-S3, a very similar board, which explains the installation of iATKOS in better detail:

http://forum.insanel...showtopic=80512



-----------------------------------------------------------------------------------------------------------

AIGHOST's How-to (Using ToH RC2 DVD)

Please see this thread: http://forum.insanel...&...st&p=526141

I managed to install Leo pre/post-patching the HDD itself. Using brazilmac postpatch (as a reference) and info from punkrockml13.
(with one interesting output about shutdown) - i'll write about it later.
Concern this info as a guide.
My system is only a reference, so where you have different setup (like hdd or folder placement - just edit it).
I'll update this post in a process of testing the method.

-------------------------------------------------------------------------------------------------------------

Lonewolf's Installation Guides (Using ToH RC2 DVD)

http://forum.insanel...&...st&p=530007

As A.I.Ghost and some one else on this thread, I tried many different ways of installing Leo on a DS3 mainboard: BrazilMac pre & post-patch, ToH, ToH + BrazilMac post-path, changing the position of the HD and the BIOS setup, using Kaliway CD, etc...
All of them finished always in the same way: an un-bootable Leo installation! Finally, I found 3 different solution. It could be that many of the problems I got were related to the Matrox HD, which is an 'old' SATA1...



--------------------------------------------------------------------------------------------------------------

These are manual fixes which are important to keep track of for the G965P-DS3

IDE Support:

In order to get IDE Support, AppleVIAATA.kext must be replaced with a copy with the correct device ids. The following is a copy of the AppleVIAATA.kext from the Brazilmac installation:

Attached File  AppleVIAATA.kext.zip   138.56KB   946 downloads

Follow the video directions to see how to install a kext.

Sound:

The GA-965P-DS3 uses ALC sound. An easy installer has been created for it by skippyretard. Please use ALC883 for early revisions and ALC888 for rev. 2.0 and later:

Attached File  ALC883Audio.mpkg.zip   1.09MB   685 downloads Rev. 1.0

Attached File  ALC888Audio.mpkg.zip   1.09MB   1428 downloads Rev. 2.0, 3.3


I believe SPDIF works after using these installers. Can someone please confirm? If it does not work, then this thread has the information that has traditionally made it work:

http://forum.insanel...showtopic=32859

Video:

This will depend upon your videocard. If you are running an ATI video card, you will probably have success with Natit. Download this kext:

Attached File  Natit_ATIauto.kext.zip   46.52KB   559 downloads

Then follow these directions:

1. Unzip Natit_ATIauto.kext.zip to Natit.kext
2. Move Natit.kext into the Extensions folder located at System/Library/Extensions
3. Open the terminal located in /Applications/Utilities and run the following commands:

cd /System/Library/Extensions
sudo chown -R root:wheel Natit.kext
sudo chmod -R 755 Natit.kext
cd /System/Library
sudo rm -rf Extensions.mkext
sudo diskutil repairPermissions /

LAN: This is only for rev. 2.0, rev. 3.3, or any revision that uses Yukon controller 8056. For those that have 8053 (rev 1.0), LAN works without modification. This how-to was written by Royco. If you find it helpful, be sure to thank him! =)

Open the terminal from /Applications/Utilities and type the following:

sudo nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/Info.plist

(find and change: <key>Yukon-88E8053</key>)
(to: <key>Yukon-88E8056</key>) <-- change "53" to "56"

(find and change: <string>0x436211AB</string>)
(to: <string>0x436411AB</string>) <-- change "62" to "64"

(find and change: <string>Yukon Gigabit Adapter 88E8053 Singleport Copper$</string>)
(to: <string>Yukon Gigabit Adapter 88E8056 Singleport Copper$</string>) <-- change "53" to "56"

Ctrl O <--- Thats letter O
Enter
Ctrl X

sudo chown -R root:wheel /System/Library/Extensions/IONetworkingFamily.kext
sudo rm -rf /System/Library/Extensions.mkext
Reboot.

After rebooting your LAN might not be working yet and showing up as disconnected. Do the following.
- Go to System Preferences, Click on the network icon.
- On the left pane select your ethernet, on the right pane where it says "Configure" select "off".
- Click apply.
- Now back to "Configure" select "Using DHCP". Click apply.
- Your LAN should be working by now.

Leopard has Yukon2.kext, Tiger and other IoNetworkingFamily.kext pathces uses Yukon.kext. So make sure to make a note of than since installing such patches will break your LAN and would need kext editing again.
________________________________________________________________

Flat Image


For the Flat-image installation, please see Royco's thread at this address:

http://forum.insanel...showtopic=68934


-------------------------------------------------------------------------------------------

Brazilmac Original Method

This method has been archived into the following .rtf file:

Attached File  Brazilmac.rtf   7.18KB   893 downloads

---------------------------------------------------------------------------------------------

TOH DVD with Brazilmac postpatch

Since iATKOS and Kalyway have released full install discs, the TOH DVD with Brazilmac postpatch has been archived in the following .rtf:

Attached File  TOH__Brazilmac_postpatch_.rtf   3.56KB   174 downloads

Edited by Conroe Mac, 10 January 2008 - 06:02 AM.


#2
royco

royco

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
Thanks for the guide. Still waiting for my download to finish. Ill try it and report what I got.

#3
UneeK

UneeK

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Croatia
tested and working. Love this mainboard.

#4
robotskip

robotskip

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 450 posts
  • Location:Australia.
I <3 this motherboard too (Except the whole no IDE drive thing though) but unfortunately thanks to awful Australian broadband I don't have the bandwidth to spare at the moment for Leopard, damn it. ;)

#5
alexandros7

alexandros7

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 247 posts
I'm downloadin brazilmac prepatched.. will this function with my p965 ds3 well or do I have to do something?

#6
chelhydra

chelhydra

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 143 posts
I created the patched leo image using brazilmac's method and when i boot from the dvd it loads for a while and after loading AppleVIAATA.kext it throws the following message and then freezes->
BSD root: disk1s3, major 14, minor 6

Keep in mind that i patched the dvd in my macbook, not the hackintosh pc.

Both my dvd-rom and hd are hooked on the j-micron controller on ide mode. This used to work on tiger JaS with ppf patch.

#7
Conroe Mac

Conroe Mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 505 posts
  • Location:USA
  • Interests:Beer, fast cars/women, and kicking babies.

I <3 this motherboard too (Except the whole no IDE drive thing though) but unfortunately thanks to awful Australian broadband I don't have the bandwidth to spare at the moment for Leopard, damn it. ;)

You should be able to do with this with the retail disc if you don't have the bandwidth to download the leopard disc. You'll need to create a .dmg image with the retail disc like the one available for download. The other files you need are less than 20 mb.

I'm downloadin brazilmac prepatched.. will this function with my p965 ds3 well or do I have to do something?

The prepatched disc is very similar and a later release than the patch I am describing. Both are based on the same methods. The prepatched should work just as well and get you about 95% there. Please let us know what kind of luck you have with the prepatched disc =).

I created the patched leo image using brazilmac's method and when i boot from the dvd it loads for a while and after loading AppleVIAATA.kext it throws the following message and then freezes->BSD root: disk1s3, major 14, minor 6Keep in mind that i patched the dvd in my macbook, not the hackintosh pc.Both my dvd-rom and hd are hooked on the j-micron controller on ide mode. This used to work on tiger JaS with ppf patch.

I used AHCI and the orange ports to get leopard working. I set AHCI to ON and Native Ports 0-3 to ON. If you didn't have any problems (errors) burning the dvd, then I would start there.

tested and working. Love this mainboard.

Great to hear that! How is your video? I am thinking of adding a section at the bottom to describe the reinstallation of natit.

#8
royco

royco

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
Im Lovin it!! LAN, Sound, Video working! Still working on Sleep.

#9
Conroe Mac

Conroe Mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 505 posts
  • Location:USA
  • Interests:Beer, fast cars/women, and kicking babies.

Im Lovin it!! LAN, Sound, Video working! Still working on Sleep.


Awesome. We have three good installations on this board so far and one that we're still working on. The sleep may be my fault because of the answer I put to the prompt during the prepatch. I put a note in the guide to have someone try to answer the prompt differently. I am not positive on that one. If you get sleep to work, let me know as it's not working for me right now either. If you solve it, I'll put it in the guide and give you credit =)

#10
Sabr

Sabr

    Well, it was fun while it lasted.

  • Retired
  • 3,883 posts
  • Gender:Male
  • Location:United Kingdom.
Ok - I also have this board (not sure if you remember Conroe Mac, but I was quite active in the other 965P-DS3 thread) and I'm wondering what Leopard image you used? Was it the 6.62 GB one?

#11
SA22C

SA22C

    Escaping the Reality Distortion Field

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Location:Soviet Kanukistan
Am I out of luck if I have an IDE optical drive?

Also, AHCI will break my XP install, is it possible to install Leopard without AHCI enabled?

#12
Conroe Mac

Conroe Mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 505 posts
  • Location:USA
  • Interests:Beer, fast cars/women, and kicking babies.
The image I used was APPLE.MAC.OSX.LEOPARD.V10.5.ISO-OSX. Any image should work though. Of course, I remember you Sabr. It's great to see you again. People come back out of the woodwork when it's time for leopard =)

Am I out of luck if I have an IDE optical drive? Also, AHCI will break my XP install, is it possible to install Leopard without AHCI enabled?

You could use the intel matrix drivers for XP or you could patch the installation dvd for IDE from the original IDE patch. I'm not sure exactly where you would get that though. It might be worth waiting for another DVD which should be out shortly.

#13
UneeK

UneeK

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Croatia

Great to hear that! How is your video? I am thinking of adding a section at the bottom to describe the reinstallation of natit.


I simply used that natit included with postpatch files. works good so far with 7900GS.

Only problem Im having is with network. I have DS3 rev 3.3 and I used same method like in tiger (edited kext like described here http://forum.insanel...mp;#entry245032 only with smalled modifications. Nothing comlicated.)
Problem is that when I boot into Leo network is working ok. I have internet access and everything but after like 10 minutes of using internet it simply stops ALL traffic over network. Still working on a fix. If you guys have same prob with solution :( pls reply

Sound working out of the box.

#14
Conroe Mac

Conroe Mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 505 posts
  • Location:USA
  • Interests:Beer, fast cars/women, and kicking babies.

I simply used that natit included with postpatch files. works good so far with 7900GS.

Only problem Im having is with network. I have DS3 rev 3.3 and I used same method like in tiger (edited kext like described here http://forum.insanel...mp;#entry245032 only with smalled modifications. Nothing comlicated.)
Problem is that when I boot into Leo network is working ok. I have internet access and everything but after like 10 minutes of using internet it simply stops ALL traffic over network. Still working on a fix. If you guys have same prob with solution :P pls reply

Sound working out of the box.


That is very strange. Does the rev. 3.3 have a different Yukon controller? I believe mine has the Marvell 8053 Gigabit LAN Controller and it has worked perfectly.

If we get everything working perfectly and I feel industrious, I might make a post-patch just for the DS3. Chances are that a DVD will come out soon though so I'll probably give that a shot first. That will go in the partition where my Tiger is now. I don't need to run two copies of OS X =)

#15
Sabr

Sabr

    Well, it was fun while it lasted.

  • Retired
  • 3,883 posts
  • Gender:Male
  • Location:United Kingdom.

The image I used was APPLE.MAC.OSX.LEOPARD.V10.5.ISO-OSX. Any image should work though. Of course, I remember you Sabr. It's great to see you again. People come back out of the woodwork when it's time for leopard =)


Excellent - thanks Conroe Mac. :)

#16
Mebster

Mebster

    Why So Ridiculous?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,300 posts
  • Gender:Female
  • Location:1998
I know we're not supposed to ask questions here so can someone please reply with a pm and I'll delete my post.

Does anyone have any idea as to how successful this method will be on a Intel i945G motherboard with a SSE3 processor and a GMA950 graphics card?

Is this totally the wrong method for me and is there something else I should be following instead?

#17
Conroe Mac

Conroe Mac

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 505 posts
  • Location:USA
  • Interests:Beer, fast cars/women, and kicking babies.

I know we're not supposed to ask questions here so can someone please reply with a pm and I'll delete my post.

Does anyone have any idea as to how successful this method will be on a Intel i945G motherboard with a SSE3 processor and a GMA950 graphics card?

Is this totally the wrong method for me and is there something else I should be following instead?


It's okay to ask questions, but this isn't very relevant to this thread which is for the GA-965P-DS3. My answer is that this process is likely to work if you have an SSE3 capable processor and hardware that worked well under Tiger. So far, this specific method has mostly been tested under P5W and GA-965P motherboards, but that doesn't mean it won't work for others. If you understand what kexts are necessary to make your specific hardware work, you should be able to put something together that works perfectly. If you don't know what those kexts are or how to install them, then I suggest you wait for a better installer in the form of a DVD release. This method is for getting Leopard running and I am hoping to refine it in this thread to getting leopard running perfect on the GA-965P-DS3.

#18
royco

royco

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts

That is very strange. Does the rev. 3.3 have a different Yukon controller? I believe mine has the Marvell 8053 Gigabit LAN Controller and it has worked perfectly.

If we get everything working perfectly and I feel industrious, I might make a post-patch just for the DS3. Chances are that a DVD will come out soon though so I'll probably give that a shot first. That will go in the partition where my Tiger is now. I don't need to run two copies of OS X =)



The 3.3 Has a different Yukon Controller, 8056 i think. Because thats what I change on the yukon.kext. So for those with ver 3.3 boards having trouble with LAN even after editing Yukon2.kext, enter a static IP address instead of doing DHCP. Let it run for a while then switch back to DHCP, this solved my problem with my LAN showing as disconnected.

#19
Cliffton Beach

Cliffton Beach

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
I used to hang around the old thread as well, though I'm less likely to be remembered.

I'm running out of partitions, and have to decide whether to blow away my working Tiger install to make room for Leopard. According to this thread Leopard installs well on my mobo (a plus). The other question is: is it worth it? Eventually of course software will require it, but for now are there any major benefits? Of course I've read the reviews, but I'm interested in what the hackintosh guys say.

#20
Laik

Laik

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Kiev, Ukraine
Cliffton Beach
I ordered a new 500gb disk for leo. Its only $118, and you can get 250Gb for under $70.
Is hdd space really a problem?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy