Jump to content

Work x1950gt pro ! Dev_ID = 0x72801002 and 0x72881002 !


  • Please log in to reply
1885 replies to this topic

#81
oiasdas

oiasdas

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
I have a Saphire x1950pro AGP 512mb card


I installed by taking the ATINDRV.kext from the jcool installation and placing it in the extensions folder.
Then I took the files Bronya has offered, except for ATINDRV.kext and placed them in the extensions folder.
I followed the commands to repair permissions and rebooted and my card is working.


As of right now, I have full support, although there is MAJOR mouse tearing and in system profile my card shows as PCI instead of AGP, and 256 instead of 512 mb. The system also seems jumpy and is no where as smooth as when I had my 6600GT working. It is a promising start, but there is a bit more that needs to be done to get this ready for prime time.

I have attempted to install AGPGart, which stopped QE/CI from working. I installed Natit, which caused OS X to boot to black screens. I will be attempting to get this to work pretty much all night. Any help would be greatly appreciated.

#82
ksong

ksong

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
i install the driver under 10.5 9a499,but it is not work ;)

#83
Scrizz

Scrizz

    The Scrizz

  • Members
  • PipPipPipPipPip
  • 282 posts
  • Gender:Male
here's new pack for x1950gt(7288) replaced atindrv with Bronyas new and added a gl driver
x1950gt_7288_scrz.zip

and here's natit for x1950gt(7288)
Natit x1950gt 7288

and don't forget

sudo -s also enter the password root!
chown -R 0:0 /system/library/extensions
chmod -R 755 /system/library/extensions
rm /system/library/extensions.mkext
rm /system/library/extensions.kextcache
kextcache -k -z /system/library/extensions

;)
all thanks goes to Bronya!

#84
oiasdas

oiasdas

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Alright, tried all sorts of configurations.

The best I can get as of right now with my sapphire x1950pro 512mb AGP is one screen with QE/CI and mouse tearing. What I CANNOT get working is resolution changing, rotation, dual monitors, and I cannot get rid of the mouse tearing.

#85
Sipheren

Sipheren

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
  • Gender:Male
  • Location:Aus/Gold Coast
  • Interests:Computer, Cars

This method worked for me with no ATI Displays installed. I had a hell of a time getting anything over DVI or VGA before installing jccools driver. I think it wasn't recognizing my LCD properly.

1. Install jccools, reboot into non CI/QE mode over DVI, change resolution.
2. Overwrite all extensions with Bronya's extensions except for ATINDRV.kext, reboot.
3. It just works, even DVI!

This is with an 7280 id Ati Radeon 1950 Pro 256mb on PCI-E, running a fresh install of Tub's 4.10 Test1.

Bronya you are a star for getting this working. I've held back on running OSX on my system because of the poor video performance playing videos and such at 1680x1050. I can finally start using OSX every day.


Second this method, works perfect, on dual DVI, 2 screens, no tearing. Thanks very much!!

Attached File  Screenshot.png   897.5KB   309 downloads

#86
Scrizz

Scrizz

    The Scrizz

  • Members
  • PipPipPipPipPip
  • 282 posts
  • Gender:Male
for my agp friends I have this special package:
Attached File  Natit.agp.zip   46.33KB   153 downloads

and for my x1950gt(7288) AGP peeps:
QE/CI/OpenGL/Rotation + NO mouse tearing!
x1950gt agp


and don't forget to

sudo -s also enter the root password!
chown -R 0:0 /system/library/extensions
chmod -R 755 /system/library/extensions
rm /system/library/extensions.mkext
rm /system/library/extensions.kextcache
kextcache -k -z /system/library/extensions


TEll me how it goes

#87
palote

palote

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
hi..

i got my 1950 pro with QE and CI enabled but when starting Adobe After Effects crashes and says that a problem occurs while invoquing OpenGL or something like that...
i can run x-bech with no problem (openGL benchs normally) but why i cant run it when opening Adobe AE???

Any ideas?

Cheers

#88
^kaneda

^kaneda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts

here's new pack for x1950gt(7288) replaced atindrv with Bronyas new and added a gl driver
x1950gt_7288_scrz.zip

and here's natit for x1950gt(7288)
Natit x1950gt 7288

and don't forget


^_^
all thanks goes to Bronya!

well now it works i can used EDID info from the LCD manage res and gamma... and else.. BUT the second display ( AOC 17" ) works like a mirrow from the first display and it doesnt shows up graphics/displays in system profiler... any idea of hot to use extended display??!!

#89
oiasdas

oiasdas

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

for my agp friends I have this special package:
Attached File  Natit.agp.zip   46.33KB   153 downloads

and for my x1950gt(7288) AGP peeps:
QE/CI/OpenGL/Rotation + NO mouse tearing!
x1950gt agp
and don't forget to
TEll me how it goes



I tried your natit package for AGP, but it didnt really do anything for me. I am running a Sapphire x1950Pro 512 mb AGP card. System Profiler showed it as still running PCI, and QE/CI were still enabled. Also, the second monitor still showed as mirrored.




I have found that disabling Beamsync and enabling quartz2d helps a lot. Also, I installed Mouse Locater which nearly got rid of all of the mouse tearing.

Posted Image

#90
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 1,107 posts
  • Gender:Male

System Profiler showed it as still running PCI


It is difficult to you to edit configuration.plist?

#91
oiasdas

oiasdas

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
I went and tried that when you gave that advice to another person on here. My configuration.plist already showed IOAGPDevice. I didnt have IOPCIDevice. There was nothing for me to change, yet it still shows as PCI.

#92
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 1,107 posts
  • Gender:Male

well now it works i can used EDID info from the LCD manage res and gamma... and else.. BUT the second display ( AOC 17" ) works like a mirrow from the first display and it doesnt shows up graphics/displays in system profiler... any idea of hot to use extended display??!!

Try x1900natit_dual.kext from Diabolik!

i install the driver under 10.5 9a499,but it is not work :angry2:

For me in leo 499 works QE/CI <-also as well as in Tiger 10.4.10!!!

I went and tried that when you gave that advice to another person on here. My configuration.plist already showed IOAGPDevice. I didnt have IOPCIDevice. There was nothing for me to change, yet it still shows as PCI.

You read ?http://forum.insanel...o...8988&st=60#

#93
oiasdas

oiasdas

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Posted Image

That is what I see when I open it up.

#94
^kaneda

^kaneda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
x1900natit_dual.kext??? where can i download that?

#95
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 1,107 posts
  • Gender:Male

I tried your natit package for AGP, but it didnt really do anything for me. I am running a Sapphire x1950Pro 512 mb AGP card. System Profiler showed it as still running PCI, and QE/CI were still enabled. Also, the second monitor still showed as mirrored.I have found that disabling Beamsync and enabling quartz2d helps a lot. Also, I installed Mouse Locater which nearly got rid of all of the mouse tearing.

You Delete all ATI*.kext!!! Then establish natit.kext and original atindrv.kext from 10.4.8 or more, then establish mine atiradeonx1000.kext and atiradeonx1000ga.plugin then for you will work resolution monitor!!!

x1900natit_dual.kext??? where can i download that?

Any natit_dual.kext !!!

Posted ImageThat is what I see when I open it up.

It is clear, then you replace in atindrv.kext, there info.plist, edit and find IOPCIDevice <-replace on IOAGPDevice! Also inside atiradeonx1000.kext too it is necessary to edit info.plist and replace IOPCIDevice on IOAGPDevice... Try!

here's new pack for x1950gt(7288) replaced atindrv with Bronyas new and added a gl driverx1950gt_7288_scrz.zipand here's natit for x1950gt(7288)Natit x1950gt 7288and don't forget :Dall thanks goes to Bronya!

:angry2:

#96
Scrizz

Scrizz

    The Scrizz

  • Members
  • PipPipPipPipPip
  • 282 posts
  • Gender:Male
try this
for agp
put these in extensions folder and replace old ones
won't "show" agp, but is using agp
should give QE/CI/Rotation etc...

#97
^kaneda

^kaneda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
i fail to get extended display, anyone could?

#98
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 1,107 posts
  • Gender:Male

i fail to get extended display, anyone could?

You are not able to edit ... :rolleyes:

#99
^kaneda

^kaneda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts

You are not able to edit ... :rolleyes:

i edit natit with my dev id and with de secondary display id but then nothing change (it doesnt read the edid of the lcd anymore just that... ) i edit the atix1000 kext with the secondary id and then i get a kernel panic... what else i should try to edit?

#100
frEEki

frEEki

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
ALLRIGHT!!!

NOW ITS WORKING :) :D :D

I finally managed to get everthing working 100%

First i installed the driver pack from jccools driver. That made my PC booting into 1680x1050 without CI/QE.
Then i installed the files from atiradeonx1950pro_dmitrik_Edited.zip.

I replaced the ATINDRV too!!!! (Leaving it from jccools made my kernel panic!)
Delete cache and fixed permissions.

TAA DAAA...

Now i have a fully supported eax1950Pro PCI-E running on my system!!

Thanx everyone for your great work and your posts on this board!!!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy