Jump to content

[Guide] Z820 - El Capitan The great guide (Sucess)

* * * * * 3 votes Z820 lsi2308 tusb7320 tusb7340 thunderbolt

  • Please log in to reply
89 replies to this topic

#1
bilbo

bilbo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts

————————————————————————————————————————

 

THE GREAT GUIDE

 

EL CAPITAN + Z820

 

 

 

***

 

 

01/09/2016

 

 

*********************************************************************************

————————————————————————————————————————

————————————————————————————————————————

 

z820_gallery_img2_tcm_245_1443303.jpgel_capitan.jpg

 

 

 

Introduction:

 

Hi everybody.

 

I’m glad to release this guide to enjoy this beauty running El Capitán. It has been a long and hard way. I've been trying to get a stable hackintosh since Mavericks (with a lot of drawbacks), and Yosemite (same problems). Finally, with El Capitan, I have succeeded. This version is awesome, works perfectly, fluently , skips important problems and allow new support for some hardware.

 

Some important topics:

 

1. What is the main goal of this tread?

 

Not only show the how-to. I’d like gather all Z820 owners here to talk and share problems, tips, and refine this guide. We are not too much z820-users. Search info is frustrating. So please, join here.

 

2. Please, help to improve this guide.

 

I’m not an expert. I’m far from to be an expert. This is only the result of hours, days, of searching, tries, and trial-and-error method. If you see something wrong, or which could be improved, please, just say it, and I’ll fix it.

 

3. Specs.

 

This is a guide for my specs. There are several revisions and versions (V1, V2 , bios versions, dual, not dual cpu...), and some custom hardware peripheral (graphic card, pci cards).

 

You have two ways.

 

- To be lazy, download my files and … anything else. If your hardware does not match, is incompatible, or something is updated, you’ll not know how adapt it and fix it. :thumbsdown_anim:

 

- Try to understand what I do and adapt it for your specs. And then, share it ;)

 

 

My specs are:

 

Intel Xeon Processor E5-2630 v2 dual.

Bios version 3.85

Graphics Card: Quadro K5000

Memory: 64gb ram

 

Common Hardware:

 

Audio card Realtek ALC262

Internal SATA-SAS controller LSI 2308

USB3 internal controller Texas Instruments TUSB37320/40

 

 

And:

 

LSI Sas-Sata Raid 9620 8i

PCI Thunderbolt Card HP

USB 3 PCI  Conceptronic

 

 

And finally , one last topic more:

 

4. English is not my native language. If you see how I kill your language, please, just say it and I’ll fix it too :)

 

 

 

Ok let’s go.

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART I

 

1-BIOS SETUP

 

 

(Preface. This whole guide is for UEFI systems. It’s not important to follow it. Keep in mind it to adapt some settings if you use legacy-bios mode.)

 

 

On storage options: set ACHI mode.

 

screen1.jpg

 

On security options: disable Vt-d

 

screen2.jpg

 

On Advanced, set PXE , storage and graphics to EFI. (in that case)

 

screen3.jpg

 

 

On power, set Os power management to Enabled. This option will allow Power Management later.

 

screen4.jpg

 

 

Throughout my experiments, I haven't found any other option with a negative impact specially important. But, If you don’t need any special option, reset the bios to default can be a good idea.

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART II:

 

INSTALLATION

 

 

1- MEDIA CREATION

 

(This guide assume you have a MacOs runnig . I have no idea how do it on PC)

 

-Download El Capitan from AppleStore. Currently, is 10.11.6. Final version. No need to update. Let the file in /Applications

 

-Download my compressed folder with all necessary stuff.

 

-Format one USB stick with common settings:

 

Go to Partition Tab, choose 1 partition in “partition layout”, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as you want. Ok to Apply.

 

-On a terminal window, type:

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USBName --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction

-Change “USBName” by your usb name. Enter and type your admin password. It will take 10-15 minutes. (When it finish , you’ll see the prompt again)

 

-Download Clover from here . Version used to make this guide: Clover_v2.3k_r3676

 

-Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick

 

-Click on Customize.

 

-Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI based)

 

-This is optional: choose Bootcamp in Themes. I like this theme because looks like a real mac. The rest of themes are horrible.

 

-In Drivers64UEFI select: / EmuVariableUefi-64 / OsxAptionFix2Drv

 

screen5.jpg

 

 

Let the rest of option unselected and Click on Install.

 

 

 

 

2- CONFIGURE CLOVER

 

When clover finish, It will mount EFI partition. Time to modify it.

 

2.1 Config.plist

 

Clover makes a config.plist with some options pre-selected. Change the original config.plist by mine. But take a look to options (with clover configurator) to understand it in order to be able to adapt them for your specs. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options.

 

Acpi.

No options activated. Ignore section dsdt.patches for the moment. I'll explain it later.

 

screen6.jpg

 

Boot

Bootflags needed are only -v and npci=0x2000.

 

screen7.jpg

 

 

dart=o is no needed with vt-d deactivated on Bios. Kext-dev-mode=1 is for Yosemite only. rootless=0 is for first betas of Capitan.

 

No options activated in Cpu/Device/Disable driver

 

Gui options.

 

screen11.jpg

 

Graphics. No Graphic injection. At least, no needed for my Quadro card. With this option I boot with only 1 screen. (I have two monitors). Check it out for your card video.

 

Screen12.jpg

 

Kernels Patches needed

 

Screen13.jpg

 

RT Variables to deactivate security policy in el Capitan. Similar to kext-dev-mode in Yosemite.

 

Screen14.jpg

 

 

SMBIOS Set to Mac Pro 5,1. This is important to skip black screen with boot with SMBIOS 6,1. We will fix that later.

 

Screen15.jpg

 

 

System parameter : “No caches” enabled. It’s optional. I like activate this option to test instead of press space bar in every boot.

 

Screen16.jpg

 

Thats all.

 

 

2.2 -Drivers64UEFI folder.

 

You’ll see more drivers installed. That is because some of them are mandatories. That is fine.

As usual, delete VBoxHfs-64 driver and replace it by HFSPlus.efi.

 

screen17.jpg

 

 

2.3 Kexts:

 

You can use my kexts from my stuff folder, or download them from original sites.

 

-Download X79 dmg from RampageDev's site. Mount it and go to /Files/Step2/10.11 to current/StandardKext and grab next kexts:

 

-FakeSMC.kext .

-VoodooTSCync.kext, (to avoid boot with cpus=1)

-AppleintleE1000e.kext. Not important now, but it will allow to get internet on first boot

 

…and copy them to your /EFI/CLOVER/Kexts/10.11

 

Important. OpenFakeSMC.kext , (show Package contents) and delete LPCSensors from /Contents/Plugins. This LPC plugin freeze the boot !

 

 

screen18.jpg

 

Note. My folder has a couple of kexts more. We will talk about it later.  ;)

 

3- FIXING USB PORTS

 

If we boot now, we will get the annoying “PCI configuration Begin” error. This is cause the usb issue of El Capitán. We could even avoid this booting using an HDD instead of an USB stick. Which is really weird. But anyway, once we reach the installer, the USB won’t be recognized, so no mouse, no keyboard. The right way is fix the usb ports.

 

Here I have to give credit s to these german guys which allowed me see the solution and refine it. Credit also to the user from the ton--mac forum who found the forum and linked it

 

So, we are going to fix the problem. It has two parts:

 

1-First

Go to here and download last version of USBinjectAll.kext of the-never-well-enough-praised Rehabman :) . Copy the kext to /EFI/CLOVER/Kexts/10.11

 

2-Second.

We have now to apply a DSDT patch to rename usb devices. But doing this now, we have to extract it, clean it and compile it, and finally fix it. And now it’s not the right moment. We can do it with DSDT-patch-on the fly of Clover.

 

Copy the next dsdt-patches code to the config.plist, using plistedit pro or add them manually with Cloverconfigurator.

 

Spoiler

 

This is a common patch adapted for Z820. Note that the name of original names of the devices are specifically taken from original Z820 dsdt.This patch will change from EUSB and USBE, to EH01 and EH02. (required by El Capitán). If you use cloverconfigurator, the hex64 code of ASCII names, will be converted to hexadecimal.

 

 

And that's all. Our Clover-USB is clean and works. Ready to boot

 

Reboot from the USB stick and install El Capitan. :lol: . One last good tip is gather in a folder all stuff necessary to repeat the process and copy it to USB. You will have it available directly after first boot.

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART III:

 

FIRST BOOT

 

 

4- On first reboot, install clover again on HDD, repeating same process and same options , but keep in mind you have to add some options on clover’s screen install:

 

-Install RC scripts on target volume

-Optional RC scripts

-Install Clover Preference Panel.

 

screen19.jpg

 

 

 

Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. We can extract the USB installer and reboot from our HDD

 

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART IV:

 

FIRST CLOVER SETUP.

 

Now we have to refine our System.

 

5- First, mount efi partition (you can use EFIMounter ) , open the config.plist and add some options. Again I remark that I like let unchecked as options as possible. I prefer to have a config.plist clean and with minimum options activated. You can adapt it to your preferences later. The rest of options needed will be included in every section.

 

-Acpi:

 

Activate “deleted unused” in new way fixes. This is only to refine a bit the dsdt injected by clover.

 

We don’t need add any option in power management section. Except:

 

-Check Smart UPS option. This set the PC as workstation (type 3). Now it’s not important but later it will be in order to get a right power management.

 

 

-Boot.

 

No changes from our basic config.plist. You can remove -v option when you’ll get stable your system.

 

-Cpu.

 

Add the right CPU ID. For my CPU is 0x0a01

 

-Devices / Disable drivers / Gui / Graphics / Kernel and Kext patches. / RT variables

 

No changes

 

-SMBIOS.

 

Set the right SMBIOS. This is important. Generate a new SMBIOS 6,1.

 

-System parameters.

 

No changes. “No caches” stills activate. This a personal preference. You can deactivate later

 

Save the config.plist file.

 

Now, important, If we reboot, we will have a black screen. It’s a known problem since Yosemite but it’s easy to fix.

 

6- No reboot. Go to /S/L/E. Copy AppleGraphicsControl.kext to your desktop.Go to contents>plugins>AppleGraphicsDevicePolicy.kext/Contents/ . Open Info.plist. Search line related to SMBIOS 6.1

 

<key>F60DEB81FF30ACF6 </key>

<string>Config2</string>

 

- and change “config2” by “none”

 

<key>F60DEB81FF30ACF6 </key>

<string>none</string>

 

 

-Save and close. With your favorite utility, install the new kext (is a good idea if you set a colour-label to the file). Repair permissions and rebuild cache. Reboot.

 

Now we have the z820 running El Capitan, with the right smbios, and with some basic clover settings, ready to still working.

 

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART V:

 

FIXING

 

A- GRAPHICS.

 

My Quadro card works out of the box. No need to fix or inject anything. And, the best thing, no need to rollback old or patched kext form previous versions ;-). I guess is the same for geforce cards.

 

7- Install web driver. Remember activate nvda_drv=1 bootflag in clover after install nvidia driver.

Reboot and select the new driver in preferences. Reboot if nedded. For quadro cards, you can activate ECC memory, although you'll lose some mb of vram. ECC can be important for video or 3D renders.

 

8- Install cuda drivers.

 

B. ETHERNET.

 

Its’ works with AppleintelE1000E kext.

 

C.USB 2.

 

Works with the dsdt patches of clover and the USBInjectAll.kext that we already have.

 

 

For the next fixes , we need patch the dsdt. So, it’s time work on it.

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART VI:

 

DSDT.

 

9- DSDT extraction:

 

On your current system, reboot and press F4 on clover screen (or search how extract ACPI tables from linux or windows). Then, boot normally. You will find your original DSDT on EFI/CLOVER/ACPI/Origin (there will be more tables. Keep DSDT and SSDT files, and delete the rest of them)

 

Preserve a copy of original file. Always edit a copy. I like compress the original files to preserve them of changes.

 

10- MacISAL

 

Download MacIASL Important. Don’t use 1.4 version. It reports errors and compile the dsdt in a wrong way. I use 1.3 ML version.

 

Open it and set some extra repositories: In preferences/ Sources tab add rehab man repository typing next url:

 

 http://raw.github.co...DT-Patch/master

 

Set in preferences ACPI specification 4.0. Ignore 5.0, at this time.

 

screen21.jpgscreen22.jpg

 

 

11. Cleaning

 

The main goal is apply some fixes. It’s easy, but to compile, MacIASL needs clean all errors. So, we have to clean it first.

 

Click compile button and you’ll see the errors. (If you click over the error, you’ll jump to the right line)

 

These are syntax error of my original DSDT-bios 385. Maybe your dsdt has similar errors.

 

screen23.jpg

 

Let’s go to fix them

 

11.1 -Posible operator timeout is ignored

 

-Replace

 

Acquire (MUT0, 0x0FFF)

 

….by

 

Acquire (MUT0, 0x0FFFF)

 

(note: four “f”)

 

11.2- Invalid object type for reserved name (found buffer , requires Package)

 

It’s more complicated than only change “buffer” by “Package”. The best is apply “PLD buffer/Package Error” patch.

Click Patch button, search in rehabman branch, and search below “Various Syntax Error”. Select the patch , click apply and close

 

From every and now, you can press Compile button to see how errors disappear from the list

 

In addition, maybe you can fix warnings (yellow triangles). Is not required. But I like clean it completely. In my DSDT I have.

 

 

11.3- Not all control paths return a value (WHB_) (and _E1D , _INI , and others variables)

 

Insert “Return (Zero)” to close all open tags. For instance:

 

-from:

 

Spoiler

 

-to:

 

Spoiler

 

- For almost the cases the insert place is before the last } which close the paragraph. In some of them, the fix not so obvious.

 

For instance:

 

Spoiler

 

 

When you place the Return (Zero), click on compile button. It more errors appears, it means that it’s not the right place.

 

 

One fix more. In my case, I have:

 

11.4- Use of compiler reserved name (_T_0) and (_T_1)

 

This is a common error fixed in several generic rename-devices patches. But now we want fix only this error. I’ve separated the code from the patch “Basic Apple Device Rename” from jpalm patches.

 

Click patch , open, and select the patch1 file from my folder. You’ll see next code:

 

into_all all code_regex _T_([0-6]) replaceall_matched begin T_%1 end;

 

Click apply.

 

 

11.5 Finally, although we can ignore ACPI 5.0 I like fix this too. This is optional. Set ACPI 5.0 in preferences, and click in compile. There is only a kind of error to fix:

 

-Min/Max/Length/Gran are all zero, but no resource tag

 

In sections like that:

 

QWordMemory (ResourceProducer, PosDecode, MinFixed, MaxFixed, Cacheable, ReadWrite,

0x0000000000000000, // Granularity

0x0000000000000000, // Range Minimum

0x0000000000000000, // Range Maximum

0x0000000000000000, // Translation Offset

0x0000000000000000, // Length

 

 

…the new Length value is:

 

Length = (Range Maximum - Range Minimum) + 1

 

 

- In this example:

 

0x0000000000000001, // Length

 

 

(As you can see, the new value is 1 in all errors. But check it out, just in case)

 

Click in compile button to check everything is right. Set again ACPI 4.0

 

12- One fix more. Add the patch number 2 from my folder. This apply more common devices names fixes. Compile it.

 

That’s all to get a clean dsdt. Save it and rename it as “DSDT-clean” or whatever.

 

 

13. OPTIONAL

 

Here you can apply also the USB2 rename fixes directly to the dsdt. It´s your personal choice. Personally, I did it because we are applying more fixes. If you do it, delete the dsdt-patches in clover.

 

- Make a new copy of the DSDT.

 

-Apply patch3 from my folder. I have separated the necessary code from “Basic Apple Device Rename” and I have modified it for our Z820 devices and my method to apply fixes.

 

-Compile it and save it as “clean-usbfixed” or whatever. Delete the dsdt-patches in clover. Copy this "clean-usbfixed" and place it on /EFI/CLOVER/ACPI/Patched. Rename it to DSDT.aml. Reboot.

 

We can continue fixing things.

 

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART VII:

 

FIXING-2

 

 

D-FIREWIRE.

 

If you don’t have any Firewire peripheral, maybe is not important, but I like fix it to get a System as functional as possible. Also, fixing firewire, we fix IRQ conflicts, which can be important. This can be fixed using some clover fixes. I prefer clean the DSDT.

 

14. Open the DSDT. Locate Devices IPCI   IPIC , TIMR and RTC (use search function). Delete these lines:

 

IRQNoFlags ()

{2}

 

 

15. Locate device HPET. insert IRQs flags (in red).

 

Device (HPET)

{

Name (_HID, EisaId ("PNP0103"))

Name (CRS, ResourceTemplate ()

{

IRQNoFlags ()

{0,8,11}

Memory32Fixed (ReadWrite,

0xFED00000, // Address Base

0x00000400, // Address Length

)

})

OperationRegion (HCNT, SystemMemory, HPTC, 0x04)

Field (HCNT, DWordAcc, NoLock, Preserve)

 

Compile and save.

 

16. Open config.plist and select FixHPET in ACPI section. It’s important. It prevents random resets 20-30 seconds after boot. This fix changes the structure of HPET branch. I’ve compared before and after to apply this fix and I’m not sure what it does. Anyway, only apply the fix.

 

Reboot. Check firewire in System profiler. It should be active.

 

 

E- AUDIO

 

A hard topic. Unlike to for Mavericks and Yosemite, I couldn’t find the appropriate AppleHDA for El capitan. I found the solution thanks to MacPeet here

 

 

17- Look into my folder/patch audio. Install the AppleHDA (it’s the original kext from 10.11.6 including layout28.zml.zlib and Platforms.zml.zlib needed for ALC262). Install also realtekALC.kext attached. Fix permissions and rebuild cache.

 

18-Add the following patchs to config.plist. Use Clover configurator or plistedit. The code is:

 

Spoiler

 

screen24.jpg

 

(I have included one additional patch to avoid one annoying error on the console output. Credits to the author )

 

19- Set Inject Kexts option to Yes, just in case:

 

<key>InjectKexts</key>

<string>Yes</string>

 

screen26.jpg

 

 

 

20- And Set Audio inject to 28. If you use clover configurator, let the other options unchecked.

 

<key>Audio</key>

<dict>

<key>Inject</key>

<string>28</string>

</dict>

 

screen27.jpg

 

 

 

21- Now we have to patch the DSDT. Open it, find the branch /—_sb /—PC10/ — PEX4/ . Locate the space between the end of PXE4  device and the first of the next branch (Device PCI1 in my case) and add the new HDEF device adding next code

 

Screen28.jpg

 

Spoiler

 

This code is ready for ALC262 audio card.

 

Be careful with the point to insert and the format. You should see the new branch in the left window of MaciASL editor

 

22- This code needs insert a DGTP method in DSDT. Search in MaciASL, patch button - general branch - add DGTP. This patch adds one additional DGTP branch at the end of the dsdt

 

screen29.jpg

 

Compile and save it. Reboot. Check the audio panel.

 

 

F- LSI 2308 Controller

 

 

screen28_B.jpg

 

Yes. It works. A big release of this guide. The drivers for LSI 2308 SATA-SAS internal controller. :thumbsup_anim: :thumbsup_anim: They come from one unsupported driver. They are patched for work without restrictions  ;)  I mean, more than one disk and raid support. I have two disks (windows and linux SO) working, and I tested attaching until 2 disks more and it works great. I don’t have more free disks ^_^ . This a big chance for more users what can test them in terms of reliability and performance.

 

Your will find it into my stuff folder

 

Note. I have included this drivers in installation folder too. The installer recognize perfectly all HD attached to the LSI 2308 controller. Anyway, be careful installing the SO in these HDs. We need test it. I’m sure that it works, but, just in case. My recommended ports to attach system HD are the two natives ACHI SATA ports (SAT0 and SAT1). Read Z820 documentation for more info.

 

 

G- THUNDERBOLT PCIE

 

 

 

hp_f3f43at_hp_thunderbolt_2_pcie_1_port_screen28_C.jpg

 

 

It works too!!. :thumbsup_anim: :thumbsup_anim: :thumbsup_anim:  I’m talking about of the HP Oem TB card, of course. But this is not a merit of mine. All credits to El Capitan :P . A big surprise when I installed the SO and I could see how it is recognized by the system. I only have one external HD TB and it works. Just a warning. Harddisks are only recognized at boot. No hot-plug. I don’t have TB raids to test the real performance. Again, a good point like homework ;) . I’d like also test the video output of TB, but I don’t have the appropriate DP bridge cable.

 

Anyway, a good new.

 

 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART VIII:

 

Power Management

 

This is the more complex part. What I know is the result of thousand of tries. Help to improve this guide. If you see something wrong or which could be improved, please, just say it.

 

23- Follow instructions from here:

 

a- skip step 1 . It’s not needed for Ivy bridge cpus. Go to step2

 

b - Patch the appleintelpowermagement.kext with the command AICPMPatch and instructions provided by stinga11. That is what Asus AICPUMP clover patch do. But Stinga11 is right. It doesn’t work for x79 platform to get Power management. I checked it. So, use the command following the instructions

 

(Note: Important: Deselect Asus AICPUMP kernel patch from clover )

 

c - Install the 10.11 X79PlatformPlugin.kext of the guide.

 

d - Fix permissions and rebuild cache.

 

24- Install HW monitor. Be careful and deselect fakesmc or plugins on installation screen. Launch the app. Set your favorite icons and info to show on bar menu. Set the app to launch on every boot.

 

Reboot.

 

Now you can see the cpu speed. It’s still running at speed stock. We don’t have PM yet. Lets go to fix later.

 

Now we are going to install the tool to check our C and P - states. The usual tools are the AppleIntelCPUPowerManagementInfo.kext or the most recent the AppleIntelInfo.kext , they both from piker. But none of them work. They cause a kernel Panic in our PC. Fortunately, one user from this forum patched a right version a time ago.

I don’t know the kind of patch , and if it depends of the architecture , bios (msr-locked) or whatever. It’s and old version, but it works.

 

25- So, copy the AppleIntelCPUPowerManagementInfo.kext from my folder and copy it to the kext folder of clover.

 

Although it shouldn't be necessary, I sometimes have kernel panics when I install this kind of kexts. My advice is reboot without caches (if you don’t keep this option in clover) and then, rebuild it with your favorite utility.

 

So, reboot :)

 

26- To check C and P states, type on a terminal:

 

cat /var/log/system.log | grep "AICPUPMI:"

 

We don’t have PM yet, so you’ll see only a couple of states.

 

Now we have our system ready for the last step:

 

27- Generate the SSDT with ssdtPRGen.sh. Go to piker’s website  and follow the instructions to download it and how to use it.

 

But, if you try any command to generate the ssdt, you’ll get next error.

 

No ACPI Processor declarations found in the DSDT!

 

What does it mean?. The script is not to able to find processor declarations in our dsdt. To fix it, I do something… we would say, not pretty usual, but it works for me: Add them manually.

 

28- In my bios version, those processor declarations are in one of the native SSDT. The bios has 3 SSDT. Go back where you extracted the original tables at first of this guide. To identify it, open every ssdt with maciasl until see one with SCK0 / SCK1… (and so on) branchs. The tip is search the word "processor" into the code. In my case (and I guess for the rest of bios versions) , the ssdt is the number 2. Select all code of the ssdt (except the comments) and copy it to the end of your current dsdt. Be careful with } and don’t break the right end of the dsdt.

 

screen30.jpg

 

You can compare it with my final dsdt of my stuff.

 

Reboot to activate this change into dsdt.

 

 

29- Now, again on Piker’s script, we have to type the right command. After tries and tries, that is the syntax I use for the last ssdtPRGen.sh version:

 

./ssdtPRGen.sh -p 'E5-2630 v2' -b Mac-F60DEB81FF30ACF6 -w 3 -x 1 -cpus 2 -l 24

 

Which means:

 

-p 'E5-2630 v2' — The cpu model. Change it for yours. Search in /YourUSer/Library/ssdtPRGen/Data/Ivy Bridge.cfg file to use the right syntax.

 

-b Mac-F60DEB81FF30ACF6 - SMBIOS of 6,1 definition

 

-w 3 Considers the PC as a workstation, (remember smartUPS option in clover) to get a more appropriate PM

 

-x 1 Set the xcpm method.

 

-cpus 2 . Set the number of Cpus. (dual for me)

 

-l 24 . Set the number of threads. Keep in mind hyper threading (HT). In this example, I have 2 hexacore cpus . So (6 x 2 of HT)= 12 x 2 cpus = 24

 

These two last options are important to get a right PM. I had an old script generated (a few years ago) without this options. Now with this new commands, I can see a bit more performance on tests.

 

 

Back to the terminal, press enter to generate the ssdt and check the terminal output. we don’t should see any error. Select “No” for the last script’s option to copy the ssdt generated. The ssdt is in /YourUser/Library/ssdtPRGen/. Delete the ssdt.dsl version. Copy the ssdt.aml to EFI/CLOVER/ACPI/patched.

 

30- Enable on clover -xcpm flag or use this custom flag recommended by the script

 

-xcpm_ipi

 

Currently, I'm using this custom flag. I’m trying to figure out what it does. No much information.

 

 

Reboot. Remember, without caches, and then rebuild it with your favorite utility.

 

Now , finally, we should have PM. Check HM monitors info. The cpu should move between lower state in idle, to stock speed clock, and reaching higher values under heavy work requirement

Check the output of AppleIntelCPUPowerManagementInfo.kext with cat /var/log/system.log | grep "AICPUPMI:

 

The output doesn’t refresh. Introduce again the command (up cursor) while tests are running, and the new states will be shown. You can use geekbench, prime95 for mac, cinebench...etc

 

One example of my output:

 

Spoiler

 

Thats are my results on Geekbench or Cinebench. :

 

screen31.jpgscreen35.jpg

 

screen32.jpg

 

 

As you can see, the behavior in idle is a bit erratic. I found out that the guilty is… the graphic window of hardware monitor :). The behavior in real idle is stable, in x12 multiplier. And it ups to 29-30 in turbo. Anyway sometimes I think that the cpus are a little …. edgy. But I’ve checked on windows , and I can see the same behavior…. so I’m happy with the performance.

 

That is the result of my tests on windows:

 

screen33.jpgscreen34.jpg

 

 

Geekbench shows lower result. Maybe different background tasks, the crappy windows 10… or simply a different Power management policies.

Cinebench shows similar result on CPU. But note the big difference in graphics performance. That is always the case since my first tests on Mavericks three years ago. That is because MacOs doesn’t support last openGL versions. Graphic cards always show a lower performance than in windows. But don’t worry. You have the awesome metal :sick: . A great idea to follow the standard of the industry. <_< :thumbsdown_anim:

 

My graphic card show speed memories and speed clock expected, showing some states in idle . Just in case, I have followed some guide to get Graphics PM with no impact. This is what it is.


 

 

---------------------------------------------------------------------------------------------------------------------------------

 

 

PART XIX:

 

USB3

 

The last part of this guide. This is because it is incomplete. I have working the Texas USB 3 internal controller, but with an error which prevent the use.

 

To get USB3 working:

 

 

31- Rehabman has several generic guides. But maybe this guide adapted from rehabman's guides is more concise.

 

Go to directly to step 1 of part 1, adding the DSDT patch in clover.

 

In step 2, create the new SSDT-XOSI file.

 

In step 3, download the FakePCIID and FakePCIID_XHCIMux kexts from rehabman’s bigbucket site . Download the last version, extract it , open "release" folder, and copy only these two kexts to your clover extension folder.

 

32- Download the GenericUSBXHCI.kext from rehabman. Go to here , download last version. Again, extract it and copy it to your clover extension folder. This is the new kext for non-intel usb3 controllers for El Capitan.

 

33- Rename USB3 device in the DSDT. Open the dsdt and search “USB3”. Replace it by “XHC”. Compile and save it.

 

Reboot.

 

Test your usb3 ports. They are not shown in System profiler but it doesn’t matter. Plug one usb3 stick in one of the usb3 ports, and try to copy some file (bigger than 2 or 3 mb) You’ll have an annoying error -36. No solution here. The only clue is this thread, (and next 4 pages). They are talking about zenith’s generic driver for Yosemite, Maverics, etc. Maybe this new kext controller needs another patch like Zenith432 did for those ASM1042 users.

 

Note. I had this error with that version in Mavericks and now with this new rehabman’s version. That is because I think this card needs a specific fix into the code. :-(. Searching,  I have seen another users with same error.

 

You have another way. Buy one compatible USB3 PCI card. They are cheap. Search info to find compatible controller model. It works. I bought one conceptronic card and works like a charm with the steps described above. . But , that the front ports can't be used , is really annoying .

 

 

END OF THE GUIDE

 

That’s all. I hope it helps to Z820 users. I expect comments, tests, fixes, and improvements ;) . Again, sorry for my English.

 

 

 

attached file:

 

Attached File  Z820-EL_CAPITAN_stuff.zip   3.68MB   468 downloads



#2
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 4,442 posts
  • Gender:Not Telling
  • Location:home
  • Interests:If you try to please everyone, then you have certainly forgotten you
great guide! you have described everything perfectly.

#3
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,526 posts
  • Gender:Male

Perfect! Congrats for your great job clap.gif



#4
hugodlc

hugodlc

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Fantastic guide, I used a lot of information from it to update my Mavericks Z820 install.
Thank you!!

 

Some info that might help.

 

I can confirm the SAS drivers work in Mavericks and I'm testing reliability on a spare HD.

S.M.A.R.T. staus doesn't work out of the box, but with SATSMARTDriver-0.10.dmg you get it.

No hot plug!!! Motherboard will do a hard shutdown and won't power back up unless you remove the power supply and will scare you for life!!!

The speed on the SAS controller using SSD's is over 450MB/s read/write. cool!

 

Can't make the firewire port work. I think I managed to get it working once, but don't remember the exact combination of settings, and the problem is it needs Clover to work, and in my case Clover makes the fans in the Z820 spin like crazy, so unless there is a fix for slowing the speed of the fans, I'm using Chameleon, as I use my computer for audio work and silence is gold.

 

Same problem with USB3. USB2 devices will work with GenericUSBXHCI, but USB3 drives will not work. they will mount but that's pretty much it. no read, no write.

 

Speedstep in my computer actually slows down Geekbench scores, even when CPU clock is in turbo mode. but the CPU runs cooler and so the computer is quieter, so I sacrifice a bit of speed for silence.

 

I'm using a GTX780 ti for GPU and the NVIDIA web drivers and performance is ok, nothing comparable to windows, but at least very decent.

 

I need to use older Apple ACPIPlatform and IOPCIFamily kexts to run smooth with the GTX card.

 

Another thing I had to do was modify my AppleIntelE1000e kext because I was having network interface crashes on large file transfers >10GB.
Changed the NETIF_F_TS0 key to false in the info.plist and so far it's stable in my tests. (I see your version of the kext has the same edit)

 

I'll try to get my hands on a Thunderbolt card and test on Mavericks, and will keep trying to figure out the USB3 problems, after which this will be the best MacPro replacement build ever!!

 

Thanks again for the great guide!!



#5
ant-gr

ant-gr

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hi, very detailed guide.

my specs are:

Intel Xeon Processor E5-2680 v2 dual.

Bios version 3.90

Graphics Card: 2 x gtx980

Memory: 128gb ram

 

i don't have  el capitan 10.11.6 so i am trying with 10.11.5

 

I have built the usb according to your guide , but when it boots stays stacked at the very beginning with a lot of : +++++++++++++++++++++++++++++++++++++++++

Could you please help me to overcome this???

 

thanks



#6
ant-gr

ant-gr

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

silly me!

i had to unplug the 2nd GFX. 



#7
bilbo

bilbo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts

Sorry for the delay. I'm a little busy these days.

 

Hugodlc, weird behaviour. Could you post your bios version?

 

 

I don't have problems with hotplug using internal lsi controller. I attach the hd's using a sata bracket like this. No problem attaching or mount disks. And of course no problem with mb.

 

About firewire, as I wrote, the point is fix irq conflict, but maybe rollbacking ACPIPlatform and IOPCIFamily kexts is the guilty. In my tries with Yosemite, I had to rollback these kexts too, and I lost firewire inmediatley.

 

Forget thunderbolt on pcie on maverciks. El Capitán has the appropiate kext to make TB pciecard works

 

I can´t see any unusual  with speedfans either. The behaviour related to noise and speed is identical to windows (and between chameleon and clover)

 

I could recommend you strongly update to el capitan. ^_^


ant-gr , how was with your test?



#8
hugodlc

hugodlc

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Bilbo,

My bios is 3.88 A

The hotplug problem might have been a cable that came loose and shorted something for a second inside the case, as I later found when I opened it to install a usb3 card. https://www.amazon.c...duct/B00JFR2H64 (Works great BTW)

I agree that the firewire culprit is most likely the rollback kexts, but I seem to remember that I managed to get firewire working booting with clover, rollback kexts, no speedstep. but don't remember the exact settings I used.

Can't update to el Capitan because of software compatibility issues, and as for the speed fan thing, where do you have your fan idle settings at?

I have it at the lowest setting and both windows and chameleon keep it slow and quiet unless under stress, but clover for some reason brings the fans up to a speed where they make too much noise to have the cpu in the same room and do audio work with it. Maybe when I'm able to move the cpu to another room I'll give it another try.

 

Did some tests with Sierra last week, and it boots, but I had the same fan problem, so didn't bother to test thoroughly.



#9
bilbo

bilbo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
where do you have your fan idle settings at?

I have it at the lowest setting and both windows and chameleon keep it slow and quiet unless under stress, but clover for some reason brings the fans up to a speed where they make too much noise to have the cpu in the same room and do audio work with it. Maybe when I'm able to move the cpu to another room I'll give it another try.

 

As I know, speed fans can´t be configured.  They are part of power management. Maybe some wrong PM brings on wrong speed fans.

I've just tested it using prime95 during 25min. Cpus running at stable 2.9 ghz , Power consumption: reaching 57 W . Temperatures between 55~63 Celsius. And speed fan keeping an stable speed between 1230 and 1290 rpm. I couldn't say it it is noisy because It's subjective. I would say from 5 , quiet (more or less)  to 10, noisy ... only 6.  I can't hear a big difference between idle and performance either.



#10
asiansurf

asiansurf

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

HP Z620 with Sierra works!

 

Thanks to Bilbo, his detailed instructions also works for a HP Z620 with Sierra!

 

My rig :

HP Z620 with the following specifications :

- E5-2620

- ATI R5 240 1GB

- Bootblock 28/12/2011

- BIOs 3.88a

 

Clover_v2.3k_r3773 used for preparing USB with Sierra.

Clover configurator 4.33.0 used.

 

All instructions by Bilbo followed to the letter.  Except for the following customisations for my rig :

- My R5 240 is similar to the AMD HD 7xxx Oland series.  Therefore, it only works with a Fake-ID:0x67981002 with FBname:Oland

- The E5-2620 CPU ID: type 0x0A01

 

I don't have a LSI 2308 or a thunderbolt card and therefore I stopped after the instructions for Audio.

 

This is my first Hackintosh and I don't know much about why I have to do the things in the instructions.

 

Everything works so far except :

- No video after waking from sleep

- Initially, all 6-cores and HT were active upon boot, then subsequently only 6 cores active regardless or load. System becomes a little laggy even while typing this post while watching the Apple keynote on Safari.

 

Do I have to continue with the Power Management instruction for my Sandy Bridge CPU so that the problems faced above will be solved?



#11
Dr Droid

Dr Droid

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Excellent guide bilbo! I am piecing together a HP Z820 + 2xE5-2680 (V1) for video production. I am looking forward to hackintosh this Z workstation. 



#12
Jordidh

Jordidh

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi,

I'm trying to work the Z840 too with Sierra 10.12.2. Working correctly but only with original AstekFusion2 kext that only works with one device. If I try to startup with patched unlimited Astek2Fusion kexts I am getting a reboot after PCI Init... Maybe need a recompile kext to work with Sierra? If I boot on Capitan Hard Drive I can load with your patched LSI 2308 AstekFusion2 kexts kit.

Anybody with Z820 or Z840 can check If can load Sierra with this patched unlimited LSI 2308 AstekFusion2 kexts?

Thanks,

#13
leigh75

leigh75

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hello fellow Z workstation Hackintoshers. :)

 

My Setup:

 

My specs are:

 

z820

Intel Xeon Processor E5-2690 v1 dual.

Bios version 3.88

Graphics Card: GTX 980 Ti

Memory: 128gb ram

 

Common Hardware:

 

Audio card Realtek ALC262

Internal SATA-SAS controller LSI 2308

USB3 internal controller Texas Instruments TUSB37320/40

 

 

And:

 

PCI Thunderbolt Card HP

 

 

I think I can say I have managed to get my z820 up and running as a Hackintosh.

Only Thunderbolt is not working. But it did at one point. Before I went to step VIII I think.

I couldn't see the board in System Info but the TH drives mounted perfectly.

I really need Thunderbolt to work... :) I have all my Media on there. Oh by the way, this is going to be and Editing and color grading workstation.

PM is aslo working thanks to Piker. :)

 

If any one has any tips to help me fix this before I start all over again it would be super duper awesomely cool. :)

Also, I have noticed that Safari does not work correctly... buggie, unsatble, clicks not working .. etc.. Chrome is perfect.

 

Cheers and thanks for any kind help.

 

Leigh

Paris, France



#14
Blaggah

Blaggah

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 460 posts
  • Gender:Male
  • Location:MA
@Leigh75, regarding your Thunderbolt not working, I read somewhere that users had their Thunderbolt ports working in hackintosh by installing the drivers first in Windows. You might wanna try that and see if it works.

#15
bilbo

bilbo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts


Everything works so far except :

- No video after waking from sleep

- Initially, all 6-cores and HT were active upon boot, then subsequently only 6 cores active regardless or load. System becomes a little laggy even while typing this post while watching the Apple keynote on Safari.

 

Do I have to continue with the Power Management instruction for my Sandy Bridge CPU so that the problems faced above will be solved?

 

Sorry for the delay answering.  I bet that laggy behaviour is cause some graphic issue. I had same issues on Mavericks until fix a bug with my quadro cards. But sorry, no idea about ATI cards.

 

To have the right PM is your choice. A flat-performance and no headaches, or a bit of effort and one more efficent performance. ^_^

 

-------

 

 

Hi,

I'm trying to work the Z840 too with Sierra 10.12.2. Working correctly but only with original AstekFusion2 kext that only works with one device. If I try to startup with patched unlimited Astek2Fusion kexts I am getting a reboot after PCI Init... Maybe need a recompile kext to work with Sierra? If I boot on Capitan Hard Drive I can load with your patched LSI 2308 AstekFusion2 kexts kit.

Anybody with Z820 or Z840 can check If can load Sierra with this patched unlimited LSI 2308 AstekFusion2 kexts?

Thanks,

 

Thanks for share your test. Interesting (and worrying). I'm on El capitan and I can´t check it. We need people interested to test it.

 

It's interesting that you have managed to install Sierra on Z840. Could you make a little summary about? I know some people interesed.

 

------

 



I think I can say I have managed to get my z820 up and running as a Hackintosh.

Only Thunderbolt is not working. But it did at one point. Before I went to step VIII I think.

I couldn't see the board in System Info but the TH drives mounted perfectly.

I really need Thunderbolt to work... :) I have all my Media on there. Oh by the way, this is going to be and Editing and color grading workstation.


 

 

My thunderbolt worked out of the box.  Check the bios option about Thunderbolt (it should be in Legacy mode). And like Blaggah says, install last thunderbolt divers on windows. Did you any inappropriate edit of dsdt? Sorry, but no experience with pegasus Raids.

 

Did you get some interesting extra info from Pike?



#16
hugodlc

hugodlc

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

For anyone that is interested, managed to get firewire to work in Mavericks by editing the DSDT (IRQ problem) and removing power management, weird huh? also PM seemed to be killing the performance of my machine a bit.

 

Also installed El Capitan using Chameleon Enoch and everything except sound works perfectly. (can't figure out how to inject the audio device with Chameleon) but El Capitan seems to be buggier with the Pro tools video engine so I'm sticking with Mavericks.

 

One last thing, the speedier fans seem to be related to EFI boot. I installed windows 10 EFI and it showed the same problem, re-installed it in legacy boot mode and fans are quiet.

It looks like (at least in my Z820) the fan speed control is managed by the motherboard bios, and unfortunately it is bypassed if I use EFI boot of any kind.



#17
leigh75

leigh75

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

@Leigh75, regarding your Thunderbolt not working, I read somewhere that users had their Thunderbolt ports working in hackintosh by installing the drivers first in Windows. You might wanna try that and see if it works.

Thanks for pointing that out. I had already done so. The PC side of the workstation is on a seperate SSD and working just fine. Although I don't feel TH is implmented as well under Windows as it is under native OSX machines. Maybe also something to do with Sandy Bridge Xeons....

 

 

Any how, thanks again for tipping in. :)


 

My thunderbolt worked out of the box.  Check the bios option about Thunderbolt (it should be in Legacy mode). And like Blaggah says, install last thunderbolt divers on windows. Did you any inappropriate edit of dsdt? Sorry, but no experience with pegasus Raids.

 

Did you get some interesting extra info from Pike?

Hi Bilbo

 

So, I don't know what happened, changed, but I now have my TH drives ap and mounted on my desktop and they 100 % functional.

Still no Promise R6... But that could be something else....

I will keep an eye on all this and hope that TH will be stable. I am using Legacy mode in the Bios..

 

I am happy to say that I think I have a pretty good z820 dual Xeon E5 2690 Sandy Bridge hackintosh up and running with 128 Gb RAM + GTX 980 Ti + TH HP OEM Board. Audio, FW 400, Ethernet NICs, USB 2.0 and PM are working too. Only USB 3.0 is only in read mode. But I can grab a cheap USB 3.0 card to fix that.

 

Maybe you could tell me what you think of my Geekbench results.

 

Single-Core Score Multi-Core Score 3369 22948

 

Cheers to all



#18
Jordidh

Jordidh

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Hi Bilbo,

 

For Installing Sierra on Z840 I follow the Metacollin guide for PM in Sierra with Broadwell. I have a dual E5-2623 V4 and a Nvidia Original TITAN 6GB, that works with MacOs system drivers.

 

The Sleep doesn't work, I think is because I don't know how to patch the Z840 DDST and I'm using a Supermicro C612 SSDT.

 

First creating the installer Sierra USB like this: https://eladnava.com...intosh-vanilla/

 

I have used the Sierra Install 10.12.0

 

Second: Installing Clover V2.4 R3974.pkg in EFI mode

 

I have disabled USB 3 on BIOS

 

Using the SupermicroDSDT from metacollin post and copying to EFI/CLOVER/Acpi/patched

 

I have copied to EFI/CLOVER//drivers64UEFI/ this drivers: HFSPlus.efi, OsxAptioFix2Drv-free2000.efi and to EFI/CLOVER//kext/10.12 the Original AstekFusion2Adapter.Kext, AstekFusion2Family.kext, AppleALC.kext, FakeSMC.kext, IntelMAusiEthernet.kext, USBInjectAll.kext and VoodooTSCSync.kext.

 

-The original AstekFusion2Family.kext only allow to me to work with one HDD. I have tried several times with the AstekFusion2Adapter and Family.kexts patched (Provided by bilbo in this post) to unlimited devices, but always I get a Kernel panic with restart. With el Capitan this patched kexts works correctly.

 

-If you have more HDDs installed, and can't install, be sure that you are installing it in HDD-0 canister, because I think that appart of only work with one device, the LSI kext only work with the first HDD detected.

 

-I have extracted the SSDT using a Ubuntu live CD with the util ssdtPRgen by Pike R. Alpha, using this options -doard-id Mac-F60DEB81FF30ACF6,  -cpus 2,  -x 1

You need your own SSDT according to your CPUs

 

-Then copied the resulting SSDT to EFI/CLOVER/ACPI/patched

 

-Using Clover Configurator 4.37 I have checked this options:

 

In Acpi section:

 

Activated: FixDisplay, FixUSB, FixFirewire, AddDTGP, FixHDA, FakeLPC, FixLAN, FixDarwin, FixShutdown, FixIPIC.

 

On Drop Tables, like Metacollin explain in his post, , Signature SSDT,Type/key: TableId, String/Number:PmMgt. on SSDT section Plugin Type =1, PLimit Dict =0 , all the rest dissabled.

 

Smart UPS enabled. 

 

In Boot option

 

I have checked - Verbose, npci=0x2000, darkwake, dart=0, nv_disable=1 and in custom flags -xcpm_ipi

 

 

The Cpu, Devices, Disable Drivers, Gui and Graphics section remain as Clover installed.

 

Then in Kernel and Kext Patches, nothing checked, no FakeCPUID, nope..

 

But in Kext to Patch I placed exactly the patches Kext to patch IOPCIFamily (X99 patch by braumbear) and KerneltoPatch xcpm_idle patch, xcpm_bootstrap Sierra, xcpm_core_scope_msrs, Xcpm_pkg_scope_msr ... all from Pike R. Alpha, like posted by Metacollin in this post

 

Prease, note that there are a Kerneltopatch for Broadwell (E5 V4 Xeon) and a different patch for Haswell (E5 V3 Xeon), you only can do one of this that matches your CPU as showed in Metacollin post.

 

Rt Variables, remain as is installed

 

In SMBIOS section then generate a wizard MacPro 6,1.

 

In System Parameters I have checked No caches, Inject System ID an Nvidiaweb

 

Then save the config.plist, and close Clover Config.

 

At this point, I have started the Z840 with the USB prepared as related.

 

I installed Sierra Succesfully (No problems with Nvidia because Original GTX Titan) but with nv_disable=1

 

After Sierra it's installed, then I have installed Real Vnc to gain remote access and deal with Nvidia MacPro 6,1 problems, because if I update to 10.12.2, need to apply the ADGPFix, you can find the link to download in the Metacollin post

 

Well, If I remember correctly the order is this, before disable nv_disable=1, you need to install RealVnc, configure it, and test connection, I recommend to configure auto login to automated Realvnc load with the black screen after disable nv-disable=1. Apply de ADGPFix. Then  disable nv_disable=1 and enable nvda_drv=1.Test Real Vnc before restart. If you have Nvidia GTX9XX based card, install nvidia web driver. Then Restart If all is correct, then you have a good load with nvidia driver on Sierra 10.12.

 

Well, at this point I have managed to update to 10.12.2. (Important, if you update to 10.12.1 or 10.12.2, you need to have dart=0, without this I'm not get a System load)Then the ADGPFix goes to trash.... nv_disable=1 checked (I supose if you have Nvidia not Osx native suported). Restart. At this point you need to log in through a remote connection using RealVnc in order to reaply the ADGPFix, after this, I have checked nv_disable another time, to install nvidia web driver after another restart. Install Nvidia web driver, and be sure to have in EFI/CLOVER/drivers64UEFI this file: EmuVariableUefi-64.efi (This is to create a nvram.plist file that simulates the NVRAM) without this, the Nvidia driver doesn't load because after restart not store the nvda_drv=1 instance.

 

Well I asume that is a bit lousy, but I related the same process I have done, because first I get the goal to install 10.12, but I have tried many times to get updated 10.12.1-10.12.2, because dart=0, ADGPFix with RealVnc, and finally EmuVariableUefi-64.efi. Too much trial and error, and targeting the issues one by one around the forums.

 

Maybe you can do a straight way by trying to install Sierra 10.12.2 directly, but I don't check it or doing it in Z840 because I find the dart=0 issue when I have a working 10.12.0 installation. I think it should work, but if you find issues, try first the 10.12.0 approach + updates.

 

At this point, I proceed to do the Piker's Alpha's frequencyVectorsEdit.sh script to patch the frequency vectors and tell the kernel to load the P-states, as explain Metacollin in his post

 

I have checked the working condition of P-states using AppleIntelInfo and IntelPowerGadget (Installed using Pacifist to extract the files, because refuses to install the pkg becuse dual CPU)

 

At this point I proceeded to install the VoodooHDA V2.8.9, that enables the Realtek Audio ALC221, without the pops sounds that creates previous versions. I don't install the .pkg, I've opened it with pacifist and I have added the VoodooHDA.kext to EFI/CLOVER/kext/Other. Then I install AppleHDADisabler.kext in EFI/CLOVER/kext/Other.

Then placed the VoodooHDA.prefPane in System/Library/PreferencePanes

 

Then I restart and activate the USB 3 in Bios. and with clover config I apply the USB 3 patch called AppleUSBXHCIPCI Find Hex 83BD74FFFFFF10 and Replace HEx 83BD74FFFFFF1B. And add the kexts FakePCIID_XHCIMux.kext, FakePCIID.kext, X99_Injector USB 3.kext. Well, maybe some kext it's not needed but with the three, my USB 3.0 is working fine.

 

This is not a perfect Sierra functioning, but the turbo speed and low C-states works, audio works, USB 3.0 works, One LSI HDD works, and Nvidia works. I only miss two things, have a well working Z840 DSDT with GFX1 patch, Thunderbolt and S3 Sleep states, and the second, a Astek Fusion Kext patched to unlimited HDDs ( I don't know why doesn't work on Sierra, maybe it  need to be compiled in Sierra, but I don't know and don't have this skills).

 

After this, If you whan't a little more, can generate a unused serial number, and a UUID to get the Hackintosh Z840 with a iCloud account, you can find easy how to do by google about iMessage thicks, that enable too icloud.

 

The great next steep is if somebody can create a well patched HP Z840 DSDT, I think this will optimize the experience with the Z840, that in this stage is very satisfing after some weeks and a lot of hours, trying things, browsing forums and of course, this will not be possible with the efforts of Metacollin, Pike R. Alpha, Braumbear and more people that build this house of cards.

 

And of course, if somebody know how to patch de AstekFusion kexts to work with sierra will be great too,

 

Sorry if I forget some step, but I think I post all the important information.

 

Maybe with a little of more testing, maybe some clover options checked in Acpi, and some USB kext are not needed or redundant... I have not arrived yet to optimize this.

 

A easy work, is to Install Sierra to a HDD from a real supported Mac, update, then install Clover in that hardrive and prepare the EFI partirion with Clover Configurator as I descrived (add Nvda_drv=1 too), last install Nvidia web driver and  apply ADGPFix. Shutdown and mount that HDD on your HDD-0 bay Z840. I have a MacPro 5,1 and can boot the Sierra Z840 HDD if I attach to it.

 

For testing purposes, I cloned the Vanilla Sierra in two or three drives, install clover in every HDD, and copy the EFI folder to every EFI partition. Then if I do something wrong, I always have a working HDD, It's good to when you are trying to find some Kext that works, or to test if a kext it's working when you install through .pkg. Save a Copy of EFI folder when you have working EFI and name it EFI (Working), because If you do several tests, changing options or kexts on clover partition, it's easy to forget or loose the options that do work the system. Because sometimes you need to restart several times testing to find a solution to working a device, the Z840 spend several time to pass the post.... Zzzzz... and after some restarts you don't know who you are, less, what options do work the system after 3 or 4 restarts with differents configs.

 

Please, If you get a Z840 working Sierra, and find some optimization or wrong tip in the process descrived, share with us...



#19
bilbo

bilbo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts

LOL.. I'm going to need more than 5 min to assimilate that info :P  .. Great job. I find it some weird steps but I have to read it more carefully.



#20
Jordidh

Jordidh

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Hi bilbo

 

I have updated to 10.12.3 without issue, using the RealVnc trick. This is, using combo update and after restart, I connect to Z840 using RealVnc to reapply the ADGPFix, install Nvidia web driver, restart and with monitor signal working, execute the Piker's Alpha's frequencyVectorsEdit.sh script.

 

Maybe with your experience can find some steps or Kext that can be done or optimized with another approach... 

 

I have tested, the same Clover EFI settings without DSDT files, only the SSDT generated with the script on EFI/CLOVER/ACPI/patched, and the system load too. But at first looking around, It seems that Sleep S3 works, but when wake doesn't work and hangs with a beach ball.

 

I will test more to find if there are any advantage with Supermicro DSDT over Clover patch "on the fly" or reverse. In other post I have uploaded the Z840 DSDT and the IOReg because maybe somebody can help in patch it. I have tried to compare both DSDT but it seems to be diferent folders sctructure and I haven't any program skills.








1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy