Jump to content

Clover General discussion

Bootloader EFI Clover

  • Please log in to reply
5179 replies to this topic

#561
fau7i

fau7i

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 111 posts
  • Gender:Male
  • Location:Malaysia

I have a problem so I split the disk

100 Mb Fat32 UEFI
50GB MacOSX
50GB Win7
300Gb Storage

My problem is not being able to make bootable the partition UEFI-Fat32 where I installed Clover


So, you were not installing in EFI partition. Then, just flag your FAT32 UEFI partition as active.

#562
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
and so that is activated?

Diskuti lista
Mkdir / Volumes / EFI
Sudo mount-t msdos / dev/diskXs1 / Volumes / efi
Ls / Volumes / efi / EFI / *


#563
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 256 posts
  • Gender:Male
Before doing anything, better make DarwinDump. Choose options: Bootloader config files, and all options that start with Disk. We should be able to see from that what went wrong.

#564
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
this is My Dumper
Attached File  DarwinDumper_2.5.7_AMI_X64_896_ML_antonio.zip   147.39KB   5 downloads

#565
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Taiwan
@Slice
How can I reset PRAM/NVRAM in Clover?
I encountered this problem while installing with InstallESD.dmg:
Posted Image

I found out it has something to do with NVRAM on really mac:
https://discussions....tart=0&tstart=0


Here is the installation log:
Spoiler


#566
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States

How can I reset PRAM/NVRAM in Clover?


You will need to type these two commands in Terminal to clear the NVRAM. Then restart your computer (Mac), keep in mind you will also need to redo some of your your settings in System Preferences after the restart, like your computer name, re-enable Find My Mac, and a good idea to look at the Guest account options to make sure they have not changed.

sudo rm /nvram.plist

sudo nvram -c

If you want to see the contents of your NVRAM you can use this command on a real Mac or a Hackintosh with Clover.

nvram -p

Good Luck hope this helps!

-Mrengles

PS. This would probably be a good thing to add to the Q & A post. :wink2:

#567
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
  • Location:Taiwan

You will need to type these two commands in Terminal to clear the NVRAM. Then restart your computer (Mac), keep in mind you will also need to redo some of your your settings in System Preferences after the restart, like your computer name, re-enable Find My Mac, and a good idea to look at the Guest account options to make sure they have not changed.

sudo rm /nvram.plist

sudo nvram -c

If you want to see the contents of your NVRAM you can use this command on a real Mac or a Hackintosh with Clover.

nvram -p

Good Luck hope this helps!

-Mrengles

PS. This would probably be a good thing to add to the Q & A post. :wink2:

Installed successfully. Thanks! :)
I found out that with Clover r883, I don't need to delete <key>Kernel Cache</key> in com.apple.Boot.plist or put S/L/E in the root folder.
Everything just works pretty great as if it's a real mac!

#568
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States

Installed successfully. Thanks! :)
I found out that with Clover r883, I don't need to delete <key>Kernel Cache</key> in com.apple.Boot.plist or put S/L/E in the root folder.
Everything just works pretty great as if it's a real mac!


So what are you doing just restore the Installer ESD.dmg to a USB Flash Drive, boot from it, and install Mountain Lion? Are you injecting any kexts, or booting without kernelcache?

Thanks!

#569
FredWst

FredWst

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 236 posts
  • Gender:Male
  • Location:France
Hello,

CloverGrowerV4.2
bug fix, Update edk2 IF Clover updated, was NOT doing it.
Check post#2


I get error with CloverGrowerV4.2.

Work Folder: /Users/fred/Documents/CloverGrowerV4.2
Available : 391261 MB
Getting SVN Source, Hang ten…
Entering function getSOURCE:
Entering function getFILE:
ERROR:
Local edk2 Folder Not Found..
Making Local edk2 Folder...
cat: /Users/fred/Documents/CloverGrowerV4.2/src/edk2/Lvers.txt: No such file or directory
Mac-Pro-de-Frederic:CloverGrowerV4.2 fred$


Regards

#570
polkaholga

polkaholga

    InsanelyMac Geek

  • Donators
  • 148 posts
  • Gender:Male
  • Location:Otherland

Hello,



I get error with CloverGrowerV4.2.



Regards


i had the same one and just copied /src/edk2 from v3.9 to resolve it
.../src in v4.2 was empty

#571
FredWst

FredWst

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 236 posts
  • Gender:Male
  • Location:France
Hello,

I've found what's wrong.
If you try to build from scratch that's my case, it does'nt work because Lvers.txt does not exist the first time.

I do that:

if [ "$1" == "edk2" ]; then
if [ "$access" == "co" ] || [ "${cloverUpdate}" == "Yes" ];then
getREVISIONSEDK2
if [ -f "${edk2DIR}"/Svers.txt ]; then
#edk2Local=`cat "${edk2DIR}"/Lvers.txt`
edk2Local=0
if [ "${checksvnRevision}" == "${edk2Local}" ]; then
update="No"
return

fi



Should check if Lvers.txt exist, if not create with 0 revision inside.

or this


if [ -f "${edk2DIR}"/Svers.txt ]; then

if [ -f "${edk2DIR}"/Lvers.txt ]; then

edk2Local=`cat "${edk2DIR}"/Lvers.txt`

else

edk2Local=0

fi

if [ "${checksvnRevision}" == "${edk2Local}" ]; then

update="No"

return

fi

fi



Regards

#572
dmazar

dmazar

    InsanelyMac Sage

  • Coders
  • 256 posts
  • Gender:Male

this is My Dumper
Attached File  DarwinDumper_2.5.7_AMI_X64_896_ML_antonio.zip   147.39KB   5 downloads

Well, you have MBR formatted disk (not GPT). But this is not a problem, unless you are trying to do native UEFI boot - you can only do standard BIOS Clover boot (we call it CloverEFI) with MBR disk.

Your UEFI (fat32) partition is not bootable because you did not install any master boot (boot0) and partition boot (boot1*) code to this disk. I guess the easiest way to do that is to use Clover installer and select "BIOS MBR boot0hfs (HFS+Fat32)". Choose your UEFI partition as target.

#573
vmacpro

vmacpro

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Anyone notice problems with conflicting config files, when clover boots from cd or usb, it uses the config files from the installed local drive? This is also happening with 897.

When real refit is installed on the internal drive on a macbook pro, clover boots from a CD version on a macbookpro and themes mixup. This was only tested with an older version. Right now I don't have direct acces to the real Macs. But in near future I can test real MacPro 1.1 /2.1 again, the 2.1 Macpro with a hd5700 ended with a blackscreen and cursor on a older version of Clover CD, but with high resolution 1600x1200.

Offtopic: I finally discovered that I had to pass to Questionaries/Quizes from this forum to reply to this topic ;-)

#574
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States
Welcome to the forum vmacpro. =)

Haven't had this issue at all. What do you mean by "real refit installed" sorry if this is a dumb overlooked question.

I hope you get some help. The best thing you can do for yourself is read this entire thread from start to finish. and study the first twenty something posts by the Developers. Please don't take that the wrong way. I'm not trying to be rude or snub in any way. I learned allot about Clover by doing that myself. There is so much "good" information in this thread, about installing, troubleshooting, booting, you name name it.

Good luck with Clover, I'm sure your learn to love it too. Its the best Mac bootloader available!

-Mrengles

#575
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male

Well, you have MBR formatted disk (not GPT). But this is not a problem, unless you are trying to do native UEFI boot - you can only do standard BIOS Clover boot (we call it CloverEFI) with MBR disk.

Your UEFI (fat32) partition is not bootable because you did not install any master boot (boot0) and partition boot (boot1*) code to this disk. I guess the easiest way to do that is to use Clover installer and select "BIOS MBR boot0hfs (HFS+Fat32)". Choose your UEFI partition as target.


Yes my goal and start directly with UEFI.

Tomorrow night I try to follow this installation
BIOS MBR boot0hfs (HFS+Fat32)

is a problem that my disk sectors are 4096 B ?

#576
vmacpro

vmacpro

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

What do you mean by "real refit installed" sorry if this is a dumb overlooked question.


On a real Mac, I installed refit from http://refit.sourceforge.net/ and when I boot clover from CD on a Mac where on the internal disk refit was installed it mixes up the looks of cloverCD as its booting.

This mix up of config/themes also happens on pc's with just clover local internal disk install while booting from the clover CD version. I think I cannot be more clear on this to explain it?

#577
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States

On a real Mac, I installed refit from http://refit.sourceforge.net/ and when I boot clover from CD on a Mac where on the internal disk refit was installed it mixes up the looks of cloverCD as its booting.

This mix up of config/themes also happens on pc's with just clover local internal disk install while booting from the clover CD version. I think I cannot be more clear on this to explain it?


Why don't you try removing the "real refit install" on all the other locations and just use Clover?

#578
Liquid Ice

Liquid Ice

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

For the 6780 you need graphics injector=Yes and that's it. Clover will do the rest for that card.

Why don't you post your conf.plist so we can help.


My config file is:

<plist version="1.0">
<dict>
<key>SystemParameters</key>
<dict>
  <key>boot-args</key>
  <string>-v npci=0x2000</string>
  <key>prev-lang:kbd</key>
  <string>en:0</string>
  <key>InjectSystemID</key>
  <string>Yes</string>
  <key>LegacyBoot</key>
  <string>PBR</string>
</dict>
<key>Pointer</key>
<dict>
  <key>Speed</key>
  <string>8</string>
</dict>
<key>Graphics</key>
<dict>
  <key>GraphicsInjector</key>
  <string>Yes</string>
  <key>PatchVBiosBytes</key>
  <dict>
   <key>Find</key>
   <data>gAeoAqAF</data>
   <key>Replace</key>
   <data>gAeoAjgE</data>
  </dict>
</dict>
</dict>
</plist>

My hardware is as follows:

i7 3770K
Gigabyte z77x-up5 th
Crucial M4 256GB (OSX Install)
OCZ Vertex 4 128GB (Windows 7)
WD 640 GB (OSX files)
Seagate 1TB (exfat files)

BIOS is F11 (UEFI).

Can anyone help me configure the boot file. I cant get past the UUID is

#579
Mrengles

Mrengles

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 117 posts
  • Gender:Male
  • Location:United States
@Liquid Ice

If you just downloaded the iso file and moved EFI to your usb or hard drive your missing some need drivers.

You should try using the installer from SF.

What's files do you have in drivers64 and drivers64Uefi?

#580
Liquid Ice

Liquid Ice

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

@Liquid Ice

If you just downloaded the iso file and moved EFI to your usb or hard drive your missing some need drivers.

You should try using the installer from SF.

What's files do you have in drivers64 and drivers64Uefi?



Drivers64UEFI

CsmVideoDxe-64.efi

DataHubDxe-64.efi

FSInject-64.efi

HFSPLus-64.efi

NTFS-64.efi

OsxFatBianryDrv-64.efi

OsxLowMemFixDrv-64.efi

PartitionDxe-64.efi

VboxExt2-64.efi


Drivers64

FSInject-64.efi

Ps2MouseDxe-64.efi

UsbMouseDxe-64.efi

VBoxExt2-64.efi

XhciDxe-64.efi


@mrengles - Used the installer





Also tagged with one or more of these keywords: Bootloader, EFI, Clover


2 user(s) are reading this topic

2 members, 0 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy